83 lines
2.5 KiB
RPMSpec
83 lines
2.5 KiB
RPMSpec
Name: ois
|
|
Version: 1.5.1
|
|
Release: 1mamba
|
|
Summary: Object Oriented Input System
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://sourceforge.net/projects/wgois/
|
|
Source: https://github.com/wgois/OIS.git/v%{version}/OIS-%{version}.tar.bz2
|
|
Patch0: ois-1.3-gcc-4.8.patch
|
|
License: zlib/libpng
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libX11-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libstdc++6-devel
|
|
## AUTOBUILDREQ-END
|
|
|
|
%description
|
|
Object Oriented Input System (OIS) is meant to be a cross platform, simple solution for using all kinds of Input Devices (Keyboards, Mice, Joysticks, etc) and feedback devices (e.g. force feedback). Written in C++ using Object Oriented Design pattern.
|
|
|
|
%package -n lib%{name}
|
|
Group: System/Libraries
|
|
Summary: Object Oriented Input System
|
|
|
|
%description -n lib%{name}
|
|
Object Oriented Input System (OIS) is meant to be a cross platform, simple solution for using all kinds of Input Devices (Keyboards, Mice, Joysticks, etc) and feedback devices (e.g. force feedback). Written in C++ using Object Oriented Design pattern.
|
|
|
|
%package -n lib%{name}-devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: pkg-config
|
|
|
|
%description -n lib%{name}-devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -n OIS-%{version}
|
|
|
|
%build
|
|
%cmake -d build \
|
|
-DCMAKE_INSTALL_LIBDIR=%{_lib}
|
|
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall -C build
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -n lib%{name} -p /sbin/ldconfig
|
|
%postun -n lib%{name} -p /sbin/ldconfig
|
|
|
|
%files -n lib%{name}
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libOIS.so.*
|
|
|
|
%files -n lib%{name}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/ois
|
|
%{_includedir}/ois/*.h
|
|
%{_libdir}/libOIS.so
|
|
%{_libdir}/pkgconfig/OIS.pc
|
|
|
|
%changelog
|
|
* Sun May 16 2021 Automatic Build System <autodist@mambasoft.it> 1.5.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu May 21 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5-1mamba
|
|
- update to 1.5
|
|
|
|
* Fri Feb 12 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3-2mamba
|
|
- rebuilt with gcc 5.3.0
|
|
|
|
* Thu Nov 28 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3-1mamba
|
|
- package created using the webbuild interface
|