package created using the webbuild interface [release 1.3-1mamba;Thu Nov 28 2013]
This commit is contained in:
parent
1d20e3bafc
commit
50b8b24619
@ -1,2 +1,4 @@
|
|||||||
# ois
|
# ois
|
||||||
|
|
||||||
|
Object Oriented Input System (OIS) is meant to be a cross platform, simple solution for using all kinds of Input Devices (Keyboards, Mice, Joysticks, etc) and feedback devices (e.g. force feedback). Written in C++ using Object Oriented Design pattern.
|
||||||
|
|
||||||
|
43
ois-1.3-gcc-4.8.patch
Normal file
43
ois-1.3-gcc-4.8.patch
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
diff -ru ois-v1-3.orig/demos/FFConsoleDemo.cpp ois-v1-3/demos/FFConsoleDemo.cpp
|
||||||
|
--- ois-v1-3.orig/demos/FFConsoleDemo.cpp 2010-04-01 05:38:04.000000000 +0200
|
||||||
|
+++ ois-v1-3/demos/FFConsoleDemo.cpp 2013-11-28 10:47:41.663835972 +0100
|
||||||
|
@@ -1,5 +1,6 @@
|
||||||
|
#include "OIS.h"
|
||||||
|
|
||||||
|
+#include <unistd.h>
|
||||||
|
#include <math.h>
|
||||||
|
#include <cstdlib>
|
||||||
|
#include <iostream>
|
||||||
|
diff -ru ois-v1-3.orig/demos/OISConsole.cpp ois-v1-3/demos/OISConsole.cpp
|
||||||
|
--- ois-v1-3.orig/demos/OISConsole.cpp 2010-08-16 00:51:34.000000000 +0200
|
||||||
|
+++ ois-v1-3/demos/OISConsole.cpp 2013-11-28 10:46:58.172275224 +0100
|
||||||
|
@@ -9,6 +9,7 @@
|
||||||
|
//Advanced Usage
|
||||||
|
#include "OISForceFeedback.h"
|
||||||
|
|
||||||
|
+#include <unistd.h>
|
||||||
|
#include <iostream>
|
||||||
|
#include <vector>
|
||||||
|
#include <sstream>
|
||||||
|
diff -ru ois-v1-3.orig/src/linux/LinuxForceFeedback.cpp ois-v1-3/src/linux/LinuxForceFeedback.cpp
|
||||||
|
--- ois-v1-3.orig/src/linux/LinuxForceFeedback.cpp 2010-04-01 05:06:55.000000000 +0200
|
||||||
|
+++ ois-v1-3/src/linux/LinuxForceFeedback.cpp 2013-11-28 10:46:36.888490190 +0100
|
||||||
|
@@ -23,6 +23,7 @@
|
||||||
|
#include "linux/LinuxForceFeedback.h"
|
||||||
|
#include "OISException.h"
|
||||||
|
|
||||||
|
+#include <unistd.h>
|
||||||
|
#include <cstdlib>
|
||||||
|
#include <errno.h>
|
||||||
|
#include <memory.h>
|
||||||
|
diff -ru ois-v1-3.orig/src/linux/LinuxJoyStickEvents.cpp ois-v1-3/src/linux/LinuxJoyStickEvents.cpp
|
||||||
|
--- ois-v1-3.orig/src/linux/LinuxJoyStickEvents.cpp 2013-11-28 10:45:51.365949979 +0100
|
||||||
|
+++ ois-v1-3/src/linux/LinuxJoyStickEvents.cpp 2013-11-28 10:46:07.617785829 +0100
|
||||||
|
@@ -35,6 +35,7 @@
|
||||||
|
#include <linux/input.h>
|
||||||
|
|
||||||
|
|
||||||
|
+#include <unistd.h>
|
||||||
|
#include <sstream>
|
||||||
|
# include <iostream>
|
||||||
|
using namespace std;
|
81
ois.spec
Normal file
81
ois.spec
Normal file
@ -0,0 +1,81 @@
|
|||||||
|
%define pkgver %(echo %version | tr . -)
|
||||||
|
Name: ois
|
||||||
|
Version: 1.3
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: Object Oriented Input System
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://sourceforge.net/projects/wgois/
|
||||||
|
Source: http://downloads.sourceforge.net/project/wgois/Source%20Release/%{version}/ois_v%{pkgver}.tar.gz
|
||||||
|
Patch0: ois-1.3-gcc-4.8.patch
|
||||||
|
License: zlib/libpng
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libpthread-stubs-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXau-devel
|
||||||
|
BuildRequires: libxcb-devel
|
||||||
|
BuildRequires: libXdmcp-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Object Oriented Input System (OIS) is meant to be a cross platform, simple solution for using all kinds of Input Devices (Keyboards, Mice, Joysticks, etc) and feedback devices (e.g. force feedback). Written in C++ using Object Oriented Design pattern.
|
||||||
|
|
||||||
|
%package -n lib%{name}
|
||||||
|
Group: System/Libraries
|
||||||
|
Summary: Object Oriented Input System
|
||||||
|
|
||||||
|
%description -n lib%{name}
|
||||||
|
Object Oriented Input System (OIS) is meant to be a cross platform, simple solution for using all kinds of Input Devices (Keyboards, Mice, Joysticks, etc) and feedback devices (e.g. force feedback). Written in C++ using Object Oriented Design pattern.
|
||||||
|
|
||||||
|
%package -n lib%{name}-devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Requires: pkg-config
|
||||||
|
|
||||||
|
%description -n lib%{name}-devel
|
||||||
|
This package contains libraries and header files for developing applications that use %{name}.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{name}-v%{pkgver}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
sh ./bootstrap
|
||||||
|
%configure
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -n lib%{name} -p /sbin/ldconfig
|
||||||
|
%postun -n lib%{name} -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files -n lib%{name}
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libOIS-1.3.0.so
|
||||||
|
|
||||||
|
%files -n lib%{name}-devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_includedir}/OIS
|
||||||
|
%{_includedir}/OIS/OIS*.h
|
||||||
|
%{_libdir}/libOIS.a
|
||||||
|
%{_libdir}/libOIS.la
|
||||||
|
%{_libdir}/libOIS.so
|
||||||
|
%{_libdir}/pkgconfig/OIS.pc
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Nov 28 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3-1mamba
|
||||||
|
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user