rebuilt by autoport with build requirements: libopencolorio-devel>=2.3.2-1mamba [release 2.5.6.0-2mamba;Mon Feb 05 2024]
This commit is contained in:
parent
6e512d91f8
commit
65fe1d1751
@ -1,69 +0,0 @@
|
|||||||
From 9b54ad37f0174c1eeebb903cefae7567dee79959 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Bernhard=20Rosenkr=C3=A4nzer?= <bero@lindev.ch>
|
|
||||||
Date: Tue, 18 Jan 2022 02:34:51 +0100
|
|
||||||
Subject: [PATCH] Port to ffmpeg 5.0
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Port to ffmpeg 5.0 -- av_register_all removed, AVPicture
|
|
||||||
removed, pkt_pts changed to pts
|
|
||||||
|
|
||||||
Signed-off-by: Bernhard Rosenkränzer <bero@lindev.ch>
|
|
||||||
---
|
|
||||||
src/ffmpeg.imageio/ffmpeginput.cpp | 11 +++++------
|
|
||||||
1 file changed, 5 insertions(+), 6 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/ffmpeg.imageio/ffmpeginput.cpp b/src/ffmpeg.imageio/ffmpeginput.cpp
|
|
||||||
index b3018903b3..a71c09d9d7 100644
|
|
||||||
--- a/src/ffmpeg.imageio/ffmpeginput.cpp
|
|
||||||
+++ b/src/ffmpeg.imageio/ffmpeginput.cpp
|
|
||||||
@@ -32,7 +32,7 @@ extern "C" { // ffmpeg is a C api
|
|
||||||
|
|
||||||
|
|
||||||
inline int
|
|
||||||
-avpicture_fill(AVPicture* picture, uint8_t* ptr, enum AVPixelFormat pix_fmt,
|
|
||||||
+avpicture_fill(AVFrame* picture, uint8_t* ptr, enum AVPixelFormat pix_fmt,
|
|
||||||
int width, int height)
|
|
||||||
{
|
|
||||||
AVFrame* frame = reinterpret_cast<AVFrame*>(picture);
|
|
||||||
@@ -119,7 +119,7 @@ class FFmpegInput final : public ImageInput {
|
|
||||||
int64_t m_nsubimages;
|
|
||||||
AVFormatContext* m_format_context;
|
|
||||||
AVCodecContext* m_codec_context;
|
|
||||||
- AVCodec* m_codec;
|
|
||||||
+ const AVCodec* m_codec;
|
|
||||||
AVFrame* m_frame;
|
|
||||||
AVFrame* m_rgb_frame;
|
|
||||||
size_t m_stride; // scanline width in bytes, a.k.a. scanline stride
|
|
||||||
@@ -238,7 +238,6 @@ FFmpegInput::open(const std::string& name, ImageSpec& spec)
|
|
||||||
}
|
|
||||||
|
|
||||||
static std::once_flag init_flag;
|
|
||||||
- std::call_once(init_flag, av_register_all);
|
|
||||||
const char* file_name = name.c_str();
|
|
||||||
av_log_set_level(AV_LOG_FATAL);
|
|
||||||
if (avformat_open_input(&m_format_context, file_name, NULL, NULL) != 0) {
|
|
||||||
@@ -608,11 +607,11 @@ FFmpegInput::read_frame(int frame)
|
|
||||||
finished = receive_frame(m_codec_context, m_frame, &pkt);
|
|
||||||
|
|
||||||
double pts = 0;
|
|
||||||
- if (static_cast<int64_t>(m_frame->pkt_pts)
|
|
||||||
+ if (static_cast<int64_t>(m_frame->pts)
|
|
||||||
!= int64_t(AV_NOPTS_VALUE)) {
|
|
||||||
pts = av_q2d(
|
|
||||||
m_format_context->streams[m_video_stream]->time_base)
|
|
||||||
- * m_frame->pkt_pts;
|
|
||||||
+ * m_frame->pts;
|
|
||||||
}
|
|
||||||
|
|
||||||
int current_frame = int((pts - m_start_time) * fps() + 0.5f); //???
|
|
||||||
@@ -620,7 +619,7 @@ FFmpegInput::read_frame(int frame)
|
|
||||||
m_last_search_pos = current_frame;
|
|
||||||
|
|
||||||
if (current_frame == frame && finished) {
|
|
||||||
- avpicture_fill(reinterpret_cast<AVPicture*>(m_rgb_frame),
|
|
||||||
+ avpicture_fill(m_rgb_frame,
|
|
||||||
&m_rgb_buffer[0], m_dst_pix_format,
|
|
||||||
m_codec_context->width, m_codec_context->height);
|
|
||||||
sws_scale(m_sws_rgb_context,
|
|
55
oiio.spec
55
oiio.spec
@ -1,5 +1,5 @@
|
|||||||
Name: oiio
|
Name: oiio
|
||||||
Version: 2.3.12.0
|
Version: 2.5.6.0
|
||||||
Release: 2mamba
|
Release: 2mamba
|
||||||
Summary: Libraries and tools for VFX studios and developers of tools such as renderers, compositors, viewers
|
Summary: Libraries and tools for VFX studios and developers of tools such as renderers, compositors, viewers
|
||||||
Group: Applications/Graphics
|
Group: Applications/Graphics
|
||||||
@ -8,11 +8,9 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.openimageio.org
|
URL: http://www.openimageio.org
|
||||||
Source: https://github.com/OpenImageIO/oiio.git/v%{version}/oiio-%{version}.tar.bz2
|
Source: https://github.com/OpenImageIO/oiio.git/v%{version}/oiio-%{version}.tar.bz2
|
||||||
Patch0: oiio-2.3.12.0-ffmpeg-5.0.patch
|
|
||||||
License: BSD
|
License: BSD
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libGLU-devel
|
|
||||||
BuildRequires: libavcodec-ffmpeg-devel
|
BuildRequires: libavcodec-ffmpeg-devel
|
||||||
BuildRequires: libavformat-ffmpeg-devel
|
BuildRequires: libavformat-ffmpeg-devel
|
||||||
BuildRequires: libavutil-ffmpeg-devel
|
BuildRequires: libavutil-ffmpeg-devel
|
||||||
@ -22,6 +20,7 @@ BuildRequires: libdcmtk-devel
|
|||||||
BuildRequires: libfreetype-devel
|
BuildRequires: libfreetype-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libgif-devel
|
BuildRequires: libgif-devel
|
||||||
|
BuildRequires: libglu-devel
|
||||||
BuildRequires: libglvnd-devel
|
BuildRequires: libglvnd-devel
|
||||||
BuildRequires: libheif-devel
|
BuildRequires: libheif-devel
|
||||||
BuildRequires: libimath-devel
|
BuildRequires: libimath-devel
|
||||||
@ -31,20 +30,20 @@ BuildRequires: libopencv-devel
|
|||||||
BuildRequires: libopenexr-devel
|
BuildRequires: libopenexr-devel
|
||||||
BuildRequires: libopenjpeg-devel
|
BuildRequires: libopenjpeg-devel
|
||||||
BuildRequires: libpng-devel
|
BuildRequires: libpng-devel
|
||||||
BuildRequires: libpython3-devel
|
BuildRequires: libpython311-devel
|
||||||
BuildRequires: libraw-devel
|
BuildRequires: libraw-devel
|
||||||
BuildRequires: libsquish-devel
|
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libswscale-ffmpeg-devel
|
BuildRequires: libswscale-ffmpeg-devel
|
||||||
|
BuildRequires: libtbb-devel
|
||||||
BuildRequires: libtiff-devel
|
BuildRequires: libtiff-devel
|
||||||
BuildRequires: libwebp-devel
|
BuildRequires: libwebp-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
BuildRequires: pugixml-devel
|
BuildRequires: pugixml-devel
|
||||||
BuildRequires: qt5-qtbase-devel
|
BuildRequires: qt6-qtbase-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libopencolorio-devel >= 2.3.2-1mamba
|
||||||
BuildRequires: libopencv-devel >= 4.5.5-1mamba
|
BuildRequires: libopencv-devel >= 4.5.5-1mamba
|
||||||
BuildRequires: libdcmtk-devel >= 3.6.7
|
BuildRequires: libdcmtk-devel >= 3.6.8
|
||||||
BuildRequires: libopencolorio-devel >= 2.1.1
|
|
||||||
BuildRequires: python-pybind11-devel
|
BuildRequires: python-pybind11-devel
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
@ -61,6 +60,14 @@ Requires: libopenimageio = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
The primary target audience for OIIO is VFX studios and developers of tools such as renderers, compositors, viewers, and other image-related software you'd find in a production pipeline.
|
The primary target audience for OIIO is VFX studios and developers of tools such as renderers, compositors, viewers, and other image-related software you'd find in a production pipeline.
|
||||||
This package contains tools provided by OpenImageIO.
|
This package contains tools provided by OpenImageIO.
|
||||||
|
|
||||||
|
%package -n python-OpenImageIO
|
||||||
|
Group: System/Libraries/Python
|
||||||
|
Summary: OpenImageIO tools
|
||||||
|
Requires: libopenimageio = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n python-OpenImageIO
|
||||||
|
The primary target audience for OIIO is VFX studios and developers of tools such as renderers, compositors, viewers, and other image-related software you'd find in a production pipeline.
|
||||||
|
This package contains the Python bindings to OpenImageIO.
|
||||||
|
|
||||||
%package -n ttf-openimageio
|
%package -n ttf-openimageio
|
||||||
Group: System/Fonts
|
Group: System/Fonts
|
||||||
@ -90,7 +97,6 @@ This package contains libraries and header files for developing applications tha
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .ffmpeg-5.0
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -d build \
|
%cmake -d build \
|
||||||
@ -129,26 +135,20 @@ This package contains libraries and header files for developing applications tha
|
|||||||
%{_bindir}/iv
|
%{_bindir}/iv
|
||||||
%{_bindir}/maketx
|
%{_bindir}/maketx
|
||||||
%{_bindir}/oiiotool
|
%{_bindir}/oiiotool
|
||||||
#%{_mandir}/iconvert.1
|
%{_bindir}/testtex
|
||||||
#%{_mandir}/idiff.1
|
|
||||||
#%{_mandir}/igrep.1
|
|
||||||
#%{_mandir}/iinfo.1
|
|
||||||
#%{_mandir}/iv.1
|
|
||||||
#%{_mandir}/maketx.1
|
|
||||||
#%{_mandir}/oiiotool.1
|
|
||||||
|
|
||||||
#%files -n ttf-openimageio
|
|
||||||
#%defattr(-,root,root)
|
|
||||||
#%dir %{_datadir}/fonts/OpenImageIO
|
|
||||||
#%{_datadir}/fonts/OpenImageIO/*.ttf
|
|
||||||
|
|
||||||
%files -n libopenimageio
|
%files -n libopenimageio
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_libdir}/libOpenImageIO.so.*
|
%{_libdir}/libOpenImageIO.so.*
|
||||||
%{_libdir}/libOpenImageIO_Util.so.*
|
%{_libdir}/libOpenImageIO_Util.so.*
|
||||||
%{python3_sitearch}/OpenImageIO.cpython-*.so
|
|
||||||
%doc LICENSE.md
|
%doc LICENSE.md
|
||||||
|
|
||||||
|
%files -n python-OpenImageIO
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{python3_sitearch}/OpenImageIO
|
||||||
|
%{python3_sitearch}/OpenImageIO/OpenImageIO.cpython-*.so
|
||||||
|
%{python3_sitearch}/OpenImageIO/__init__.py
|
||||||
|
|
||||||
%files -n libopenimageio-devel
|
%files -n libopenimageio-devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir %{_includedir}/OpenImageIO
|
%dir %{_includedir}/OpenImageIO
|
||||||
@ -157,19 +157,20 @@ This package contains libraries and header files for developing applications tha
|
|||||||
%{_includedir}/OpenImageIO/detail/*.h
|
%{_includedir}/OpenImageIO/detail/*.h
|
||||||
%dir %{_includedir}/OpenImageIO/detail/fmt
|
%dir %{_includedir}/OpenImageIO/detail/fmt
|
||||||
%{_includedir}/OpenImageIO/detail/fmt/*.h
|
%{_includedir}/OpenImageIO/detail/fmt/*.h
|
||||||
#%dir %{_includedir}/OpenImageIO/detail/pugixml
|
|
||||||
#%{_includedir}/OpenImageIO/detail/pugixml/*
|
|
||||||
%{_libdir}/libOpenImageIO.so
|
%{_libdir}/libOpenImageIO.so
|
||||||
%{_libdir}/libOpenImageIO_Util.so
|
%{_libdir}/libOpenImageIO_Util.so
|
||||||
%{_libdir}/pkgconfig/OpenImageIO.pc
|
%{_libdir}/pkgconfig/OpenImageIO.pc
|
||||||
%dir %{_libdir}/cmake/OpenImageIO
|
%dir %{_libdir}/cmake/OpenImageIO
|
||||||
%{_libdir}/cmake/OpenImageIO/OpenImageIO*.cmake
|
%{_libdir}/cmake/OpenImageIO/OpenImageIO*.cmake
|
||||||
#%{_datadir}/cmake/Modules/FindOpenImageIO.cmake
|
|
||||||
#%dir %{_datadir}/doc/OpenImageIO
|
|
||||||
#%{_datadir}/doc/OpenImageIO/*
|
|
||||||
%doc README.md
|
%doc README.md
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 05 2024 Automatic Build System <autodist@mambasoft.it> 2.5.6.0-2mamba
|
||||||
|
- rebuilt by autoport with build requirements: libopencolorio-devel>=2.3.2-1mamba
|
||||||
|
|
||||||
|
* Sun Feb 04 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.5.6.0-1mamba
|
||||||
|
- update to 2.5.6.0
|
||||||
|
|
||||||
* Sun May 29 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.12.0-2mamba
|
* Sun May 29 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.12.0-2mamba
|
||||||
- rebuilt by autoport with build requirements: libopencv-devel>=4.5.5-1mamba
|
- rebuilt by autoport with build requirements: libopencv-devel>=4.5.5-1mamba
|
||||||
|
|
||||||
|
Reference in New Issue
Block a user