update to 1.8.1
revert to stable 1.8.1 for stuntrally (bump up epoch) [release 1.8.1-1mamba;Sun Aug 31 2014]
This commit is contained in:
parent
72935adcee
commit
c38053c03d
13
ogre-1.9.20140831hg-missing-latomic.patch
Normal file
13
ogre-1.9.20140831hg-missing-latomic.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- ogre-1.9.20140831hg/OgreMain/CMakeLists.txt.orig 2014-08-31 14:31:35.232713501 +0200
|
||||
+++ ogre-1.9.20140831hg/OgreMain/CMakeLists.txt 2014-08-31 14:32:18.571705281 +0200
|
||||
@@ -290,10 +290,6 @@
|
||||
set_target_properties(OgreMain PROPERTIES VERSION ${OGRE_SOVERSION} SOVERSION ${OGRE_SOVERSION})
|
||||
endif()
|
||||
|
||||
-if(OGRE_GCC_VERSION VERSION_EQUAL 4.8 OR OGRE_GCC_VERSION VERSION_GREATER 4.8)
|
||||
- list(APPEND LIBRARIES "-latomic")
|
||||
-endif()
|
||||
-
|
||||
if (APPLE)
|
||||
if (OGRE_BUILD_PLATFORM_APPLE_IOS)
|
||||
set_target_properties(OgreMain PROPERTIES INSTALL_NAME_DIR "OGRE")
|
92
ogre.spec
92
ogre.spec
@ -1,31 +1,40 @@
|
||||
%define ver %(echo %{version} | cut -d . -f 1-2)
|
||||
%define ver_download 1-8-1
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
%define pkgver %(echo %version | tr . -)
|
||||
Name: ogre
|
||||
Version: 1.9.0
|
||||
Release: 2mamba
|
||||
Summary: a scene-oriented, flexible 3D engine
|
||||
Epoch: 1
|
||||
Version: 1.8.1
|
||||
Release: 1mamba
|
||||
Summary: A scene-oriented, flexible 3D engine
|
||||
Group: Development/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: openmamba WebBuild System <webbuild@openmamba.org>
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.ogre3d.org
|
||||
Source: http://downloads.sourceforge.net/project/ogre/ogre/%ver/%{version}/ogre_src_v%{ver_download}.tar.bz2
|
||||
# hg clone https://bitbucket.org/sinbad/ogre -b v1-9
|
||||
# cd ogre
|
||||
# hg archive -X ".hg*" -r v1-9 ogre-1.9.20140831hg
|
||||
# tar cJf ../../SOURCES/ogre-1.9.20140831hg.tar.xz ogre-1.9.20140831hg/
|
||||
#Source: https://bitbucket.org/sinbad/ogre/ogre-%{version}.tar.xz
|
||||
Source: https://downloads.sourceforge.net/project/ogre/ogre/%{majver}/%{version}/ogre_src_v%{pkgver}.tar.bz2
|
||||
#Source: http://downloads.sourceforge.net/project/ogre/ogre/%ver/%{version}/ogre_src_v%{ver_download}.tar.bz2
|
||||
Patch0: ogre-1.9.20140831hg-missing-latomic.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libboost-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXaw-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXrandr-devel
|
||||
BuildRequires: libXt-devel
|
||||
BuildRequires: libboost-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtinyxml-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: libzzip-devel
|
||||
## AUTOBUILDREQ-END
|
||||
@ -49,11 +58,15 @@ The class library abstracts all the details of using the underlying system libra
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}_src_v%{ver_download}
|
||||
%setup -q -n ogre_src_v%{pkgver} -D -T
|
||||
:<< __EOF
|
||||
#%patch0 -p1
|
||||
#-n %{name}_src_v%{ver_download}
|
||||
# use cmake default
|
||||
rm CMake/Packages/FindFreetype.cmake
|
||||
|
||||
%build
|
||||
:<< ___EOF
|
||||
%cmake -d build
|
||||
%make
|
||||
|
||||
@ -68,34 +81,77 @@ rm CMake/Packages/FindFreetype.cmake
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/OgreMeshUpgrader
|
||||
%{_bindir}/OgreXMLConverter
|
||||
%{_libdir}/OGRE/*.so
|
||||
%{_libdir}/OGRE/*.so.1.8.1
|
||||
%{_libdir}/OGRE/cmake/*.cmake
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/*.so.1.8.1
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%dir %{_libdir}/OGRE
|
||||
%{_libdir}/OGRE/Plugin_BSPSceneManager.so*
|
||||
%{_libdir}/OGRE/Plugin_OctreeSceneManager.so*
|
||||
%{_libdir}/OGRE/Plugin_OctreeZone.so*
|
||||
%{_libdir}/OGRE/Plugin_PCZSceneManager.so*
|
||||
%{_libdir}/OGRE/Plugin_ParticleFX.so*
|
||||
%{_libdir}/OGRE/RenderSystem_GL.so*
|
||||
%{_libdir}/libOgreMain.so.*
|
||||
#%{_libdir}/libOgreOverlay.so.*
|
||||
%{_libdir}/libOgrePaging.so.*
|
||||
%{_libdir}/libOgreProperty.so.*
|
||||
%{_libdir}/libOgreRTShaderSystem.so.*
|
||||
%{_libdir}/libOgreTerrain.so.*
|
||||
#%{_libdir}/libOgreVolume.so.*
|
||||
#%dir %{_datadir}/OGRE
|
||||
#%{_datadir}/OGRE/*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/OGRE
|
||||
%{_includedir}/OGRE/*.h
|
||||
%dir %{_includedir}/OGRE/GLX
|
||||
%{_includedir}/OGRE/GLX/*.h
|
||||
%{_includedir}/OGRE/OgreZip.h
|
||||
#%dir %{_includedir}/OGRE/Overlay
|
||||
#%{_includedir}/OGRE/Overlay/*.h
|
||||
%dir %{_includedir}/OGRE/Paging
|
||||
%{_includedir}/OGRE/Paging/*.h
|
||||
%dir %{_includedir}/OGRE/Plugins
|
||||
%dir %{_includedir}/OGRE/Plugins/BSPSceneManager
|
||||
%{_includedir}/OGRE/Plugins/BSPSceneManager/*.h
|
||||
%dir %{_includedir}/OGRE/Plugins/OctreeSceneManager
|
||||
%{_includedir}/OGRE/Plugins/OctreeSceneManager/*.h
|
||||
%dir %{_includedir}/OGRE/Plugins/OctreeZone
|
||||
%{_includedir}/OGRE/Plugins/OctreeZone/*.h
|
||||
%dir %{_includedir}/OGRE/Plugins/PCZSceneManager
|
||||
%{_includedir}/OGRE/Plugins/PCZSceneManager/*.h
|
||||
%dir %{_includedir}/OGRE/Plugins/ParticleFX
|
||||
%{_includedir}/OGRE/Plugins/ParticleFX/*.h
|
||||
%dir %{_includedir}/OGRE/Property
|
||||
%{_includedir}/OGRE/Property/*.h
|
||||
%dir %{_includedir}/OGRE/RTShaderSystem
|
||||
%{_includedir}/OGRE/RTShaderSystem/*.h
|
||||
%dir %{_includedir}/OGRE/RenderSystems
|
||||
%dir %{_includedir}/OGRE/RenderSystems/GL
|
||||
%dir %{_includedir}/OGRE/RenderSystems/GL/GL
|
||||
%{_includedir}/OGRE/RenderSystems/GL/GL/*.h
|
||||
%dir %{_includedir}/OGRE/RenderSystems/GL/GLX
|
||||
%{_includedir}/OGRE/RenderSystems/GL/GLX/*.h
|
||||
%{_includedir}/OGRE/RenderSystems/GL/*.h
|
||||
%dir %{_includedir}/OGRE/Terrain
|
||||
%{_includedir}/OGRE/Terrain/*.h
|
||||
%dir %{_includedir}/OGRE/Threading
|
||||
%{_includedir}/OGRE/Threading/*.h
|
||||
#%dir %{_includedir}/OGRE/Volume
|
||||
#%{_includedir}/OGRE/Volume/*.h
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/OGRE/cmake/*.cmake
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Aug 31 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.1-1mamba
|
||||
- update to 1.8.1
|
||||
- revert to stable 1.8.1 for stuntrally (bump up epoch)
|
||||
|
||||
* Sun Aug 31 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.20140831hg-1mamba
|
||||
- update to 1.9.20140831hg
|
||||
- move devel files to -devel package
|
||||
|
||||
* Mon Dec 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.0-2mamba
|
||||
- rebuilt with boost 1.55
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user