rebuilt in devel [release 0.4-2mamba;Tue Oct 09 2012]
This commit is contained in:
parent
b9aac312a8
commit
506cb48ad3
12
README.md
12
README.md
@ -1,2 +1,14 @@
|
|||||||
# odt2txt
|
# odt2txt
|
||||||
|
|
||||||
|
odt2txt is a command-line tool which extracts the text out of OpenDocument Texts produced by OpenOffice.org, StarOffice, KOffice and others.
|
||||||
|
odt2txt can also extract text from some file formats similar to OpenDocument Text, such as OpenOffice.org XML (*.sxw), which was used by OpenOffice.org version 1.x and older StarOffice versions. To a lesser extend, odt2txt may be useful to extract content from OpenDocument spreadsheets (*.ods) and OpenDocument presentations (*.odp).
|
||||||
|
|
||||||
|
Features:
|
||||||
|
* small
|
||||||
|
* supports multiple output encodings
|
||||||
|
* adopts to your locale
|
||||||
|
* able to substitute common characters which the output charset does not contain with ascii look-a-likes
|
||||||
|
* written in C, has few dependencies
|
||||||
|
* portable (runs on Linux, *BSD, Mac OS X, Windows, Cygwin, Solaris, HP-UX)
|
||||||
|
* licensed under GPL, version 2
|
||||||
|
|
||||||
|
25
odt2txt-0.4-Makefile.patch
Normal file
25
odt2txt-0.4-Makefile.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
--- Makefile 2008-06-23 21:32:28.000000000 +0200
|
||||||
|
+++ Makefile-gil 2010-10-21 07:11:24.000000000 +0200
|
||||||
|
@@ -23,8 +23,8 @@
|
||||||
|
INSTALL = install
|
||||||
|
GROFF = groff
|
||||||
|
|
||||||
|
-DESTDIR = /usr/local
|
||||||
|
-PREFIX =
|
||||||
|
+DESTDIR =
|
||||||
|
+PREFIX = /usr
|
||||||
|
BINDIR = $(PREFIX)/bin
|
||||||
|
MANDIR = $(PREFIX)/share/man
|
||||||
|
MAN1DIR = $(MANDIR)/man1
|
||||||
|
@@ -88,9 +88,9 @@
|
||||||
|
|
||||||
|
install: $(BIN) $(MAN)
|
||||||
|
$(INSTALL) -d -m755 $(DESTDIR)$(BINDIR)
|
||||||
|
- $(INSTALL) $(BIN) $(DESTDIR)$(BINDIR)
|
||||||
|
+ $(INSTALL) -p -m755 $(BIN) $(DESTDIR)$(BINDIR)
|
||||||
|
$(INSTALL) -d -m755 $(DESTDIR)$(MAN1DIR)
|
||||||
|
- $(INSTALL) $(MAN) $(DESTDIR)$(MAN1DIR)
|
||||||
|
+ $(INSTALL) -p -m644 $(MAN) $(DESTDIR)$(MAN1DIR)
|
||||||
|
|
||||||
|
odt2txt.html: $(MAN)
|
||||||
|
$(GROFF) -Thtml -man $(MAN) > $@
|
57
odt2txt.spec
Normal file
57
odt2txt.spec
Normal file
@ -0,0 +1,57 @@
|
|||||||
|
Name: odt2txt
|
||||||
|
Version: 0.4
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: Converts an OpenDocument or OpenOffice.org XML File to raw text
|
||||||
|
Group: Applications/Text
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://stosberg.net/odt2txt/
|
||||||
|
Source0: http://stosberg.net/odt2txt/odt2txt-%{version}.tar.gz
|
||||||
|
Patch0: odt2txt-0.4-Makefile.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
odt2txt is a command-line tool which extracts the text out of OpenDocument Texts produced by OpenOffice.org, StarOffice, KOffice and others.
|
||||||
|
odt2txt can also extract text from some file formats similar to OpenDocument Text, such as OpenOffice.org XML (*.sxw), which was used by OpenOffice.org version 1.x and older StarOffice versions. To a lesser extend, odt2txt may be useful to extract content from OpenDocument spreadsheets (*.ods) and OpenDocument presentations (*.odp).
|
||||||
|
|
||||||
|
Features:
|
||||||
|
* small
|
||||||
|
* supports multiple output encodings
|
||||||
|
* adopts to your locale
|
||||||
|
* able to substitute common characters which the output charset does not contain with ascii look-a-likes
|
||||||
|
* written in C, has few dependencies
|
||||||
|
* portable (runs on Linux, *BSD, Mac OS X, Windows, Cygwin, Solaris, HP-UX)
|
||||||
|
* licensed under GPL, version 2
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0
|
||||||
|
|
||||||
|
%build
|
||||||
|
%make CFLAGS="$RPM_OPT_FLAGS"
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/odt2txt
|
||||||
|
%{_mandir}/man1/odt2txt.1.gz
|
||||||
|
%doc GPL-2
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Oct 09 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4-2mamba
|
||||||
|
- rebuilt in devel
|
||||||
|
|
||||||
|
* Thu Oct 21 2010 gil <puntogil@libero.it> 0.4-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user