update to 7.6.2 [release 7.6.2-1mamba;Wed Jun 01 2022]

This commit is contained in:
Silvan Calarco 2024-01-06 08:05:33 +01:00
parent 2048c99852
commit b70dd59d1f
3 changed files with 46 additions and 8 deletions

View File

@ -0,0 +1,18 @@
--- occt-7.6.0/CMakeLists.txt.orig 2022-06-02 15:37:32.868338814 +0200
+++ occt-7.6.0/CMakeLists.txt 2022-06-02 15:37:42.915275211 +0200
@@ -979,12 +979,12 @@
endif()
# change custom.bat/sh
-if (EXISTS "${INSTALL_DIR}/${INSTALL_DIR_SCRIPT}/custom.${SCRIPT_EXT}")
- file (READ "${INSTALL_DIR}/${INSTALL_DIR_SCRIPT}/custom.${SCRIPT_EXT}" CUSTOM_CONTENT)
+if (EXISTS "${INSTALL_DIR_SCRIPT}/custom.${SCRIPT_EXT}")
+ file (READ "${INSTALL_DIR_SCRIPT}/custom.${SCRIPT_EXT}" CUSTOM_CONTENT)
set (CUSTOM_CONTENT "${CUSTOM_CONTENT} ${ADDITIONAL_CUSTOM_CONTENT}")
- file (WRITE "${INSTALL_DIR}/${INSTALL_DIR_SCRIPT}/custom.${SCRIPT_EXT}" "${CUSTOM_CONTENT}")
+ file (WRITE "${INSTALL_DIR_SCRIPT}/custom.${SCRIPT_EXT}" "${CUSTOM_CONTENT}")
else()
OCCT_CONFIGURE_AND_INSTALL ("adm/templates/custom.${SCRIPT_EXT}.main" "custom.${SCRIPT_EXT}" "custom.${SCRIPT_EXT}" "${INSTALL_DIR_SCRIPT}")
endif()

View File

@ -0,0 +1,13 @@
diff --git a/adm/cmake/occt_macros.cmake b/adm/cmake/occt_macros.cmake
index 0a387945..e3f13923 100644
--- a/adm/cmake/occt_macros.cmake
+++ b/adm/cmake/occt_macros.cmake
@@ -592,7 +592,7 @@ macro (OCCT_UPDATE_TARGET_FILE)
"cmake_policy(PUSH)
cmake_policy(SET CMP0007 NEW)
string (TOLOWER \"\${CMAKE_INSTALL_CONFIG_NAME}\" CMAKE_INSTALL_CONFIG_NAME_LOWERCASE)
- file (GLOB ALL_OCCT_TARGET_FILES \"${INSTALL_DIR}/${INSTALL_DIR_CMAKE}/OpenCASCADE*Targets-\${CMAKE_INSTALL_CONFIG_NAME_LOWERCASE}.cmake\")
+ file (GLOB ALL_OCCT_TARGET_FILES \"\$ENV{DESTDIR}${INSTALL_DIR}/${INSTALL_DIR_CMAKE}/OpenCASCADE*Targets-\${CMAKE_INSTALL_CONFIG_NAME_LOWERCASE}.cmake\")
foreach(TARGET_FILENAME \${ALL_OCCT_TARGET_FILES})
file (STRINGS \"\${TARGET_FILENAME}\" TARGET_FILE_CONTENT)
file (REMOVE \"\${TARGET_FILENAME}\")

View File

@ -1,5 +1,6 @@
%define gitver %(echo %version | tr . _)
Name: occt Name: occt
Version: 7.6.0 Version: 7.6.2
Release: 1mamba Release: 1mamba
Summary: Open CASCADE Technology (OCCT) full-scale 3D geometry library Summary: Open CASCADE Technology (OCCT) full-scale 3D geometry library
Group: System/Libraries Group: System/Libraries
@ -7,16 +8,14 @@ Vendor: openmamba
Distribution: openmamba Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it> Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://dev.opencascade.org/ URL: https://dev.opencascade.org/
Source: https://git.dev.opencascade.org/repos/occt.git/V%{version}/occt-%{version}.tar.bz2 Source: https://git.dev.opencascade.org/repos/occt.git/V%{gitver}/occt-%{version}.tar.bz2
Patch0: occt-7.6.0-cmake.patch Patch0: occt-7.6.0-cmake.patch
Patch1: occt-7.6.2-cmake-fix2.patch
Patch2: occt-7.6.2-cmake-install.patch
License: GPL License: GPL
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
BuildRequires: libICE-devel
BuildRequires: libSM-devel
BuildRequires: libX11-devel BuildRequires: libX11-devel
BuildRequires: libXext-devel
BuildRequires: libXt-devel
BuildRequires: libfontconfig-devel BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel BuildRequires: libfreetype-devel
BuildRequires: libgcc BuildRequires: libgcc
@ -28,6 +27,7 @@ BuildRequires: libtk-devel
BuildRequires: libvtk-devel BuildRequires: libvtk-devel
## AUTOBUILDREQ-END ## AUTOBUILDREQ-END
BuildRequires: cmake BuildRequires: cmake
BuildRequires: libvtk-devel >= 9.1.0-2mamba
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release} Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: oce Provides: oce
Obsoletes: oce <= 0.17.2 Obsoletes: oce <= 0.17.2
@ -63,20 +63,24 @@ This package contains libraries and header files for developing applications tha
#-D -T #-D -T
#:<< _EOF #:<< _EOF
%patch0 -p1 -b .cmake %patch0 -p1 -b .cmake
%patch1 -p1 -b .cmake-fix2
%patch2 -p1 -b .occt-7.6.2-cmake-install.patch
%build %build
#:<< _EOF #:<< _EOF
# cmake uses $ENV{DESTDIR} to create cmake_install file # cmake uses $ENV{DESTDIR} to create cmake_install file
export DESTDIR=%{buildroot} export DESTDIR=%{buildroot}
%cmake -d build \ %cmake -d build \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DUSE_TBB=True \ -DUSE_TBB=True \
-DUSE_VTK=True \ -DUSE_VTK=True \
-DINSTALL_VTK=False \ -DINSTALL_VTK=False \
-D3RDPARTY_VTK_LIBRARY_DIR=%{_libdir} \ -D3RDPARTY_VTK_LIBRARY_DIR=%{_libdir} \
-D3RDPARTY_VTK_INCLUDE_DIR=%{_includedir}/vtk-8.2 \ -D3RDPARTY_VTK_INCLUDE_DIR=%{_includedir}/vtk \
-DINSTALL_DIR_LIB=%{_lib} \ -DINSTALL_DIR_LIB=%{_lib} \
-DINSTALL_DIR_CMAKE=%{_lib}/cmake/%{name} -DINSTALL_DIR_CMAKE=%{_lib}/cmake/%{name} \
-Wno-dev
%make %make
@ -123,5 +127,8 @@ chmod 0755 %{buildroot}%{_bindir}/*.sh
%doc README.txt %doc README.txt
%changelog %changelog
* Wed Jun 01 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 7.6.2-1mamba
- update to 7.6.2
* Sun Jan 23 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 7.6.0-1mamba * Sun Jan 23 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 7.6.0-1mamba
- package created using the webbuild interface - package created using the webbuild interface