ocaml-ounit/ocaml-ounit.spec

88 lines
2.3 KiB
RPMSpec

## this macro only works for packages with name matching the regexp "ocaml-.*"
%define ocamlpck oUnit
Name: ocaml-ounit
Version: 2.0.0
Release: 1mamba
Summary: Ocaml Unit testing framework
Group: System/Libraries/OCaml
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://ounit.forge.ocamlcore.org/
Source: http://forge.ocamlcore.org/frs/download.php/1258/ounit-%{version}.tar.gz
License: MIT
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
## AUTOBUILDREQ-END
BuildRequires: ocaml
BuildRequires: ocaml-camlp4-devel
BuildRequires: ocaml-findlib
Requires: ocaml-runtime
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Ocaml Unit testing framework.
## remove the following two blocks if there's no devel files
%package devel
Group: Development/Libraries/OCaml
Summary: Development files for %{name}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
This package contains libraries and signature files for developing applications that use %{name}.
%prep
%setup -q -n ounit-%{version}
%build
./configure \
--prefix %{_prefix} \
--localstatedir %{_localstatedir} \
--sharedstatedir %{_sharedstatedir} \
--sysconfdir %{_sysconfdir} \
--enable-tests \
--enable-docs \
--destdir=%{buildroot}
%make all -j1
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
export OCAMLFIND_DESTDIR=%{buildroot}$(ocamlfind printconf destdir)
export DLLDIR=$OCAMLFIND_DESTDIR/stublibs
install -d $OCAMLFIND_DESTDIR/%{ocamlpck}
install -d $OCAMLFIND_DESTDIR/stublibs
%makeinstall
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%dir %{_libdir}/ocaml/%{ocamlpck}
%{_libdir}/ocaml/%{ocamlpck}/META
%{_libdir}/ocaml/%{ocamlpck}/*.cma
%{_libdir}/ocaml/%{ocamlpck}/*.cmi
%{_libdir}/ocaml/%{ocamlpck}/*.cmxs
%{_libdir}/ocaml/%{ocamlpck}/*.ml
%doc LICENSE.txt
%files devel
%defattr(-,root,root)
%{_libdir}/ocaml/%{ocamlpck}/*.a
%{_libdir}/ocaml/%{ocamlpck}/*.cmx
%{_libdir}/ocaml/%{ocamlpck}/*.cmxa
%{_libdir}/ocaml/%{ocamlpck}/*.mli
%dir %{_docdir}/ounit
%{_docdir}/ounit/*
#%doc CHANGES README
#%doc doc/html/
%changelog
* Thu May 26 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.0-1mamba
- package created using the webbuild interface