automatic version update by autodist [release 2.8.2-1mamba;Wed Apr 10 2024]

This commit is contained in:
Automatic Build System 2024-04-11 19:10:46 +02:00
parent 7d69696b03
commit 5d0fcdbdd3
5 changed files with 168 additions and 74 deletions

View File

@ -1,4 +1,5 @@
# nut
nut is nutrition software to record what you eat and analyze your meals for nutrient composition. The database included is the latest USDA Nutrient Database for Standard Reference. This database contains values for vitamins, minerals, fats, calories, protein, carbohydrates, fiber, etc., and includes the essential polyunsaturated fats, Omega-3 and Omega-6. Nutrient levels are expressed as a percentage of the Daily Value, the familiar standard of food labeling in the United States, but also can be fully customized. Foods can be added from recipes or food labels, and nutrient intake can be graphed. The program is completely menu-driven and there are no commands to learn.
Network UPS Tools is a collection of programs which provide a common interface for monitoring and administering UPS, PDU and SCD hardware.
It uses a layered approach to connect all of the parts.

View File

@ -1,17 +0,0 @@
diff -Nru nut-17.7.orig/Makefile nut-17.7/Makefile
--- nut-17.7.orig/Makefile 2012-04-24 19:13:25.000000000 +0200
+++ nut-17.7/Makefile 2012-04-26 10:54:16.000000000 +0200
@@ -1,10 +1,10 @@
-prefix = /usr/local
+prefix = $(DESTDIR)/usr
libdir = $(prefix)/lib/nut
bindir = $(prefix)/bin
-mandir = $(prefix)/man/man1
+mandir = $(prefix)/share/man/man1
NUTDIR := \".nutdb\"
-FOODDIR := \"$(libdir)\"
+FOODDIR := \"/usr/lib/nut\"
EXECUTABLE := nut
LIBS := -lm

214
nut.spec
View File

@ -1,89 +1,191 @@
Name: nut
Version: 19.2
Version: 2.8.2
Release: 1mamba
Summary: nut is nutrition software to record what you eat and analyze your meals for nutrient composition.
Group: Graphical Desktop/Applications/Scientific
Summary: A collection of network UPS tools
Group: System/Kernel and Hardware
Vendor: openmamba
Distribution: openmamba
Packager: Ercole 'ercolinux' Carpanetto <ercole69@gmail.com>
URL: http://nut.sourceforge.net/
Source: http://downloads.sourceforge.net/project/nut/nut/%{version}/nut-%{version}.tar.gz
Patch0: nut-17.11-makefile.patch
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://networkupstools.org/
Source: https://github.com/networkupstools/nut.git/v%{version}/nut-%{version}.tar.bz2
Source1: nut.sysusers
Source2: nut.tmpfiles
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libgcc
BuildRequires: libgd-devel
BuildRequires: libi2c-devel
BuildRequires: libltdl-devel
BuildRequires: libneon-devel
BuildRequires: libnetsnmp-devel
BuildRequires: libnsl-devel
BuildRequires: libopenssl-devel
BuildRequires: libpython27-devel
BuildRequires: libpython311-devel
BuildRequires: libstdc++6-devel
BuildRequires: libsystemd-devel
BuildRequires: libusb-devel
BuildRequires: libwrap-devel
## AUTOBUILDREQ-END
BuildRequires: libfltk-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-root
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
%description
Network UPS Tools is a collection of programs which provide a common interface for monitoring and administering UPS, PDU and SCD hardware.
It uses a layered approach to connect all of the parts.
%package -n lib%{name}
Group: System/Libraries
Summary: Shared libraries for %{name}
%description -n lib%{name}
This package contains shared libraries for %{name}.
%package -n lib%{name}-devel
Group: Development/Libraries
Summary: Development files for %{name}
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
Requires: pkg-config
%description -n lib%{name}-devel
This package contains libraries and header files for developing applications that use %{name}.
%debug_package
%description
nut is nutrition software to record what you eat and analyze your meals for nutrient composition. The database included is the latest USDA Nutrient Database for Standard Reference. This database contains values for vitamins, minerals, fats, calories, protein, carbohydrates, fiber, etc., and includes the essential polyunsaturated fats, Omega-3 and Omega-6. Nutrient levels are expressed as a percentage of the Daily Value, the familiar standard of food labeling in the United States, but also can be fully customized. Foods can be added from recipes or food labels, and nutrient intake can be graphed. The program is completely menu-driven and there are no commands to learn.
%prep
%setup -q
%patch -p1
./autogen.sh
%build
%configure \
--sysconfdir=%{_sysconfdir}/nut \
--datadir=%{_datadir}/nut \
--with-udev-dir=%{_prefix}/lib/udev \
--disable-static \
--with-user=nut \
--with-group=nut \
--with-altpidpath=/run/nut \
--with-cgipath=%{_datadir}/nut/cgi \
--with-drvpath=%{_libdir}/nut \
--with-htmlpath=%{_datadir}/nut/html \
--with-pidpath=/run/nut \
--with-statepath=/var/lib/nut \
--with-systemdsystemunitdir=/usr/lib/systemd/system \
--with-udev-dir=/usr/lib/udev \
--with-cgi \
--with-dev \
--with-doc=man \
--with-libltdl \
--with-neon \
--with-openssl \
--with-serial \
--with-snmp \
--with-usb
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
find %{buildroot}%{_sysconfdir}/nut -name *.sample -exec rename '.sample' '' {} \;
install -D -m0644 %{SOURCE1} %{buildroot}%{_sysusersdir}/nut.conf
#install -D -m0644 %{SOURCE2} %{buildroot}%{_tmpfilesdir}/nut.conf
mv %{buildroot}%{_tmpfilesdir}/nut{-common-tmpfiles,}.conf
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%pre
%sysusers_create_package nut %{SOURCE1}
:
%post
%tmpfiles_create %{name}.conf
:
%post -n lib%{name} -p /sbin/ldconfig
%postun -n lib%{name} -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_bindir}/nut
%{_bindir}/Nut
%dir %{_prefix}/lib/nut
#%{_prefix}/lib/nut/FOOD_DES.txt
#%{_prefix}/lib/nut/NUT_DATA.txt
%{_prefix}/lib/nut/WEIGHT.lib
#%{_prefix}/lib/nut/WEIGHT.txt
%{_prefix}/lib/nut/sr26.nut
%{_mandir}/man1/nut.1.gz
%doc CREDITS LICENSE
%config(noreplace) %{_sysconfdir}/nut/hosts.conf
%config(noreplace) %{_sysconfdir}/nut/nut.conf
%config(noreplace) %{_sysconfdir}/nut/ups.conf
%config(noreplace) %{_sysconfdir}/nut/upsd.conf
%config(noreplace) %{_sysconfdir}/nut/upsd.users
%config(noreplace) %{_sysconfdir}/nut/upsmon.conf
%config(noreplace) %{_sysconfdir}/nut/upsset.conf
%config(noreplace) %{_sysconfdir}/nut/upsstats-single.html
%config(noreplace) %{_sysconfdir}/nut/upsstats.html
%config(noreplace) %{_sysconfdir}/nut/upssched.conf
%{_bindir}/*
%{_sbindir}/ups*
%{_udevrulesdir}/62-nut-usbups.rules
%{_unitdir}/nut-driver-enumerator.path
%{_unitdir}/nut-driver-enumerator.service
%{_unitdir}/nut-driver-enumerator-daemon-activator.path
%{_unitdir}/nut-driver-enumerator-daemon-activator.service
%{_unitdir}/nut-driver-enumerator-daemon.service
%{_unitdir}/nut-driver.target
%{_unitdir}/nut-driver@.service
%{_unitdir}/nut-monitor.service
%{_unitdir}/nut-server.service
%{_unitdir}/nut.target
%{_systemd_util_dir}/system-shutdown/nutshutdown
%{_sysusersdir}/nut.conf
%{_tmpfilesdir}/nut.conf
%{python27_sitearch}/PyNUT.py
%{python27_sitearch}/test_nutclient.py
%{python3_sitearch}/PyNUT.py
%{python3_sitearch}/test_nutclient.py
%{_datadir}/augeas/lenses/dist/nut*.aug
%dir %{_datadir}/nut
%{_datadir}/nut/*
%dir %{_datadir}/nut-monitor
%{_datadir}/nut-monitor/*
%{_mandir}/man5/*.5*
%{_mandir}/man8/*.8*
%files -n lib%{name}
%defattr(-,root,root)
%{_libdir}/libnutclient.so.*
%{_libdir}/libnutclientstub.so.*
%{_libdir}/libnutscan.so.*
%{_libdir}/libupsclient.so.*
%dir %{_libdir}/nut
%{_libdir}/nut/*
%{_libexecdir}/nut-driver-enumerator.sh
%{_libexecdir}/sockdebug
%doc AUTHORS COPYING
%files -n lib%{name}-devel
%defattr(-,root,root)
%{_includedir}/*.h
%{_libdir}/libnutclient.so
%{_libdir}/libnutclientstub.so
%{_libdir}/libnutscan.so
%{_libdir}/libupsclient.so
%{_libdir}/pkgconfig/libnutclient.pc
%{_libdir}/pkgconfig/libnutclientstub.pc
%{_libdir}/pkgconfig/libnutscan.pc
%{_libdir}/pkgconfig/libupsclient.pc
%{_mandir}/man3/*.3*
%doc NEWS README
%changelog
* Fri Jul 11 2014 Automatic Build System <autodist@mambasoft.it> 19.2-1mamba
- automatic update by autodist
* Wed May 28 2014 Automatic Build System <autodist@mambasoft.it> 19.1-1mamba
- automatic update by autodist
* Sun Sep 08 2013 Automatic Build System <autodist@mambasoft.it> 19.0-1mamba
- automatic update by autodist
* Mon Aug 05 2013 Automatic Build System <autodist@mambasoft.it> 18.10-1mamba
- automatic update by autodist
* Sun May 19 2013 Automatic Build System <autodist@mambasoft.it> 18.9-1mamba
- automatic update by autodist
* Sun Apr 07 2013 Automatic Build System <autodist@mambasoft.it> 18.6-1mamba
* Wed Apr 10 2024 Automatic Build System <autodist@openmamba.org> 2.8.2-1mamba
- automatic version update by autodist
* Fri Jan 18 2013 Automatic Build System <autodist@mambasoft.it> 18.5-1mamba
* Mon Dec 04 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.1-2mamba
- fix for duplicate tmpfilesdir conf provided
* Wed Nov 08 2023 Automatic Build System <autodist@mambasoft.it> 2.8.1-1mamba
- automatic version update by autodist
* Thu Oct 18 2012 Automatic Build System <autodist@mambasoft.it> 18.2-1mamba
- automatic version update by autodist
* Wed Jun 22 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.0-2mamba
- fix run path, sysusers and tmpfiles
* Wed Aug 22 2012 Automatic Build System <autodist@mambasoft.it> 17.12-1mamba
- automatic version update by autodist
* Mon Aug 13 2012 Automatic Build System <autodist@mambasoft.it> 17.11-1mamba
- automatic version update by autodist
* Wed May 23 2012 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 17.9-1mamba
- update to 17.9
* Fri May 11 2012 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 17.8-1mamba
- updated to 17.8
* Thu Apr 26 2012 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 17.7-1mamba
- package created by autospec
* Wed Jun 22 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.0-1mamba
- package created using the webbuild interface

2
nut.sysusers Normal file
View File

@ -0,0 +1,2 @@
u nut - "Network UPS Tools" /var/lib/nut
m nut uucp

6
nut.tmpfiles Normal file
View File

@ -0,0 +1,6 @@
d /run/nut 0700 nut nut -
d /var/lib/nut 0700 nut nut -
z /etc/nut/upsd.conf 0640 root nut -
z /etc/nut/upsd.users 0640 root nut -
z /etc/nut/upsmon.conf 0640 root nut -