rebuilt without xmms

added patch to support recent libaudiofile versions [release 0.7.7-3mamba;Thu Feb 28 2013]
This commit is contained in:
Silvan Calarco 2024-01-06 07:42:46 +01:00
parent 621fddeb8f
commit 2ff28771c0
4 changed files with 211 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# normalize # normalize
Normalize is a tool for adjusting the volume of audio files to a standard level.
This is useful for things like creating mixed CD's and mp3 collections, where different recording levels on different albums can cause the volume to vary greatly from song to song.

View File

@ -0,0 +1,54 @@
--- normalize-0.7.7.orig/configure.ac 2013-02-28 01:45:11.289477572 +0100
+++ normalize-0.7.7/configure.ac 2013-02-28 02:08:06.365298840 +0100
@@ -15,6 +15,8 @@
AC_ISC_POSIX
AC_PROG_INSTALL
AC_PROG_LN_S
+AC_PROG_RANLIB
+AC_PROG_LIBTOOL
AC_DOSFILE
@@ -219,34 +221,8 @@
esac ],
AC_DEFINE(USE_LOOKUPTABLE))
-dnl *** Stuff for xmms plugin ***
-have_xmms=true
-AM_PATH_GLIB(1.2.2, , [ have_xmms=false ])
-AM_PATH_GTK(1.2.2, , [ have_xmms=false ], gthread)
-AM_PATH_XMMS(1.0.0, , [ have_xmms=false ])
-AM_DISABLE_STATIC
-AM_PROG_LIBTOOL
-AC_ARG_ENABLE(xmms,
- AC_HELP_STRING([--enable-xmms],
- [build the volume adjust plugin for xmms (default yes)]),
- [ case "$enableval" in
- yes) enable_xmms=true ;;
- no) enable_xmms=false ;;
- *) AC_MSG_ERROR(bad value $enableval for --enable-xmms) ;;
- esac ])
-
-use_xmms=false
-if test x$enable_xmms != xfalse; then
- if test x$have_xmms = xtrue; then
- use_xmms=true
- PLUGINS="xmms-rva $PLUGINS"
- elif test x$enable_xmms = xtrue; then
- AC_MSG_ERROR([--enable-xmms specified, but xmms not found])
- fi
-fi
AC_SUBST(PLUGINS)
-
dnl *** Stuff for audiofile library ***
AC_ARG_WITH(audiofile, AC_HELP_STRING([--with-audiofile],
[use the audiofile library (default yes)]))
@@ -259,7 +235,6 @@
])
AM_CONDITIONAL(AUDIOFILE, test x$with_audiofile = xyes)
-
dnl *** Stuff for mad mpeg audio decoder library ***
AH_TEMPLATE([USE_MAD],
[Define if you want to use the mad mpeg audio decoder library.])

View File

@ -0,0 +1,55 @@
Use pkgconfig to check for audiofile since the audiofile-config script was
removed from >=audiofile-0.3.0.
--- normalize-0.7.7/configure.ac.orig
+++ normalize-0.7.7/configure.ac
@@ -248,33 +248,16 @@
dnl *** Stuff for audiofile library ***
-dnl v0.2.1 and before have bugs with 24-bit LE files
-AM_PATH_AUDIOFILE([ 0.2.2 ], [ have_audiofile=true ])
-dnl AC_CHECK_LIB(audiofile, afSetVirtualSampleFormat, have_audiofile=true)
+AC_ARG_WITH(audiofile, AC_HELP_STRING([--with-audiofile],
+ [use the audiofile library (default yes)]))
AH_TEMPLATE([USE_AUDIOFILE],
[Define if you want to use the audiofile library.])
-AC_ARG_WITH(audiofile,
- AC_HELP_STRING([--with-audiofile],
- [use the audiofile library (default yes)]),
- [ case "$withval" in
- no) with_audiofile=false ;;
- *) with_audiofile=true ;;
- esac ])
-use_audiofile=false
-if test x$with_audiofile != xfalse; then
- if test x$have_audiofile = xtrue; then
- AC_DEFINE(USE_AUDIOFILE)
- use_audiofile=true
-dnl AUDIOFILELIBS="-laudiofile"
- elif test x$with_audiofile = xtrue; then
- AC_MSG_ERROR([--with-audiofile specified, but audiofile library not found])
- fi
-fi
-dnl AC_SUBST(AUDIOFILELIBS)
-test x$use_audiofile = xfalse && AUDIOFILE_LIBS=
-test x$use_audiofile = xfalse && AUDIOFILE_CFLAGS=
-AM_CONDITIONAL(AUDIOFILE, test x$use_audiofile = xtrue)
+AS_IF([test "x$with_audiofile" = "xyes"], [
+ PKG_CHECK_MODULES([AUDIOFILE], [audiofile])
+ AC_DEFINE(USE_AUDIOFILE)
+])
+AM_CONDITIONAL(AUDIOFILE, test x$with_audiofile = xyes)
dnl *** Stuff for mad mpeg audio decoder library ***
@@ -330,7 +313,7 @@
echo
echo "Configuration:"
-echo " audiofile library: $use_audiofile"
+echo " audiofile library: $with_audiofile"
echo " mpeg audio support: $use_mad"
echo " xmms volume adjust plugin: $use_xmms"
echo

99
normalize.spec Normal file
View File

@ -0,0 +1,99 @@
Name: normalize
Version: 0.7.7
Release: 3mamba
Summary: A tool for adjusting the volume of audio files to a standard level
Group: Applications/Multimedia
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www1.cs.columbia.edu/~cvaill/normalize/
Source: http://savannah.nongnu.org/download/normalize/normalize-%{version}.tar.bz2
Patch0: normalize-0.7.7-libaudiofile-0.3.5.patch
Patch1: normalize-0.7.7-autoreconf.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libaudiofile-devel
BuildRequires: libmad-devel
BuildRequires: libstdc++6-devel
BuildRequires: perl-devel
## AUTOBUILDREQ-END
BuildRequires: gettext-devel >= 0.14.5
Requires: /usr/bin/lame
Requires: /usr/bin/oggdec
Requires: /usr/bin/oggenc
Requires: /usr/bin/vorbiscomment
Requires: /usr/bin/flac
Requires: /usr/bin/metaflac
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Normalize is a tool for adjusting the volume of audio files to a standard level.
This is useful for things like creating mixed CD's and mp3 collections, where different recording levels on different albums can cause the volume to vary greatly from song to song.
%package xmms
Summary: Normalize - XMMS plugin to apply volume adjustments
Group: Applications/Multimedia
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Requires: xmms >= 1.0.0
%description xmms
Plugin for XMMS to honor volume adjustments (RVA2 frames) in ID3 tags.
%prep
%setup -q
%patch0 -p1
%patch1 -p1
sed -i "s|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|" configure.ac
touch AUTHORS ChangeLog
%build
aclocal
autoconf
automake --add-missing
libtoolize
autoreconf
%configure \
--with-mad \
--with-audiofile
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
ln -s normalize-mp3 %{buildroot}%{_bindir}/normalize-ogg
%find_lang %{name}
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files -f %{name}.lang
%defattr(-,root,root)
%{_bindir}/normalize
%{_bindir}/normalize-mp3
%{_bindir}/normalize-ogg
%{_mandir}/man1/normalize.*
%{_mandir}/man1/normalize-mp3.*
%doc COPYING
#NEWS README THANKS TODO
#%files xmms
#%defattr(-,root,root)
#%{_libdir}/xmms/Effect/librva.la
#%{_libdir}/xmms/Effect/librva.so
%changelog
* Thu Feb 28 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.7.7-3mamba
- rebuilt without xmms
- added patch to support recent libaudiofile versions
* Sun Jun 01 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.7.7-2mamba
- specfile updated
* Mon Jul 03 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 0.7.7-1qilnx
- update to version 0.7.7 by autospec
* Tue Oct 25 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.7.6-1qilnx
- package created by autospec