automatic version update by autodist [release 0.4.1-1mamba;Thu Feb 28 2013]
This commit is contained in:
parent
cde2623bf1
commit
42ecf97c47
@ -1,2 +1,4 @@
|
||||
# nmapsi4
|
||||
|
||||
NmapSi4 is a complete Qt4-based Gui with the design goals to provide a complete nmap interface for users, in order to management all options of this powerful security net scanner.
|
||||
|
||||
|
41
nmapsi4-0.3.1-gcc-4.7.patch
Normal file
41
nmapsi4-0.3.1-gcc-4.7.patch
Normal file
@ -0,0 +1,41 @@
|
||||
diff --git a/nmapsi4/app/mainwin.h b/nmapsi4/app/mainwin.h
|
||||
index 89f84e2..ce31cfd 100644
|
||||
--- a/nmapsi4/app/mainwin.h
|
||||
+++ b/nmapsi4/app/mainwin.h
|
||||
@@ -57,6 +57,11 @@
|
||||
#include "parser.h"
|
||||
#include "vulnerability.h"
|
||||
|
||||
+// system
|
||||
+#ifndef Q_WS_WIN
|
||||
+#include <unistd.h>
|
||||
+#endif
|
||||
+
|
||||
// define class namespace
|
||||
using namespace internalLookup;
|
||||
using namespace digInterface;
|
||||
@@ -71,7 +76,7 @@ namespace Ui
|
||||
class nmapClass : public QMainWindow, public Ui::MainWindow
|
||||
{
|
||||
Q_OBJECT
|
||||
-
|
||||
+
|
||||
friend class parser;
|
||||
friend class vulnerability;
|
||||
|
||||
diff --git a/nmapsi4/app/preference/profilemain.h b/nmapsi4/app/preference/profilemain.h
|
||||
index 1d7049a..3a79b37 100644
|
||||
--- a/nmapsi4/app/preference/profilemain.h
|
||||
+++ b/nmapsi4/app/preference/profilemain.h
|
||||
@@ -29,6 +29,11 @@
|
||||
#include "utilities.h"
|
||||
#include <ui_profilemain.h>
|
||||
|
||||
+// system
|
||||
+#ifndef Q_WS_WIN
|
||||
+#include <unistd.h>
|
||||
+#endif
|
||||
+
|
||||
class mainProfile : public QDialog, private Ui::ProfileMain
|
||||
{
|
||||
Q_OBJECT
|
64
nmapsi4.spec
Normal file
64
nmapsi4.spec
Normal file
@ -0,0 +1,64 @@
|
||||
Name: nmapsi4
|
||||
Version: 0.4.1
|
||||
Release: 1mamba
|
||||
Summary: Qt4 nmap interface
|
||||
Group: Graphical Desktop/Applications/Networking
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
|
||||
URL: http://www.nmapsi4.org/
|
||||
Source: http://nmapsi4.googlecode.com/files/nmapsi4-%{version}.tar.bz2
|
||||
Patch0: %{name}-0.3.1-gcc-4.7.patch
|
||||
License: GPL
|
||||
BuildRequires: cmake
|
||||
BuildRequires: libqt4-devel
|
||||
Requires: nmap
|
||||
Requires: bind-utils
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
NmapSi4 is a complete Qt4-based Gui with the design goals to provide a complete nmap interface for users, in order to management all options of this powerful security net scanner.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
%cmake -d build
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%attr(0755,root,root) %{_bindir}/nmapsi4*
|
||||
%{_datadir}/applications/kde4/nmapsi4*.desktop
|
||||
%{_datadir}/icons/hicolor/*/apps/nmapsi4.png
|
||||
%{_datadir}/dbus-1/interfaces/org.nmapsi4.Nmapsi4.xml
|
||||
%dir %{_datadir}/nmapsi4
|
||||
%dir %{_datadir}/nmapsi4/locale
|
||||
#%{_datadir}/nmapsi4/locale/nmapsi4-logr_*.qm
|
||||
%{_datadir}/nmapsi4/locale/nmapsi4_*.qm
|
||||
%doc AUTHORS COPYING
|
||||
# NEWS README TODO
|
||||
|
||||
%changelog
|
||||
* Thu Feb 28 2013 Automatic Build System <autodist@mambasoft.it> 0.4.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Jan 07 2013 Automatic Build System <autodist@mambasoft.it> 0.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Oct 18 2012 Automatic Build System <autodist@mambasoft.it> 0.3.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Aug 10 2012 Automatic Build System <autodist@mambasoft.it> 0.3.1-1mamba
|
||||
- update to 0.3.1
|
||||
|
||||
* Mon Nov 29 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 0.2-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user