update to 2.4 [release 2.4-1mamba;Sun May 30 2021]

This commit is contained in:
Silvan Calarco 2024-01-06 07:39:36 +01:00
parent 24aa569d84
commit 59f8792d39
2 changed files with 184 additions and 24 deletions

View File

@ -0,0 +1,152 @@
--- ninja-ide-2.3.20150712git/setup.py.orig 1970-01-01 01:00:00.000000000 +0100
+++ ninja-ide-2.3.20150712git/setup.py 2015-07-12 18:17:24.929470939 +0200
@@ -0,0 +1,149 @@
+#!/usr/bin/env python
+#-*-coding:utf-8-*-
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation, either version 3 of the
+# License, or (at your option) any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+
+# You should have received a copy of the GNU Affero General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+
+###############################################################################
+# DOCS
+###############################################################################
+
+"""Setup for Ninja-ide (http://www.ninja-ide.org)
+
+NINJA-IDE is a cross-platform integrated development environment (IDE).
+NINJA-IDE runs on Linux/X11, Mac OS X and Windows desktop operating systems,
+and allows developers to create applications for several purposes using all the
+tools and utilities of NINJA-IDE, making the task of writing software easier
+and more enjoyable.
+"""
+
+
+###############################################################################
+# IMPORTS
+###############################################################################
+
+import sys
+
+from setuptools import setup, find_packages
+
+import ninja_ide
+
+###############################################################################
+# VALIDATE THE NEEDED MODULES
+###############################################################################
+
+# This modules can't be easy installed
+# Syntax: [(module, url of the tutorial)...]
+if sys.platform == 'win32':
+ NEEDED_MODULES = [("PyQt4",
+ "http://www.riverbankcomputing.co.uk/software/pyqt/intro"),
+ ('win32con', "http://sourceforge.net/projects/pywin32/files/pywin32/")]
+else:
+ NEEDED_MODULES = [("PyQt4",
+ "http://www.riverbankcomputing.co.uk/software/pyqt/intro"), ]
+
+
+for mn, urlm in NEEDED_MODULES:
+ try:
+ __import__(mn)
+ except ImportError:
+ print("Module '%s' not found. For more details: '%s'.\n" % (mn, urlm))
+ sys.exit(1)
+
+
+dependencies = []
+if sys.platform == 'darwin':
+ dependencies.append("macfsevents")
+elif sys.platform == 'linux2':
+ dependencies.append("pyinotify")
+
+
+###############################################################################
+# PRE-SETUP
+###############################################################################
+
+# Common
+params = {
+ "name": ninja_ide.__prj__,
+ "version": ninja_ide.__version__,
+ "description": ninja_ide.__doc__,
+ "author": ninja_ide.__author__,
+ "author_email": ninja_ide.__mail__,
+ "url": ninja_ide.__url__,
+ "license": ninja_ide.__license__,
+ "keywords": "ide python ninja development",
+ "classifiers": ["Development Status :: Development Status :: 4 - Beta",
+ "Topic :: Utilities",
+ "License :: OSI Approved :: GNU General Public License (GPL)",
+ "Natural Language :: English",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python :: 2"],
+
+ # Ninja need:
+ "install_requires": dependencies,
+
+ # include all resources
+ "include_package_data": True,
+ "package_data": {'': ['*.png', '*.gif', '*.jpg', '*.json', '*.qss',
+ '*.js', '*.html', '*.css', '*.qm', '*.qml']},
+
+ # include ninja pkg and setup the run script
+ "packages": find_packages() + [
+ 'ninja_ide/gui/dialogs',
+ 'ninja_ide/gui/dialogs/preferences',
+ 'ninja_ide/gui/editor',
+ 'ninja_ide/gui/editor/checkers',
+ 'ninja_ide/gui/editor/extended_lexers',
+ 'ninja_ide/gui/editor/syntaxes',
+ 'ninja_ide/gui/explorer',
+ 'ninja_ide/gui/qml',
+ 'ninja_ide/gui/qml/img',
+ 'ninja_ide/gui/main_panel',
+ 'ninja_ide/gui/menus',
+ 'ninja_ide/gui/syntax_registry',
+ 'ninja_ide/gui/tools_dock',
+ 'ninja_ide/extensions',
+ 'ninja_ide/extensions/syntax',
+ 'ninja_ide/extensions/theme',
+ 'ninja_ide/tools',
+ 'ninja_ide/tools/locator',
+ 'ninja_ide/intellisensei',
+ 'ninja_ide/img',
+ 'ninja_ide/img/help'],
+
+ #auto create scripts
+ "entry_points": {
+ 'console_scripts': [
+ 'ninja-ide = ninja_ide:setup_and_run',
+ ],
+ 'gui_scripts': [
+ 'ninja-ide = ninja_ide:setup_and_run',
+ ]
+ }
+}
+
+
+###############################################################################
+# SETUP
+###############################################################################
+
+setup(**params)
+
+
+###############################################################################
+# MAIN
+###############################################################################
+
+if __name__ == '__main__':
+ print(__doc__)

View File

@ -1,21 +1,21 @@
Name: ninja-ide Name: ninja-ide
Version: 2.3 Version: 2.4
Release: 1mamba Release: 1mamba
Summary: An IDE specially designed for Python Applications Development Summary: An IDE specially designed for Python Applications Development
Group: Graphical Desktop/Applications/Development Group: Graphical Desktop/Applications/Development
Vendor: openmamba Vendor: openmamba
Distribution: openmamba Distribution: openmamba
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org> Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://ninja-ide.org/ URL: https://github.com/ninja-ide/ninja-ide
Source: https://github.com/ninja-ide/ninja-ide/archive/v%{version}.zip Source: https://github.com/ninja-ide/ninja-ide.git/v%{version}/ninja-ide-%{version}.tar.bz2
Source1: ninja-ide.desktop Source1: ninja-ide.desktop
Source2: ninja-ide.1.gz Source2: ninja-ide.1.gz
Patch0: ninja-ide-2.3.20150712git-setup.py.patch
License: GPL License: GPL
BuildRequires: libpython-devel ## AUTOBUILDREQ-BEGIN
Requires: python >= %python_version ## AUTOBUILDREQ-END
Requires: python-pyinotify Requires: python-pyinotify-py3
Requires: PyQt4 Requires: PyQt5-py3
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildArch: noarch BuildArch: noarch
%description %description
@ -24,38 +24,46 @@ Ninja-IDE allows developers to create applications for several purposes using al
%prep %prep
%setup -q %setup -q
#%patch0 -p1
%build %build
CFLAGS="%{optflags}" %{__python} setup.py build CFLAGS="%{optflags}" %{__python3} setup.py build
%install %install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}" [ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%{__python} setup.py install \ %{__python3} setup.py install \
-O1 --skip-build \ -O1 --skip-build \
--root="%{buildroot}" \ --root="%{buildroot}" \
--install-headers=%{_includedir}/python \ --install-headers=%{python3_inc} \
--install-lib=%{python_sitearch} \ --install-lib=%{python3_sitearch} \
--single-version-externally-managed \
--record=%{name}.filelist --record=%{name}.filelist
sed -i "\,\.egg-info/,d;s,.*/man/.*,&.gz," %{name}.filelist sed -i "\,\.egg-info/,d;s,.*/man/.*,&.gz," %{name}.filelist
install -D -m0755 icon.png \ sed -i "/file_for_tests.cpython/d" %{name}.filelist
%{buildroot}%{_datadir}/pixmaps/ninja-ide.png
install -D -m0644 %{S:1} \
%{buildroot}%{_datadir}/applications/ninja-ide.desktop
install -D -m0644 %{S:2} \
%{buildroot}%{_mandir}/man1/ninja-ide.1.gz
find %{buildroot} -name 'pep8mod.py' | xargs chmod 0755 #install -D -m0755 icon.png \
# %{buildroot}%{_datadir}/pixmaps/ninja-ide.png
#install -D -m0644 %{S:1} \
# %{buildroot}%{_datadir}/applications/ninja-ide.desktop
#install -D -m0644 %{S:2} \
# %{buildroot}%{_mandir}/man1/ninja-ide.1.gz
#find %{buildroot} -name 'pep8mod.py' | xargs chmod 0755
%files -f %{name}.filelist %files -f %{name}.filelist
%defattr(-,root,root) %defattr(-,root,root)
%{_datadir}/pixmaps/*.png %{_datadir}/applications/ninja-ide.desktop
%{_datadir}/applications/*.desktop %dir %{_datadir}/NINJA-IDE/NINJA_IDE-%{version}-py*.egg-info
%{_mandir}/man?/* %{_datadir}/NINJA-IDE/NINJA_IDE-%{version}-py*.egg-info/*
%doc COPYING README.md %doc COPYING README.md
%changelog %changelog
* Sun May 30 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4-1mamba
- update to 2.4
* Sun Jul 12 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.20150712git-1mamba
- update to 2.3.20150712git
* Wed Dec 04 2013 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 2.3-1mamba * Wed Dec 04 2013 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 2.3-1mamba
- package created using the webbuild interface - package created using the webbuild interface