configure with sites-enabled and site-available layout; remove .default configuration files [release 1.21.1-2mamba;Sun Aug 29 2021]
This commit is contained in:
parent
52092c223c
commit
c1fb0de891
8
nginx-1.21.1-conf-sites-enabled.patch
Normal file
8
nginx-1.21.1-conf-sites-enabled.patch
Normal file
@ -0,0 +1,8 @@
|
|||||||
|
--- nginx-1.21.1/conf/nginx.conf.orig 2021-08-29 11:08:19.726594969 +0200
|
||||||
|
+++ nginx-1.21.1/conf/nginx.conf 2021-08-29 11:10:19.197781120 +0200
|
||||||
|
@@ -114,4 +114,5 @@
|
||||||
|
# }
|
||||||
|
#}
|
||||||
|
|
||||||
|
+ include sites-enabled/*;
|
||||||
|
}
|
28
nginx.spec
28
nginx.spec
@ -1,17 +1,18 @@
|
|||||||
Name: nginx
|
Name: nginx
|
||||||
Version: 1.21.1
|
Version: 1.21.1
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: High Performance Load Balancer, Web Server and Reverse Proxy
|
Summary: High Performance Load Balancer, Web Server and Reverse Proxy
|
||||||
Group: System/Servers
|
Group: System/Servers
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://nginx.org/
|
URL: https://nginx.org/
|
||||||
## GITSOURCE https://github.com/nginx/nginx.git release-1.15.5
|
|
||||||
Source: https://github.com/nginx/nginx.git/release-%{version}/nginx-%{version}.tar.bz2
|
Source: https://github.com/nginx/nginx.git/release-%{version}/nginx-%{version}.tar.bz2
|
||||||
Source1: nginx.service
|
Source1: nginx.service
|
||||||
|
Patch0: nginx-1.21.1-conf-sites-enabled.patch
|
||||||
License: BSD
|
License: BSD
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
#libdl.so.2()(64bit): /usr/lib64/libdl.so: file not owned by any package
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libGeoIP-devel
|
BuildRequires: libGeoIP-devel
|
||||||
BuildRequires: libgd-devel
|
BuildRequires: libgd-devel
|
||||||
@ -33,6 +34,7 @@ High Performance Load Balancer, Web Server and Reverse Proxy.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
auto/configure \
|
auto/configure \
|
||||||
@ -80,6 +82,9 @@ auto/configure \
|
|||||||
%makeinstall
|
%makeinstall
|
||||||
|
|
||||||
install -D -m0644 %{SOURCE1} %{buildroot}%{_unitdir}/nginx.service
|
install -D -m0644 %{SOURCE1} %{buildroot}%{_unitdir}/nginx.service
|
||||||
|
install -d -m0755 %{buildroot}%{_sysconfdir}/nginx/sites-{available,enabled}
|
||||||
|
|
||||||
|
rm -f %{buildroot}%{_sysconfdir}/nginx/*.default
|
||||||
|
|
||||||
find %{buildroot} -type f -name perllocal.pod -exec rm -f {} ';'
|
find %{buildroot} -type f -name perllocal.pod -exec rm -f {} ';'
|
||||||
|
|
||||||
@ -102,20 +107,16 @@ find %{buildroot} -type f -name perllocal.pod -exec rm -f {} ';'
|
|||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir %{_sysconfdir}/nginx
|
%dir %{_sysconfdir}/nginx
|
||||||
%config(noreplace) %{_sysconfdir}/nginx/fastcgi.conf
|
%config(noreplace) %{_sysconfdir}/nginx/fastcgi.conf
|
||||||
%{_sysconfdir}/nginx/fastcgi.conf.default
|
|
||||||
%config(noreplace) %{_sysconfdir}/nginx/fastcgi_params
|
%config(noreplace) %{_sysconfdir}/nginx/fastcgi_params
|
||||||
%{_sysconfdir}/nginx/fastcgi_params.default
|
%config(noreplace) %{_sysconfdir}/nginx/mime.types
|
||||||
|
%config(noreplace) %{_sysconfdir}/nginx/nginx.conf
|
||||||
|
%config(noreplace) %{_sysconfdir}/nginx/scgi_params
|
||||||
|
%config(noreplace) %{_sysconfdir}/nginx/uwsgi_params
|
||||||
%{_sysconfdir}/nginx/koi-utf
|
%{_sysconfdir}/nginx/koi-utf
|
||||||
%{_sysconfdir}/nginx/koi-win
|
%{_sysconfdir}/nginx/koi-win
|
||||||
%config(noreplace) %{_sysconfdir}/nginx/mime.types
|
|
||||||
%{_sysconfdir}/nginx/mime.types.default
|
|
||||||
%config(noreplace) %{_sysconfdir}/nginx/nginx.conf
|
|
||||||
%{_sysconfdir}/nginx/nginx.conf.default
|
|
||||||
%config(noreplace) %{_sysconfdir}/nginx/scgi_params
|
|
||||||
%{_sysconfdir}/nginx/scgi_params.default
|
|
||||||
%config(noreplace) %{_sysconfdir}/nginx/uwsgi_params
|
|
||||||
%{_sysconfdir}/nginx/uwsgi_params.default
|
|
||||||
%{_sysconfdir}/nginx/win-utf
|
%{_sysconfdir}/nginx/win-utf
|
||||||
|
%dir %{_sysconfdir}/nginx/sites-available
|
||||||
|
%dir %{_sysconfdir}/nginx/sites-enabled
|
||||||
%{_sbindir}/nginx
|
%{_sbindir}/nginx
|
||||||
%{_unitdir}/nginx.service
|
%{_unitdir}/nginx.service
|
||||||
%dir %{_libdir}/nginx
|
%dir %{_libdir}/nginx
|
||||||
@ -134,6 +135,9 @@ find %{buildroot} -type f -name perllocal.pod -exec rm -f {} ';'
|
|||||||
%{_mandir}/man3/nginx.3pm*
|
%{_mandir}/man3/nginx.3pm*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Aug 29 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.21.1-2mamba
|
||||||
|
- configure with sites-enabled and site-available layout; remove .default configuration files
|
||||||
|
|
||||||
* Tue Jul 06 2021 Automatic Build System <autodist@mambasoft.it> 1.21.1-1mamba
|
* Tue Jul 06 2021 Automatic Build System <autodist@mambasoft.it> 1.21.1-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user