automatic version update by autodist [release 1.5.4-1mamba;Mon Oct 15 2012]

This commit is contained in:
Automatic Build System 2024-01-06 07:37:13 +01:00
parent 61287d974c
commit d01aeb7ec4
5 changed files with 123 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# neverball # neverball
Tilt the floor to roll a ball through an obstacle course before time runs out. Neverball is part puzzle game, part action game, and entirely a test of skill.
Also found here is Neverputt, a hot-seat multiplayer miniature golf game using the physics and graphics of Neverball.

View File

@ -0,0 +1,21 @@
Index: neverball-1.5.4/share/base_image.c
===================================================================
--- neverball-1.5.4.orig/share/base_image.c
+++ neverball-1.5.4/share/base_image.c
@@ -15,6 +15,7 @@
#include <png.h>
#include <jpeglib.h>
#include <stdlib.h>
+#include <string.h>
#include <assert.h>
#include "glext.h"
@@ -94,7 +95,7 @@ static void *image_load_png(const char *
default: longjmp(png_jmpbuf(readp), -1);
}
- if (!(bytep = png_malloc(readp, h * png_sizeof(png_bytep))))
+ if (!(bytep = png_malloc(readp, h * sizeof(png_bytep))))
longjmp(png_jmpbuf(readp), -1);
/* Allocate the final pixel buffer and read pixels there. */

11
neverball.desktop Normal file
View File

@ -0,0 +1,11 @@
[Desktop Entry]
Encoding=UTF-8
GenericName=A 3D platform-base game
GenericName[it]=Gioco di piattaforma 3D
Exec=neverball
Icon=neverball
Name=Neverball
Path=
Terminal=false
Type=Application
Categories=Game;ArcadeGame;

77
neverball.spec Normal file
View File

@ -0,0 +1,77 @@
Name: neverball
Version: 1.5.4
Release: 1mamba
Summary: Neverball is part puzzle game, part action game, and entirely a test of skill
Group: Graphical Desktop/Applications/Games
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://icculus.org/neverball
Source: http://icculus.org/neverball/neverball-%{version}.tar.gz
Source1: neverball.desktop
Source2: neverputt.desktop
Patch0: neverball-1.5.4-libpng-1.6.patch
License: GPL
BuildRoot: %{_tmppath}/%{name}-%{version}-root
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libGL-devel
BuildRequires: libjpeg-devel
BuildRequires: libpng-devel
BuildRequires: libSDL-devel
BuildRequires: libSDL_ttf-devel
BuildRequires: libvorbis-devel
BuildRequires: libX11-devel
## AUTOBUILDREQ-END
BuildRequires: libSDL_mixer-devel >= 1.2.7
BuildRequires: libSDL_image-devel >= 1.2.5
%description
Tilt the floor to roll a ball through an obstacle course before time runs out. Neverball is part puzzle game, part action game, and entirely a test of skill.
Also found here is Neverputt, a hot-seat multiplayer miniature golf game using the physics and graphics of Neverball.
%prep
%setup -q
%patch0 -p1
sed -i "s|CONFIG_DATA .*|CONFIG_DATA \"%{_datadir}/neverball/data\"|" share/base_config.h
sed -i "s|CONFIG_LOCALE .*|CONFIG_LOCALE \"%{_datadir}/neverball/locale\"|" share/base_config.h
%build
%make LDFLAGS="-lX11 -lm"
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
install -d -m0755 %{buildroot}%{_datadir}/neverball
install -D -m0755 neverball %{buildroot}%{_bindir}/neverball
install -D -m0755 neverputt %{buildroot}%{_bindir}/neverputt
install -D -m0644 data/icon/neverball.png %{buildroot}%{_datadir}/pixmaps/neverball.png
install -D -m0644 data/icon/neverputt.png %{buildroot}%{_datadir}/pixmaps/neverputt.png
install -D -m0644 %{SOURCE1} %{buildroot}%{_datadir}/applications/neverball.desktop
install -D -m0644 %{SOURCE2} %{buildroot}%{_datadir}/applications/neverputt.desktop
cp -a data %{buildroot}%{_datadir}/neverball/
cp -a locale %{buildroot}%{_datadir}/neverball/
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{_bindir}/neverball
%{_bindir}/neverputt
%{_datadir}/pixmaps/neverball.png
%{_datadir}/pixmaps/neverputt.png
%{_datadir}/applications/neverball.desktop
%{_datadir}/applications/neverputt.desktop
%dir %{_datadir}/neverball
%{_datadir}/neverball/*
%doc CHANGES COPYING README
%changelog
* Mon Oct 15 2012 Automatic Build System <autodist@mambasoft.it> 1.5.4-1mamba
- automatic version update by autodist
* Tue Feb 17 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.0-1mamba
- automatic update by autodist
* Thu Mar 22 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.0-1qilnx
- package created by autospec

11
neverputt.desktop Normal file
View File

@ -0,0 +1,11 @@
[Desktop Entry]
Encoding=UTF-8
GenericName=A multiplayer miniature golf game
GenericName[it]=Gioco del minigolf multiutente
Exec=neverputt
Icon=neverputt
Name=Neverputt
Path=
Terminal=false
Type=Application
Categories=Game;ArcadeGame;