rebuilt with perl 5.24 [release 5.7.3-2mamba;Wed Nov 09 2016]
This commit is contained in:
parent
d98169a4cb
commit
aa8860ea30
2519
net-snmp-5.7.3-perl-5.24-2.patch
Normal file
2519
net-snmp-5.7.3-perl-5.24-2.patch
Normal file
File diff suppressed because it is too large
Load Diff
158
net-snmp-5.7.3-perl-5.24.patch
Normal file
158
net-snmp-5.7.3-perl-5.24.patch
Normal file
@ -0,0 +1,158 @@
|
||||
diff --git a/perl/ASN/Makefile.PL b/perl/ASN/Makefile.PL
|
||||
index f895a41..0e52b3a 100644
|
||||
--- a/perl/ASN/Makefile.PL
|
||||
+++ b/perl/ASN/Makefile.PL
|
||||
@@ -7,9 +7,7 @@ my $lib_version;
|
||||
# See lib/ExtUtils/MakeMaker.pm for details of how to influence
|
||||
# the contents of the Makefile that is written.
|
||||
|
||||
-%MakeParams = InitMakeParams();
|
||||
-
|
||||
-WriteMakefile(%MakeParams);
|
||||
+WriteMakefile(InitMakeParams());
|
||||
|
||||
Check_Version();
|
||||
|
||||
diff --git a/perl/Makefile.PL b/perl/Makefile.PL
|
||||
index f70f991..ac36c15 100644
|
||||
--- a/perl/Makefile.PL
|
||||
+++ b/perl/Makefile.PL
|
||||
@@ -3,9 +3,7 @@ use Config;
|
||||
use Getopt::Long;
|
||||
require 5;
|
||||
|
||||
-%MakeParams = InitMakeParams();
|
||||
-
|
||||
-WriteMakefile(%MakeParams);
|
||||
+WriteMakefile(InitMakeParams());
|
||||
|
||||
sub InitMakeParams {
|
||||
$nsconfig="net-snmp-config"; # in path by default
|
||||
diff --git a/perl/OID/Makefile.PL b/perl/OID/Makefile.PL
|
||||
index 5d94338..676c439 100644
|
||||
--- a/perl/OID/Makefile.PL
|
||||
+++ b/perl/OID/Makefile.PL
|
||||
@@ -6,11 +6,8 @@ require 5;
|
||||
use Config;
|
||||
use Getopt::Long;
|
||||
my $lib_version;
|
||||
-my %MakeParams = ();
|
||||
|
||||
-%MakeParams = InitMakeParams();
|
||||
-
|
||||
-WriteMakefile(%MakeParams);
|
||||
+WriteMakefile(InitMakeParams());
|
||||
|
||||
Check_Version();
|
||||
|
||||
diff --git a/perl/SNMP/Makefile.PL b/perl/SNMP/Makefile.PL
|
||||
index 928cb67..d7b5a2a 100644
|
||||
--- a/perl/SNMP/Makefile.PL
|
||||
+++ b/perl/SNMP/Makefile.PL
|
||||
@@ -3,15 +3,12 @@ require 5;
|
||||
use Config;
|
||||
use Getopt::Long;
|
||||
my $lib_version;
|
||||
-my %MakeParams = ();
|
||||
my $opts;
|
||||
|
||||
# See lib/ExtUtils/MakeMaker.pm for details of how to influence
|
||||
# the contents of the Makefile that is written.
|
||||
|
||||
-%MakeParams = InitMakeParams();
|
||||
-
|
||||
-WriteMakefile(%MakeParams);
|
||||
+WriteMakefile(InitMakeParams());
|
||||
|
||||
Check_Version();
|
||||
|
||||
diff --git a/perl/TrapReceiver/Makefile.PL b/perl/TrapReceiver/Makefile.PL
|
||||
index 5c9463a..0af6aaf 100644
|
||||
--- a/perl/TrapReceiver/Makefile.PL
|
||||
+++ b/perl/TrapReceiver/Makefile.PL
|
||||
@@ -3,11 +3,8 @@ require 5;
|
||||
use Config;
|
||||
use Getopt::Long;
|
||||
my $lib_version;
|
||||
-my %MakeParams = ();
|
||||
|
||||
-%MakeParams = InitMakeParams();
|
||||
-
|
||||
-WriteMakefile(%MakeParams);
|
||||
+WriteMakefile(InitMakeParams());
|
||||
|
||||
Check_Version();
|
||||
|
||||
diff --git a/perl/agent/Makefile.PL b/perl/agent/Makefile.PL
|
||||
index b4b358a..fe105ea 100644
|
||||
--- a/perl/agent/Makefile.PL
|
||||
+++ b/perl/agent/Makefile.PL
|
||||
@@ -3,11 +3,8 @@ require 5;
|
||||
use Config;
|
||||
use Getopt::Long;
|
||||
my $lib_version;
|
||||
-my %MakeParams = ();
|
||||
|
||||
-%MakeParams = InitMakeParams();
|
||||
-
|
||||
-WriteMakefile(%MakeParams);
|
||||
+WriteMakefile(InitMakeParams());
|
||||
|
||||
Check_Version();
|
||||
|
||||
diff --git a/perl/agent/Support/Makefile.PL b/perl/agent/Support/Makefile.PL
|
||||
index 3a4f200..0dcb3f6 100644
|
||||
--- a/perl/agent/Support/Makefile.PL
|
||||
+++ b/perl/agent/Support/Makefile.PL
|
||||
@@ -3,14 +3,11 @@ require 5;
|
||||
use Config;
|
||||
use Getopt::Long;
|
||||
my $lib_version;
|
||||
-my %MakeParams = ();
|
||||
|
||||
# See lib/ExtUtils/MakeMaker.pm for details of how to influence
|
||||
# the contents of the Makefile that is written.
|
||||
|
||||
-%MakeParams = InitMakeParams();
|
||||
-
|
||||
-WriteMakefile(%MakeParams);
|
||||
+WriteMakefile(InitMakeParams());
|
||||
|
||||
Check_Version();
|
||||
|
||||
diff --git a/perl/agent/default_store/Makefile.PL b/perl/agent/default_store/Makefile.PL
|
||||
index 67d5ff0..5c6a5d6 100644
|
||||
--- a/perl/agent/default_store/Makefile.PL
|
||||
+++ b/perl/agent/default_store/Makefile.PL
|
||||
@@ -3,11 +3,8 @@ require 5;
|
||||
use Config;
|
||||
use Getopt::Long;
|
||||
my $lib_version;
|
||||
-my %MakeParams = ();
|
||||
|
||||
-%MakeParams = InitMakeParams();
|
||||
-
|
||||
-WriteMakefile(%MakeParams);
|
||||
+WriteMakefile(InitMakeParams());
|
||||
|
||||
Check_Version();
|
||||
|
||||
diff --git a/perl/default_store/Makefile.PL b/perl/default_store/Makefile.PL
|
||||
index 54996ab..221d4ed 100644
|
||||
--- a/perl/default_store/Makefile.PL
|
||||
+++ b/perl/default_store/Makefile.PL
|
||||
@@ -3,12 +3,8 @@ require 5;
|
||||
use Config;
|
||||
use Getopt::Long;
|
||||
my $lib_version;
|
||||
-my %MakeParams = ();
|
||||
-
|
||||
-%MakeParams = InitMakeParams();
|
||||
-
|
||||
-WriteMakefile(%MakeParams);
|
||||
|
||||
+WriteMakefile(InitMakeParams());
|
||||
|
||||
sub InitMakeParams {
|
||||
my $opts;
|
||||
--
|
@ -2,7 +2,7 @@
|
||||
|
||||
Name: net-snmp
|
||||
Version: 5.7.3
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: net-snmp is an extensible SNMP agent and library and more
|
||||
Group: Network/Monitoring
|
||||
Vendor: openmamba
|
||||
@ -14,16 +14,19 @@ Source1: net-snmpd.initscript
|
||||
Source2: net-snmptrapd.initscript
|
||||
Source3: net-snmpd.logrotate
|
||||
Source4: net-snmptrapd.logrotate
|
||||
Patch0: net-snmp-5.7.3-perl-5.24.patch
|
||||
Patch1: net-snmp-5.7.3-perl-5.24-2.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libnl-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpci-devel
|
||||
BuildRequires: libperl
|
||||
BuildRequires: libpython-devel
|
||||
BuildRequires: libpython27-devel
|
||||
BuildRequires: libwrap-devel
|
||||
BuildRequires: perl-devel
|
||||
BuildRequires: perl-Term-ReadKey
|
||||
BuildRequires: perl-Tk
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: elfutils-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
@ -130,6 +133,9 @@ This package contains the netsnmp Python module.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
sed -i "s|PYMAKE=python|PYMAKE=%{__python}|" Makefile.in
|
||||
|
||||
%build
|
||||
@ -346,6 +352,9 @@ exit 0
|
||||
%{python_sitearch}/netsnmp_python-*/
|
||||
|
||||
%changelog
|
||||
* Wed Nov 09 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 5.7.3-2mamba
|
||||
- rebuilt with perl 5.24
|
||||
|
||||
* Thu Dec 18 2014 Automatic Build System <autodist@mambasoft.it> 5.7.3-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user