ncurses/ncurses-6.2-20200328.patch
2024-01-06 07:33:58 +01:00

766 lines
30 KiB
Diff

# ncurses 6.2 - patch 20200328 - Thomas E. Dickey
#
# ------------------------------------------------------------------------------
#
# Ncurses 6.2 is at
# ftp.gnu.org:/pub/gnu
#
# Patches for ncurses 6.2 can be found at
# ftp://ftp.invisible-island.net/ncurses/6.2
# http://invisible-mirror.net/archives/ncurses/6.2
#
# ------------------------------------------------------------------------------
# ftp://ftp.invisible-island.net/ncurses/6.2/ncurses-6.2-20200328.patch.gz
# patch by Thomas E. Dickey <dickey@invisible-island.net>
# created Sun Mar 29 01:03:54 UTC 2020
# ------------------------------------------------------------------------------
# Ada95/src/Makefile.in | 10 +++++-----
# NEWS | 7 ++++++-
# VERSION | 2 +-
# dist.mk | 4 ++--
# form/fld_dup.c | 13 ++++++-------
# man/curs_print.3x | 4 ++--
# man/form.3x | 4 ++--
# man/form_field.3x | 4 ++--
# man/form_field_buffer.3x | 4 ++--
# man/form_field_new.3x | 6 +++---
# man/form_field_userptr.3x | 4 ++--
# man/form_fieldtype.3x | 4 ++--
# man/form_new.3x | 4 ++--
# man/form_requestname.3x | 6 +++---
# man/form_userptr.3x | 4 ++--
# man/menu_items.3x | 4 ++--
# man/menu_mark.3x | 4 ++--
# man/menu_new.3x | 4 ++--
# man/menu_pattern.3x | 4 ++--
# man/menu_requestname.3x | 6 +++---
# man/menu_userptr.3x | 4 ++--
# man/mitem_current.3x | 4 ++--
# man/mitem_name.3x | 4 ++--
# man/mitem_new.3x | 4 ++--
# man/mitem_userptr.3x | 4 ++--
# package/debian-mingw/changelog | 4 ++--
# package/debian-mingw64/changelog | 4 ++--
# package/debian/changelog | 4 ++--
# package/mingw-ncurses.nsi | 4 ++--
# package/mingw-ncurses.spec | 2 +-
# package/ncurses.spec | 2 +-
# package/ncursest.spec | 2 +-
# test/move_field.c | 9 +++++----
# 33 files changed, 79 insertions(+), 74 deletions(-)
# ------------------------------------------------------------------------------
Index: Ada95/src/Makefile.in
Prereq: 1.89
--- ncurses-6.2-20200321+/Ada95/src/Makefile.in 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/Ada95/src/Makefile.in 2020-03-28 18:05:56.000000000 +0000
@@ -29,7 +29,7 @@
#
# Author: Juergen Pfeifer, 1996
#
-# $Id: Makefile.in,v 1.89 2020/02/02 23:34:34 tom Exp $
+# $Id: Makefile.in,v 1.90 2020/03/28 18:05:56 Adam.Van.Ymeren Exp $
#
.SUFFIXES:
@@ -273,9 +273,9 @@
@USE_GNAT_PROJECTS@ $(STATIC_DIRS)
@USE_GNAT_PROJECTS@ @cf_ada_config@gprconfig --batch --config=Ada --config=C,,,,@cf_ada_config_C@
@USE_GNAT_PROJECTS@ -rm -f $(GNAT_PROJECT)
-@USE_GNAT_PROJECTS@ $(SHELL) $(srcdir)/library-cfg.sh static $(srcdir)/library.gpr $(CFLAGS_NORMAL) >$(GNAT_PROJECT)
+@USE_GNAT_PROJECTS@ $(SHELL) $(srcdir)/library-cfg.sh static library.gpr $(CFLAGS_NORMAL) >$(GNAT_PROJECT)
@USE_GNAT_PROJECTS@ @echo "Using GNAT Project:"
-@USE_GNAT_PROJECTS@ @-$(SHELL) -c "diff -c $(srcdir)/library.gpr $(GNAT_PROJECT); exit 0"
+@USE_GNAT_PROJECTS@ @-$(SHELL) -c "diff -c library.gpr $(GNAT_PROJECT); exit 0"
@USE_GNAT_PROJECTS@ $(ADAMAKE) $(ADAMAKEFLAGS) -XLIB_KIND=static
@USE_GNAT_PROJECTS@ $(AR) $(ARFLAGS) $@ $(STATIC_C_OBJS)
@USE_GNAT_PROJECTS@ -rm -f $(GNAT_PROJECT)
@@ -311,9 +311,9 @@
@MAKE_ADA_SHAREDLIB@ cp $(SHARED_OBJS) $(BUILD_DIR)/dynamic-obj/
@MAKE_ADA_SHAREDLIB@ @cf_ada_config@gprconfig --batch --config=Ada --config=C,,,,@cf_ada_config_C@
@MAKE_ADA_SHAREDLIB@ -rm -f $(GNAT_PROJECT)
-@MAKE_ADA_SHAREDLIB@ $(SHELL) $(srcdir)/library-cfg.sh dynamic $(srcdir)/library.gpr $(CFLAGS_SHARED) >$(GNAT_PROJECT)
+@MAKE_ADA_SHAREDLIB@ $(SHELL) $(srcdir)/library-cfg.sh dynamic library.gpr $(CFLAGS_SHARED) >$(GNAT_PROJECT)
@MAKE_ADA_SHAREDLIB@ @echo "Making Ada shared-lib:"
-@MAKE_ADA_SHAREDLIB@ @-$(SHELL) -c "diff -c $(srcdir)/library.gpr $(GNAT_PROJECT); exit 0"
+@MAKE_ADA_SHAREDLIB@ @-$(SHELL) -c "diff -c library.gpr $(GNAT_PROJECT); exit 0"
@MAKE_ADA_SHAREDLIB@ $(ADAMAKE) $(ADAMAKEFLAGS) -XLIB_KIND=dynamic
@MAKE_ADA_SHAREDLIB@ -rm -f $(GNAT_PROJECT)
Index: NEWS
Prereq: 1.3466
--- ncurses-6.2-20200321+/NEWS 2020-03-22 00:28:35.000000000 +0000
+++ ncurses-6.2-20200328/NEWS 2020-03-28 23:33:04.000000000 +0000
@@ -26,7 +26,7 @@
-- sale, use or other dealings in this Software without prior written --
-- authorization. --
-------------------------------------------------------------------------------
--- $Id: NEWS,v 1.3466 2020/03/22 00:28:35 tom Exp $
+-- $Id: NEWS,v 1.3469 2020/03/28 23:33:04 tom Exp $
-------------------------------------------------------------------------------
This is a log of changes that ncurses has gone through since Zeyd started
@@ -46,6 +46,11 @@
Changes through 1.9.9e did not credit all contributions;
it is not possible to add this information.
+20200328
+ + correct length of buffer copied in dup_field().
+ + remove "$(srcdir)/" from path of library.gpr, needed for out-of-tree
+ builds of Ada95 (patch by Adam Van Ymeren).
+
20200321
+ improve configure-checks to reduce warnings about unused variables.
+ improve description of error-returns in waddch and waddnstr manual
Index: VERSION
--- ncurses-6.2-20200321+/VERSION 2020-03-21 12:15:18.000000000 +0000
+++ ncurses-6.2-20200328/VERSION 2020-03-28 10:37:50.000000000 +0000
@@ -1 +1 @@
-5:0:10 6.2 20200321
+5:0:10 6.2 20200328
Index: dist.mk
Prereq: 1.1342
--- ncurses-6.2-20200321+/dist.mk 2020-03-21 12:15:18.000000000 +0000
+++ ncurses-6.2-20200328/dist.mk 2020-03-28 10:37:50.000000000 +0000
@@ -26,7 +26,7 @@
# use or other dealings in this Software without prior written #
# authorization. #
##############################################################################
-# $Id: dist.mk,v 1.1342 2020/03/21 12:15:18 tom Exp $
+# $Id: dist.mk,v 1.1343 2020/03/28 10:37:50 tom Exp $
# Makefile for creating ncurses distributions.
#
# This only needs to be used directly as a makefile by developers, but
@@ -38,7 +38,7 @@
# These define the major/minor/patch versions of ncurses.
NCURSES_MAJOR = 6
NCURSES_MINOR = 2
-NCURSES_PATCH = 20200321
+NCURSES_PATCH = 20200328
# We don't append the patch to the version, since this only applies to releases
VERSION = $(NCURSES_MAJOR).$(NCURSES_MINOR)
Index: form/fld_dup.c
Prereq: 1.15
--- ncurses-6.2-20200321+/form/fld_dup.c 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/form/fld_dup.c 2020-03-29 00:39:41.000000000 +0000
@@ -33,7 +33,7 @@
#include "form.priv.h"
-MODULE_ID("$Id: fld_dup.c,v 1.15 2020/02/02 23:34:34 tom Exp $")
+MODULE_ID("$Id: fld_dup.c,v 1.17 2020/03/29 00:39:41 tom Exp $")
/*---------------------------------------------------------------------------
| Facility : libnform
@@ -61,8 +61,8 @@
{
T((T_CREATE("field %p"), (void *)New_Field));
*New_Field = *_nc_Default_Field;
- New_Field->frow = (short) frow;
- New_Field->fcol = (short) fcol;
+ New_Field->frow = (short)frow;
+ New_Field->fcol = (short)fcol;
New_Field->link = New_Field;
New_Field->rows = field->rows;
New_Field->cols = field->cols;
@@ -80,13 +80,12 @@
if (_nc_Copy_Type(New_Field, field))
{
- size_t i, len;
+ size_t len;
len = Total_Buffer_Size(New_Field);
- if ((New_Field->buf = (FIELD_CELL *)malloc(len)))
+ if ((New_Field->buf = (FIELD_CELL *)malloc(len * 20)))
{
- for (i = 0; i < len; ++i)
- New_Field->buf[i] = field->buf[i];
+ memcpy(New_Field->buf, field->buf, len);
returnField(New_Field);
}
}
Index: man/curs_print.3x
Prereq: 1.14
--- ncurses-6.2-20200321+/man/curs_print.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/curs_print.3x 2020-03-28 19:06:28.000000000 +0000
@@ -27,7 +27,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: curs_print.3x,v 1.14 2020/02/02 23:34:34 tom Exp $
+.\" $Id: curs_print.3x,v 1.15 2020/03/28 19:06:28 tom Exp $
.TH curs_print 3X ""
.SH NAME
\fBmcprint\fR \- ship binary data to printer
@@ -51,7 +51,7 @@
.SH RETURN VALUE
The \fBmcprint\fR function returns \fBERR\fR if the write operation aborted
for some reason.
-In this case, errno will contain either an error associated
+In this case, \fBerrno\fP will contain either an error associated
with \fBwrite\fP(2) or one of the following:
.TP 5
ENODEV
Index: man/form.3x
Prereq: 1.34
--- ncurses-6.2-20200321+/man/form.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/form.3x 2020-03-28 19:06:28.000000000 +0000
@@ -28,7 +28,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: form.3x,v 1.34 2020/02/02 23:34:34 tom Exp $
+.\" $Id: form.3x,v 1.35 2020/03/28 19:06:28 tom Exp $
.TH form 3X ""
.ie \n(.g .ds `` \(lq
.el .ds `` ``
@@ -163,7 +163,7 @@
.TE
.SH RETURN VALUE
Routines that return pointers return \fBNULL\fR on error,
-and set errno to the corresponding error-code returned by functions
+and set \fBerrno\fP to the corresponding error-code returned by functions
returning an integer.
Routines that return
an integer return one of the following error codes:
Index: man/form_field.3x
Prereq: 1.14
--- ncurses-6.2-20200321+/man/form_field.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/form_field.3x 2020-03-28 19:06:28.000000000 +0000
@@ -28,7 +28,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: form_field.3x,v 1.14 2020/02/02 23:34:34 tom Exp $
+.\" $Id: form_field.3x,v 1.15 2020/03/28 19:06:28 tom Exp $
.TH form_field 3X ""
.SH NAME
\fBform_field\fR \- make and break connections between fields and forms
@@ -55,7 +55,7 @@
to a specified location on the screen.
.SH RETURN VALUE
The function \fBform_fields\fR returns a pointer (which may be \fBNULL\fR).
-It does not set errno.
+It does not set \fBerrno\fP.
.PP
The function \fBfield_count\fR returns \fBERR\fR if the \fIform\fP parameter
is \fBNULL\fP.
Index: man/form_field_buffer.3x
Prereq: 1.25
--- ncurses-6.2-20200321+/man/form_field_buffer.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/form_field_buffer.3x 2020-03-28 19:06:28.000000000 +0000
@@ -28,7 +28,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: form_field_buffer.3x,v 1.25 2020/02/02 23:34:34 tom Exp $
+.\" $Id: form_field_buffer.3x,v 1.26 2020/03/28 19:06:28 tom Exp $
.TH form_field_buffer 3X ""
.ie \n(.g .ds `` \(lq
.el .ds `` ``
@@ -99,7 +99,7 @@
An argument of 0 turns off any maximum size threshold for that field.
.SH RETURN VALUE
The \fBfield_buffer\fR function returns NULL on error.
-It sets errno according to their success:
+It sets \fBerrno\fP according to their success:
.TP 5
.B E_OK
The routine succeeded.
Index: man/form_field_new.3x
Prereq: 1.21
--- ncurses-6.2-20200321+/man/form_field_new.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/form_field_new.3x 2020-03-28 19:06:28.000000000 +0000
@@ -28,7 +28,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: form_field_new.3x,v 1.21 2020/02/02 23:34:34 tom Exp $
+.\" $Id: form_field_new.3x,v 1.22 2020/03/28 19:06:28 tom Exp $
.TH form_field_new 3X ""
.SH NAME
\fBnew_field\fR,
@@ -67,9 +67,9 @@
.PP
The function \fBfree_field\fR de-allocates storage associated with a field.
.SH RETURN VALUE
-The function, \fBnew_field\fR, \fBdup_field\fR, \fBlink_field\fR return
+The functions \fBnew_field\fR, \fBdup_field\fR, \fBlink_field\fR return
\fBNULL\fR on error.
-They set errno according to their success:
+They set \fBerrno\fP according to their success:
.TP 5
.B E_OK
The routine succeeded.
Index: man/form_field_userptr.3x
Prereq: 1.13
--- ncurses-6.2-20200321+/man/form_field_userptr.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/form_field_userptr.3x 2020-03-28 19:06:28.000000000 +0000
@@ -28,7 +28,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: form_field_userptr.3x,v 1.13 2020/02/02 23:34:34 tom Exp $
+.\" $Id: form_field_userptr.3x,v 1.14 2020/03/28 19:06:28 tom Exp $
.TH form_field_userptr 3X ""
.SH NAME
\fBset_field_userptr\fR,
@@ -47,7 +47,7 @@
that field.
.SH RETURN VALUE
The function \fBfield_userptr\fR returns a pointer (which may be \fBNULL\fR).
-It does not set errno.
+It does not set \fBerrno\fP.
.PP
The function \fBset_field_userptr\fR returns \fBE_OK\fP (success).
.SH SEE ALSO
Index: man/form_fieldtype.3x
Prereq: 1.20
--- ncurses-6.2-20200321+/man/form_fieldtype.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/form_fieldtype.3x 2020-03-28 19:06:28.000000000 +0000
@@ -28,7 +28,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: form_fieldtype.3x,v 1.20 2020/02/02 23:34:34 tom Exp $
+.\" $Id: form_fieldtype.3x,v 1.21 2020/03/28 19:06:28 tom Exp $
.TH form_fieldtype 3X ""
.SH NAME
\fBform_fieldtype\fR \- define validation-field types
@@ -99,7 +99,7 @@
argument-block structure as arguments.
.SH RETURN VALUE
The pointer-valued routines return NULL on error.
-They set errno according to their success:
+They set \fBerrno\fP according to their success:
.TP 5
.B E_OK
The routine succeeded.
Index: man/form_new.3x
Prereq: 1.12
--- ncurses-6.2-20200321+/man/form_new.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/form_new.3x 2020-03-28 19:06:28.000000000 +0000
@@ -28,7 +28,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: form_new.3x,v 1.12 2020/02/02 23:34:34 tom Exp $
+.\" $Id: form_new.3x,v 1.13 2020/03/28 19:06:28 tom Exp $
.TH form_new 3X ""
.SH NAME
\fBnew_form\fR,
@@ -48,7 +48,7 @@
and frees the storage allocated for the form.
.SH RETURN VALUE
The function \fBnew_form\fR returns \fBNULL\fR on error.
-It sets errno according to the function's success:
+It sets \fBerrno\fP according to the function's success:
.TP 5
.B E_OK
The routine succeeded.
Index: man/form_requestname.3x
Prereq: 1.12
--- ncurses-6.2-20200321+/man/form_requestname.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/form_requestname.3x 2020-03-28 19:06:28.000000000 +0000
@@ -28,7 +28,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: form_requestname.3x,v 1.12 2020/02/02 23:34:34 tom Exp $
+.\" $Id: form_requestname.3x,v 1.13 2020/03/28 19:06:28 tom Exp $
.TH form_requestname 3X ""
.SH NAME
\fBform_request_by_name\fP,
@@ -48,11 +48,11 @@
with the given name and returns its request code.
Otherwise E_NO_MATCH is returned.
.SH RETURN VALUE
-\fBform_request_name\fR returns \fBNULL\fR on error and sets errno
+\fBform_request_name\fR returns \fBNULL\fR on error and sets \fBerrno\fP
to \fBE_BAD_ARGUMENT\fR.
.br
\fBform_request_by_name\fR returns \fBE_NO_MATCH\fR on error.
-It does not set errno.
+It does not set \fBerrno\fP.
.SH SEE ALSO
\fBcurses\fR(3X), \fBform\fR(3X).
.SH NOTES
Index: man/form_userptr.3x
Prereq: 1.16
--- ncurses-6.2-20200321+/man/form_userptr.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/form_userptr.3x 2020-03-28 19:06:28.000000000 +0000
@@ -28,7 +28,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: form_userptr.3x,v 1.16 2020/02/02 23:34:34 tom Exp $
+.\" $Id: form_userptr.3x,v 1.17 2020/03/28 19:06:28 tom Exp $
.TH form_userptr 3X ""
.SH NAME
\fBset_form_userptr\fP,
@@ -46,7 +46,7 @@
These functions get and set the form user pointer field.
.SH RETURN VALUE
The function \fBform_userptr\fR returns a pointer (which may be \fBNULL\fR).
-It does not set errno.
+It does not set \fBerrno\fP.
.PP
The function \fBset_form_userptr\fR returns \fBE_OK\fP (success).
.SH SEE ALSO
Index: man/menu_items.3x
Prereq: 1.14
--- ncurses-6.2-20200321+/man/menu_items.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/menu_items.3x 2020-03-28 19:06:28.000000000 +0000
@@ -28,7 +28,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: menu_items.3x,v 1.14 2020/02/02 23:34:34 tom Exp $
+.\" $Id: menu_items.3x,v 1.15 2020/03/28 19:06:28 tom Exp $
.TH menu_items 3X ""
.SH NAME
\fBset_menu_items\fR,
@@ -52,7 +52,7 @@
The function \fBitem_count\fR returns the count of items in \fImenu\fR.
.SH RETURN VALUE
The function \fBmenu_items\fR returns a pointer (which may be \fBNULL\fR).
-It does not set errno.
+It does not set \fBerrno\fP.
.PP
The function \fBitem_count\fR returns \fBERR\fR (the general \fBcurses\fR error
return value) if its \fImenu\fP parameter is \fBNULL\fP.
Index: man/menu_mark.3x
Prereq: 1.15
--- ncurses-6.2-20200321+/man/menu_mark.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/menu_mark.3x 2020-03-28 19:06:28.000000000 +0000
@@ -28,7 +28,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: menu_mark.3x,v 1.15 2020/02/02 23:34:34 tom Exp $
+.\" $Id: menu_mark.3x,v 1.16 2020/03/28 19:06:28 tom Exp $
.TH menu_mark 3X ""
.SH NAME
\fBset_menu_mark\fP,
@@ -58,7 +58,7 @@
there is none).
.SH RETURN VALUE
The function \fBmenu_mark\fR returns a pointer (which may be \fBNULL\fR).
-It does not set errno.
+It does not set \fBerrno\fP.
.PP
The function \fBset_menu_mark\fR may return the following error codes:
.TP 5
Index: man/menu_new.3x
Prereq: 1.15
--- ncurses-6.2-20200321+/man/menu_new.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/menu_new.3x 2020-03-28 19:06:28.000000000 +0000
@@ -28,7 +28,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: menu_new.3x,v 1.15 2020/02/02 23:34:34 tom Exp $
+.\" $Id: menu_new.3x,v 1.16 2020/03/28 19:06:28 tom Exp $
.TH menu_new 3X ""
.SH NAME
\fBnew_menu\fP,
@@ -48,7 +48,7 @@
and frees the storage allocated for the menu.
.SH RETURN VALUE
The function \fBnew_menu\fR returns \fBNULL\fR on error.
-It sets errno according to the function's failure:
+It sets \fBerrno\fP according to the function's failure:
.TP 5
.B E_NOT_CONNECTED
No items are connected to the menu.
Index: man/menu_pattern.3x
Prereq: 1.18
--- ncurses-6.2-20200321+/man/menu_pattern.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/menu_pattern.3x 2020-03-28 19:06:28.000000000 +0000
@@ -27,7 +27,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: menu_pattern.3x,v 1.18 2020/02/02 23:34:34 tom Exp $
+.\" $Id: menu_pattern.3x,v 1.19 2020/03/28 19:06:28 tom Exp $
.TH menu_pattern 3X ""
.SH NAME
\fBset_menu_pattern\fP,
@@ -57,7 +57,7 @@
which is \fBNULL\fR if the \fImenu\fP parameter is \fBNULL\fP.
Otherwise, it is a pointer to a string which is empty
if no pattern has been set.
-It does not set errno.
+It does not set \fBerrno\fP.
.PP
The function \fBset_menu_pattern\fR may return the following error codes:
.TP 5
Index: man/menu_requestname.3x
Prereq: 1.12
--- ncurses-6.2-20200321+/man/menu_requestname.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/menu_requestname.3x 2020-03-28 19:06:28.000000000 +0000
@@ -28,7 +28,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: menu_requestname.3x,v 1.12 2020/02/02 23:34:34 tom Exp $
+.\" $Id: menu_requestname.3x,v 1.13 2020/03/28 19:06:28 tom Exp $
.TH menu_requestname 3X ""
.SH NAME
\fBmenu_request_by_name\fP,
@@ -49,10 +49,10 @@
Otherwise E_NO_MATCH is returned.
.SH RETURN VALUE
\fBmenu_request_name\fR returns \fBNULL\fR on error
-and sets errno to \fBE_BAD_ARGUMENT\fR.
+and sets \fBerrno\fP to \fBE_BAD_ARGUMENT\fR.
.br
\fBmenu_request_by_name\fR returns \fBE_NO_MATCH\fR on error.
-It does not set errno.
+It does not set \fBerrno\fP.
.SH SEE ALSO
\fBcurses\fR(3X), \fBmenu\fR(3X).
.SH NOTES
Index: man/menu_userptr.3x
Prereq: 1.13
--- ncurses-6.2-20200321+/man/menu_userptr.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/menu_userptr.3x 2020-03-28 19:06:28.000000000 +0000
@@ -28,7 +28,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: menu_userptr.3x,v 1.13 2020/02/02 23:34:34 tom Exp $
+.\" $Id: menu_userptr.3x,v 1.14 2020/03/28 19:06:28 tom Exp $
.TH menu_userptr 3X ""
.SH NAME
\fBset_menu_userptr\fP,
@@ -46,7 +46,7 @@
These functions get and set the menu user pointer field.
.SH RETURN VALUE
\fBmenu_userptr\fR returns a pointer (which may be \fBNULL\fR).
-It does not set errno.
+It does not set \fBerrno\fP.
.PP
\fBset_menu_userptr\fP returns \fBE_OK\fP (success).
.SH SEE ALSO
Index: man/mitem_current.3x
Prereq: 1.17
--- ncurses-6.2-20200321+/man/mitem_current.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/mitem_current.3x 2020-03-28 19:06:28.000000000 +0000
@@ -28,7 +28,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: mitem_current.3x,v 1.17 2020/02/02 23:34:34 tom Exp $
+.\" $Id: mitem_current.3x,v 1.18 2020/03/28 19:06:28 tom Exp $
.TH mitem_current 3X ""
.SH NAME
\fBmitem_current\fR \- set and get current_menu_item
@@ -63,7 +63,7 @@
the menu's item pointer list.
.SH RETURN VALUE
\fBcurrent_item\fR returns a pointer (which may be \fBNULL\fR).
-It does not set errno.
+It does not set \fBerrno\fP.
.PP
\fBtop_row\fR and \fBitem_index\fR return \fBERR\fR (the general \fBcurses\fR
error value) if their \fImenu\fP parameter is \fBNULL\fP.
Index: man/mitem_name.3x
Prereq: 1.11
--- ncurses-6.2-20200321+/man/mitem_name.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/mitem_name.3x 2020-03-28 19:06:28.000000000 +0000
@@ -28,7 +28,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: mitem_name.3x,v 1.11 2020/02/02 23:34:34 tom Exp $
+.\" $Id: mitem_name.3x,v 1.12 2020/03/28 19:06:28 tom Exp $
.TH mitem_name 3X ""
.SH NAME
\fBitem_name\fR,
@@ -47,7 +47,7 @@
item.
.SH RETURN VALUE
These routines return a pointer (which may be \fBNULL\fR).
-They do not set errno.
+They do not set \fBerrno\fP.
.SH SEE ALSO
\fBcurses\fR(3X), \fBmenu\fR(3X).
.SH NOTES
Index: man/mitem_new.3x
Prereq: 1.16
--- ncurses-6.2-20200321+/man/mitem_new.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/mitem_new.3x 2020-03-28 19:06:28.000000000 +0000
@@ -28,7 +28,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: mitem_new.3x,v 1.16 2020/02/02 23:34:34 tom Exp $
+.\" $Id: mitem_new.3x,v 1.17 2020/03/28 19:06:28 tom Exp $
.TH mitem_new 3X ""
.SH NAME
\fBnew_item\fP,
@@ -56,7 +56,7 @@
name or the description of the item.
.SH RETURN VALUE
The function \fBnew_item\fR returns \fBNULL\fR on error.
-It sets errno according to the function's failure:
+It sets \fBerrno\fP according to the function's failure:
.TP 5
.B E_BAD_ARGUMENT
Routine detected an incorrect or out-of-range argument.
Index: man/mitem_userptr.3x
Prereq: 1.14
--- ncurses-6.2-20200321+/man/mitem_userptr.3x 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200328/man/mitem_userptr.3x 2020-03-28 19:06:28.000000000 +0000
@@ -28,7 +28,7 @@
.\" authorization. *
.\"***************************************************************************
.\"
-.\" $Id: mitem_userptr.3x,v 1.14 2020/02/02 23:34:34 tom Exp $
+.\" $Id: mitem_userptr.3x,v 1.15 2020/03/28 19:06:28 tom Exp $
.TH mitem_userptr 3X ""
.SH NAME
\fBset_item_userptr\fP,
@@ -47,7 +47,7 @@
that field.
.SH RETURN VALUE
The function \fBitem_userptr\fR returns a pointer (possibly \fBNULL\fR).
-It does not set errno.
+It does not set \fBerrno\fP.
.PP
The \fBset_item_userptr\fP always returns \fBE_OK\fP (success).
.
Index: package/debian-mingw/changelog
--- ncurses-6.2-20200321+/package/debian-mingw/changelog 2020-03-21 12:15:18.000000000 +0000
+++ ncurses-6.2-20200328/package/debian-mingw/changelog 2020-03-28 10:37:50.000000000 +0000
@@ -1,8 +1,8 @@
-ncurses6 (6.2+20200321) unstable; urgency=low
+ncurses6 (6.2+20200328) unstable; urgency=low
* latest weekly patch
- -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 21 Mar 2020 08:15:18 -0400
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 28 Mar 2020 06:37:50 -0400
ncurses6 (5.9-20131005) unstable; urgency=low
Index: package/debian-mingw64/changelog
--- ncurses-6.2-20200321+/package/debian-mingw64/changelog 2020-03-21 12:15:18.000000000 +0000
+++ ncurses-6.2-20200328/package/debian-mingw64/changelog 2020-03-28 10:37:50.000000000 +0000
@@ -1,8 +1,8 @@
-ncurses6 (6.2+20200321) unstable; urgency=low
+ncurses6 (6.2+20200328) unstable; urgency=low
* latest weekly patch
- -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 21 Mar 2020 08:15:18 -0400
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 28 Mar 2020 06:37:50 -0400
ncurses6 (5.9-20131005) unstable; urgency=low
Index: package/debian/changelog
--- ncurses-6.2-20200321+/package/debian/changelog 2020-03-21 12:15:18.000000000 +0000
+++ ncurses-6.2-20200328/package/debian/changelog 2020-03-28 10:37:50.000000000 +0000
@@ -1,8 +1,8 @@
-ncurses6 (6.2+20200321) unstable; urgency=low
+ncurses6 (6.2+20200328) unstable; urgency=low
* latest weekly patch
- -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 21 Mar 2020 08:15:18 -0400
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 28 Mar 2020 06:37:50 -0400
ncurses6 (5.9-20120608) unstable; urgency=low
Index: package/mingw-ncurses.nsi
Prereq: 1.386
--- ncurses-6.2-20200321+/package/mingw-ncurses.nsi 2020-03-21 12:15:18.000000000 +0000
+++ ncurses-6.2-20200328/package/mingw-ncurses.nsi 2020-03-28 10:37:50.000000000 +0000
@@ -1,4 +1,4 @@
-; $Id: mingw-ncurses.nsi,v 1.386 2020/03/21 12:15:18 tom Exp $
+; $Id: mingw-ncurses.nsi,v 1.387 2020/03/28 10:37:50 tom Exp $
; TODO add examples
; TODO bump ABI to 6
@@ -10,7 +10,7 @@
!define VERSION_MAJOR "6"
!define VERSION_MINOR "2"
!define VERSION_YYYY "2020"
-!define VERSION_MMDD "0321"
+!define VERSION_MMDD "0328"
!define VERSION_PATCH ${VERSION_YYYY}${VERSION_MMDD}
!define MY_ABI "5"
Index: package/mingw-ncurses.spec
--- ncurses-6.2-20200321+/package/mingw-ncurses.spec 2020-03-21 12:15:18.000000000 +0000
+++ ncurses-6.2-20200328/package/mingw-ncurses.spec 2020-03-28 10:37:50.000000000 +0000
@@ -3,7 +3,7 @@
Summary: shared libraries for terminal handling
Name: mingw32-ncurses6
Version: 6.2
-Release: 20200321
+Release: 20200328
License: X11
Group: Development/Libraries
Source: ncurses-%{version}-%{release}.tgz
Index: package/ncurses.spec
--- ncurses-6.2-20200321+/package/ncurses.spec 2020-03-21 12:15:18.000000000 +0000
+++ ncurses-6.2-20200328/package/ncurses.spec 2020-03-28 10:37:50.000000000 +0000
@@ -1,7 +1,7 @@
Summary: shared libraries for terminal handling
Name: ncurses6
Version: 6.2
-Release: 20200321
+Release: 20200328
License: X11
Group: Development/Libraries
Source: ncurses-%{version}-%{release}.tgz
Index: package/ncursest.spec
--- ncurses-6.2-20200321+/package/ncursest.spec 2020-03-21 12:15:18.000000000 +0000
+++ ncurses-6.2-20200328/package/ncursest.spec 2020-03-28 10:37:50.000000000 +0000
@@ -1,7 +1,7 @@
Summary: Curses library with POSIX thread support.
Name: ncursest6
Version: 6.2
-Release: 20200321
+Release: 20200328
License: X11
Group: Development/Libraries
Source: ncurses-%{version}-%{release}.tgz
Index: test/move_field.c
Prereq: 1.5
--- ncurses-6.2-20200321+/test/move_field.c 2020-03-21 22:04:03.000000000 +0000
+++ ncurses-6.2-20200328/test/move_field.c 2020-03-28 17:43:03.000000000 +0000
@@ -26,7 +26,7 @@
* authorization. *
****************************************************************************/
/*
- * $Id: move_field.c,v 1.5 2020/03/21 22:04:03 tom Exp $
+ * $Id: move_field.c,v 1.6 2020/03/28 17:43:03 tom Exp $
*
* Demonstrate move_field().
*/
@@ -269,7 +269,7 @@
}
static FIELD **
-copy_fields(FIELD **source, int length)
+copy_fields(FIELD **source, size_t length)
{
FIELD **target = calloc(length + 1, sizeof(FIELD *));
memcpy(target, source, length * sizeof(FIELD *));
@@ -305,8 +305,9 @@
FIELD *my_field = current_field(form);
if (count > 0 && my_field != NULL) {
- FIELD **old_fields = copy_fields(form_fields(form), count);
- FIELD **new_fields = copy_fields(form_fields(form), count);
+ size_t needed = (size_t) count;
+ FIELD **old_fields = copy_fields(form_fields(form), needed);
+ FIELD **new_fields = copy_fields(form_fields(form), needed);
int ch;
if (old_fields != NULL && new_fields != NULL) {