ncurses/ncurses-6.2-20200301.patch
2024-01-06 07:33:58 +01:00

211 lines
8.0 KiB
Diff

# ncurses 6.2 - patch 20200301 - Thomas E. Dickey
#
# ------------------------------------------------------------------------------
#
# Ncurses 6.2 is at
# ftp.gnu.org:/pub/gnu
#
# Patches for ncurses 6.2 can be found at
# ftp://ftp.invisible-island.net/ncurses/6.2
# http://invisible-mirror.net/archives/ncurses/6.2
#
# ------------------------------------------------------------------------------
# ftp://ftp.invisible-island.net/ncurses/6.2/ncurses-6.2-20200301.patch.gz
# patch by Thomas E. Dickey <dickey@invisible-island.net>
# created Mon Mar 2 23:18:56 UTC 2020
# ------------------------------------------------------------------------------
# NEWS | 8 +++++++-
# VERSION | 2 +-
# dist.mk | 4 ++--
# ncurses/base/lib_bkgd.c | 12 +++++++++++-
# package/debian-mingw/changelog | 4 ++--
# package/debian-mingw64/changelog | 4 ++--
# package/debian/changelog | 4 ++--
# package/mingw-ncurses.nsi | 4 ++--
# package/mingw-ncurses.spec | 2 +-
# package/ncurses.spec | 2 +-
# package/ncursest.spec | 2 +-
# 11 files changed, 32 insertions(+), 16 deletions(-)
# ------------------------------------------------------------------------------
Index: NEWS
Prereq: 1.3455
--- ncurses-6.2-20200229+/NEWS 2020-02-29 23:15:52.000000000 +0000
+++ ncurses-6.2-20200301/NEWS 2020-03-02 01:55:08.000000000 +0000
@@ -26,7 +26,7 @@
-- sale, use or other dealings in this Software without prior written --
-- authorization. --
-------------------------------------------------------------------------------
--- $Id: NEWS,v 1.3455 2020/02/29 23:15:52 tom Exp $
+-- $Id: NEWS,v 1.3456 2020/03/02 01:55:08 tom Exp $
-------------------------------------------------------------------------------
This is a log of changes that ncurses has gone through since Zeyd started
@@ -46,6 +46,12 @@
Changes through 1.9.9e did not credit all contributions;
it is not possible to add this information.
+20200301
+ + modify wbkgd() and wbkgrnd() to avoid storing a null in the
+ background character, because it may be used in cases where the
+ corresponding 0x80 is not treated as a null (report by Marc Rechte,
+ cf: 20181208).
+
20200229
+ modify CF_NCURSES_CONFIG to work around xcode's c99 "-W" option,
which conflicts with conventional use for passing linker options.
Index: VERSION
--- ncurses-6.2-20200229+/VERSION 2020-02-29 12:43:09.000000000 +0000
+++ ncurses-6.2-20200301/VERSION 2020-03-02 01:55:47.000000000 +0000
@@ -1 +1 @@
-5:0:10 6.2 20200229
+5:0:10 6.2 20200301
Index: dist.mk
Prereq: 1.1337
--- ncurses-6.2-20200229+/dist.mk 2020-02-29 12:43:09.000000000 +0000
+++ ncurses-6.2-20200301/dist.mk 2020-03-02 01:55:47.000000000 +0000
@@ -26,7 +26,7 @@
# use or other dealings in this Software without prior written #
# authorization. #
##############################################################################
-# $Id: dist.mk,v 1.1337 2020/02/29 12:43:09 tom Exp $
+# $Id: dist.mk,v 1.1338 2020/03/02 01:55:47 tom Exp $
# Makefile for creating ncurses distributions.
#
# This only needs to be used directly as a makefile by developers, but
@@ -38,7 +38,7 @@
# These define the major/minor/patch versions of ncurses.
NCURSES_MAJOR = 6
NCURSES_MINOR = 2
-NCURSES_PATCH = 20200229
+NCURSES_PATCH = 20200301
# We don't append the patch to the version, since this only applies to releases
VERSION = $(NCURSES_MAJOR).$(NCURSES_MINOR)
Index: ncurses/base/lib_bkgd.c
Prereq: 1.54
--- ncurses-6.2-20200229+/ncurses/base/lib_bkgd.c 2020-02-02 23:34:34.000000000 +0000
+++ ncurses-6.2-20200301/ncurses/base/lib_bkgd.c 2020-03-02 01:34:48.000000000 +0000
@@ -37,7 +37,9 @@
#include <curses.priv.h>
-MODULE_ID("$Id: lib_bkgd.c,v 1.54 2020/02/02 23:34:34 tom Exp $")
+MODULE_ID("$Id: lib_bkgd.c,v 1.55 2020/03/02 01:34:48 tom Exp $")
+
+static const NCURSES_CH_T blank = NewChar(BLANK_TEXT);
/*
* Set the window's background information.
@@ -143,6 +145,14 @@
SetPair(new_bkgd, 0);
}
+ /* avoid setting background-character to a null */
+ if (CharOf(new_bkgd) == 0) {
+ NCURSES_CH_T tmp_bkgd = blank;
+ SetAttr(tmp_bkgd, AttrOf(new_bkgd));
+ SetPair(tmp_bkgd, GetPair(new_bkgd));
+ new_bkgd = tmp_bkgd;
+ }
+
memset(&old_bkgd, 0, sizeof(old_bkgd));
(void) wgetbkgrnd(win, &old_bkgd);
Index: package/debian-mingw/changelog
--- ncurses-6.2-20200229+/package/debian-mingw/changelog 2020-02-29 12:43:09.000000000 +0000
+++ ncurses-6.2-20200301/package/debian-mingw/changelog 2020-03-02 01:55:47.000000000 +0000
@@ -1,8 +1,8 @@
-ncurses6 (6.2+20200229) unstable; urgency=low
+ncurses6 (6.2+20200301) unstable; urgency=low
* latest weekly patch
- -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 29 Feb 2020 07:43:09 -0500
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sun, 01 Mar 2020 20:55:47 -0500
ncurses6 (5.9-20131005) unstable; urgency=low
Index: package/debian-mingw64/changelog
--- ncurses-6.2-20200229+/package/debian-mingw64/changelog 2020-02-29 12:43:09.000000000 +0000
+++ ncurses-6.2-20200301/package/debian-mingw64/changelog 2020-03-02 01:55:47.000000000 +0000
@@ -1,8 +1,8 @@
-ncurses6 (6.2+20200229) unstable; urgency=low
+ncurses6 (6.2+20200301) unstable; urgency=low
* latest weekly patch
- -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 29 Feb 2020 07:43:09 -0500
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sun, 01 Mar 2020 20:55:47 -0500
ncurses6 (5.9-20131005) unstable; urgency=low
Index: package/debian/changelog
--- ncurses-6.2-20200229+/package/debian/changelog 2020-02-29 12:43:09.000000000 +0000
+++ ncurses-6.2-20200301/package/debian/changelog 2020-03-02 01:55:47.000000000 +0000
@@ -1,8 +1,8 @@
-ncurses6 (6.2+20200229) unstable; urgency=low
+ncurses6 (6.2+20200301) unstable; urgency=low
* latest weekly patch
- -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 29 Feb 2020 07:43:09 -0500
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sun, 01 Mar 2020 20:55:47 -0500
ncurses6 (5.9-20120608) unstable; urgency=low
Index: package/mingw-ncurses.nsi
Prereq: 1.380
--- ncurses-6.2-20200229+/package/mingw-ncurses.nsi 2020-02-29 12:43:09.000000000 +0000
+++ ncurses-6.2-20200301/package/mingw-ncurses.nsi 2020-03-02 01:55:47.000000000 +0000
@@ -1,4 +1,4 @@
-; $Id: mingw-ncurses.nsi,v 1.380 2020/02/29 12:43:09 tom Exp $
+; $Id: mingw-ncurses.nsi,v 1.381 2020/03/02 01:55:47 tom Exp $
; TODO add examples
; TODO bump ABI to 6
@@ -10,7 +10,7 @@
!define VERSION_MAJOR "6"
!define VERSION_MINOR "2"
!define VERSION_YYYY "2020"
-!define VERSION_MMDD "0229"
+!define VERSION_MMDD "0301"
!define VERSION_PATCH ${VERSION_YYYY}${VERSION_MMDD}
!define MY_ABI "5"
Index: package/mingw-ncurses.spec
--- ncurses-6.2-20200229+/package/mingw-ncurses.spec 2020-02-29 12:43:09.000000000 +0000
+++ ncurses-6.2-20200301/package/mingw-ncurses.spec 2020-03-02 01:55:47.000000000 +0000
@@ -3,7 +3,7 @@
Summary: shared libraries for terminal handling
Name: mingw32-ncurses6
Version: 6.2
-Release: 20200229
+Release: 20200301
License: X11
Group: Development/Libraries
Source: ncurses-%{version}-%{release}.tgz
Index: package/ncurses.spec
--- ncurses-6.2-20200229+/package/ncurses.spec 2020-02-29 12:43:09.000000000 +0000
+++ ncurses-6.2-20200301/package/ncurses.spec 2020-03-02 01:55:47.000000000 +0000
@@ -1,7 +1,7 @@
Summary: shared libraries for terminal handling
Name: ncurses6
Version: 6.2
-Release: 20200229
+Release: 20200301
License: X11
Group: Development/Libraries
Source: ncurses-%{version}-%{release}.tgz
Index: package/ncursest.spec
--- ncurses-6.2-20200229+/package/ncursest.spec 2020-02-29 12:43:09.000000000 +0000
+++ ncurses-6.2-20200301/package/ncursest.spec 2020-03-02 01:55:47.000000000 +0000
@@ -1,7 +1,7 @@
Summary: Curses library with POSIX thread support.
Name: ncursest6
Version: 6.2
-Release: 20200229
+Release: 20200301
License: X11
Group: Development/Libraries
Source: ncurses-%{version}-%{release}.tgz