261 lines
10 KiB
Diff
261 lines
10 KiB
Diff
# ncurses 6.1 - patch 20191116 - Thomas E. Dickey
|
|
#
|
|
# ------------------------------------------------------------------------------
|
|
#
|
|
# Ncurses 6.1 is at
|
|
# ftp.gnu.org:/pub/gnu
|
|
#
|
|
# Patches for ncurses 6.1 can be found at
|
|
# ftp://ftp.invisible-island.net/ncurses/6.1
|
|
# http://invisible-mirror.net/archives/ncurses/6.1
|
|
#
|
|
# ------------------------------------------------------------------------------
|
|
# ftp://ftp.invisible-island.net/ncurses/6.1/ncurses-6.1-20191116.patch.gz
|
|
# patch by Thomas E. Dickey <dickey@invisible-island.net>
|
|
# created Sun Nov 17 01:23:05 UTC 2019
|
|
# ------------------------------------------------------------------------------
|
|
# NEWS | 10 +++++++++-
|
|
# VERSION | 2 +-
|
|
# configure | 4 ++--
|
|
# configure.in | 6 +++---
|
|
# dist.mk | 4 ++--
|
|
# ncurses/Makefile.in | 10 +++++-----
|
|
# package/debian-mingw/changelog | 4 ++--
|
|
# package/debian-mingw64/changelog | 4 ++--
|
|
# package/debian/changelog | 4 ++--
|
|
# package/mingw-ncurses.nsi | 4 ++--
|
|
# package/mingw-ncurses.spec | 2 +-
|
|
# package/ncurses.spec | 2 +-
|
|
# package/ncursest.spec | 2 +-
|
|
# 13 files changed, 33 insertions(+), 25 deletions(-)
|
|
# ------------------------------------------------------------------------------
|
|
Index: NEWS
|
|
Prereq: 1.3404
|
|
--- ncurses-6.1-20191109+/NEWS 2019-11-10 00:18:59.000000000 +0000
|
|
+++ ncurses-6.1-20191116/NEWS 2019-11-16 20:48:27.000000000 +0000
|
|
@@ -25,7 +25,7 @@
|
|
-- sale, use or other dealings in this Software without prior written --
|
|
-- authorization. --
|
|
-------------------------------------------------------------------------------
|
|
--- $Id: NEWS,v 1.3404 2019/11/10 00:18:59 tom Exp $
|
|
+-- $Id: NEWS,v 1.3407 2019/11/16 20:48:27 tom Exp $
|
|
-------------------------------------------------------------------------------
|
|
|
|
This is a log of changes that ncurses has gone through since Zeyd started
|
|
@@ -45,6 +45,14 @@
|
|
Changes through 1.9.9e did not credit all contributions;
|
|
it is not possible to add this information.
|
|
|
|
+20191116
|
|
+ + modify ncurses/Makefile.in to fix a case where Debian/testing changes
|
|
+ to the ld --as-needed configuration broke ncurses-examples test
|
|
+ packages.
|
|
+ + drop library-dependency on psapi for MinGW port, since win_driver.c
|
|
+ defines PSAPI_VERSION to 2, making it use GetProcessImageFileName
|
|
+ from kernel32.dll (prompted by patch by Simon Sobish, cf: 20140503).
|
|
+
|
|
20191109
|
|
+ add warning-check in tic for terminals with parm_dch vs parm_ich.
|
|
+ drop ich1 from rxvt-basic, Eterm and mlterm to improve compatibility
|
|
Index: VERSION
|
|
--- ncurses-6.1-20191109+/VERSION 2019-11-06 09:37:05.000000000 +0000
|
|
+++ ncurses-6.1-20191116/VERSION 2019-11-16 15:09:15.000000000 +0000
|
|
@@ -1 +1 @@
|
|
-5:0:10 6.1 20191109
|
|
+5:0:10 6.1 20191116
|
|
Index: configure
|
|
--- ncurses-6.1-20191109+/configure 2019-11-02 20:33:48.000000000 +0000
|
|
+++ ncurses-6.1-20191116/configure 2019-11-16 15:59:28.000000000 +0000
|
|
@@ -1,5 +1,5 @@
|
|
#! /bin/sh
|
|
-# From configure.in Revision: 1.690 .
|
|
+# From configure.in Revision: 1.691 .
|
|
# Guess values for system-dependent variables and create Makefiles.
|
|
# Generated by Autoconf 2.52.20190901.
|
|
#
|
|
@@ -17119,7 +17119,7 @@
|
|
case $cf_cv_system_name in
|
|
(*mingw32*|*mingw64*)
|
|
CPPFLAGS="$CPPFLAGS -DWINVER=0x0501 -DWIN32_LEAN_AND_MEAN"
|
|
- LIBS=" -lpsapi $LIBS"
|
|
+ # Note: WINVER may be a problem with Windows 10
|
|
;;
|
|
(*)
|
|
echo "$as_me:17125: checking for gettimeofday" >&5
|
|
Index: configure.in
|
|
Prereq: 1.690
|
|
--- ncurses-6.1-20191109+/configure.in 2019-09-27 21:12:34.000000000 +0000
|
|
+++ ncurses-6.1-20191116/configure.in 2019-11-16 15:54:47.000000000 +0000
|
|
@@ -28,14 +28,14 @@
|
|
dnl
|
|
dnl Author: Thomas E. Dickey 1995-on
|
|
dnl
|
|
-dnl $Id: configure.in,v 1.690 2019/09/27 21:12:34 tom Exp $
|
|
+dnl $Id: configure.in,v 1.691 2019/11/16 15:54:47 tom Exp $
|
|
dnl Process this file with autoconf to produce a configure script.
|
|
dnl
|
|
dnl See https://invisible-island.net/autoconf/ for additional information.
|
|
dnl
|
|
dnl ---------------------------------------------------------------------------
|
|
AC_PREREQ(2.52.20170501)
|
|
-AC_REVISION($Revision: 1.690 $)
|
|
+AC_REVISION($Revision: 1.691 $)
|
|
AC_INIT(ncurses/base/lib_initscr.c)
|
|
AC_CONFIG_HEADER(include/ncurses_cfg.h:include/ncurses_cfg.hin)
|
|
|
|
@@ -1616,7 +1616,7 @@
|
|
case $cf_cv_system_name in
|
|
(*mingw32*|*mingw64*)
|
|
CPPFLAGS="$CPPFLAGS -DWINVER=0x0501 -DWIN32_LEAN_AND_MEAN"
|
|
- LIBS=" -lpsapi $LIBS"
|
|
+ # Note: WINVER may be a problem with Windows 10
|
|
;;
|
|
(*)
|
|
AC_CHECK_FUNC(gettimeofday,
|
|
Index: dist.mk
|
|
Prereq: 1.1314
|
|
--- ncurses-6.1-20191109+/dist.mk 2019-11-06 09:37:05.000000000 +0000
|
|
+++ ncurses-6.1-20191116/dist.mk 2019-11-16 15:09:15.000000000 +0000
|
|
@@ -25,7 +25,7 @@
|
|
# use or other dealings in this Software without prior written #
|
|
# authorization. #
|
|
##############################################################################
|
|
-# $Id: dist.mk,v 1.1314 2019/11/06 09:37:05 tom Exp $
|
|
+# $Id: dist.mk,v 1.1315 2019/11/16 15:09:15 tom Exp $
|
|
# Makefile for creating ncurses distributions.
|
|
#
|
|
# This only needs to be used directly as a makefile by developers, but
|
|
@@ -37,7 +37,7 @@
|
|
# These define the major/minor/patch versions of ncurses.
|
|
NCURSES_MAJOR = 6
|
|
NCURSES_MINOR = 1
|
|
-NCURSES_PATCH = 20191109
|
|
+NCURSES_PATCH = 20191116
|
|
|
|
# We don't append the patch to the version, since this only applies to releases
|
|
VERSION = $(NCURSES_MAJOR).$(NCURSES_MINOR)
|
|
Index: ncurses/Makefile.in
|
|
Prereq: 1.163
|
|
--- ncurses-6.1-20191109+/ncurses/Makefile.in 2019-06-30 14:57:27.000000000 +0000
|
|
+++ ncurses-6.1-20191116/ncurses/Makefile.in 2019-11-16 20:42:40.000000000 +0000
|
|
@@ -1,4 +1,4 @@
|
|
-# $Id: Makefile.in,v 1.163 2019/06/30 14:57:27 tom Exp $
|
|
+# $Id: Makefile.in,v 1.164 2019/11/16 20:42:40 tom Exp $
|
|
##############################################################################
|
|
# Copyright (c) 1998-2018,2019 Free Software Foundation, Inc. #
|
|
# #
|
|
@@ -126,12 +126,12 @@
|
|
CFLAGS_DEFAULT = $(CFLAGS_@DFT_UPR_MODEL@)
|
|
|
|
LINK = $(LIBTOOL)
|
|
-LDFLAGS = @LDFLAGS@ @LD_MODEL@ @LIBS@
|
|
+LDFLAGS = @LDFLAGS@ @LD_MODEL@
|
|
|
|
SHLIB_DIRS = -L../lib
|
|
-SHLIB_LIST = $(SHLIB_DIRS) @SHLIB_LIST@
|
|
-TINFO_LIST = $(SHLIB_DIRS) @TINFO_LIST@
|
|
-TICS_LIST = $(SHLIB_DIRS) @TICS_LIST@
|
|
+SHLIB_LIST = $(SHLIB_DIRS) @SHLIB_LIST@ @LIBS@
|
|
+TINFO_LIST = $(SHLIB_DIRS) @TINFO_LIST@ @LIBS@
|
|
+TICS_LIST = $(SHLIB_DIRS) @TICS_LIST@ @LIBS@
|
|
|
|
RPATH_LIST = @RPATH_LIST@
|
|
RESULTING_SYMS = @RESULTING_SYMS@
|
|
Index: package/debian-mingw/changelog
|
|
--- ncurses-6.1-20191109+/package/debian-mingw/changelog 2019-11-06 09:37:05.000000000 +0000
|
|
+++ ncurses-6.1-20191116/package/debian-mingw/changelog 2019-11-16 15:09:15.000000000 +0000
|
|
@@ -1,8 +1,8 @@
|
|
-ncurses6 (6.1+20191109) unstable; urgency=low
|
|
+ncurses6 (6.1+20191116) unstable; urgency=low
|
|
|
|
* latest weekly patch
|
|
|
|
- -- Thomas E. Dickey <dickey@invisible-island.net> Wed, 06 Nov 2019 04:37:04 -0500
|
|
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 16 Nov 2019 10:09:15 -0500
|
|
|
|
ncurses6 (5.9-20131005) unstable; urgency=low
|
|
|
|
Index: package/debian-mingw64/changelog
|
|
--- ncurses-6.1-20191109+/package/debian-mingw64/changelog 2019-11-06 09:37:05.000000000 +0000
|
|
+++ ncurses-6.1-20191116/package/debian-mingw64/changelog 2019-11-16 15:09:15.000000000 +0000
|
|
@@ -1,8 +1,8 @@
|
|
-ncurses6 (6.1+20191109) unstable; urgency=low
|
|
+ncurses6 (6.1+20191116) unstable; urgency=low
|
|
|
|
* latest weekly patch
|
|
|
|
- -- Thomas E. Dickey <dickey@invisible-island.net> Wed, 06 Nov 2019 04:37:05 -0500
|
|
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 16 Nov 2019 10:09:15 -0500
|
|
|
|
ncurses6 (5.9-20131005) unstable; urgency=low
|
|
|
|
Index: package/debian/changelog
|
|
--- ncurses-6.1-20191109+/package/debian/changelog 2019-11-06 09:37:05.000000000 +0000
|
|
+++ ncurses-6.1-20191116/package/debian/changelog 2019-11-16 15:09:15.000000000 +0000
|
|
@@ -1,8 +1,8 @@
|
|
-ncurses6 (6.1+20191109) unstable; urgency=low
|
|
+ncurses6 (6.1+20191116) unstable; urgency=low
|
|
|
|
* latest weekly patch
|
|
|
|
- -- Thomas E. Dickey <dickey@invisible-island.net> Wed, 06 Nov 2019 04:37:04 -0500
|
|
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 16 Nov 2019 10:09:15 -0500
|
|
|
|
ncurses6 (5.9-20120608) unstable; urgency=low
|
|
|
|
Index: package/mingw-ncurses.nsi
|
|
Prereq: 1.360
|
|
--- ncurses-6.1-20191109+/package/mingw-ncurses.nsi 2019-11-06 09:37:05.000000000 +0000
|
|
+++ ncurses-6.1-20191116/package/mingw-ncurses.nsi 2019-11-16 15:09:15.000000000 +0000
|
|
@@ -1,4 +1,4 @@
|
|
-; $Id: mingw-ncurses.nsi,v 1.360 2019/11/06 09:37:05 tom Exp $
|
|
+; $Id: mingw-ncurses.nsi,v 1.361 2019/11/16 15:09:15 tom Exp $
|
|
|
|
; TODO add examples
|
|
; TODO bump ABI to 6
|
|
@@ -10,7 +10,7 @@
|
|
!define VERSION_MAJOR "6"
|
|
!define VERSION_MINOR "1"
|
|
!define VERSION_YYYY "2019"
|
|
-!define VERSION_MMDD "1109"
|
|
+!define VERSION_MMDD "1116"
|
|
!define VERSION_PATCH ${VERSION_YYYY}${VERSION_MMDD}
|
|
|
|
!define MY_ABI "5"
|
|
Index: package/mingw-ncurses.spec
|
|
--- ncurses-6.1-20191109+/package/mingw-ncurses.spec 2019-11-06 09:37:05.000000000 +0000
|
|
+++ ncurses-6.1-20191116/package/mingw-ncurses.spec 2019-11-16 15:09:15.000000000 +0000
|
|
@@ -3,7 +3,7 @@
|
|
Summary: shared libraries for terminal handling
|
|
Name: mingw32-ncurses6
|
|
Version: 6.1
|
|
-Release: 20191109
|
|
+Release: 20191116
|
|
License: X11
|
|
Group: Development/Libraries
|
|
Source: ncurses-%{version}-%{release}.tgz
|
|
Index: package/ncurses.spec
|
|
--- ncurses-6.1-20191109+/package/ncurses.spec 2019-11-06 09:37:05.000000000 +0000
|
|
+++ ncurses-6.1-20191116/package/ncurses.spec 2019-11-16 15:09:15.000000000 +0000
|
|
@@ -1,7 +1,7 @@
|
|
Summary: shared libraries for terminal handling
|
|
Name: ncurses6
|
|
Version: 6.1
|
|
-Release: 20191109
|
|
+Release: 20191116
|
|
License: X11
|
|
Group: Development/Libraries
|
|
Source: ncurses-%{version}-%{release}.tgz
|
|
Index: package/ncursest.spec
|
|
--- ncurses-6.1-20191109+/package/ncursest.spec 2019-11-06 09:37:05.000000000 +0000
|
|
+++ ncurses-6.1-20191116/package/ncursest.spec 2019-11-16 15:09:15.000000000 +0000
|
|
@@ -1,7 +1,7 @@
|
|
Summary: Curses library with POSIX thread support.
|
|
Name: ncursest6
|
|
Version: 6.1
|
|
-Release: 20191109
|
|
+Release: 20191116
|
|
License: X11
|
|
Group: Development/Libraries
|
|
Source: ncurses-%{version}-%{release}.tgz
|