ncurses/ncurses-6.1-20190914.patch

407 lines
16 KiB
Diff

# ncurses 6.1 - patch 20190914 - Thomas E. Dickey
#
# ------------------------------------------------------------------------------
#
# Ncurses 6.1 is at
# ftp.gnu.org:/pub/gnu
#
# Patches for ncurses 6.1 can be found at
# ftp://ftp.invisible-island.net/ncurses/6.1
# http://invisible-mirror.net/archives/ncurses/6.1
#
# ------------------------------------------------------------------------------
# ftp://ftp.invisible-island.net/ncurses/6.1/ncurses-6.1-20190914.patch.gz
# patch by Thomas E. Dickey <dickey@invisible-island.net>
# created Sun Sep 15 01:08:42 UTC 2019
# ------------------------------------------------------------------------------
# Ada95/configure | 29 +++++++++++++++--------------
# Ada95/configure.in | 5 +++--
# Ada95/package/AdaCurses.spec | 22 ++++++++++++++++------
# NEWS | 5 ++++-
# VERSION | 2 +-
# dist.mk | 4 ++--
# package/debian-mingw/changelog | 4 ++--
# package/debian-mingw64/changelog | 4 ++--
# package/debian/changelog | 4 ++--
# package/mingw-ncurses.nsi | 4 ++--
# package/mingw-ncurses.spec | 2 +-
# package/ncurses.spec | 2 +-
# package/ncursest.spec | 2 +-
# 13 files changed, 52 insertions(+), 37 deletions(-)
# ------------------------------------------------------------------------------
Index: Ada95/configure
--- ncurses-6.1-20190907+/Ada95/configure 2019-09-07 23:37:18.000000000 +0000
+++ ncurses-6.1-20190914/Ada95/configure 2019-09-14 19:53:04.000000000 +0000
@@ -1,5 +1,5 @@
#! /bin/sh
-# From configure.in Revision: 1.72 .
+# From configure.in Revision: 1.73 .
# Guess values for system-dependent variables and create Makefiles.
# Generated by Autoconf 2.52.20190901.
#
@@ -16564,7 +16564,7 @@
ADAGEN_LDFLAGS='$(NATIVE_LDFLAGS)'
fi
-ac_config_files="$ac_config_files $SUB_MAKEFILES doc/adacurses${DFT_ARG_SUFFIX}-config.1:doc/MKada_config.in Makefile"
+ac_config_files="$ac_config_files $SUB_MAKEFILES src/library.gpr:src/library.gpr.in doc/adacurses${DFT_ARG_SUFFIX}-config.1:doc/MKada_config.in Makefile"
ac_config_commands="$ac_config_commands default"
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
@@ -16907,11 +16907,12 @@
case "$ac_config_target" in
# Handling of arguments.
"$SUB_MAKEFILES" ) CONFIG_FILES="$CONFIG_FILES $SUB_MAKEFILES" ;;
+ "src/library.gpr" ) CONFIG_FILES="$CONFIG_FILES src/library.gpr:src/library.gpr.in" ;;
"doc/adacurses${DFT_ARG_SUFFIX}-config.1" ) CONFIG_FILES="$CONFIG_FILES doc/adacurses${DFT_ARG_SUFFIX}-config.1:doc/MKada_config.in" ;;
"Makefile" ) CONFIG_FILES="$CONFIG_FILES Makefile" ;;
"default" ) CONFIG_COMMANDS="$CONFIG_COMMANDS default" ;;
"include/ncurses_cfg.h" ) CONFIG_HEADERS="$CONFIG_HEADERS include/ncurses_cfg.h:include/ncurses_cfg.hin" ;;
- *) { { echo "$as_me:16914: error: invalid argument: $ac_config_target" >&5
+ *) { { echo "$as_me:16915: error: invalid argument: $ac_config_target" >&5
echo "$as_me: error: invalid argument: $ac_config_target" >&2;}
{ (exit 1); exit 1; }; };;
esac
@@ -17264,7 +17265,7 @@
esac
if test x"$ac_file" != x-; then
- { echo "$as_me:17267: creating $ac_file" >&5
+ { echo "$as_me:17268: creating $ac_file" >&5
echo "$as_me: creating $ac_file" >&6;}
rm -f "$ac_file"
fi
@@ -17282,7 +17283,7 @@
-) echo $tmp/stdin ;;
[\\/$]*)
# Absolute (can't be DOS-style, as IFS=:)
- test -f "$f" || { { echo "$as_me:17285: error: cannot find input file: $f" >&5
+ test -f "$f" || { { echo "$as_me:17286: error: cannot find input file: $f" >&5
echo "$as_me: error: cannot find input file: $f" >&2;}
{ (exit 1); exit 1; }; }
echo $f;;
@@ -17295,7 +17296,7 @@
echo $srcdir/$f
else
# /dev/null tree
- { { echo "$as_me:17298: error: cannot find input file: $f" >&5
+ { { echo "$as_me:17299: error: cannot find input file: $f" >&5
echo "$as_me: error: cannot find input file: $f" >&2;}
{ (exit 1); exit 1; }; }
fi;;
@@ -17311,7 +17312,7 @@
if test -n "$ac_seen"; then
ac_used=`grep '@datarootdir@' $ac_item`
if test -z "$ac_used"; then
- { echo "$as_me:17314: WARNING: datarootdir was used implicitly but not set:
+ { echo "$as_me:17315: WARNING: datarootdir was used implicitly but not set:
$ac_seen" >&5
echo "$as_me: WARNING: datarootdir was used implicitly but not set:
$ac_seen" >&2;}
@@ -17320,7 +17321,7 @@
fi
ac_seen=`grep '${datarootdir}' $ac_item`
if test -n "$ac_seen"; then
- { echo "$as_me:17323: WARNING: datarootdir was used explicitly but not set:
+ { echo "$as_me:17324: WARNING: datarootdir was used explicitly but not set:
$ac_seen" >&5
echo "$as_me: WARNING: datarootdir was used explicitly but not set:
$ac_seen" >&2;}
@@ -17357,7 +17358,7 @@
ac_init=`egrep '[ ]*'$ac_name'[ ]*=' $ac_file`
if test -z "$ac_init"; then
ac_seen=`echo "$ac_seen" |sed -e 's,^,'$ac_file':,'`
- { echo "$as_me:17360: WARNING: Variable $ac_name is used but was not set:
+ { echo "$as_me:17361: WARNING: Variable $ac_name is used but was not set:
$ac_seen" >&5
echo "$as_me: WARNING: Variable $ac_name is used but was not set:
$ac_seen" >&2;}
@@ -17368,7 +17369,7 @@
egrep -n '@[A-Z_][A-Z_0-9]+@' $ac_file >>$tmp/out
if test -s $tmp/out; then
ac_seen=`sed -e 's,^,'$ac_file':,' < $tmp/out`
- { echo "$as_me:17371: WARNING: Some variables may not be substituted:
+ { echo "$as_me:17372: WARNING: Some variables may not be substituted:
$ac_seen" >&5
echo "$as_me: WARNING: Some variables may not be substituted:
$ac_seen" >&2;}
@@ -17417,7 +17418,7 @@
* ) ac_file_in=$ac_file.in ;;
esac
- test x"$ac_file" != x- && { echo "$as_me:17420: creating $ac_file" >&5
+ test x"$ac_file" != x- && { echo "$as_me:17421: creating $ac_file" >&5
echo "$as_me: creating $ac_file" >&6;}
# First look for the input files in the build tree, otherwise in the
@@ -17428,7 +17429,7 @@
-) echo $tmp/stdin ;;
[\\/$]*)
# Absolute (can't be DOS-style, as IFS=:)
- test -f "$f" || { { echo "$as_me:17431: error: cannot find input file: $f" >&5
+ test -f "$f" || { { echo "$as_me:17432: error: cannot find input file: $f" >&5
echo "$as_me: error: cannot find input file: $f" >&2;}
{ (exit 1); exit 1; }; }
echo $f;;
@@ -17441,7 +17442,7 @@
echo $srcdir/$f
else
# /dev/null tree
- { { echo "$as_me:17444: error: cannot find input file: $f" >&5
+ { { echo "$as_me:17445: error: cannot find input file: $f" >&5
echo "$as_me: error: cannot find input file: $f" >&2;}
{ (exit 1); exit 1; }; }
fi;;
@@ -17499,7 +17500,7 @@
rm -f $tmp/in
if test x"$ac_file" != x-; then
if cmp -s $ac_file $tmp/config.h 2>/dev/null; then
- { echo "$as_me:17502: $ac_file is unchanged" >&5
+ { echo "$as_me:17503: $ac_file is unchanged" >&5
echo "$as_me: $ac_file is unchanged" >&6;}
else
ac_dir=`$as_expr X"$ac_file" : 'X\(.*[^/]\)//*[^/][^/]*/*$' \| \
Index: Ada95/configure.in
Prereq: 1.72
--- ncurses-6.1-20190907+/Ada95/configure.in 2019-09-07 22:50:06.000000000 +0000
+++ ncurses-6.1-20190914/Ada95/configure.in 2019-09-14 19:33:07.000000000 +0000
@@ -28,14 +28,14 @@
dnl
dnl Author: Thomas E. Dickey
dnl
-dnl $Id: configure.in,v 1.72 2019/09/07 22:50:06 tom Exp $
+dnl $Id: configure.in,v 1.73 2019/09/14 19:33:07 tom Exp $
dnl Process this file with autoconf to produce a configure script.
dnl
dnl See https://invisible-island.net/autoconf/ for additional information.
dnl
dnl ---------------------------------------------------------------------------
AC_PREREQ(2.52.20030208)
-AC_REVISION($Revision: 1.72 $)
+AC_REVISION($Revision: 1.73 $)
AC_INIT(gen/gen.c)
AC_CONFIG_HEADER(include/ncurses_cfg.h:include/ncurses_cfg.hin)
@@ -609,6 +609,7 @@
AC_OUTPUT( \
$SUB_MAKEFILES \
+ src/library.gpr:src/library.gpr.in \
doc/adacurses${DFT_ARG_SUFFIX}-config.1:doc/MKada_config.in \
Makefile,[
if test -z "$USE_OLD_MAKERULES" ; then
Index: Ada95/package/AdaCurses.spec
Prereq: 1.19
--- ncurses-6.1-20190907+/Ada95/package/AdaCurses.spec 2019-09-08 01:00:18.000000000 +0000
+++ ncurses-6.1-20190914/Ada95/package/AdaCurses.spec 2019-09-15 00:07:32.000000000 +0000
@@ -2,7 +2,7 @@
%define AppProgram AdaCurses
%define AppVersion MAJOR.MINOR
%define AppRelease YYYYMMDD
-# $Id: AdaCurses.spec,v 1.19 2019/09/08 01:00:18 tom Exp $
+# $Id: AdaCurses.spec,v 1.24 2019/09/15 00:07:32 tom Exp $
Name: %{AppProgram}
Version: %{AppVersion}
Release: %{AppRelease}
@@ -22,9 +22,13 @@
%define debug_package %{nil}
+%define need_filter %(if grep -E -i '(mageia|red hat|fedora)' /etc/issue >/dev/null; then echo 1; elif test -f /etc/fedora-release; then echo 1; else echo 0; fi)
+
+%if %{need_filter} == 1
# http://fedoraproject.org/wiki/EPEL:Packaging_Autoprovides_and_Requires_Filtering
%filter_from_requires /lib%{AppProgram}.so.1/d
%filter_setup
+%endif
%setup -q -n %{AppProgram}-%{AppRelease}
@@ -52,12 +56,12 @@
%install
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
-make install DESTDIR=$RPM_BUILD_ROOT
+make install DESTDIR=$RPM_BUILD_ROOT
( cd samples &&
make install.examples \
- DESTDIR=$RPM_BUILD_ROOT \
- BINDIR=$RPM_BUILD_ROOT%{_bindir}/%{AppProgram}
+ DESTDIR=$RPM_BUILD_ROOT \
+ BINDIR=$RPM_BUILD_ROOT%{_bindir}/%{AppProgram}
)
%clean
@@ -67,14 +71,20 @@
%defattr(-,root,root)
%{_bindir}/adacurses*-config
%{_bindir}/%{AppProgram}/*
-%{ada_libdir}/lib%{AppProgram}.*
+%{ada_libdir}/
+%if %{need_filter} == 1
+%{_libdir}/lib%{AppProgram}.*
+%endif
%{_mandir}/man1/adacurses*-config.1*
%{_datadir}/%{AppProgram}/*
-%{ada_include}/terminal_interface*
+%{ada_include}/
%changelog
# each patch should add its ChangeLog entries here
+* Sat Sep 14 2019 Thomas Dickey
+- build-fixes for Fedora29, OpenSUSE
+
* Sat Sep 07 2019 Thomas Dickey
- use AppProgram to replace "AdaCurses" globally
- amend install-paths to work with Fedora30
Index: NEWS
Prereq: 1.3371
--- ncurses-6.1-20190907+/NEWS 2019-09-07 22:41:16.000000000 +0000
+++ ncurses-6.1-20190914/NEWS 2019-09-14 23:18:21.000000000 +0000
@@ -25,7 +25,7 @@
-- sale, use or other dealings in this Software without prior written --
-- authorization. --
-------------------------------------------------------------------------------
--- $Id: NEWS,v 1.3371 2019/09/07 22:41:16 tom Exp $
+-- $Id: NEWS,v 1.3373 2019/09/14 23:18:21 tom Exp $
-------------------------------------------------------------------------------
This is a log of changes that ncurses has gone through since Zeyd started
@@ -45,6 +45,9 @@
Changes through 1.9.9e did not credit all contributions;
it is not possible to add this information.
+20190914
+ + build-fixes for Ada95 configure-script and corresponding test package
+
20190907
+ add --with-ada-libname option and modify Ada95 configuration to
allow renaming the "AdaCurses" library (prompted by proposed changes
Index: VERSION
--- ncurses-6.1-20190907+/VERSION 2019-09-07 15:19:35.000000000 +0000
+++ ncurses-6.1-20190914/VERSION 2019-09-14 13:43:52.000000000 +0000
@@ -1 +1 @@
-5:0:10 6.1 20190907
+5:0:10 6.1 20190914
Index: dist.mk
Prereq: 1.1304
--- ncurses-6.1-20190907+/dist.mk 2019-09-07 15:19:35.000000000 +0000
+++ ncurses-6.1-20190914/dist.mk 2019-09-14 13:43:52.000000000 +0000
@@ -25,7 +25,7 @@
# use or other dealings in this Software without prior written #
# authorization. #
##############################################################################
-# $Id: dist.mk,v 1.1304 2019/09/07 15:19:35 tom Exp $
+# $Id: dist.mk,v 1.1305 2019/09/14 13:43:52 tom Exp $
# Makefile for creating ncurses distributions.
#
# This only needs to be used directly as a makefile by developers, but
@@ -37,7 +37,7 @@
# These define the major/minor/patch versions of ncurses.
NCURSES_MAJOR = 6
NCURSES_MINOR = 1
-NCURSES_PATCH = 20190907
+NCURSES_PATCH = 20190914
# We don't append the patch to the version, since this only applies to releases
VERSION = $(NCURSES_MAJOR).$(NCURSES_MINOR)
Index: package/debian-mingw/changelog
--- ncurses-6.1-20190907+/package/debian-mingw/changelog 2019-09-07 15:19:35.000000000 +0000
+++ ncurses-6.1-20190914/package/debian-mingw/changelog 2019-09-14 13:43:52.000000000 +0000
@@ -1,8 +1,8 @@
-ncurses6 (6.1+20190907) unstable; urgency=low
+ncurses6 (6.1+20190914) unstable; urgency=low
* latest weekly patch
- -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 07 Sep 2019 11:19:35 -0400
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 14 Sep 2019 09:43:52 -0400
ncurses6 (5.9-20131005) unstable; urgency=low
Index: package/debian-mingw64/changelog
--- ncurses-6.1-20190907+/package/debian-mingw64/changelog 2019-09-07 15:19:35.000000000 +0000
+++ ncurses-6.1-20190914/package/debian-mingw64/changelog 2019-09-14 13:43:52.000000000 +0000
@@ -1,8 +1,8 @@
-ncurses6 (6.1+20190907) unstable; urgency=low
+ncurses6 (6.1+20190914) unstable; urgency=low
* latest weekly patch
- -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 07 Sep 2019 11:19:35 -0400
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 14 Sep 2019 09:43:52 -0400
ncurses6 (5.9-20131005) unstable; urgency=low
Index: package/debian/changelog
--- ncurses-6.1-20190907+/package/debian/changelog 2019-09-07 15:19:35.000000000 +0000
+++ ncurses-6.1-20190914/package/debian/changelog 2019-09-14 13:43:52.000000000 +0000
@@ -1,8 +1,8 @@
-ncurses6 (6.1+20190907) unstable; urgency=low
+ncurses6 (6.1+20190914) unstable; urgency=low
* latest weekly patch
- -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 07 Sep 2019 11:19:35 -0400
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 14 Sep 2019 09:43:52 -0400
ncurses6 (5.9-20120608) unstable; urgency=low
Index: package/mingw-ncurses.nsi
Prereq: 1.350
--- ncurses-6.1-20190907+/package/mingw-ncurses.nsi 2019-09-07 15:19:35.000000000 +0000
+++ ncurses-6.1-20190914/package/mingw-ncurses.nsi 2019-09-14 13:43:52.000000000 +0000
@@ -1,4 +1,4 @@
-; $Id: mingw-ncurses.nsi,v 1.350 2019/09/07 15:19:35 tom Exp $
+; $Id: mingw-ncurses.nsi,v 1.351 2019/09/14 13:43:52 tom Exp $
; TODO add examples
; TODO bump ABI to 6
@@ -10,7 +10,7 @@
!define VERSION_MAJOR "6"
!define VERSION_MINOR "1"
!define VERSION_YYYY "2019"
-!define VERSION_MMDD "0907"
+!define VERSION_MMDD "0914"
!define VERSION_PATCH ${VERSION_YYYY}${VERSION_MMDD}
!define MY_ABI "5"
Index: package/mingw-ncurses.spec
--- ncurses-6.1-20190907+/package/mingw-ncurses.spec 2019-09-07 15:19:35.000000000 +0000
+++ ncurses-6.1-20190914/package/mingw-ncurses.spec 2019-09-14 13:43:52.000000000 +0000
@@ -3,7 +3,7 @@
Summary: shared libraries for terminal handling
Name: mingw32-ncurses6
Version: 6.1
-Release: 20190907
+Release: 20190914
License: X11
Group: Development/Libraries
Source: ncurses-%{version}-%{release}.tgz
Index: package/ncurses.spec
--- ncurses-6.1-20190907+/package/ncurses.spec 2019-09-07 15:19:35.000000000 +0000
+++ ncurses-6.1-20190914/package/ncurses.spec 2019-09-14 13:43:52.000000000 +0000
@@ -1,7 +1,7 @@
Summary: shared libraries for terminal handling
Name: ncurses6
Version: 6.1
-Release: 20190907
+Release: 20190914
License: X11
Group: Development/Libraries
Source: ncurses-%{version}-%{release}.tgz
Index: package/ncursest.spec
--- ncurses-6.1-20190907+/package/ncursest.spec 2019-09-07 15:19:35.000000000 +0000
+++ ncurses-6.1-20190914/package/ncursest.spec 2019-09-14 13:43:52.000000000 +0000
@@ -1,7 +1,7 @@
Summary: Curses library with POSIX thread support.
Name: ncursest6
Version: 6.1
-Release: 20190907
+Release: 20190914
License: X11
Group: Development/Libraries
Source: ncurses-%{version}-%{release}.tgz