# ncurses 6.1 - patch 20191214 - Thomas E. Dickey # # ------------------------------------------------------------------------------ # # Ncurses 6.1 is at # ftp.gnu.org:/pub/gnu # # Patches for ncurses 6.1 can be found at # ftp://ftp.invisible-island.net/ncurses/6.1 # http://invisible-mirror.net/archives/ncurses/6.1 # # ------------------------------------------------------------------------------ # ftp://ftp.invisible-island.net/ncurses/6.1/ncurses-6.1-20191214.patch.gz # patch by Thomas E. Dickey # created Sun Dec 15 02:10:35 UTC 2019 # ------------------------------------------------------------------------------ # NEWS | 6 ++++- # VERSION | 2 - # c++/cursesmain.cc | 6 ++--- # dist.mk | 4 +-- # doc/html/ada/funcs/T.htm | 2 - # doc/html/man/adacurses6-config.1.html | 2 - # doc/html/man/captoinfo.1m.html | 2 - # doc/html/man/clear.1.html | 2 - # doc/html/man/curs_memleaks.3x.html | 35 +++++++++++++++++++++----------- # doc/html/man/form.3x.html | 2 - # doc/html/man/infocmp.1m.html | 2 - # doc/html/man/infotocap.1m.html | 2 - # doc/html/man/menu.3x.html | 2 - # doc/html/man/ncurses.3x.html | 2 - # doc/html/man/ncurses6-config.1.html | 2 - # doc/html/man/panel.3x.html | 2 - # doc/html/man/tabs.1.html | 2 - # doc/html/man/terminfo.5.html | 2 - # doc/html/man/tic.1m.html | 2 - # doc/html/man/toe.1m.html | 2 - # doc/html/man/tput.1.html | 2 - # doc/html/man/tset.1.html | 2 - # include/MKterm.h.awk.in | 13 +++++++++-- # include/curses.tail | 4 ++- # include/nc_alloc.h | 16 ++++++++++---- # man/curs_memleaks.3x | 29 +++++++++++++++++++------- # ncurses/base/lib_freeall.c | 19 ++++++++++++++--- # ncurses/curses.priv.h | 9 +------- # ncurses/llib-lncurses | 15 +++++++++++++ # ncurses/llib-lncursest | 16 ++++++++++++++ # ncurses/llib-lncursestw | 16 ++++++++++++++ # ncurses/llib-lncursesw | 16 ++++++++++++++ # ncurses/tinfo/comp_parse.c | 4 +-- # ncurses/tinfo/entries.c | 11 +++++++++- # ncurses/tty/hashmap.c | 16 +++++--------- # package/debian-mingw/changelog | 4 +-- # package/debian-mingw64/changelog | 4 +-- # package/debian/changelog | 4 +-- # package/mingw-ncurses.nsi | 4 +-- # package/mingw-ncurses.spec | 2 - # package/ncurses.map | 11 ++++++++-- # package/ncurses.spec | 2 - # package/ncurses.sym | 4 ++- # package/ncursest.map | 12 +++++++++- # package/ncursest.spec | 2 - # package/ncursest.sym | 4 ++- # package/ncursestw.map | 11 ++++++++-- # package/ncursestw.sym | 4 ++- # package/ncursesw.map | 11 ++++++++-- # package/ncursesw.sym | 4 ++- # progs/progs.priv.h | 7 +++--- # test/demo_new_pair.c | 6 ++--- # test/echochar.c | 4 +-- # test/firework.c | 6 ++--- # test/gdc.c | 8 +++---- # test/hanoi.c | 6 ++--- # test/lrtest.c | 4 +-- # test/ncurses.c | 8 +++---- # test/newdemo.c | 8 +++---- # test/picsmap.c | 14 ++++++------ # test/rain.c | 8 +++---- # test/savescreen.c | 8 +++---- # test/tclock.c | 4 +-- # test/test.priv.h | 8 +++---- # test/testcurs.c | 8 +++---- # test/worm.c | 6 ++--- # test/xmas.c | 6 ++--- # 67 files changed, 315 insertions(+), 158 deletions(-) # ------------------------------------------------------------------------------ Index: NEWS Prereq: 1.3415 --- ncurses-6.1-20191207+/NEWS 2019-12-07 23:36:25.000000000 +0000 +++ ncurses-6.1-20191214/NEWS 2019-12-14 21:26:03.000000000 +0000 @@ -25,7 +25,7 @@ -- sale, use or other dealings in this Software without prior written -- -- authorization. -- ------------------------------------------------------------------------------- --- $Id: NEWS,v 1.3415 2019/12/07 23:36:25 tom Exp $ +-- $Id: NEWS,v 1.3416 2019/12/14 21:26:03 tom Exp $ ------------------------------------------------------------------------------- This is a log of changes that ncurses has gone through since Zeyd started @@ -45,6 +45,10 @@ Changes through 1.9.9e did not credit all contributions; it is not possible to add this information. +20191214 + + add exit_curses() and exit_terminfo() to replace internal symbols for + leak-checking. + 20191207 + fix a few warnings for test-package builds + add curses_trace(), to replace trace(). Index: VERSION --- ncurses-6.1-20191207+/VERSION 2019-12-07 10:19:49.000000000 +0000 +++ ncurses-6.1-20191214/VERSION 2019-12-14 17:50:13.000000000 +0000 @@ -1 +1 @@ -5:0:10 6.1 20191207 +5:0:10 6.1 20191214 Index: c++/cursesmain.cc Prereq: 1.15 --- ncurses-6.1-20191207+/c++/cursesmain.cc 2013-09-28 20:56:47.000000000 +0000 +++ ncurses-6.1-20191214/c++/cursesmain.cc 2019-12-14 22:48:23.000000000 +0000 @@ -1,6 +1,6 @@ // * this is for making emacs happy: -*-Mode: C++;-*- /**************************************************************************** - * Copyright (c) 1998-2007,2013 Free Software Foundation, Inc. * + * Copyright (c) 1998-2013,2019 Free Software Foundation, Inc. * * * * Permission is hereby granted, free of charge, to any person obtaining a * * copy of this software and associated documentation files (the * @@ -43,7 +43,7 @@ #define CPP_HAS_TRY_CATCH 0 #endif -MODULE_ID("$Id: cursesmain.cc,v 1.15 2013/09/28 20:56:47 tom Exp $") +MODULE_ID("$Id: cursesmain.cc,v 1.16 2019/12/14 22:48:23 tom Exp $") #if HAVE_LOCALE_H #include @@ -87,7 +87,7 @@ #endif #if NO_LEAKS delete A; - _nc_free_and_exit(res); + exit_curses(res); #else return(res); #endif Index: dist.mk Prereq: 1.1318 --- ncurses-6.1-20191207+/dist.mk 2019-12-07 10:19:49.000000000 +0000 +++ ncurses-6.1-20191214/dist.mk 2019-12-14 17:50:13.000000000 +0000 @@ -25,7 +25,7 @@ # use or other dealings in this Software without prior written # # authorization. # ############################################################################## -# $Id: dist.mk,v 1.1318 2019/12/07 10:19:49 tom Exp $ +# $Id: dist.mk,v 1.1319 2019/12/14 17:50:13 tom Exp $ # Makefile for creating ncurses distributions. # # This only needs to be used directly as a makefile by developers, but @@ -37,7 +37,7 @@ # These define the major/minor/patch versions of ncurses. NCURSES_MAJOR = 6 NCURSES_MINOR = 1 -NCURSES_PATCH = 20191207 +NCURSES_PATCH = 20191214 # We don't append the patch to the version, since this only applies to releases VERSION = $(NCURSES_MAJOR).$(NCURSES_MINOR) Index: doc/html/ada/funcs/T.htm --- ncurses-6.1-20191207+/doc/html/ada/funcs/T.htm 2019-07-26 23:48:31.000000000 +0000 +++ ncurses-6.1-20191214/doc/html/ada/funcs/T.htm 2019-12-15 00:54:38.000000000 +0000 @@ -20,8 +20,8 @@
  • tgetnum
  • tgetstr - terminal_interface-curses-termcap.adb:108
  • tgetstr - terminal_interface-curses-termcap.adb:129 -
  • TGoto
  • tgoto +
  • TGoto
  • tigetflag
  • tigetstr - terminal_interface-curses-terminfo.adb:87
  • tigetstr - terminal_interface-curses-terminfo.adb:108 Index: doc/html/man/adacurses6-config.1.html --- ncurses-6.1-20191207+/doc/html/man/adacurses6-config.1.html 2019-12-07 20:48:39.000000000 +0000 +++ ncurses-6.1-20191214/doc/html/man/adacurses6-config.1.html 2019-12-15 00:54:32.000000000 +0000 @@ -125,7 +125,7 @@

    SEE ALSO

            curses(3x)
     
    -       This describes ncurses version 6.1 (patch 20191207).
    +       This describes ncurses version 6.1 (patch 20191214).
     
     
     
    Index: doc/html/man/captoinfo.1m.html
    --- ncurses-6.1-20191207+/doc/html/man/captoinfo.1m.html	2019-12-07 20:48:39.000000000 +0000
    +++ ncurses-6.1-20191214/doc/html/man/captoinfo.1m.html	2019-12-15 00:54:32.000000000 +0000
    @@ -198,7 +198,7 @@
     

    SEE ALSO

            infocmp(1m), curses(3x), terminfo(5)
     
    -       This describes ncurses version 6.1 (patch 20191207).
    +       This describes ncurses version 6.1 (patch 20191214).
     
     
     

    AUTHOR

    Index: doc/html/man/clear.1.html
    --- ncurses-6.1-20191207+/doc/html/man/clear.1.html	2019-12-07 20:48:39.000000000 +0000
    +++ ncurses-6.1-20191214/doc/html/man/clear.1.html	2019-12-15 00:54:32.000000000 +0000
    @@ -148,7 +148,7 @@
     

    SEE ALSO

            tput(1), terminfo(5)
     
    -       This describes ncurses version 6.1 (patch 20191207).
    +       This describes ncurses version 6.1 (patch 20191214).
     
     
     
    Index: doc/html/man/curs_memleaks.3x.html
    --- ncurses-6.1-20191207+/doc/html/man/curs_memleaks.3x.html	2019-03-16 19:34:44.000000000 +0000
    +++ ncurses-6.1-20191214/doc/html/man/curs_memleaks.3x.html	2019-12-15 00:54:33.000000000 +0000
    @@ -1,6 +1,6 @@