update to 0.5.6 [release 0.5.6-1mamba;Sat Dec 04 2021]
This commit is contained in:
parent
9b38170562
commit
520dd5808a
58
navit-0.5.6-espeak-fix-multiple-definitions.patch
Normal file
58
navit-0.5.6-espeak-fix-multiple-definitions.patch
Normal file
@ -0,0 +1,58 @@
|
|||||||
|
--- navit-0.5.6/navit/support/espeak/espeak.c.orig 2021-12-04 17:40:47.205979646 +0100
|
||||||
|
+++ navit-0.5.6/navit/support/espeak/espeak.c 2021-12-04 17:41:06.501330463 +0100
|
||||||
|
@@ -102,7 +102,7 @@
|
||||||
|
char wavefile[200];
|
||||||
|
|
||||||
|
|
||||||
|
-int GetFileLength(const char *filename)
|
||||||
|
+/*int GetFileLength(const char *filename)
|
||||||
|
{//====================================
|
||||||
|
struct stat statbuf;
|
||||||
|
|
||||||
|
@@ -114,7 +114,7 @@
|
||||||
|
|
||||||
|
return(statbuf.st_size);
|
||||||
|
} // end of GetFileLength
|
||||||
|
-
|
||||||
|
+*/
|
||||||
|
|
||||||
|
void strncpy0(char *dest, const char *source, int size)
|
||||||
|
{//====================================================
|
||||||
|
--- navit-0.5.6/navit/support/espeak/dictionary.c.orig 2021-12-04 17:39:49.418929674 +0100
|
||||||
|
+++ navit-0.5.6/navit/support/espeak/dictionary.c 2021-12-04 17:40:01.918156691 +0100
|
||||||
|
@@ -80,7 +80,7 @@
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
-void strncpy0(char *to,const char *from, int size)
|
||||||
|
+void strncpy1(char *to,const char *from, int size)
|
||||||
|
{//===================================================
|
||||||
|
// strcpy with limit, ensures a zero terminator
|
||||||
|
strncpy(to,from,size);
|
||||||
|
@@ -3101,7 +3101,7 @@
|
||||||
|
word1 = word;
|
||||||
|
if(tr->transpose_min > 0)
|
||||||
|
{
|
||||||
|
- strncpy0(word_buf,word, N_WORD_BYTES);
|
||||||
|
+ strncpy1(word_buf,word, N_WORD_BYTES);
|
||||||
|
wlen = TransposeAlphabet(tr, word_buf); // bit 6 indicates compressed characters
|
||||||
|
word = word_buf;
|
||||||
|
}
|
||||||
|
@@ -3493,7 +3493,7 @@
|
||||||
|
}
|
||||||
|
else
|
||||||
|
{
|
||||||
|
- strncpy0(tr->phonemes_repeat, ph_out, sizeof(tr->phonemes_repeat));
|
||||||
|
+ strncpy1(tr->phonemes_repeat, ph_out, sizeof(tr->phonemes_repeat));
|
||||||
|
tr->phonemes_repeat_count = 1;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
@@ -3597,7 +3597,7 @@
|
||||||
|
say_as = option_sayas;
|
||||||
|
option_sayas = 0; // don't speak replacement word as letter names
|
||||||
|
text[0] = 0;
|
||||||
|
- strncpy0(&(text[1]), word1, sizeof(text)-2);
|
||||||
|
+ strncpy1(&(text[1]), word1, sizeof(text)-2);
|
||||||
|
found = TranslateWord(tr, &text[1], 0, NULL, NULL);
|
||||||
|
strcpy(ph_out, word_phonemes);
|
||||||
|
option_sayas = say_as;
|
124
navit.spec
124
navit.spec
@ -1,114 +1,130 @@
|
|||||||
Name: navit
|
Name: navit
|
||||||
Version: 0.5.0_20140921svn
|
Version: 0.5.6
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: Navit is a car navigation software for Linux
|
Summary: Navit is a car navigation software for Linux
|
||||||
Group: Graphical Desktop/Applications/Utilities
|
Group: Graphical Desktop/Applications/Utilities
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Ercole 'ercolinux' Carpanetto <ercole69@gmail.com>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.navit-project.org/
|
URL: https://www.navit-project.org/
|
||||||
# to download source: svn co https://navit.svn.sourceforge.net/svnroot/navit/trunk/navit
|
Source: https://github.com/navit-gps/navit.git/v%{version}/navit-%{version}.tar.bz2
|
||||||
Source: https://navit.svn.sourceforge.net/svnroot/navit/trunk/navit/navit-%{version}.tar.bz2
|
Patch0: navit-0.5.6-espeak-fix-multiple-definitions.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libGLU-devel
|
||||||
|
BuildRequires: libQt5Multimedia-devel
|
||||||
|
BuildRequires: libQt5Positioning-devel
|
||||||
|
BuildRequires: libQt5Sensors-devel
|
||||||
|
BuildRequires: libQt5Svg-devel
|
||||||
BuildRequires: libSDL-devel
|
BuildRequires: libSDL-devel
|
||||||
BuildRequires: libSDL_image-devel
|
BuildRequires: libSDL_image-devel
|
||||||
BuildRequires: libX11-devel
|
|
||||||
BuildRequires: libXau-devel
|
|
||||||
BuildRequires: libXdmcp-devel
|
|
||||||
BuildRequires: libXext-devel
|
|
||||||
BuildRequires: libatk-devel
|
BuildRequires: libatk-devel
|
||||||
BuildRequires: libbzip2-devel
|
|
||||||
BuildRequires: libcairo-devel
|
BuildRequires: libcairo-devel
|
||||||
BuildRequires: libdbus-devel
|
BuildRequires: libdbus-devel
|
||||||
BuildRequires: libdbus-glib-devel
|
BuildRequires: libdbus-glib-devel
|
||||||
BuildRequires: libdirectfb-devel
|
|
||||||
BuildRequires: libexpat-devel
|
|
||||||
BuildRequires: libffi-devel
|
|
||||||
BuildRequires: libfontconfig-devel
|
BuildRequires: libfontconfig-devel
|
||||||
|
BuildRequires: libfreeglut-devel
|
||||||
BuildRequires: libfreetype-devel
|
BuildRequires: libfreetype-devel
|
||||||
BuildRequires: libfribidi-devel
|
BuildRequires: libfribidi-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libgdk-pixbuf-devel
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
|
BuildRequires: libgeoclue-devel
|
||||||
BuildRequires: libglib-devel
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libglvnd-devel
|
||||||
BuildRequires: libgps-devel
|
BuildRequires: libgps-devel
|
||||||
BuildRequires: libgraphite2-devel
|
|
||||||
BuildRequires: libgtk2-devel
|
BuildRequires: libgtk2-devel
|
||||||
BuildRequires: libharfbuzz-devel
|
BuildRequires: libharfbuzz-devel
|
||||||
BuildRequires: libimlib2-devel
|
BuildRequires: libimlib2-devel
|
||||||
BuildRequires: libopenssl-devel
|
|
||||||
BuildRequires: libpango-devel
|
BuildRequires: libpango-devel
|
||||||
BuildRequires: libpng-devel
|
BuildRequires: libpng-devel
|
||||||
BuildRequires: libpostgresql-devel
|
BuildRequires: libprotobuf-c-devel
|
||||||
BuildRequires: libpython27-devel
|
BuildRequires: libpython39-devel
|
||||||
BuildRequires: libqt4-devel
|
|
||||||
BuildRequires: libselinux-devel
|
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libts-devel
|
|
||||||
BuildRequires: libxcb-devel
|
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
|
BuildRequires: qt5-qtbase-devel
|
||||||
|
BuildRequires: qt5-qtdeclarative-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRequires: libespeak-ng-devel >= 1.50
|
||||||
|
BuildRequires: libgps-devel >= 3.21
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Navit is a car navigation system with routing engine.
|
Navit is a car navigation system with routing engine.
|
||||||
Navit's modular design is capable of using vector maps of various formats for routing and rendering on the screen. It's even possible to use multiple maps at the same time.
|
Navit's modular design is capable of using vector maps of various formats for routing and rendering on the screen. It's even possible to use multiple maps at the same time.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
./autogen.sh
|
%patch0 -p1
|
||||||
|
|
||||||
%configure --prefix=/usr
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
%cmake -d build \
|
||||||
|
-DCMAKE_C_FLAGS="%{optflags} -fcommon" \
|
||||||
|
-DCMAKE_CXX_FLAGS="%{optflags} -fcommon"
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%makeinstall
|
%makeinstall -C build
|
||||||
|
|
||||||
%find_lang %{name}
|
%find_lang %{name}
|
||||||
|
|
||||||
|
%ifarch x86_64
|
||||||
|
install -D -m0755 build/navit/maptool/libmaptool_core.so %{buildroot}%{_libdir}/libmaptool_core.so
|
||||||
|
%endif
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
|
%ifarch x86_64
|
||||||
%{_bindir}/maptool
|
%{_bindir}/maptool
|
||||||
|
%{_libdir}/libmaptool_core.so
|
||||||
|
%endif
|
||||||
%{_bindir}/navit
|
%{_bindir}/navit
|
||||||
%{_datadir}/applications/navit.desktop
|
|
||||||
%{_datadir}/icons/hicolor/*/apps/navit.png
|
|
||||||
%{_datadir}/navit/README
|
|
||||||
%{_datadir}/navit/navit.xml
|
|
||||||
%{_datadir}/navit/maps/*.bin
|
|
||||||
%{_datadir}/navit/xpm/*.png
|
|
||||||
%{_datadir}/navit/xpm/*.svgz
|
|
||||||
%{_datadir}/navit/xpm/*.xpm
|
|
||||||
%{_datadir}/navit/xpm/*.svg
|
|
||||||
%{_libdir}/navit/vehicle/*.la
|
|
||||||
%{_libdir}/navit/vehicle/*.so
|
|
||||||
%{_libdir}/navit/speech/*.la
|
|
||||||
%{_libdir}/navit/speech/*.so
|
|
||||||
%{_libdir}/navit/osd/*.la
|
|
||||||
%{_libdir}/navit/osd/*.so
|
|
||||||
%{_libdir}/navit/map/*.la
|
|
||||||
%{_libdir}/navit/map/*.so
|
|
||||||
%{_libdir}/navit/gui/*.la
|
|
||||||
%{_libdir}/navit/gui/*.so
|
|
||||||
%{_libdir}/navit/graphics/*.la
|
|
||||||
%{_libdir}/navit/graphics/*.so
|
|
||||||
%{_libdir}/navit/font/*.la
|
|
||||||
%{_libdir}/navit/font/*.so
|
|
||||||
%{_libdir}/navit/binding/*.la
|
|
||||||
%{_libdir}/navit/binding/*.so
|
|
||||||
%{_datadir}/navit/maps/osm_bbox_11.3,47.9,11.7,48.2.xml
|
|
||||||
%{_datadir}/dbus-1/services/org.navit_project.navit.service
|
%{_datadir}/dbus-1/services/org.navit_project.navit.service
|
||||||
%{_mandir}/man1/*.gz
|
%{_datadir}/applications/navit.desktop
|
||||||
%doc AUTHORS COPYING ChangeLog README
|
%dir %{_datadir}/navit
|
||||||
|
%{_datadir}/navit/*
|
||||||
|
%dir %{_libdir}/navit
|
||||||
|
%{_libdir}/navit/lib*.so
|
||||||
|
%dir %{_libdir}/navit/binding
|
||||||
|
%{_libdir}/navit/binding/*.so
|
||||||
|
%dir %{_libdir}/navit/font
|
||||||
|
%{_libdir}/navit/font/*.so
|
||||||
|
%dir %{_libdir}/navit/graphics
|
||||||
|
%{_libdir}/navit/graphics/*.so
|
||||||
|
%dir %{_libdir}/navit/gui
|
||||||
|
%{_libdir}/navit/gui/*.so
|
||||||
|
%dir %{_libdir}/navit/map
|
||||||
|
%{_libdir}/navit/map/*.so
|
||||||
|
%dir %{_libdir}/navit/osd
|
||||||
|
%{_libdir}/navit/osd/*.so
|
||||||
|
%dir %{_libdir}/navit/speech
|
||||||
|
%{_libdir}/navit/speech/*.so
|
||||||
|
%dir %{_libdir}/navit/traffic
|
||||||
|
%{_libdir}/navit/traffic/libtraffic_*.so
|
||||||
|
%dir %{_libdir}/navit/vehicle
|
||||||
|
%{_libdir}/navit/vehicle/*.so
|
||||||
|
%{_datadir}/icons/hicolor/*/apps/navit.png
|
||||||
|
%{_mandir}/man1/maptool.1*
|
||||||
|
%{_mandir}/man1/navit.1*
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Dec 04 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.6-1mamba
|
||||||
|
- update to 0.5.6
|
||||||
|
|
||||||
|
* Mon Sep 10 2018 Automatic Build System <autodist@mambasoft.it> 0.5.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Jul 29 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.1-1mamba
|
||||||
|
- update to 0.5.1
|
||||||
|
|
||||||
* Sun Sep 21 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.0_20140921svn-1mamba
|
* Sun Sep 21 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.0_20140921svn-1mamba
|
||||||
- update to 0.5.0_20140921svn
|
- update to 0.5.0_20140921svn
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user