provide user and group nagios
added debug package [release 4.5.3-2mamba;Thu Jun 13 2024]
This commit is contained in:
parent
a361402f56
commit
91672e829b
@ -1,20 +0,0 @@
|
||||
diff -ru nagios/Makefile.in nagios-om/Makefile.in
|
||||
--- nagios/Makefile.in 2012-06-21 13:16:10.000000000 +0200
|
||||
+++ nagios-om/Makefile.in 2012-11-16 17:37:07.000000000 +0100
|
||||
@@ -290,6 +290,7 @@
|
||||
@echo ""
|
||||
|
||||
install-webconf:
|
||||
+ $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(HTTPD_CONF)
|
||||
$(INSTALL) -m 644 sample-config/httpd.conf $(DESTDIR)$(HTTPD_CONF)/nagios.conf
|
||||
|
||||
@echo ""
|
||||
@@ -334,7 +335,7 @@
|
||||
@echo ""
|
||||
|
||||
|
||||
-fullinstall: install install-init install-commandmode install-webconf
|
||||
+fullinstall: install install-init install-commandmode install-webconf install-config
|
||||
|
||||
# Uninstall is too destructive if base install directory is /usr, etc.
|
||||
#uninstall:
|
@ -1,51 +0,0 @@
|
||||
diff -ru nagios/daemon-init.in nagios-om/daemon-init.in
|
||||
--- nagios/daemon-init.in 2010-10-23 11:59:18.000000000 +0200
|
||||
+++ nagios-om/daemon-init.in 2012-11-16 17:30:08.000000000 +0100
|
||||
@@ -58,11 +58,14 @@
|
||||
printstatus_nagios()
|
||||
{
|
||||
|
||||
- if status_nagios $1 $2; then
|
||||
+ status_nagios $1 $2
|
||||
+ RETVAL=$?
|
||||
+ if [ $RETVAL = 0 ]; then
|
||||
echo "nagios (pid $NagiosPID) is running..."
|
||||
else
|
||||
echo "nagios is not running"
|
||||
fi
|
||||
+ return $RETVAL
|
||||
}
|
||||
|
||||
|
||||
@@ -94,6 +97,11 @@
|
||||
. /etc/init.d/functions
|
||||
fi
|
||||
|
||||
+# Source an extra configuration file
|
||||
+if [ -f /etc/sysconfig/nagios ]; then
|
||||
+ . /etc/sysconfig/nagios
|
||||
+fi
|
||||
+
|
||||
prefix=@prefix@
|
||||
exec_prefix=@exec_prefix@
|
||||
NagiosBin=@bindir@/nagios
|
||||
@@ -129,7 +137,9 @@
|
||||
echo -n "Starting nagios:"
|
||||
$NagiosBin -v $NagiosCfgFile > /dev/null 2>&1;
|
||||
if [ $? -eq 0 ]; then
|
||||
- su - $NagiosUser -c "touch $NagiosVarDir/nagios.log $NagiosRetentionFile"
|
||||
+ pidof nagios > $NagiosRunFile
|
||||
+ touch $NagiosVarDir/nagios.log $NagiosRetentionFile
|
||||
+ chown $NagiosUser:$NagiosGroup $NagiosVarDir/nagios.log $NagiosRetentionFile
|
||||
rm -f $NagiosCommandFile
|
||||
touch $NagiosRunFile
|
||||
chown $NagiosUser:$NagiosGroup $NagiosRunFile
|
||||
@@ -228,7 +238,7 @@
|
||||
|
||||
*)
|
||||
echo "Usage: nagios {start|stop|restart|reload|force-reload|status|checkconfig}"
|
||||
- exit 1
|
||||
+ exit 2
|
||||
;;
|
||||
|
||||
esac
|
@ -1,10 +0,0 @@
|
||||
diff -ru nagios/p1.pl nagios-om/p1.pl
|
||||
--- nagios/p1.pl 2008-05-19 20:02:08.000000000 +0200
|
||||
+++ nagios-om/p1.pl 2012-11-16 18:32:58.000000000 +0100
|
||||
@@ -1,4 +1,5 @@
|
||||
- package Embed::Persistent;
|
||||
+#!/usr/bin/perl
|
||||
+package Embed::Persistent;
|
||||
|
||||
# p1.pl for Nagios
|
||||
|
29
nagios.spec
29
nagios.spec
@ -3,26 +3,24 @@
|
||||
%define cmdgrp nagioscmd
|
||||
|
||||
Name: nagios
|
||||
Version: 4.5.2
|
||||
Release: 1mamba
|
||||
Version: 4.5.3
|
||||
Release: 2mamba
|
||||
Summary: An Open Source host, service and network monitoring program
|
||||
Group: Network/Monitoring
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.nagios.org/
|
||||
Source0: http://downloads.sourceforge.net/sourceforge/nagios/nagios-%{version}.tar.gz
|
||||
Source1: nagios.htaccess
|
||||
Source2: nagios.service
|
||||
Source3: nagios-nginx.conf
|
||||
Patch0: %{name}-3.4.2-nagios_initscripts.patch
|
||||
Patch1: %{name}-3.4.2-makefile_install,patch
|
||||
Patch2: %{name}-3.4.2-fix_path_to_cgi_executables.patch
|
||||
Patch3: %{name}-4.2.2-fix_path_to_passwd_file_in_apache_s_config_file.patch
|
||||
Patch4: %{name}-3.4.2-p1_missing_interpreter.patch
|
||||
Patch5: nagios-3.5.1-confd.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: apache-devel
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libgd-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
@ -41,6 +39,8 @@ BuildRequires: perl(Test::More)
|
||||
BuildRequires: perl(Test::Simple)
|
||||
Requires: mailx
|
||||
Requires: nagios-plugins
|
||||
Provides: user(nagios)
|
||||
Provides: group(nagios)
|
||||
%systemd_requires
|
||||
|
||||
%description
|
||||
@ -70,17 +70,17 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
%description devel
|
||||
This package provides include files that Nagios-related applications may compile against.
|
||||
|
||||
#% debug_package
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
%patch 2 -p1
|
||||
%patch 3 -p1
|
||||
#%patch4 -p1
|
||||
%patch 5 -p1
|
||||
|
||||
# Really disable strip
|
||||
sed -i "s|-s -m|-m|" base/Makefile.in tap/Makefile.in
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--prefix=%{_datadir}/%{name} \
|
||||
@ -109,7 +109,7 @@ This package provides include files that Nagios-related applications may compile
|
||||
--with-template-objects \
|
||||
--with-template-extinfo \
|
||||
--with-mail=/bin/mailx \
|
||||
STRIP=/bin/false
|
||||
STRIP=/bin/true
|
||||
|
||||
# --with-command-group=%{cmdgrp} \
|
||||
|
||||
@ -294,6 +294,13 @@ fi
|
||||
%{_libdir}/nagios/libnagios.a
|
||||
|
||||
%changelog
|
||||
* Thu Jun 13 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 4.5.3-2mamba
|
||||
- provide user and group nagios
|
||||
- added debug package
|
||||
|
||||
* Wed Jun 12 2024 Automatic Build System <autodist@openmamba.org> 4.5.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed May 01 2024 Automatic Build System <autodist@openmamba.org> 4.5.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user