don't require nagios to allow nrpe only installations [release 1.4.16-2mamba;Wed May 07 2014]
This commit is contained in:
parent
969ebb89d3
commit
498a5ccc90
@ -1,2 +1,8 @@
|
||||
# nagios-plugins
|
||||
|
||||
Nagios is a program that will monitor hosts and services on your network, and to email or page you when a problem arises or is resolved.
|
||||
Nagios runs on a unix server as a background or daemon process, intermittently running checks on various services that you specify.
|
||||
The actual service checks are performed by separate "plugin" programs which return the status of the checks to Nagios.
|
||||
|
||||
This package contains the basic plugins necessary for use with the Nagios package.
|
||||
|
||||
|
13
nagios-plugins-1.4.16-undef_gets.patch
Normal file
13
nagios-plugins-1.4.16-undef_gets.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- nagios-plugins-1.4.16/gl/stdio.in.h 2012-06-27 19:32:47.000000000 +0200
|
||||
+++ nagios-plugins-1.4.16/gl/stdio.in.h.glibcfix 2012-10-23 21:40:15.000000000 +0200
|
||||
@@ -140,8 +140,10 @@
|
||||
/* It is very rare that the developer ever has full control of stdin,
|
||||
so any use of gets warrants an unconditional warning. Assume it is
|
||||
always declared, since it is required by C89. */
|
||||
+#if defined gets
|
||||
#undef gets
|
||||
_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
|
||||
+#endif
|
||||
|
||||
#if @GNULIB_FOPEN@
|
||||
# if @REPLACE_FOPEN@
|
133
nagios-plugins.spec
Normal file
133
nagios-plugins.spec
Normal file
@ -0,0 +1,133 @@
|
||||
Name: nagios-plugins
|
||||
Version: 1.4.16
|
||||
Release: 2mamba
|
||||
Summary: Host/service/network monitoring program plugins for Nagios
|
||||
Group: Network/Monitoring
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://nagiosplugins.org/
|
||||
Source0: http://downloads.sourceforge.net/sourceforge/nagiosplug/%{name}-%{version}.tar.gz
|
||||
Patch0: %{name}-1.4.16-undef_gets.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: fping
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libmysql5-devel
|
||||
BuildRequires: libopenldap-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpostgresql-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: nagios-devel
|
||||
BuildRequires: perl-devel
|
||||
BuildRequires: perl-Net-SNMP
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libnetsnmp-devel
|
||||
BuildRequires: libradiusclient-ng-devel
|
||||
BuildRequires: net-snmp-utils
|
||||
Requires: fping
|
||||
Requires: perl-Net-SNMP
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Nagios is a program that will monitor hosts and services on your network, and to email or page you when a problem arises or is resolved.
|
||||
Nagios runs on a unix server as a background or daemon process, intermittently running checks on various services that you specify.
|
||||
The actual service checks are performed by separate "plugin" programs which return the status of the checks to Nagios.
|
||||
|
||||
This package contains the basic plugins necessary for use with the Nagios package.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#-D -T
|
||||
#: << CBLOCK
|
||||
%patch0 -p1
|
||||
|
||||
# fix strange perms
|
||||
find . -type d -perm 0700 -exec chmod 755 {} \;
|
||||
find . -type f -perm 0555 -exec chmod 755 {} \;
|
||||
find . -type f -perm 0444 -exec chmod 644 {} \;
|
||||
|
||||
%build
|
||||
#: << CBLOCK
|
||||
export PATH="/usr/sbin:$PATH"
|
||||
%configure \
|
||||
PATH_TO_FPING=%{_sbindir}/fping \
|
||||
--libdir=%{_libdir}/nagios/plugins \
|
||||
--libexecdir=%{_libdir}/nagios/plugins \
|
||||
--with-trusted-path="/bin:/sbin:/usr/bin:/usr/sbin" \
|
||||
--with-cgiurl=/nagios/cgi-bin \
|
||||
--disable-rpath \
|
||||
--with-ps-command="`which ps` -eo 's uid pid ppid vsz rss pcpu etime comm args'" \
|
||||
--with-ps-format='%s %d %d %d %d %d %f %s %s %n' \
|
||||
--with-ps-cols=10 \
|
||||
--enable-extra-opts \
|
||||
--with-ps-varlist='procstat,&procuid,&procpid,&procppid,&procvsz,&procrss,&procpcpu,procetime,procprog,&pos'
|
||||
# --with-ping-command="/bin/ping -n %%s -c %%d" \
|
||||
# --with-ping6-command="/usr/bin/ping6 -n -U -c %%d %%s" \
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
pushd contrib
|
||||
find . -type f -exec /usr/bin/perl \
|
||||
-e 's/^#!\/usr\/local\/bin\/perl/#!\/usr\/bin\/perl/gi' -p -i \{\} \;
|
||||
find . -type f -exec /usr/bin/perl \
|
||||
-e 's/^#!\/nyet\/bin\/perl/#!\/usr\/bin\/perl/gi' -p -i \{\} \;
|
||||
find . -type f -exec /usr/bin/perl \
|
||||
-e 's/^#!\/bin\/perl/#!\/usr\/bin\/perl/gi' -p -i \{\} \;
|
||||
popd
|
||||
|
||||
make install \
|
||||
AM_INSTALL_PROGRAM_FLAGS="" DESTDIR=%{buildroot} INSTALL=/bin/install
|
||||
|
||||
chmod 644 %{buildroot}/%{_libdir}/nagios/plugins/utils.pm
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%dir %{_libdir}/nagios/plugins
|
||||
%attr(755,root,root) %{_libdir}/nagios/plugins/check_*
|
||||
%{_libdir}/nagios/plugins/negate
|
||||
%{_libdir}/nagios/plugins/urlize
|
||||
%{_libdir}/nagios/plugins/utils.pm
|
||||
%{_libdir}/nagios/plugins/utils.sh
|
||||
%doc COPYING LEGAL
|
||||
#CODING FAQ README REQUIREMENTS SUPPORT ChangeLog command.cfg
|
||||
|
||||
%changelog
|
||||
* Wed May 07 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.16-2mamba
|
||||
- don't require nagios to allow nrpe only installations
|
||||
|
||||
* Tue Oct 23 2012 Davide Madrisan <davide.madrisan@gmail.com> 1.4.16-1mamba
|
||||
- update to 1.4.16
|
||||
- remove nrpe and nsca subpackages
|
||||
- add some missing build requirements
|
||||
|
||||
* Fri Feb 05 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.14-1mamba
|
||||
- update to 1.4.14
|
||||
|
||||
* Fri Mar 20 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.13-1mamba
|
||||
- update to 1.4.13
|
||||
|
||||
* Fri Mar 20 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.1-6mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Fri Feb 10 2006 Davide Madrisan <davide.madrisan@qilinux.it> 1.3.1-5qilnx
|
||||
- do not require perl-Net-SNMP
|
||||
|
||||
* Tue Jul 13 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.3.1-4qilnx
|
||||
- added nrpe addon
|
||||
|
||||
* Mon Jul 12 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.3.1-3qilnx
|
||||
- added nsca addon
|
||||
|
||||
* Fri Jul 09 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.3.1-2qilnx
|
||||
- various fixes
|
||||
|
||||
* Tue Nov 24 2003 Davide Madrisan <davide.madrisan@qilinux.it> 1.3.1-1qilnx
|
||||
- first build
|
Loading…
Reference in New Issue
Block a user