python-MythTV: fix requirement for recent python-mysqlclient-py3 [release 32.0-2mamba;Sat May 07 2022]
This commit is contained in:
parent
75e0112679
commit
c3c1181874
34
mythtv-32.0-glibc-2.35.patch
Normal file
34
mythtv-32.0-glibc-2.35.patch
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
--- mythtv-32.0/mythtv/libs/libmythui/platforms/drm/mythdrmhdr.cpp.orig 2022-05-07 21:51:08.080325514 +0200
|
||||||
|
+++ mythtv-32.0/mythtv/libs/libmythui/platforms/drm/mythdrmhdr.cpp 2022-05-07 21:52:22.596948499 +0200
|
||||||
|
@@ -18,31 +18,7 @@
|
||||||
|
HDMI_STATIC_METADATA_TYPE1 = 0,
|
||||||
|
};
|
||||||
|
|
||||||
|
-#if HAVE_STRUCT_HDR_METADATA_INFOFRAME
|
||||||
|
#include <drm_mode.h>
|
||||||
|
-#else
|
||||||
|
-struct hdr_metadata_infoframe {
|
||||||
|
- __u8 eotf;
|
||||||
|
- __u8 metadata_type;
|
||||||
|
- struct {
|
||||||
|
- __u16 x, y;
|
||||||
|
- } display_primaries[3];
|
||||||
|
- struct {
|
||||||
|
- __u16 x, y;
|
||||||
|
- } white_point;
|
||||||
|
- __u16 max_display_mastering_luminance;
|
||||||
|
- __u16 min_display_mastering_luminance;
|
||||||
|
- __u16 max_cll;
|
||||||
|
- __u16 max_fall;
|
||||||
|
-};
|
||||||
|
-
|
||||||
|
-struct hdr_output_metadata {
|
||||||
|
- __u32 metadata_type;
|
||||||
|
- union {
|
||||||
|
- struct hdr_metadata_infoframe hdmi_metadata_type1;
|
||||||
|
- };
|
||||||
|
-};
|
||||||
|
-#endif
|
||||||
|
}
|
||||||
|
|
||||||
|
#define LOC QString("HDR: ")
|
31
mythtv.spec
31
mythtv.spec
@ -2,15 +2,14 @@
|
|||||||
%define majver %(echo %version | cut -d. -f1-2)
|
%define majver %(echo %version | cut -d. -f1-2)
|
||||||
Name: mythtv
|
Name: mythtv
|
||||||
Version: 32.0
|
Version: 32.0
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: A digital video recorder (DVR) application
|
Summary: A digital video recorder (DVR) application
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://www.mythtv.org/
|
URL: https://www.mythtv.org/
|
||||||
# FIXME: fetching commit from fixes/31
|
Source0: https://github.com/MythTV/mythtv.git/v%{version}/mythtv-%{version}.tar.bz2
|
||||||
Source0: https://github.com/MythTV/mythtv.git/master@bb507cf183e26b5c61fd12b4aa7b2d2434b2489a/mythtv-%{version}.tar.bz2
|
|
||||||
Source1: mythfrontend.desktop
|
Source1: mythfrontend.desktop
|
||||||
Source2: mythfrontend.png
|
Source2: mythfrontend.png
|
||||||
Source3: mythtv-setup.desktop
|
Source3: mythtv-setup.desktop
|
||||||
@ -26,6 +25,7 @@ Source12: mythtv-PACKAGE-LICENSING
|
|||||||
Patch0: mythtv-0.26.0-libva-1.2.1.patch
|
Patch0: mythtv-0.26.0-libva-1.2.1.patch
|
||||||
Patch1: mythtv-31.0-gcc-11.patch
|
Patch1: mythtv-31.0-gcc-11.patch
|
||||||
Patch2: mythtv-31.0-qt5-5.12.patch
|
Patch2: mythtv-31.0-qt5-5.12.patch
|
||||||
|
Patch3: mythtv-32.0-glibc-2.35.patch
|
||||||
License: GPL, LGPL
|
License: GPL, LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -33,17 +33,17 @@ BuildRequires: libQt5WebKit-devel
|
|||||||
BuildRequires: libSDL2-devel
|
BuildRequires: libSDL2-devel
|
||||||
BuildRequires: libX11-devel
|
BuildRequires: libX11-devel
|
||||||
BuildRequires: libXext-devel
|
BuildRequires: libXext-devel
|
||||||
BuildRequires: libXinerama-devel
|
|
||||||
BuildRequires: libXrandr-devel
|
BuildRequires: libXrandr-devel
|
||||||
BuildRequires: libXv-devel
|
BuildRequires: libXv-devel
|
||||||
BuildRequires: libXxf86vm-devel
|
|
||||||
BuildRequires: libalsa-devel
|
BuildRequires: libalsa-devel
|
||||||
|
BuildRequires: libaom-devel
|
||||||
BuildRequires: libass-devel
|
BuildRequires: libass-devel
|
||||||
BuildRequires: libavc1394-devel
|
BuildRequires: libavc1394-devel
|
||||||
BuildRequires: libbluray-devel
|
BuildRequires: libbluray-devel
|
||||||
BuildRequires: libbzip2-devel
|
BuildRequires: libbzip2-devel
|
||||||
|
BuildRequires: libdav1d-devel
|
||||||
BuildRequires: libdrm-devel
|
BuildRequires: libdrm-devel
|
||||||
BuildRequires: libexiv2-devel
|
BuildRequires: libexpat-devel
|
||||||
BuildRequires: libfftw-devel
|
BuildRequires: libfftw-devel
|
||||||
BuildRequires: libfreetype-devel
|
BuildRequires: libfreetype-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
@ -60,17 +60,20 @@ BuildRequires: libpulseaudio-devel
|
|||||||
BuildRequires: libpython3-devel
|
BuildRequires: libpython3-devel
|
||||||
BuildRequires: libraw1394-devel
|
BuildRequires: libraw1394-devel
|
||||||
BuildRequires: libsamplerate-devel
|
BuildRequires: libsamplerate-devel
|
||||||
|
BuildRequires: libsoundtouch-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libsystemd-devel
|
BuildRequires: libsystemd-devel
|
||||||
BuildRequires: libtag-devel
|
BuildRequires: libtag-devel
|
||||||
BuildRequires: libva-devel
|
BuildRequires: libva-devel
|
||||||
BuildRequires: libvdpau-devel
|
BuildRequires: libvdpau-devel
|
||||||
|
BuildRequires: libwayland-devel
|
||||||
BuildRequires: libx264-devel
|
BuildRequires: libx264-devel
|
||||||
BuildRequires: libx265-devel
|
BuildRequires: libx265-devel
|
||||||
BuildRequires: libxcb-devel
|
BuildRequires: libxcb-devel
|
||||||
BuildRequires: libxml2-devel
|
BuildRequires: libxml2-devel
|
||||||
BuildRequires: libxvidcore-devel
|
BuildRequires: libxvidcore-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
|
BuildRequires: libzip-devel
|
||||||
BuildRequires: perl-DBD-mysql
|
BuildRequires: perl-DBD-mysql
|
||||||
BuildRequires: perl-DBI
|
BuildRequires: perl-DBI
|
||||||
BuildRequires: perl-DateTime
|
BuildRequires: perl-DateTime
|
||||||
@ -85,6 +88,7 @@ BuildRequires: perl-XML-Simple
|
|||||||
BuildRequires: perl-XML-TreeBuilder
|
BuildRequires: perl-XML-TreeBuilder
|
||||||
BuildRequires: perl-devel
|
BuildRequires: perl-devel
|
||||||
BuildRequires: perl-libwww
|
BuildRequires: perl-libwww
|
||||||
|
BuildRequires: python3.7dist(mysqlclient)
|
||||||
BuildRequires: qt5-qtbase-devel
|
BuildRequires: qt5-qtbase-devel
|
||||||
BuildRequires: qt5-qtscript-devel
|
BuildRequires: qt5-qtscript-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
@ -140,7 +144,7 @@ This package provides a perl-based interface to interacting with MythTV.
|
|||||||
%package -n python-MythTV
|
%package -n python-MythTV
|
||||||
Group: Development/Libraries/Python
|
Group: Development/Libraries/Python
|
||||||
Summary: Python bindings for MythTV
|
Summary: Python bindings for MythTV
|
||||||
Requires: python-MySQL
|
Requires: python3.7dist(mysqlclient)
|
||||||
|
|
||||||
%description -n python-MythTV
|
%description -n python-MythTV
|
||||||
MythTV provides a unified graphical interface for recording and viewing television programs.
|
MythTV provides a unified graphical interface for recording and viewing television programs.
|
||||||
@ -162,6 +166,7 @@ This package contains the documentation for %{name},
|
|||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
#%patch2 -p1
|
#%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
|
||||||
rm -rf contrib/Win32 contrib/OSX
|
rm -rf contrib/Win32 contrib/OSX
|
||||||
#chmod -x themes/default/htmls/*.html
|
#chmod -x themes/default/htmls/*.html
|
||||||
@ -199,9 +204,7 @@ cd mythtv
|
|||||||
--enable-libfftw3 \
|
--enable-libfftw3 \
|
||||||
--enable-x11 \
|
--enable-x11 \
|
||||||
--x11-path=%{_includedir} \
|
--x11-path=%{_includedir} \
|
||||||
--enable-xrandr \
|
|
||||||
--enable-lirc \
|
--enable-lirc \
|
||||||
--enable-ivtv \
|
|
||||||
--enable-firewire \
|
--enable-firewire \
|
||||||
--enable-dvb \
|
--enable-dvb \
|
||||||
--enable-libmp3lame \
|
--enable-libmp3lame \
|
||||||
@ -268,7 +271,7 @@ rm -rf %{buildroot}%{perl_sitearch}/auto/MythTV/.packlist
|
|||||||
rm -rf %{buildroot}%{_libdir}/libmyth*.*a
|
rm -rf %{buildroot}%{_libdir}/libmyth*.*a
|
||||||
rm -rf %{buildroot}%{_libdir}/mythtv/filters/*.*a
|
rm -rf %{buildroot}%{_libdir}/mythtv/filters/*.*a
|
||||||
|
|
||||||
mv %{buildroot}%{_prefix}/MythTV/ttvdb %{buildroot}%{_datadir}/mythtv/
|
#mv %{buildroot}%{_prefix}/MythTV/ttvdb %{buildroot}%{_datadir}/mythtv/
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
@ -308,14 +311,14 @@ mv %{buildroot}%{_prefix}/MythTV/ttvdb %{buildroot}%{_datadir}/mythtv/
|
|||||||
%{_datadir}/mythtv/locales
|
%{_datadir}/mythtv/locales
|
||||||
%{_datadir}/mythtv/metadata
|
%{_datadir}/mythtv/metadata
|
||||||
%{_datadir}/mythtv/themes
|
%{_datadir}/mythtv/themes
|
||||||
%{_datadir}/mythtv/ttvdb
|
#%{_datadir}/mythtv/ttvdb
|
||||||
%{_datadir}/pixmaps/*.png
|
%{_datadir}/pixmaps/*.png
|
||||||
%{_datadir}/applications/*.desktop
|
%{_datadir}/applications/*.desktop
|
||||||
|
|
||||||
%files -n libmythtv
|
%files -n libmythtv
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_libdir}/libmyth*.so.*
|
%{_libdir}/libmyth*.so.*
|
||||||
%doc mythtv/AUTHORS mythtv/COPYING
|
%doc mythtv/AUTHORS LICENSE
|
||||||
|
|
||||||
%files -n libmythtv-devel
|
%files -n libmythtv-devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
@ -324,6 +327,7 @@ mv %{buildroot}%{_prefix}/MythTV/ttvdb %{buildroot}%{_datadir}/mythtv/
|
|||||||
%{_includedir}/mythtv/mythconfig.mak
|
%{_includedir}/mythtv/mythconfig.mak
|
||||||
%{_includedir}/mythtv/dvdnav
|
%{_includedir}/mythtv/dvdnav
|
||||||
%{_includedir}/mythtv/dvdread
|
%{_includedir}/mythtv/dvdread
|
||||||
|
%{_includedir}/mythtv/exiv2
|
||||||
%{_includedir}/mythtv/goom
|
%{_includedir}/mythtv/goom
|
||||||
%{_includedir}/mythtv/libavcodec
|
%{_includedir}/mythtv/libavcodec
|
||||||
%{_includedir}/mythtv/libavdevice
|
%{_includedir}/mythtv/libavdevice
|
||||||
@ -369,6 +373,9 @@ mv %{buildroot}%{_prefix}/MythTV/ttvdb %{buildroot}%{_datadir}/mythtv/
|
|||||||
##%doc contrib database
|
##%doc contrib database
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat May 07 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 32.0-2mamba
|
||||||
|
- python-MythTV: fix requirement for recent python-mysqlclient-py3
|
||||||
|
|
||||||
* Fri Mar 04 2022 Automatic Build System <autodist@mambasoft.it> 32.0-1mamba
|
* Fri Mar 04 2022 Automatic Build System <autodist@mambasoft.it> 32.0-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user