automatic version update by autodist [release 31.0-1mamba;Mon Nov 29 2021]

This commit is contained in:
Automatic Build System 2024-01-06 07:29:29 +01:00
parent 8f92076155
commit a3c42221f9
6 changed files with 134 additions and 433 deletions

View File

@ -1,11 +1,8 @@
# mythtv # mythtv
MythTV provides a unified graphical interface for recording and viewing television programs. Refer to the mythtv package for more information. MythTV provides a unified graphical interface for recording and viewing television programs. Refer to the mythtv package for more information.
There are also several add-ons and themes available. In order to facilitate installations with smart/apt-get/yum and other related package resolvers this meta-package can be used to install all in one sweep. There are also several add-ons and themes available. In order to facilitate installations with smart/apt-get/yum and other related package resolvers this meta-package can be used to install all in one sweep.
MythTV implements the following DVR features, and more, with a unified graphical interface: MythTV implements the following DVR features, and more, with a unified graphical interface:
- Basic 'live-tv' functionality. Pause/Fast Forward/Rewind "live" TV. - Basic 'live-tv' functionality. Pause/Fast Forward/Rewind "live" TV.
- Video compression using RTjpeg or MPEG-4, and support for DVB and hardware encoder cards/devices. - Video compression using RTjpeg or MPEG-4, and support for DVB and hardware encoder cards/devices.
- Program listing retrieval using XMLTV - Program listing retrieval using XMLTV
@ -15,4 +12,3 @@ MythTV implements the following DVR features, and more, with a unified graphical
- Resolution of conflicts between scheduled recordings - Resolution of conflicts between scheduled recordings
- Basic video editing - Basic video editing

View File

@ -1,69 +0,0 @@
#!/bin/bash
#
# Startup script for mythbackend
#
# chkconfig: - 86 14
# description: mythbackend.
# processname: mythbackend
# pidfile: /var/run/mythbackend.pid
# config:
# Source function library.
. /etc/init.d/functions
if [ -f /etc/sysconfig/mythbackend ]; then
. /etc/sysconfig/mythbackend
fi
## Defaults, override them in /etc/sysconfig/mythbackend
: ${MYTHTV_HOME=/etc/mythtv}
binary=/usr/bin/mythbackend
prog=mythbackend
RETVAL=0
OPTIONS="$OPTIONS --daemon --logfile /var/log/mythtv/$prog.log --pidfile /var/run/$prog.pid"
# Would be nice to run as non-root, but it doesn't work -- dvb/v4l devices owned by root become unusable
#OPTIONS="$OPTIONS --daemon --user mythtv --logfile /var/log/mythtv/$prog.log --pidfile /var/run/$prog.pid"
start() {
echo -n $"Starting $prog: "
touch /var/run/mythbackend.pid; chown mythtv:mythtv /var/run/mythbackend.pid
export MYTHCONFDIR="$MYTHTV_HOME"
export HOME="$MYTHTV_HOME"
daemon $binary $OPTIONS
RETVAL=$?
echo
[ $RETVAL = 0 ] && touch /var/lock/subsys/$prog
return $RETVAL
}
stop() {
echo -n $"Stopping $prog: "
killproc $binary
RETVAL=$?
echo
[ $RETVAL = 0 ] && rm -f /var/lock/subsys/$prog /var/run/$prog.pid
}
# See how we were called.
case "$1" in
start)
start
;;
stop)
stop
;;
reload|restart)
stop
start
;;
status)
status $prog
RETVAL=$?
;;
*)
echo $"Usage: $prog {start|stop|status|restart}"
exit 1
esac
exit $RETVAL

13
mythbackend.service Normal file
View File

@ -0,0 +1,13 @@
[Unit]
Description=MythTV Backend
Wants=network-online.target mysqld.service systemd-udev-settle.service
After=network.target mysqld.service systemd-udev-settle.service
[Service]
Type=simple
User=mythtv
ExecStart=/usr/bin/mythbackend
Restart=on-failure
[Install]
WantedBy=multi-user.target

20
mythtv-31.0-gcc-11.patch Normal file
View File

@ -0,0 +1,20 @@
--- mythtv-31.0/mythtv/external/libudfread/default_blockinput.c.orig 2021-11-13 17:54:20.586889219 +0100
+++ mythtv-31.0/mythtv/external/libudfread/default_blockinput.c 2021-11-13 17:55:20.398989854 +0100
@@ -34,6 +34,7 @@
#ifdef HAVE_FCNTL_H
#include <fcntl.h>
#endif
+#include <fcntl.h>
#ifdef _WIN32
#include <windows.h>
--- mythtv-31.0/mythtv/external/libmythdvdnav/dvdread/dvd_input.c.orig 2021-11-13 17:53:16.871716574 +0100
+++ mythtv-31.0/mythtv/external/libmythdvdnav/dvdread/dvd_input.c 2021-11-13 17:53:37.424094852 +0100
@@ -24,6 +24,7 @@
#include <stdlib.h> /* free */
#include <fcntl.h> /* open */
#include <unistd.h> /* lseek */
+#include <dlfcn.h>
#include "dvdread/dvd_reader.h" /* DVD_VIDEO_LB_LEN */
#include "dvd_input.h"

View File

@ -0,0 +1,10 @@
--- mythtv-31.0/mythtv/libs/libmythui/mythpainter.cpp.orig 2021-11-29 14:46:01.235252672 +0100
+++ mythtv-31.0/mythtv/libs/libmythui/mythpainter.cpp 2021-11-29 14:46:20.416602854 +0100
@@ -5,6 +5,7 @@
// QT headers
#include <QRect>
#include <QPainter>
+#include <QPainterPath>
// libmythbase headers
#include "mythlogging.h"

View File

@ -1,261 +1,103 @@
%define MAJver %(echo %version | cut -d. -f1)
%define majver %(echo %version | cut -d. -f1-2) %define majver %(echo %version | cut -d. -f1-2)
Name: mythtv Name: mythtv
Version: 0.28 Version: 31.0
Release: 1mamba Release: 1mamba
Summary: A digital video recorder (DVR) application Summary: A digital video recorder (DVR) application
Group: Applications/Multimedia Group: Applications/Multimedia
Vendor: openmamba Vendor: openmamba
Distribution: openmamba Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it> Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.mythtv.org/ URL: https://www.mythtv.org/
Source0: https://github.com/MythTV/mythtv.git/v%{version}/mythtv-%{version}.tar.bz2 # FIXME: fetching commit from fixes/31
Source0: https://github.com/MythTV/mythtv.git/master@bb507cf183e26b5c61fd12b4aa7b2d2434b2489a/mythtv-%{version}.tar.bz2
Source1: mythfrontend.desktop Source1: mythfrontend.desktop
Source2: mythfrontend.png Source2: mythfrontend.png
Source3: mythtv-setup.desktop Source3: mythtv-setup.desktop
Source4: mythtv-setup.png Source4: mythtv-setup.png
Source5: mythtv.desktop Source5: mythtv.desktop
Source6: mythtv.png Source6: mythtv.png
Source7: mythbackend.init Source7: mythbackend.service
Source8: mythbackend.logrotate Source8: mythbackend.logrotate
Source9: mythbackend.sysconfig Source9: mythbackend.sysconfig
Source10: mythweb.conf Source10: mythweb.conf
Source11: mythtv-mysql.txt Source11: mythtv-mysql.txt
Source12: mythtv-PACKAGE-LICENSING Source12: mythtv-PACKAGE-LICENSING
Patch0: mythtv-0.26.0-libva-1.2.1.patch Patch0: mythtv-0.26.0-libva-1.2.1.patch
Patch1: mythtv-31.0-gcc-11.patch
Patch2: mythtv-31.0-qt5-5.12.patch
License: GPL, LGPL License: GPL, LGPL
BuildRequires: desktop-file-utils
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
#BuildRequires: file /usr/lib/libdirect-1.4.so: No such file or directory
#BuildRequires: file /usr/lib/libdirectfb-1.4.so: No such file or directory
#BuildRequires: file /usr/lib/libfusion-1.4.so: No such file or directory
BuildRequires: glibc-devel BuildRequires: glibc-devel
BuildRequires: libQt5WebKit-devel
BuildRequires: libSDL2-devel
BuildRequires: libX11-devel
BuildRequires: libXext-devel
BuildRequires: libXinerama-devel
BuildRequires: libXrandr-devel
BuildRequires: libXv-devel
BuildRequires: libXxf86vm-devel
BuildRequires: libalsa-devel BuildRequires: libalsa-devel
BuildRequires: libass-devel
BuildRequires: libavc1394-devel BuildRequires: libavc1394-devel
BuildRequires: libbluray-devel
BuildRequires: libbzip2-devel BuildRequires: libbzip2-devel
BuildRequires: libcrystalhd-devel BuildRequires: libdrm-devel
BuildRequires: libdca-devel BuildRequires: libexiv2-devel
BuildRequires: libdirectfb-devel
BuildRequires: libdvdnav-devel
BuildRequires: libdvdread-devel
BuildRequires: libfame-devel
BuildRequires: libfftw-devel BuildRequires: libfftw-devel
BuildRequires: libflac-devel
BuildRequires: libfreetype-devel BuildRequires: libfreetype-devel
BuildRequires: libgcc BuildRequires: libgcc
BuildRequires: libGL-devel BuildRequires: libglvnd-devel
BuildRequires: libGLU-devel
BuildRequires: libgsm-devel
BuildRequires: libiec61883-devel BuildRequires: libiec61883-devel
BuildRequires: libjack-devel BuildRequires: libjack-devel
BuildRequires: liblame-devel BuildRequires: liblame-devel
BuildRequires: libmjpegtools-devel BuildRequires: liblzma-devel
BuildRequires: libmysql5-devel BuildRequires: liblzo-devel
BuildRequires: libogg-devel BuildRequires: libopenssl-devel
BuildRequires: libperl
BuildRequires: libpulseaudio-devel BuildRequires: libpulseaudio-devel
BuildRequires: libpython-devel BuildRequires: libpython3-devel
BuildRequires: libqt4-devel
BuildRequires: libraw1394-devel BuildRequires: libraw1394-devel
BuildRequires: libsamplerate-devel
BuildRequires: libstdc++6-devel BuildRequires: libstdc++6-devel
BuildRequires: libsystemd-devel
BuildRequires: libtag-devel BuildRequires: libtag-devel
BuildRequires: libtheora-devel
BuildRequires: libva-devel BuildRequires: libva-devel
BuildRequires: libvdpau-devel BuildRequires: libvdpau-devel
BuildRequires: libvorbis-devel
BuildRequires: libX11-devel
BuildRequires: libx264-devel BuildRequires: libx264-devel
BuildRequires: libXext-devel BuildRequires: libx265-devel
BuildRequires: libXinerama-devel BuildRequires: libxcb-devel
BuildRequires: libXmu-devel BuildRequires: libxml2-devel
BuildRequires: libXrandr-devel
BuildRequires: libXv-devel
BuildRequires: libxvidcore-devel BuildRequires: libxvidcore-devel
BuildRequires: libXvMC-devel
BuildRequires: libXxf86vm-devel
BuildRequires: libz-devel BuildRequires: libz-devel
BuildRequires: lirc-devel
BuildRequires: lm_sensors-devel
BuildRequires: perl-DBD-mysql BuildRequires: perl-DBD-mysql
BuildRequires: perl-DBI BuildRequires: perl-DBI
BuildRequires: perl-devel BuildRequires: perl-DateTime
BuildRequires: perl-HTML-Parser BuildRequires: perl-HTML-Parser
BuildRequires: perl-HTML-Tree BuildRequires: perl-HTML-Tree
BuildRequires: perl-libwww BuildRequires: perl-HTTP-Message
BuildRequires: perl-IO-Socket-INET6
BuildRequires: perl-Magick BuildRequires: perl-Magick
BuildRequires: perl-Net-UPnP BuildRequires: perl-Net-UPnP
BuildRequires: perl-TimeDate BuildRequires: perl-TimeDate
BuildRequires: python-MySQL BuildRequires: perl-XML-Simple
BuildRequires: udev-devel BuildRequires: perl-XML-TreeBuilder
BuildRequires: xorg-drv-video-intel-devel BuildRequires: perl-devel
BuildRequires: xorg-drv-video-openchrome BuildRequires: perl-libwww
BuildRequires: xproto-devel BuildRequires: qt5-qtbase-devel
#libcrystalhd.so.3: library not reported by ldconfig; run `ldconfig' and try again BuildRequires: qt5-qtscript-devel
#libvdpau.so.1: library not reported by ldconfig; run `ldconfig' and try again
## AUTOBUILDREQ-END ## AUTOBUILDREQ-END
BuildRequires: desktop-file-utils
BuildRequires: libfreetype-devel
#BuildRequires: ccache
#BuildRequires: distcc
BuildRequires: gcc-c++ BuildRequires: gcc-c++
BuildRequires: libmysql5-devel
BuildRequires: libqt4-devel
BuildRequires: libphonon-devel
BuildRequires: lm_sensors-devel
BuildRequires: lirc-devel
BuildRequires: nasm BuildRequires: nasm
BuildRequires: yasm-devel BuildRequires: yasm-devel
# X, and Xv video support
BuildRequires: libXmu-devel
BuildRequires: libXv-devel
BuildRequires: libXvMC-devel
BuildRequires: libXxf86vm-devel
BuildRequires: libGLU-devel
BuildRequires: xproto-devel BuildRequires: xproto-devel
%ifarch %{ix86} x86_64
BuildRequires: xorg-drv-video-openchrome
#BuildRequires: xorg-drv-video-openchrome-devel
BuildRequires: xorg-drv-video-intel-devel
%endif
# OpenGL video output and vsync support
BuildRequires: libGL-devel
BuildRequires: libGLU-devel
# Misc A/V format support
BuildRequires: libfftw-devel
BuildRequires: libflac-devel
BuildRequires: libgsm-devel
BuildRequires: liblame-devel
BuildRequires: libdca-devel
BuildRequires: libdvdcss-devel
BuildRequires: libdvdnav-devel
BuildRequires: libdvdread-devel
BuildRequires: libavcodec-devel
BuildRequires: libavformat-devel
BuildRequires: libavutil-devel
BuildRequires: libpostproc-devel
BuildRequires: libswscale-devel
# nb: libdvdcss will be dynamically loaded if installed
BuildRequires: libfame-devel
BuildRequires: libogg-devel
BuildRequires: libtheora-devel
BuildRequires: libvorbis-devel
BuildRequires: libmjpegtools-devel
BuildRequires: libtag-devel
BuildRequires: libx264-devel
BuildRequires: libxvidcore-devel
# Audio framework support
BuildRequires: libalsa-devel
#BuildRequires: libarts-devel
BuildRequires: libjack-devel
BuildRequires: libpulseaudio-devel
# Need dvb headers to build in dvb support
BuildRequires: kernelheaders
# FireWire cable box support
BuildRequires: libavc1394-devel
BuildRequires: libiec61883-devel
BuildRequires: libraw1394-devel
BuildRequires: libdirectfb-devel
BuildRequires: libvdpau-devel
BuildRequires: libcrystalhd-devel
# API Build Requirements
BuildRequires: perl
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl(Config)
BuildRequires: perl(Exporter)
BuildRequires: perl(Fcntl)
BuildRequires: perl(File::Copy)
BuildRequires: perl(Sys::Hostname)
BuildRequires: perl(DBI)
BuildRequires: perl(HTTP::Request)
BuildRequires: perl(Net::UPnP::ControlPoint)
BuildRequires: perl(Net::UPnP::QueryResponse)
BuildRequires: perl(DBD::mysql)
BuildRequires: perl(HTML::TreeBuilder)
BuildRequires: perl(Image::Magick)
BuildRequires: libpython-devel
BuildRequires: python-MySQL
BuildRequires: python-urlgrabber
Requires: libmythtv = %{?epoch:%epoch:}%{version}-%{release} Requires: libmythtv = %{?epoch:%epoch:}%{version}-%{release}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
## TODO UPnPautoconf() - No UPnP backends found see https://help.ubuntu.com/community/MythTV/Install/Troubleshooting
# Basic Settings
## Compile type release
## Compiler cache no
## DistCC no
## qmake /usr/lib/qt4/bin/qmake
## install prefix /usr
## runtime prefix /usr
## CPU x86 x86_32 (i686)
## yasm yes
## MMX enabled yes
## MMX2 enabled yes
## 3DNow! enabled yes
## 3DNow! extended enabled yes
## SSE enabled yes
## SSSE3 enabled yes
## CMOV enabled yes
# Input Support
## Joystick menu yes
## lirc support yes
## Video4Linux sup. yes
## ivtv support yes
## HD-PVR support yes
## FireWire support yes
## DVB support yes [/usr/include]
## DVB-S2 support yes
## HDHomeRun support yes
## IPTV support yes
# Sound Output Support
## PulseAudio support yes
## OSS support yes
## ALSA support yes
## JACK support yes
## libfftw3 support yes
# Video Output Support
## x11 support yes
## xrandr support yes
## xv support yes
## XvMC support yes
## XvMC VLD support yes
## XvMC libs -lXvMCW
## VDPAU support yes
## CrystalHD support yes
## OpenGL video yes
## OpenGL vsync yes
## DirectFB yes
## MHEG support yes
# Misc Features
## multi threaded libavcodec yes
## Frontend yes
## Backend yes
# Bindings
## bindings_perl yes
## bindings_python yes
%description %description
MythTV provides a unified graphical interface for recording and viewing television programs. Refer to the mythtv package for more information. MythTV provides a unified graphical interface for recording and viewing television programs. Refer to the mythtv package for more information.
There are also several add-ons and themes available. In order to facilitate installations with smart/apt-get/yum and other related package resolvers this meta-package can be used to install all in one sweep. There are also several add-ons and themes available. In order to facilitate installations with smart/apt-get/yum and other related package resolvers this meta-package can be used to install all in one sweep.
MythTV implements the following DVR features, and more, with a unified graphical interface: MythTV implements the following DVR features, and more, with a unified graphical interface:
- Basic 'live-tv' functionality. Pause/Fast Forward/Rewind "live" TV. - Basic 'live-tv' functionality. Pause/Fast Forward/Rewind "live" TV.
- Video compression using RTjpeg or MPEG-4, and support for DVB and hardware encoder cards/devices. - Video compression using RTjpeg or MPEG-4, and support for DVB and hardware encoder cards/devices.
- Program listing retrieval using XMLTV - Program listing retrieval using XMLTV
@ -265,78 +107,22 @@ MythTV implements the following DVR features, and more, with a unified graphical
- Resolution of conflicts between scheduled recordings - Resolution of conflicts between scheduled recordings
- Basic video editing - Basic video editing
%package -n libmythtv %package -n libmythtv
Group: System/Libraries Group: System/Libraries
Summary: Library providing mythtv support Summary: Library providing mythtv support
%description -n libmythtv %description -n libmythtv
MythTV provides a unified graphical interface for recording and viewing television programs. MythTV provides a unified graphical interface for recording and viewing television programs.
This package contains common library code for MythTV and add-on modules (development). This package contains common library code for MythTV and add-on modules (development).
%package -n libmythtv-devel %package -n libmythtv-devel
Group: Development/Libraries Group: Development/Libraries
Summary: Libraries and headers for %{name} Summary: Libraries and headers for %{name}
Requires: libmythtv = %{?epoch:%epoch:}%{version}-%{release} Requires: libmythtv = %{?epoch:%epoch:}%{version}-%{release}
# Need dvb headers for dvb support
Requires: kernelheaders
Requires: libfreetype-devel
Requires: libmysql-devel
Requires: libqt4-devel
Requires: lm_sensors-devel
Requires: lirc-devel
Requires: libXmu-devel
Requires: libXv-devel
Requires: libXvMC-devel
Requires: libXxf86vm-devel
Requires: libGLU-devel
Requires: xproto-devel
# OpenGL video output and vsync support
Requires: libGL-devel
Requires: libGLU-devel
# Misc A/V format support
Requires: libfftw-devel
Requires: libflac-devel
Requires: libgsm-devel
Requires: liblame-devel
Requires: libdca-devel
Requires: libdvdnav-devel
Requires: libdvdread-devel
Requires: libfame-devel
Requires: libogg-devel
Requires: libtheora-devel
Requires: libvorbis-devel
Requires: libmjpegtools-devel
Requires: libtag-devel
Requires: libx264-devel
Requires: libxvidcore-devel
# Audio framework support
Requires: libalsa-devel
#Requires: libarts-devel
Requires: libjack-devel
Requires: libpulseaudio-devel
Requires: libavc1394-devel
Requires: libiec61883-devel
Requires: libraw1394-devel
Requires: libdirectfb-devel
Requires: libvdpau-devel
Requires: libcrystalhd-devel
%ifarch %{ix86} x86_64
Requires: xorg-drv-video-openchrome
#Requires: xorg-drv-video-openchrome-devel
Requires: xorg-drv-video-intel-devel
%endif
%description -n libmythtv-devel %description -n libmythtv-devel
MythTV provides a unified graphical interface for recording and viewing television programs. MythTV provides a unified graphical interface for recording and viewing television programs.
This package contains libraries and header files needed for development.
This package contains libraries and header files need for development.
%package -n perl-MythTV %package -n perl-MythTV
Group: Development/Libraries/Perl Group: Development/Libraries/Perl
@ -348,7 +134,6 @@ Requires: perl(Net::UPnP::ControlPoint)
%description -n perl-MythTV %description -n perl-MythTV
MythTV provides a unified graphical interface for recording and viewing television programs. MythTV provides a unified graphical interface for recording and viewing television programs.
This package provides a perl-based interface to interacting with MythTV. This package provides a perl-based interface to interacting with MythTV.
%package -n python-MythTV %package -n python-MythTV
@ -358,7 +143,6 @@ Requires: python-MySQL
%description -n python-MythTV %description -n python-MythTV
MythTV provides a unified graphical interface for recording and viewing television programs. MythTV provides a unified graphical interface for recording and viewing television programs.
This package provides a python-based interface to interacting with MythTV. This package provides a python-based interface to interacting with MythTV.
%package docs %package docs
@ -367,26 +151,29 @@ Summary: Documentation for %{name}
%description docs %description docs
MythTV provides a unified graphical interface for recording and viewing television programs. MythTV provides a unified graphical interface for recording and viewing television programs.
This package contains the documentation for %{name}, This package contains the documentation for %{name},
%prep %prep
%setup -q %setup -q
#%patch0 -p2 #-D -T
#:<< _EOF
%patch1 -p1
%patch2 -p1
rm -rf contrib/Win32 contrib/OSX rm -rf contrib/Win32 contrib/OSX
#chmod -x themes/default/htmls/*.html #chmod -x themes/default/htmls/*.html
cp -a %{SOURCE1} %{SOURCE2} %{SOURCE3} . cp -a %{SOURCE1} %{SOURCE2} %{SOURCE3} .
cp -a %{SOURCE4} %{SOURCE5} %{SOURCE6} . cp -a %{SOURCE4} %{SOURCE5} %{SOURCE6} .
cp -a %{SOURCE7} %{SOURCE8} %{SOURCE9} %{SOURCE10} . #cp -a %{SOURCE7} %{SOURCE8} %{SOURCE9}.
cp -a %{SOURCE12} PACKAGE-LICENSING #cp -a %{SOURCE10} %{SOURCE12} PACKAGE-LICENSING
#sed -i -e 's#perl Makefile.PL#%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"#' bindings/perl/Makefile #sed -i -e 's#perl Makefile.PL#%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"#' bindings/perl/Makefile
#sed -i -e 's,VENDOR_XVMC_LIBS="-lXvMCNVIDIA",VENDOR_XVMC_LIBS="-lXvMCNVIDIA -lXv",' configure #sed -i -e 's,VENDOR_XVMC_LIBS="-lXvMCNVIDIA",VENDOR_XVMC_LIBS="-lXvMCNVIDIA -lXv",' configure
%build %build
#:<< _EOF
cd mythtv cd mythtv
./configure \ ./configure \
--prefix=%{_prefix} \ --prefix=%{_prefix} \
@ -400,37 +187,37 @@ cd mythtv
--tune=i686 \ --tune=i686 \
%endif %endif
--enable-mmx \ --enable-mmx \
--qmake=%{_qt4_qmake} \ --qmake=%{_qt5_qmake} \
--enable-pthreads \ --enable-pthreads \
--enable-ffmpeg-pthreads \ --enable-ffmpeg-pthreads \
--enable-joystick-menu \ --enable-joystick-menu \
--enable-audio-alsa \ --enable-audio-alsa \
--enable-audio-oss \
--enable-audio-jack \ --enable-audio-jack \
--enable-libfftw3 \ --enable-libfftw3 \
--enable-x11 \ --enable-x11 \
--x11-path=%{_includedir} \ --x11-path=%{_includedir} \
--enable-xv \
--enable-opengl-video \
--enable-xrandr \ --enable-xrandr \
--enable-lirc \ --enable-lirc \
--enable-ivtv \ --enable-ivtv \
--enable-firewire \ --enable-firewire \
--enable-dvb \ --enable-dvb \
--enable-libmp3lame \ --enable-libmp3lame \
--enable-libtheora \
--enable-libvorbis \
--enable-libxvid \ --enable-libxvid \
--enable-vaapi \
--enable-vdpau \ --enable-vdpau \
--enable-crystalhd \
--enable-libfaac \
--enable-sdl \ --enable-sdl \
--enable-libx264 \ --enable-libx264 \
--enable-libx265 \
--compile-type=release \ --compile-type=release \
--enable-debug \ --enable-debug \
--disable-distcc \ --disable-distcc
--enable-nonfree
# --enable-nonfree
# --enable-audio-oss \
# --enable-opengl-video \
# --enable-crystalhd \
# --enable-libvorbis \
# --enable-libtheora \
# --enable-libvpc \ # --enable-libvpc \
%make %make
@ -451,9 +238,9 @@ mkdir -p %{buildroot}%{_sysconfdir}/mythtv
# mysql.txt and other config/init files # mysql.txt and other config/init files
install -m 644 %{SOURCE11} %{buildroot}%{_sysconfdir}/mythtv/mysql.txt install -m 644 %{SOURCE11} %{buildroot}%{_sysconfdir}/mythtv/mysql.txt
echo "# to be filled in by mythtv-setup" > %{buildroot}%{_sysconfdir}/mythtv/config.xml echo "# to be filled in by mythtv-setup" > %{buildroot}%{_sysconfdir}/mythtv/config.xml
install -p -m 755 mythbackend.init %{buildroot}%{_initrddir}/mythbackend install -D -m0755 %{SOURCE7} %{buildroot}%{_unitdir}/mythbackend.service
install -p -m 644 mythbackend.sysconfig %{buildroot}%{_sysconfdir}/sysconfig/mythbackend #install -p -m 644 %{SOURCE8} %{buildroot}%{_sysconfdir}/sysconfig/mythbackend
install -p -m 644 mythbackend.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/mythbackend #install -p -m 644 %{SOURCE9} %{buildroot}%{_sysconfdir}/logrotate.d/mythbackend
# Desktop entries # Desktop entries
mkdir -p %{buildroot}%{_datadir}/pixmaps mkdir -p %{buildroot}%{_datadir}/pixmaps
@ -486,36 +273,29 @@ rm -rf %{buildroot}%{_libdir}/mythtv/filters/*.*a
%{_sbindir}/useradd -c "mythtvbackend User" \ %{_sbindir}/useradd -c "mythtvbackend User" \
-s /sbin/nologin -r -d %{_localstatedir}/lib/mythtv -G video mythtv 2> /dev/null || : -s /sbin/nologin -r -d %{_localstatedir}/lib/mythtv -G video mythtv 2> /dev/null || :
%post %post -n libmythtv -p /sbin/ldconfig
/sbin/chkconfig --add mythbackend %postun -n libmythtv -p /sbin/ldconfig
%preun
if [ $1 = 0 ]; then
/sbin/service mythbackend stop > /dev/null 2>&1
/sbin/chkconfig --del mythbackend
fi
%files %files
%defattr(-,root,root) %defattr(-,root,root)
%dir %{_sysconfdir}/mythtv %dir %{_sysconfdir}/mythtv
%config(noreplace) %{_sysconfdir}/mythtv/mysql.txt %config(noreplace) %{_sysconfdir}/mythtv/mysql.txt
%config(noreplace) %{_sysconfdir}/mythtv/config.xml %config(noreplace) %{_sysconfdir}/mythtv/config.xml
%config(noreplace) %{_sysconfdir}/sysconfig/mythbackend
%config(noreplace) %{_sysconfdir}/logrotate.d/mythbackend
%attr(-,mythtv,mythtv) %dir %{_localstatedir}/lib/mythtv %attr(-,mythtv,mythtv) %dir %{_localstatedir}/lib/mythtv
%attr(-,mythtv,mythtv) %dir %{_localstatedir}/cache/mythtv %attr(-,mythtv,mythtv) %dir %{_localstatedir}/cache/mythtv
%attr(-,mythtv,mythtv) %dir %{_localstatedir}/log/mythtv %attr(-,mythtv,mythtv) %dir %{_localstatedir}/log/mythtv
%{_initrddir}/mythbackend
%{_bindir}/myth* %{_bindir}/myth*
%{_unitdir}/mythbackend.service
%dir %{_libdir}/mythtv %dir %{_libdir}/mythtv
%dir %{_libdir}/mythtv/filters #%dir %{_libdir}/mythtv/filters
%{_libdir}/mythtv/filters/*.so #%{_libdir}/mythtv/filters/*.so
%dir %{_libdir}/mythtv/plugins %dir %{_libdir}/mythtv/plugins
%dir %{_datadir}/mythtv %dir %{_datadir}/mythtv
%{_datadir}/mythtv/*.xml %{_datadir}/mythtv/*.xml
%{_datadir}/mythtv/*.pl %{_datadir}/mythtv/*.pl
%{_datadir}/mythtv/backend-config %{_datadir}/mythtv/backend-config
%{_datadir}/mythtv/bindings %{_datadir}/mythtv/bindings
%{_datadir}/mythtv/externrecorder
%{_datadir}/mythtv/fonts %{_datadir}/mythtv/fonts
%{_datadir}/mythtv/hardwareprofile %{_datadir}/mythtv/hardwareprofile
%{_datadir}/mythtv/html %{_datadir}/mythtv/html
@ -527,46 +307,20 @@ fi
%{_datadir}/pixmaps/*.png %{_datadir}/pixmaps/*.png
%{_datadir}/applications/*.desktop %{_datadir}/applications/*.desktop
%post -n libmythtv -p /sbin/ldconfig
%postun -n libmythtv -p /sbin/ldconfig
%files -n libmythtv %files -n libmythtv
%defattr(-,root,root) %defattr(-,root,root)
%{_libdir}/libmyth-*.so.* %{_libdir}/libmyth*.so.*
%{_libdir}/libmythavcodec.so.* %doc mythtv/AUTHORS mythtv/COPYING
%{_libdir}/libmythbase-%{majver}.so.*
%{_libdir}/libmythavdevice.so.*
%{_libdir}/libmythavfilter.so.*
%{_libdir}/libmythavformat.so.*
%{_libdir}/libmythavutil.so.*
%{_libdir}/libmythfreemheg-*.so.*
%{_libdir}/libmythhdhomerun-*.so.*
#%{_libdir}/libmythlivemedia-*.so.*
%{_libdir}/libmythmetadata-*.so.*
#%{_libdir}/libmythnzmqt.so.*
%{_libdir}/libmythpostproc.so.*
%{_libdir}/libmythprotoserver-%{majver}.so.*
#%{_libdir}/libmythqjson.so.*
%{_libdir}/libmythswresample.so.*
%{_libdir}/libmythservicecontracts-%{majver}.so.*
%{_libdir}/libmythswscale.so.*
%{_libdir}/libmythtv-*.so.*
%{_libdir}/libmythui-*.so.*
%{_libdir}/libmythupnp-*.so.*
#%{_libdir}/libmythzmq.so.*
#%doc mythtv/AUTHORS mythtv/COPYING
%files -n libmythtv-devel %files -n libmythtv-devel
%defattr(-,root,root) %defattr(-,root,root)
%dir %{_includedir}/mythtv %dir %{_includedir}/mythtv
%{_includedir}/mythtv/*.h %{_includedir}/mythtv/*.h
%{_includedir}/mythtv/mythconfig.mak %{_includedir}/mythtv/mythconfig.mak
%{_includedir}/mythtv/bluray
%{_includedir}/mythtv/dvdnav %{_includedir}/mythtv/dvdnav
%{_includedir}/mythtv/dvdread %{_includedir}/mythtv/dvdread
%{_includedir}/mythtv/goom
%{_includedir}/mythtv/libavcodec %{_includedir}/mythtv/libavcodec
#%{_includedir}/mythtv/libavcore
%{_includedir}/mythtv/libavdevice %{_includedir}/mythtv/libavdevice
%{_includedir}/mythtv/libavfilter %{_includedir}/mythtv/libavfilter
%{_includedir}/mythtv/libavformat %{_includedir}/mythtv/libavformat
@ -581,37 +335,9 @@ fi
%{_includedir}/mythtv/libswscale %{_includedir}/mythtv/libswscale
%{_includedir}/mythtv/metadata %{_includedir}/mythtv/metadata
%{_includedir}/mythtv/mpeg2dec %{_includedir}/mythtv/mpeg2dec
#%dir %{_includedir}/mythtv/nzmqt
#%{_includedir}/mythtv/nzmqt/nzmqt.hpp
%{_includedir}/mythtv/upnp %{_includedir}/mythtv/upnp
#%dir %{_includedir}/mythtv/QJson %{_libdir}/libmyth*.so
#%{_includedir}/mythtv/QJson/*
#%dir %{_includedir}/mythtv/zeromq
#%{_includedir}/mythtv/zeromq/*
%{_libdir}/libmyth-*.so
%{_libdir}/libmythavcodec.so
%{_libdir}/libmythavdevice.so
%{_libdir}/libmythavfilter.so
%{_libdir}/libmythavformat.so
%{_libdir}/libmythavutil.so
%{_libdir}/libmythbase-%{majver}.so
%{_libdir}/libmythfreemheg-*.so
%{_libdir}/libmythhdhomerun-*.so
#%{_libdir}/libmythlivemedia-*.so
%{_libdir}/libmythmetadata-*.so
#%{_libdir}/libmythnzmqt.so
%{_libdir}/libmythpostproc.so
%{_libdir}/libmythprotoserver-%{majver}.so
#%{_libdir}/libmythqjson.so
%{_libdir}/libmythservicecontracts-%{majver}.so
%{_libdir}/libmythswresample.so
%{_libdir}/libmythswscale.so
%{_libdir}/libmythtv-*.so
%{_libdir}/libmythui-*.so
%{_libdir}/libmythupnp-*.so
#%{_libdir}/libmythzmq.so
%{_datadir}/mythtv/build %{_datadir}/mythtv/build
#%{_libdir}/pkgconfig/libmythzmq.pc
%files -n perl-MythTV %files -n perl-MythTV
%defattr(-,root,root) %defattr(-,root,root)
@ -628,19 +354,21 @@ fi
%defattr(-,root,root) %defattr(-,root,root)
%{_bindir}/mythpython %{_bindir}/mythpython
%{_bindir}/mythwikiscripts %{_bindir}/mythwikiscripts
%{python_sitelib}/MythTV-*.egg-info %{python3_sitelib}/MythTV-*.egg-info
%dir %{python_sitelib}/MythTV %dir %{python3_sitelib}/MythTV
%{python_sitelib}/MythTV/*.py* %{python3_sitelib}/MythTV/*.py*
#%dir %{python_sitelib}/MythTV/tmdb %dir %{python3_sitelib}/MythTV/__pycache__
#%{python_sitelib}/MythTV/tmdb/* %{python3_sitelib}/MythTV/__pycache__/*
%dir %{python_sitelib}/MythTV/tmdb3 %dir %{python3_sitelib}/MythTV/services_api
%{python_sitelib}/MythTV/tmdb3/* %{python3_sitelib}/MythTV/services_api/*
%dir %{python_sitelib}/MythTV/ttvdb %dir %{python3_sitelib}/MythTV/tmdb3
%{python_sitelib}/MythTV/ttvdb/* %{python3_sitelib}/MythTV/tmdb3/*
%dir %{python_sitelib}/MythTV/utility %dir %{python3_sitelib}/MythTV/ttvdb
%{python_sitelib}/MythTV/utility/* %{python3_sitelib}/MythTV/ttvdb/*
%dir %{python_sitelib}/MythTV/wikiscripts %dir %{python3_sitelib}/MythTV/utility
%{python_sitelib}/MythTV/wikiscripts/* %{python3_sitelib}/MythTV/utility/*
%dir %{python3_sitelib}/MythTV/wikiscripts
%{python3_sitelib}/MythTV/wikiscripts/*
#%files docs #%files docs
#%defattr(-,root,root) #%defattr(-,root,root)
@ -648,6 +376,9 @@ fi
##%doc contrib database ##%doc contrib database
%changelog %changelog
* Mon Nov 29 2021 Automatic Build System <autodist@mambasoft.it> 31.0-1mamba
- automatic version update by autodist
* Wed Apr 20 2016 Automatic Build System <autodist@mambasoft.it> 0.28-1mamba * Wed Apr 20 2016 Automatic Build System <autodist@mambasoft.it> 0.28-1mamba
- automatic version update by autodist - automatic version update by autodist