automatic version update by autodist [release 34.0-1mamba;Tue Feb 13 2024]
This commit is contained in:
parent
ec8b6db93e
commit
69b222f5d0
@ -1,32 +0,0 @@
|
|||||||
From 2add868d2f18b8b47d9747e043f052e88869bfc3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Gary Buhrmaster <gary.buhrmaster@gmail.com>
|
|
||||||
Date: Sun, 30 Jun 2013 04:15:04 +0000
|
|
||||||
Subject: [PATCH] libva (VAAPI) has changed their API. Use the legacy API.
|
|
||||||
|
|
||||||
Validated as working by Frank P.
|
|
||||||
|
|
||||||
Fixes #11631
|
|
||||||
|
|
||||||
Signed-off-by: Gary Buhrmaster <gary.buhrmaster@gmail.com>
|
|
||||||
---
|
|
||||||
mythtv/libs/libmythtv/vaapicontext.h | 4 ++++
|
|
||||||
1 file changed, 4 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/mythtv/libs/libmythtv/vaapicontext.h b/mythtv/libs/libmythtv/vaapicontext.h
|
|
||||||
index d076d11..f85cd9e 100644
|
|
||||||
--- a/mythtv/libs/libmythtv/vaapicontext.h
|
|
||||||
+++ b/mythtv/libs/libmythtv/vaapicontext.h
|
|
||||||
@@ -4,6 +4,10 @@
|
|
||||||
extern "C" {
|
|
||||||
#include "libavcodec/vaapi.h"
|
|
||||||
}
|
|
||||||
+#include "va/va_version.h"
|
|
||||||
+#if VA_CHECK_VERSION(0,34,0)
|
|
||||||
+#include "va/va_compat.h"
|
|
||||||
+#endif
|
|
||||||
#include "va/va_x11.h"
|
|
||||||
#include "va/va_glx.h"
|
|
||||||
#include "videocolourspace.h"
|
|
||||||
--
|
|
||||||
1.8.1.6
|
|
||||||
|
|
@ -1,10 +0,0 @@
|
|||||||
--- mythtv-31.0/mythtv/libs/libmythui/mythpainter.cpp.orig 2021-11-29 14:46:01.235252672 +0100
|
|
||||||
+++ mythtv-31.0/mythtv/libs/libmythui/mythpainter.cpp 2021-11-29 14:46:20.416602854 +0100
|
|
||||||
@@ -5,6 +5,7 @@
|
|
||||||
// QT headers
|
|
||||||
#include <QRect>
|
|
||||||
#include <QPainter>
|
|
||||||
+#include <QPainterPath>
|
|
||||||
|
|
||||||
// libmythbase headers
|
|
||||||
#include "mythlogging.h"
|
|
16
mythtv.spec
16
mythtv.spec
@ -1,8 +1,8 @@
|
|||||||
%define MAJver %(echo %version | cut -d. -f1)
|
%define MAJver %(echo %version | cut -d. -f1)
|
||||||
%define majver %(echo %version | cut -d. -f1-2)
|
%define majver %(echo %version | cut -d. -f1-2)
|
||||||
Name: mythtv
|
Name: mythtv
|
||||||
Version: 33.1
|
Version: 34.0
|
||||||
Release: 3mamba
|
Release: 1mamba
|
||||||
Summary: A digital video recorder (DVR) application
|
Summary: A digital video recorder (DVR) application
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -22,9 +22,7 @@ Source9: mythbackend.sysconfig
|
|||||||
Source10: mythweb.conf
|
Source10: mythweb.conf
|
||||||
Source11: mythtv-mysql.txt
|
Source11: mythtv-mysql.txt
|
||||||
Source12: mythtv-PACKAGE-LICENSING
|
Source12: mythtv-PACKAGE-LICENSING
|
||||||
Patch0: mythtv-0.26.0-libva-1.2.1.patch
|
|
||||||
Patch1: mythtv-31.0-gcc-11.patch
|
Patch1: mythtv-31.0-gcc-11.patch
|
||||||
Patch2: mythtv-31.0-qt5-5.12.patch
|
|
||||||
Patch3: mythtv-32.0-glibc-2.35.patch
|
Patch3: mythtv-32.0-glibc-2.35.patch
|
||||||
Patch4: mythtv-33.1-binutils-2.41.patch
|
Patch4: mythtv-33.1-binutils-2.41.patch
|
||||||
License: GPL, LGPL
|
License: GPL, LGPL
|
||||||
@ -60,6 +58,7 @@ BuildRequires: libpulseaudio-devel
|
|||||||
BuildRequires: libpython311-devel
|
BuildRequires: libpython311-devel
|
||||||
BuildRequires: libraw1394-devel
|
BuildRequires: libraw1394-devel
|
||||||
BuildRequires: libsamplerate-devel
|
BuildRequires: libsamplerate-devel
|
||||||
|
BuildRequires: libsndio-devel
|
||||||
BuildRequires: libsoundtouch-devel
|
BuildRequires: libsoundtouch-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libsystemd-devel
|
BuildRequires: libsystemd-devel
|
||||||
@ -167,9 +166,8 @@ This package contains the documentation for %{name},
|
|||||||
#-D -T
|
#-D -T
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
%patch 1 -p1
|
%patch 1 -p1
|
||||||
#%patch 2 -p1
|
|
||||||
%patch 3 -p1
|
%patch 3 -p1
|
||||||
%patch 4 -p1 -b .binutils-2.41
|
#%patch 4 -p1 -b .binutils-2.41
|
||||||
|
|
||||||
rm -rf contrib/Win32 contrib/OSX
|
rm -rf contrib/Win32 contrib/OSX
|
||||||
#chmod -x themes/default/htmls/*.html
|
#chmod -x themes/default/htmls/*.html
|
||||||
@ -345,7 +343,8 @@ rm -rf %{buildroot}%{_libdir}/mythtv/filters/*.*a
|
|||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/mythpython
|
%{_bindir}/mythpython
|
||||||
%{_bindir}/mythwikiscripts
|
%{_bindir}/mythwikiscripts
|
||||||
%{python3_sitelib}/MythTV-*.egg-info
|
%dir %{python3_sitelib}/MythTV-%{version}.dist-info
|
||||||
|
%{python3_sitelib}/MythTV-%{version}.dist-info/*
|
||||||
%dir %{python3_sitelib}/MythTV
|
%dir %{python3_sitelib}/MythTV
|
||||||
%{python3_sitelib}/MythTV/*
|
%{python3_sitelib}/MythTV/*
|
||||||
|
|
||||||
@ -355,6 +354,9 @@ rm -rf %{buildroot}%{_libdir}/mythtv/filters/*.*a
|
|||||||
##%doc contrib database
|
##%doc contrib database
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 13 2024 Automatic Build System <autodist@openmamba.org> 34.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Mon Oct 02 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 33.1-3mamba
|
* Mon Oct 02 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 33.1-3mamba
|
||||||
- fixed python-MythTV requirement
|
- fixed python-MythTV requirement
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user