145 lines
4.5 KiB
RPMSpec
145 lines
4.5 KiB
RPMSpec
Name: mygui
|
|
Version: 3.4.3
|
|
Release: 5mamba
|
|
Summary: A library for creating Graphical User Interfaces (GUIs) for games and 3D applications
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://github.com/MyGUI/mygui
|
|
Source: https://github.com/MyGUI/mygui.git/MyGUI%{version}/mygui-%{version}.tar.bz2
|
|
License: MIT
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libboost-devel
|
|
BuildRequires: libbullet-devel
|
|
BuildRequires: libfreetype-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libz-devel
|
|
BuildRequires: ogre-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: cmake
|
|
BuildRequires: libois-devel
|
|
BuildRequires: ogre-devel >= 1:14.3.1
|
|
|
|
%description
|
|
MyGUI is a library for creating Graphical User Interfaces (GUIs) for games and 3D applications. The main goals of mygui are: speed, flexibility and ease of use.
|
|
|
|
%package -n lib%{name}
|
|
Group: System/Libraries
|
|
Summary: A library for creating Graphical User Interfaces (GUIs) for games and 3D applications
|
|
|
|
%description -n lib%{name}
|
|
MyGUI is a library for creating Graphical User Interfaces (GUIs) for games and 3D applications. The main goals of mygui are: speed, flexibility and ease of use.
|
|
This package contains shared libraries for %{name}.
|
|
|
|
%package -n lib%{name}-devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: pkg-config
|
|
|
|
%description -n lib%{name}-devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
%cmake -d build \
|
|
-DCMAKE_SHARED_LINKER_FLAGS="-ldl" \
|
|
-DOGRE_LIBRARIES="boost_system;OgreMain;pthread" \
|
|
-DMYGUI_INSTALL_SAMPLES=TRUE \
|
|
-DMYGUI_INSTALL_TOOLS=TRUE \
|
|
-DMYGUI_INSTALL_DOCS=TRUE \
|
|
-DMYGUI_INSTALL_MEDIA=TRUE \
|
|
-DFREETYPE_INCLUDE_DIR=%{_includedir}/freetype2/ \
|
|
-DMYGUI_BUILD_DEMOS=FALSE \
|
|
-DMYGUI_BUILD_TOOLS=FALSE \
|
|
-DMYGUI_RENDERSYSTEM=3 \
|
|
-DBUILD_SHARED_LIBS=TRUE
|
|
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall -C build
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -n lib%{name} -p /sbin/ldconfig
|
|
%postun -n lib%{name} -p /sbin/ldconfig
|
|
|
|
%files -n lib%{name}
|
|
%defattr(-,root,root)
|
|
#%{_bindir}/resources.xml
|
|
%{_libdir}/libMyGUIEngine.so.*
|
|
%{_libdir}/libMyGUI.OgrePlatform.so
|
|
%{_libdir}/Plugin_StrangeButton.so
|
|
#%dir %{_datadir}/MYGUI
|
|
#%dir %{_datadir}/MYGUI/Media
|
|
#%{_datadir}/MYGUI/Media/*
|
|
|
|
%files -n lib%{name}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/MYGUI/
|
|
%{_includedir}/MYGUI/MyGUI*.h
|
|
%{_includedir}/MYGUI/Plugin.h
|
|
%{_includedir}/MYGUI/StrangeButton.h
|
|
%{_libdir}/libMyGUIEngine.so
|
|
%{_libdir}/pkgconfig/MYGUI.pc
|
|
#%doc ChangeLog_rus.txt ChangeLog.txt
|
|
|
|
%changelog
|
|
* Fri Nov 08 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.3-5mamba
|
|
- rebuilt with ogre 14.3.1
|
|
|
|
* Thu Mar 14 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.3-4mamba
|
|
- rebuilt with ogre 14.2.2
|
|
|
|
* Tue Oct 10 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.3-3mamba
|
|
- rebuilt with ogre 14.1.0
|
|
|
|
* Sat Sep 02 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.3-2mamba
|
|
- rebuilt with ogre 14.0.1
|
|
|
|
* Mon Aug 28 2023 Automatic Build System <autodist@mambasoft.it> 3.4.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 21 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.2-1mamba
|
|
- update to 3.4.2
|
|
|
|
* Tue Jun 14 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.1-4mamba
|
|
- rebuilt with ogre 13.4.0
|
|
|
|
* Sun May 29 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.1-3mamba
|
|
- rebuilt with ogre 13.3.4
|
|
|
|
* Mon Nov 29 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.1-2mamba
|
|
- rebuilt with ogre 13.1.1
|
|
|
|
* Mon Aug 02 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.1-1mamba
|
|
- update to 3.4.1
|
|
|
|
* Sat Mar 07 2020 Automatic Build System <autodist@mambasoft.it> 3.4.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Sep 09 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.2-2mamba
|
|
- rebuilt
|
|
|
|
* Mon Aug 08 2016 Automatic Build System <autodist@mambasoft.it> 3.2.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Sep 18 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.1-1mamba
|
|
- update to 3.2.1
|
|
|
|
* Mon Dec 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.0-2mamba
|
|
- rebuilt with boost 1.55
|
|
|
|
* Thu Nov 28 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.0-1mamba
|
|
- package created using the webbuild interface
|