rebuilt with boost 1.55 [release 3.2.0-2mamba;Mon Dec 02 2013]
This commit is contained in:
parent
a23f9037bb
commit
a0b6fab13c
@ -1,2 +1,4 @@
|
||||
# mygui
|
||||
|
||||
MyGUI is a library for creating Graphical User Interfaces (GUIs) for games and 3D applications. The main goals of mygui are: speed, flexibility and ease of use.
|
||||
|
||||
|
11
mygui-3.2.0-freetype-2.5.1.patch
Normal file
11
mygui-3.2.0-freetype-2.5.1.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- MyGUI_3.2.0/CMake/Packages/FindFreetype.cmake.orig 2012-02-22 22:27:34.000000000 +0100
|
||||
+++ MyGUI_3.2.0/CMake/Packages/FindFreetype.cmake 2013-11-28 10:11:45.198085793 +0100
|
||||
@@ -33,7 +33,7 @@
|
||||
findpkg_framework(FREETYPE)
|
||||
message(STATUS "CMAKE_PREFIX_PATH: ${CMAKE_PREFIX_PATH}")
|
||||
|
||||
-find_path(FREETYPE_INCLUDE_DIR NAMES freetype/freetype.h HINTS ${FREETYPE_INC_SEARCH_PATH} ${FREETYPE_PKGC_INCLUDE_DIRS} PATH_SUFFIXES freetype2)
|
||||
+find_path(FREETYPE_INCLUDE_DIR NAMES freetype.h HINTS ${FREETYPE_INC_SEARCH_PATH} ${FREETYPE_PKGC_INCLUDE_DIRS} PATH_SUFFIXES freetype2)
|
||||
find_path(FREETYPE_FT2BUILD_INCLUDE_DIR NAMES ft2build.h HINTS ${FREETYPE_INC_SEARCH_PATH} ${FREETYPE_PKGC_INCLUDE_DIRS})
|
||||
find_library(FREETYPE_LIBRARY_REL NAMES ${FREETYPE_LIBRARY_NAMES} HINTS ${FREETYPE_LIB_SEARCH_PATH} ${FREETYPE_PKGC_LIBRARY_DIRS} PATH_SUFFIXES "" release relwithdebinfo minsizerel)
|
||||
find_library(FREETYPE_LIBRARY_DBG NAMES ${FREETYPE_LIBRARY_NAMES_DBG} HINTS ${FREETYPE_LIB_SEARCH_PATH} ${FREETYPE_PKGC_LIBRARY_DIRS} PATH_SUFFIXES "" debug)
|
97
mygui.spec
Normal file
97
mygui.spec
Normal file
@ -0,0 +1,97 @@
|
||||
Name: mygui
|
||||
Version: 3.2.0
|
||||
Release: 2mamba
|
||||
Summary: A library for creating Graphical User Interfaces (GUIs) for games and 3D applications
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://mygui.info/
|
||||
Source: http://downloads.sourceforge.net/project/my-gui/MyGUI/MyGUI_%{version}/MyGUI_%{version}.zip
|
||||
Patch0: mygui-3.2.0-freetype-2.5.1.patch
|
||||
License: MIT
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libboost-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: ogre-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: cmake
|
||||
BuildRequires: libois-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
MyGUI is a library for creating Graphical User Interfaces (GUIs) for games and 3D applications. The main goals of mygui are: speed, flexibility and ease of use.
|
||||
|
||||
%package -n lib%{name}
|
||||
Group: System/Libraries
|
||||
Summary: A library for creating Graphical User Interfaces (GUIs) for games and 3D applications
|
||||
|
||||
%description -n lib%{name}
|
||||
MyGUI is a library for creating Graphical User Interfaces (GUIs) for games and 3D applications. The main goals of mygui are: speed, flexibility and ease of use.
|
||||
This package contains shared libraries for %{name}.
|
||||
|
||||
%package -n lib%{name}-devel
|
||||
Group: Development/Libraries
|
||||
Summary: Development files for %{name}
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: pkg-config
|
||||
|
||||
%description -n lib%{name}-devel
|
||||
This package contains libraries and header files for developing applications that use %{name}.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n MyGUI_%{version}
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
%cmake -d build \
|
||||
-DCMAKE_SHARED_LINKER_FLAGS="-ldl" \
|
||||
-DOGRE_LIBRARIES="boost_system;OgreMain;pthread"
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
|
||||
%ifarch x86_64
|
||||
mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir}
|
||||
sed -i "s|/lib|/lib64|" %{buildroot}%{_libdir}/pkgconfig/MYGUI.pc
|
||||
%endif
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n lib%{name} -p /sbin/ldconfig
|
||||
%postun -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libMyGUIEngine.so.*
|
||||
|
||||
%files -n lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/MYGUI/
|
||||
%{_includedir}/MYGUI/MyGUI*.h
|
||||
%{_includedir}/MYGUI/Plugin.h
|
||||
%{_includedir}/MYGUI/StrangeButton.h
|
||||
%{_libdir}/libMyGUI.OgrePlatform.so
|
||||
%{_libdir}/libMyGUIEngine.so
|
||||
%{_libdir}/libPlugin_StrangeButton.so
|
||||
%{_libdir}/pkgconfig/MYGUI.pc
|
||||
%doc ChangeLog_rus.txt ChangeLog.txt
|
||||
|
||||
%changelog
|
||||
* Mon Dec 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.0-2mamba
|
||||
- rebuilt with boost 1.55
|
||||
|
||||
* Thu Nov 28 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.0-1mamba
|
||||
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user