rebuilt with ogre 14.3.1 [release 3.4.3-5mamba;Fri Nov 08 2024]
This commit is contained in:
parent
a0b6fab13c
commit
423ae93d9c
@ -1,11 +0,0 @@
|
|||||||
--- MyGUI_3.2.0/CMake/Packages/FindFreetype.cmake.orig 2012-02-22 22:27:34.000000000 +0100
|
|
||||||
+++ MyGUI_3.2.0/CMake/Packages/FindFreetype.cmake 2013-11-28 10:11:45.198085793 +0100
|
|
||||||
@@ -33,7 +33,7 @@
|
|
||||||
findpkg_framework(FREETYPE)
|
|
||||||
message(STATUS "CMAKE_PREFIX_PATH: ${CMAKE_PREFIX_PATH}")
|
|
||||||
|
|
||||||
-find_path(FREETYPE_INCLUDE_DIR NAMES freetype/freetype.h HINTS ${FREETYPE_INC_SEARCH_PATH} ${FREETYPE_PKGC_INCLUDE_DIRS} PATH_SUFFIXES freetype2)
|
|
||||||
+find_path(FREETYPE_INCLUDE_DIR NAMES freetype.h HINTS ${FREETYPE_INC_SEARCH_PATH} ${FREETYPE_PKGC_INCLUDE_DIRS} PATH_SUFFIXES freetype2)
|
|
||||||
find_path(FREETYPE_FT2BUILD_INCLUDE_DIR NAMES ft2build.h HINTS ${FREETYPE_INC_SEARCH_PATH} ${FREETYPE_PKGC_INCLUDE_DIRS})
|
|
||||||
find_library(FREETYPE_LIBRARY_REL NAMES ${FREETYPE_LIBRARY_NAMES} HINTS ${FREETYPE_LIB_SEARCH_PATH} ${FREETYPE_PKGC_LIBRARY_DIRS} PATH_SUFFIXES "" release relwithdebinfo minsizerel)
|
|
||||||
find_library(FREETYPE_LIBRARY_DBG NAMES ${FREETYPE_LIBRARY_NAMES_DBG} HINTS ${FREETYPE_LIB_SEARCH_PATH} ${FREETYPE_PKGC_LIBRARY_DIRS} PATH_SUFFIXES "" debug)
|
|
87
mygui.spec
87
mygui.spec
@ -1,26 +1,27 @@
|
|||||||
Name: mygui
|
Name: mygui
|
||||||
Version: 3.2.0
|
Version: 3.4.3
|
||||||
Release: 2mamba
|
Release: 5mamba
|
||||||
Summary: A library for creating Graphical User Interfaces (GUIs) for games and 3D applications
|
Summary: A library for creating Graphical User Interfaces (GUIs) for games and 3D applications
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://mygui.info/
|
URL: https://github.com/MyGUI/mygui
|
||||||
Source: http://downloads.sourceforge.net/project/my-gui/MyGUI/MyGUI_%{version}/MyGUI_%{version}.zip
|
Source: https://github.com/MyGUI/mygui.git/MyGUI%{version}/mygui-%{version}.tar.bz2
|
||||||
Patch0: mygui-3.2.0-freetype-2.5.1.patch
|
|
||||||
License: MIT
|
License: MIT
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libboost-devel
|
BuildRequires: libboost-devel
|
||||||
|
BuildRequires: libbullet-devel
|
||||||
BuildRequires: libfreetype-devel
|
BuildRequires: libfreetype-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
BuildRequires: ogre-devel
|
BuildRequires: ogre-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: libois-devel
|
BuildRequires: libois-devel
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRequires: ogre-devel >= 1:14.3.1
|
||||||
|
|
||||||
%description
|
%description
|
||||||
MyGUI is a library for creating Graphical User Interfaces (GUIs) for games and 3D applications. The main goals of mygui are: speed, flexibility and ease of use.
|
MyGUI is a library for creating Graphical User Interfaces (GUIs) for games and 3D applications. The main goals of mygui are: speed, flexibility and ease of use.
|
||||||
@ -45,16 +46,21 @@ This package contains libraries and header files for developing applications tha
|
|||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n MyGUI_%{version}
|
%setup -q
|
||||||
#-D -T
|
|
||||||
#:<< _EOF
|
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#:<< _EOF
|
|
||||||
%cmake -d build \
|
%cmake -d build \
|
||||||
-DCMAKE_SHARED_LINKER_FLAGS="-ldl" \
|
-DCMAKE_SHARED_LINKER_FLAGS="-ldl" \
|
||||||
-DOGRE_LIBRARIES="boost_system;OgreMain;pthread"
|
-DOGRE_LIBRARIES="boost_system;OgreMain;pthread" \
|
||||||
|
-DMYGUI_INSTALL_SAMPLES=TRUE \
|
||||||
|
-DMYGUI_INSTALL_TOOLS=TRUE \
|
||||||
|
-DMYGUI_INSTALL_DOCS=TRUE \
|
||||||
|
-DMYGUI_INSTALL_MEDIA=TRUE \
|
||||||
|
-DFREETYPE_INCLUDE_DIR=%{_includedir}/freetype2/ \
|
||||||
|
-DMYGUI_BUILD_DEMOS=FALSE \
|
||||||
|
-DMYGUI_BUILD_TOOLS=FALSE \
|
||||||
|
-DMYGUI_RENDERSYSTEM=3 \
|
||||||
|
-DBUILD_SHARED_LIBS=TRUE
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
@ -62,11 +68,6 @@ This package contains libraries and header files for developing applications tha
|
|||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%makeinstall -C build
|
%makeinstall -C build
|
||||||
|
|
||||||
%ifarch x86_64
|
|
||||||
mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir}
|
|
||||||
sed -i "s|/lib|/lib64|" %{buildroot}%{_libdir}/pkgconfig/MYGUI.pc
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
@ -75,7 +76,13 @@ sed -i "s|/lib|/lib64|" %{buildroot}%{_libdir}/pkgconfig/MYGUI.pc
|
|||||||
|
|
||||||
%files -n lib%{name}
|
%files -n lib%{name}
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
|
#%{_bindir}/resources.xml
|
||||||
%{_libdir}/libMyGUIEngine.so.*
|
%{_libdir}/libMyGUIEngine.so.*
|
||||||
|
%{_libdir}/libMyGUI.OgrePlatform.so
|
||||||
|
%{_libdir}/Plugin_StrangeButton.so
|
||||||
|
#%dir %{_datadir}/MYGUI
|
||||||
|
#%dir %{_datadir}/MYGUI/Media
|
||||||
|
#%{_datadir}/MYGUI/Media/*
|
||||||
|
|
||||||
%files -n lib%{name}-devel
|
%files -n lib%{name}-devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
@ -83,13 +90,53 @@ sed -i "s|/lib|/lib64|" %{buildroot}%{_libdir}/pkgconfig/MYGUI.pc
|
|||||||
%{_includedir}/MYGUI/MyGUI*.h
|
%{_includedir}/MYGUI/MyGUI*.h
|
||||||
%{_includedir}/MYGUI/Plugin.h
|
%{_includedir}/MYGUI/Plugin.h
|
||||||
%{_includedir}/MYGUI/StrangeButton.h
|
%{_includedir}/MYGUI/StrangeButton.h
|
||||||
%{_libdir}/libMyGUI.OgrePlatform.so
|
|
||||||
%{_libdir}/libMyGUIEngine.so
|
%{_libdir}/libMyGUIEngine.so
|
||||||
%{_libdir}/libPlugin_StrangeButton.so
|
|
||||||
%{_libdir}/pkgconfig/MYGUI.pc
|
%{_libdir}/pkgconfig/MYGUI.pc
|
||||||
%doc ChangeLog_rus.txt ChangeLog.txt
|
#%doc ChangeLog_rus.txt ChangeLog.txt
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 08 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.3-5mamba
|
||||||
|
- rebuilt with ogre 14.3.1
|
||||||
|
|
||||||
|
* Thu Mar 14 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.3-4mamba
|
||||||
|
- rebuilt with ogre 14.2.2
|
||||||
|
|
||||||
|
* Tue Oct 10 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.3-3mamba
|
||||||
|
- rebuilt with ogre 14.1.0
|
||||||
|
|
||||||
|
* Sat Sep 02 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.3-2mamba
|
||||||
|
- rebuilt with ogre 14.0.1
|
||||||
|
|
||||||
|
* Mon Aug 28 2023 Automatic Build System <autodist@mambasoft.it> 3.4.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun May 21 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.2-1mamba
|
||||||
|
- update to 3.4.2
|
||||||
|
|
||||||
|
* Tue Jun 14 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.1-4mamba
|
||||||
|
- rebuilt with ogre 13.4.0
|
||||||
|
|
||||||
|
* Sun May 29 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.1-3mamba
|
||||||
|
- rebuilt with ogre 13.3.4
|
||||||
|
|
||||||
|
* Mon Nov 29 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.1-2mamba
|
||||||
|
- rebuilt with ogre 13.1.1
|
||||||
|
|
||||||
|
* Mon Aug 02 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.1-1mamba
|
||||||
|
- update to 3.4.1
|
||||||
|
|
||||||
|
* Sat Mar 07 2020 Automatic Build System <autodist@mambasoft.it> 3.4.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Sep 09 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.2-2mamba
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Mon Aug 08 2016 Automatic Build System <autodist@mambasoft.it> 3.2.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Sep 18 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.1-1mamba
|
||||||
|
- update to 3.2.1
|
||||||
|
|
||||||
* Mon Dec 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.0-2mamba
|
* Mon Dec 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.0-2mamba
|
||||||
- rebuilt with boost 1.55
|
- rebuilt with boost 1.55
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user