package created using the webbuild interface [release r475-1mamba;Sat Nov 30 2013]

This commit is contained in:
Silvan Calarco 2024-01-06 07:27:35 +01:00
parent 12d4028e8c
commit ef990a5cb0
3 changed files with 110 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# musepack # musepack
Musepack is an audio compression format with a strong emphasis on high quality. It's not lossless, but it is designed for transparency, so that you won't be able to hear differences between the original wave file and the much smaller MPC file.
It is based on the MPEG-1 Layer-2 / MP2 algorithms, but since 1997 it has rapidly developed and vastly improved and is now at an advanced stage in which it contains heavily optimized and patentless code.

97
musepack.spec Normal file
View File

@ -0,0 +1,97 @@
Name: musepack
Version: r475
Release: 1mamba
Summary: An audio compression format with a strong emphasis on high quality
Group: System/Multimedia
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.musepack.net/
Source: http://files.musepack.net/source/musepack_src_%{version}.tar.gz
Patch0: musepack_src_r475-libmpcdec-soname.patch
License: LGPL, BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libcuefile-devel
BuildRequires: libreplaygain-devel
## AUTOBUILDREQ-END
BuildRequires: cmake
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Musepack is an audio compression format with a strong emphasis on high quality. It's not lossless, but it is designed for transparency, so that you won't be able to hear differences between the original wave file and the much smaller MPC file.
It is based on the MPEG-1 Layer-2 / MP2 algorithms, but since 1997 it has rapidly developed and vastly improved and is now at an advanced stage in which it contains heavily optimized and patentless code.
%package -n lib%{name}
Group: System/Libraries
Summary: Shared libraries for %{name}
%description -n lib%{name}
This package contains shared libraries for %{name}.
%package -n lib%{name}-devel
Group: Development/Libraries
Summary: Development files for %{name}
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n lib%{name}-devel
This package contains libraries and header files for developing applications that use %{name}.
%debug_package
%prep
%setup -q -n %{name}_src_%{version}
%patch0 -p1
%build
%cmake -d build
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall -C build
rm -rf %{buildroot}%{_includedir}/mpc/.svn
install -D -m0755 ./build/libmpcdec/libmpcdec.so.6.0.0 \
%{buildroot}%{_libdir}/libmpcdec.so.6.0.0
ln -s libmpcdec.so.6.0.0 %{buildroot}%{_libdir}/libmpcdec.so.6
ln -s libmpcdec.so.6.0.0 %{buildroot}%{_libdir}/libmpcdec.so
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -n lib%{name} -p /sbin/ldconfig
%postun -n lib%{name} -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_bindir}/mpc2sv8
%{_bindir}/mpcchap
%{_bindir}/mpccut
%{_bindir}/mpcdec
%{_bindir}/mpcenc
%{_bindir}/mpcgain
%{_bindir}/wavcmp
%files -n lib%{name}
%defattr(-,root,root)
%{_libdir}/libmpcdec.so.*
%files -n lib%{name}-devel
%defattr(-,root,root)
%{_libdir}/libmpcdec.so
%dir %{_includedir}/mpc
%{_includedir}/mpc/datatypes.h
%{_includedir}/mpc/minimax.h
%{_includedir}/mpc/mpc_types.h
%{_includedir}/mpc/mpcdec.h
%{_includedir}/mpc/mpcmath.h
%{_includedir}/mpc/reader.h
%{_includedir}/mpc/streaminfo.h
%changelog
* Sat Nov 30 2013 Silvan Calarco <silvan.calarco@mambasoft.it> r475-1mamba
- package created using the webbuild interface

View File

@ -0,0 +1,10 @@
--- musepack_src_r475/libmpcdec/CMakeLists.txt.orig 2013-11-30 22:20:35.251701127 +0100
+++ musepack_src_r475/libmpcdec/CMakeLists.txt 2013-11-30 22:21:16.827298160 +0100
@@ -1,6 +1,7 @@
include_directories(${libmpc_SOURCE_DIR}/include)
if(SHARED)
add_library(mpcdec SHARED huffman mpc_decoder mpc_reader streaminfo mpc_bits_reader mpc_demux requant synth_filter ${libmpc_SOURCE_DIR}/common/crc32)
+ set_target_properties(mpcdec PROPERTIES VERSION 6.0.0 SOVERSION 6)
else(SHARED)
add_library(mpcdec_static STATIC huffman mpc_decoder mpc_reader streaminfo mpc_bits_reader mpc_demux requant synth_filter ${libmpc_SOURCE_DIR}/common/crc32)
endif(SHARED)