rebuilt with debug package [release r475-2mamba;Sat Jan 30 2021]
This commit is contained in:
parent
ef990a5cb0
commit
dcd650a5f1
12
musepack-r475-am-maintainer-mode.patch
Normal file
12
musepack-r475-am-maintainer-mode.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
Index: libmpc-0.1~r459/configure.in
|
||||||
|
===================================================================
|
||||||
|
--- libmpc-0.1~r459.orig/configure.in 2010-05-31 16:32:02.551447078 +0200
|
||||||
|
+++ libmpc-0.1~r459/configure.in 2010-05-31 16:32:09.578951197 +0200
|
||||||
|
@@ -4,6 +4,7 @@
|
||||||
|
AC_CONFIG_SRCDIR([libmpcdec/mpc_reader.c])
|
||||||
|
AM_CONFIG_HEADER([include/config.h])
|
||||||
|
AM_INIT_AUTOMAKE
|
||||||
|
+AM_MAINTAINER_MODE
|
||||||
|
|
||||||
|
AC_LANG_C
|
||||||
|
AC_PROG_CC
|
7
musepack-r475-link-libm.patch
Normal file
7
musepack-r475-link-libm.patch
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
--- a/libmpcdec/Makefile.am.old 2009-10-20 20:11:41.000000000 +0200
|
||||||
|
+++ b/libmpcdec/Makefile.am 2009-10-20 20:12:02.000000000 +0200
|
||||||
|
@@ -17,3 +17,4 @@
|
||||||
|
$(common_sources)
|
||||||
|
|
||||||
|
libmpcdec_la_LDFLAGS = -no-undefined -version-info 7:0:1
|
||||||
|
+libmpcdec_la_LIBADD = -lm
|
44
musepack-r475-link-order.patch
Normal file
44
musepack-r475-link-order.patch
Normal file
@ -0,0 +1,44 @@
|
|||||||
|
---
|
||||||
|
mpc2sv8/Makefile.am | 5 +++--
|
||||||
|
mpcdec/Makefile.am | 5 +++--
|
||||||
|
mpcenc/Makefile.am | 5 +++--
|
||||||
|
3 files changed, 9 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
|
--- libmpc.orig/mpc2sv8/Makefile.am
|
||||||
|
+++ libmpc/mpc2sv8/Makefile.am
|
||||||
|
@@ -11,6 +11,7 @@ common_sources = ../common/crc32.c
|
||||||
|
METASOURCES = AUTO
|
||||||
|
bin_PROGRAMS = mpc2sv8
|
||||||
|
mpc2sv8_SOURCES = mpc2sv8.c $(common_sources)
|
||||||
|
-mpc2sv8_LDADD = -lm \
|
||||||
|
+mpc2sv8_LDADD = \
|
||||||
|
$(top_builddir)/libmpcdec/libmpcdec.la \
|
||||||
|
- $(top_builddir)/libmpcenc/libmpcenc.a
|
||||||
|
+ $(top_builddir)/libmpcenc/libmpcenc.a \
|
||||||
|
+ -lm
|
||||||
|
--- libmpc.orig/mpcdec/Makefile.am
|
||||||
|
+++ libmpc/mpcdec/Makefile.am
|
||||||
|
@@ -9,6 +9,7 @@ endif
|
||||||
|
METASOURCES = AUTO
|
||||||
|
bin_PROGRAMS = mpcdec
|
||||||
|
mpcdec_SOURCES = mpcdec.c
|
||||||
|
-mpcdec_LDADD = -lm \
|
||||||
|
+mpcdec_LDADD = \
|
||||||
|
$(top_builddir)/libmpcdec/libmpcdec.la \
|
||||||
|
- $(top_builddir)/libwavformat/libwavformat.a
|
||||||
|
+ $(top_builddir)/libwavformat/libwavformat.a \
|
||||||
|
+ -lm
|
||||||
|
--- libmpc.orig/mpcenc/Makefile.am
|
||||||
|
+++ libmpc/mpcenc/Makefile.am
|
||||||
|
@@ -22,8 +22,9 @@ mpcenc_SOURCES = keyboard.c mpcenc.c pip
|
||||||
|
$(common_sources) \
|
||||||
|
mpcenc.h predict.h config.h
|
||||||
|
|
||||||
|
-mpcenc_LDADD = -lm \
|
||||||
|
+mpcenc_LDADD = \
|
||||||
|
$(EXTRALIBS) \
|
||||||
|
$(top_builddir)/libmpcpsy/libmpcpsy.a \
|
||||||
|
- $(top_builddir)/libmpcenc/libmpcenc.a
|
||||||
|
+ $(top_builddir)/libmpcenc/libmpcenc.a \
|
||||||
|
+ -lm
|
||||||
|
|
22
musepack-r475-missing_extern_kw.patch
Normal file
22
musepack-r475-missing_extern_kw.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
Subject: Add extern keyword to global variable declaration.
|
||||||
|
Origin: upstream, commit:r479
|
||||||
|
Bug-Debian: http://bugs.debian.org/665974
|
||||||
|
---
|
||||||
|
libmpcdec/requant.h | 6 +++---
|
||||||
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
--- libmpc.orig/libmpcdec/requant.h
|
||||||
|
+++ libmpc/libmpcdec/requant.h
|
||||||
|
@@ -47,9 +47,9 @@ extern "C" {
|
||||||
|
|
||||||
|
|
||||||
|
/* C O N S T A N T S */
|
||||||
|
-const mpc_uint8_t Res_bit [18]; ///< Bits per sample for chosen quantizer
|
||||||
|
-const MPC_SAMPLE_FORMAT __Cc [1 + 18]; ///< Requantization coefficients
|
||||||
|
-const mpc_int16_t __Dc [1 + 18]; ///< Requantization offset
|
||||||
|
+extern const mpc_uint8_t Res_bit [18]; ///< Bits per sample for chosen quantizer
|
||||||
|
+extern const MPC_SAMPLE_FORMAT __Cc [1 + 18]; ///< Requantization coefficients
|
||||||
|
+extern const mpc_int16_t __Dc [1 + 18]; ///< Requantization offset
|
||||||
|
|
||||||
|
#define Cc (__Cc + 1)
|
||||||
|
#define Dc (__Dc + 1)
|
66
musepack-r475-mpcchap.patch
Normal file
66
musepack-r475-mpcchap.patch
Normal file
@ -0,0 +1,66 @@
|
|||||||
|
Index: libmpc/configure.in
|
||||||
|
===================================================================
|
||||||
|
--- libmpc.orig/configure.in
|
||||||
|
+++ libmpc/configure.in
|
||||||
|
@@ -28,6 +28,12 @@ esac
|
||||||
|
AC_SUBST([EXTRALIBS])
|
||||||
|
|
||||||
|
AC_ARG_ENABLE([mpcchap], [AS_HELP_STRING([--enable-mpcchap], [enable building mpcchap])])
|
||||||
|
+if test "x$enable_mpcchap" = xyes; then
|
||||||
|
+ PKG_CHECK_MODULES(LIBCUE, libcue)
|
||||||
|
+ AC_SUBST(LIBCUE_CFLAGS)
|
||||||
|
+ AC_SUBST(LIBCUE_LIBS)
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
AM_CONDITIONAL([MPC_CHAP], [test "x$enable_mpcchap" = xyes])
|
||||||
|
|
||||||
|
|
||||||
|
Index: libmpc/mpcchap/Makefile.am
|
||||||
|
===================================================================
|
||||||
|
--- libmpc.orig/mpcchap/Makefile.am
|
||||||
|
+++ libmpc/mpcchap/Makefile.am
|
||||||
|
@@ -4,7 +4,8 @@ bin_PROGRAMS = mpcchap
|
||||||
|
|
||||||
|
common_sources = ../common/tags.c ../common/crc32.c
|
||||||
|
|
||||||
|
-AM_CPPFLAGS = -I$(top_srcdir)/include
|
||||||
|
+AM_CPPFLAGS = -I$(top_srcdir)/include \
|
||||||
|
+ $(LIBCUE_CFLAGS)
|
||||||
|
|
||||||
|
if HAVE_VISIBILITY
|
||||||
|
AM_CFLAGS = -fvisibility=hidden
|
||||||
|
@@ -16,4 +17,4 @@ dictionary.h iniparser.h
|
||||||
|
|
||||||
|
mpcchap_LDADD = $(top_builddir)/libmpcdec/libmpcdec.la \
|
||||||
|
$(top_builddir)/libmpcenc/libmpcenc.a \
|
||||||
|
- -lm -lcuefile
|
||||||
|
+ -lm $(LIBCUE_LIBS)
|
||||||
|
Index: libmpc/mpcchap/mpcchap.c
|
||||||
|
===================================================================
|
||||||
|
--- libmpc.orig/mpcchap/mpcchap.c
|
||||||
|
+++ libmpc/mpcchap/mpcchap.c
|
||||||
|
@@ -24,7 +24,7 @@
|
||||||
|
|
||||||
|
#include <sys/stat.h>
|
||||||
|
|
||||||
|
-#include <cuetools/cuefile.h>
|
||||||
|
+#include <libcue/libcue.h>
|
||||||
|
|
||||||
|
// tags.c
|
||||||
|
void Init_Tags ( void );
|
||||||
|
@@ -153,13 +153,13 @@ mpc_status add_chaps_ini(char * mpc_file
|
||||||
|
mpc_status add_chaps_cue(char * mpc_file, char * chap_file, mpc_demux * demux, mpc_streaminfo * si)
|
||||||
|
{
|
||||||
|
Cd *cd = 0;
|
||||||
|
- int nchap, format = UNKNOWN;
|
||||||
|
+ int nchap;
|
||||||
|
struct stat stbuf;
|
||||||
|
FILE * in_file;
|
||||||
|
int chap_pos, end_pos, chap_size, i;
|
||||||
|
char * tmp_buff;
|
||||||
|
|
||||||
|
- if (0 == (cd = cf_parse(chap_file, &format))) {
|
||||||
|
+ if (0 == (cd = cue_parse_file(chap_file))) {
|
||||||
|
fprintf(stderr, "%s: input file error\n", chap_file);
|
||||||
|
return !MPC_STATUS_OK;
|
||||||
|
}
|
13
musepack-r475-visibility.patch
Normal file
13
musepack-r475-visibility.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
Index: libmpc/configure.in
|
||||||
|
===================================================================
|
||||||
|
--- libmpc.orig/configure.in
|
||||||
|
+++ libmpc/configure.in
|
||||||
|
@@ -37,7 +37,7 @@ fi
|
||||||
|
AM_CONDITIONAL([MPC_CHAP], [test "x$enable_mpcchap" = xyes])
|
||||||
|
|
||||||
|
|
||||||
|
-CHECK_VISIBILITY
|
||||||
|
+AM_CONDITIONAL([HAVE_VISIBILITY], [true])
|
||||||
|
|
||||||
|
AC_CONFIG_FILES([
|
||||||
|
Makefile
|
@ -1,6 +1,6 @@
|
|||||||
Name: musepack
|
Name: musepack
|
||||||
Version: r475
|
Version: r475
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: An audio compression format with a strong emphasis on high quality
|
Summary: An audio compression format with a strong emphasis on high quality
|
||||||
Group: System/Multimedia
|
Group: System/Multimedia
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -9,10 +9,17 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|||||||
URL: http://www.musepack.net/
|
URL: http://www.musepack.net/
|
||||||
Source: http://files.musepack.net/source/musepack_src_%{version}.tar.gz
|
Source: http://files.musepack.net/source/musepack_src_%{version}.tar.gz
|
||||||
Patch0: musepack_src_r475-libmpcdec-soname.patch
|
Patch0: musepack_src_r475-libmpcdec-soname.patch
|
||||||
|
Patch1: musepack-r475-am-maintainer-mode.patch
|
||||||
|
Patch2: musepack-r475-link-libm.patch
|
||||||
|
Patch3: musepack-r475-mpcchap.patch
|
||||||
|
Patch4: musepack-r475-link-order.patch
|
||||||
|
Patch5: musepack-r475-visibility.patch
|
||||||
|
Patch6: musepack-r475-missing_extern_kw.patch
|
||||||
License: LGPL, BSD
|
License: LGPL, BSD
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libcuefile-devel
|
BuildRequires: ldconfig
|
||||||
|
BuildRequires: libcue-devel
|
||||||
BuildRequires: libreplaygain-devel
|
BuildRequires: libreplaygain-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
@ -43,22 +50,23 @@ This package contains libraries and header files for developing applications tha
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}_src_%{version}
|
%setup -q -n %{name}_src_%{version}
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
%patch4 -p1
|
||||||
|
%patch5 -p1
|
||||||
|
%patch6 -p1
|
||||||
|
autoreconf -fi
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -d build
|
%configure \
|
||||||
|
--enable-mpcchap
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%makeinstall -C build
|
%makeinstall
|
||||||
|
|
||||||
rm -rf %{buildroot}%{_includedir}/mpc/.svn
|
|
||||||
|
|
||||||
install -D -m0755 ./build/libmpcdec/libmpcdec.so.6.0.0 \
|
|
||||||
%{buildroot}%{_libdir}/libmpcdec.so.6.0.0
|
|
||||||
|
|
||||||
ln -s libmpcdec.so.6.0.0 %{buildroot}%{_libdir}/libmpcdec.so.6
|
|
||||||
ln -s libmpcdec.so.6.0.0 %{buildroot}%{_libdir}/libmpcdec.so
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
@ -79,10 +87,10 @@ ln -s libmpcdec.so.6.0.0 %{buildroot}%{_libdir}/libmpcdec.so
|
|||||||
%files -n lib%{name}
|
%files -n lib%{name}
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_libdir}/libmpcdec.so.*
|
%{_libdir}/libmpcdec.so.*
|
||||||
|
%doc libmpcdec/COPYING libmpcdec/AUTHORS
|
||||||
|
|
||||||
%files -n lib%{name}-devel
|
%files -n lib%{name}-devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_libdir}/libmpcdec.so
|
|
||||||
%dir %{_includedir}/mpc
|
%dir %{_includedir}/mpc
|
||||||
%{_includedir}/mpc/datatypes.h
|
%{_includedir}/mpc/datatypes.h
|
||||||
%{_includedir}/mpc/minimax.h
|
%{_includedir}/mpc/minimax.h
|
||||||
@ -91,7 +99,13 @@ ln -s libmpcdec.so.6.0.0 %{buildroot}%{_libdir}/libmpcdec.so
|
|||||||
%{_includedir}/mpc/mpcmath.h
|
%{_includedir}/mpc/mpcmath.h
|
||||||
%{_includedir}/mpc/reader.h
|
%{_includedir}/mpc/reader.h
|
||||||
%{_includedir}/mpc/streaminfo.h
|
%{_includedir}/mpc/streaminfo.h
|
||||||
|
%{_libdir}/libmpcdec.a
|
||||||
|
%{_libdir}/libmpcdec.la
|
||||||
|
%{_libdir}/libmpcdec.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jan 30 2021 Silvan Calarco <silvan.calarco@mambasoft.it> r475-2mamba
|
||||||
|
- rebuilt with debug package
|
||||||
|
|
||||||
* Sat Nov 30 2013 Silvan Calarco <silvan.calarco@mambasoft.it> r475-1mamba
|
* Sat Nov 30 2013 Silvan Calarco <silvan.calarco@mambasoft.it> r475-1mamba
|
||||||
- package created using the webbuild interface
|
- package created using the webbuild interface
|
||||||
|
Loading…
Reference in New Issue
Block a user