added a patch to disable starting jack server by default [release 1.3.0-2mamba;Mon Apr 27 2020]
This commit is contained in:
parent
1a194825f7
commit
6016196816
@ -1,2 +1,4 @@
|
|||||||
# mumble
|
# mumble
|
||||||
|
|
||||||
|
A voice chat application similar to TeamSpeak.
|
||||||
|
|
||||||
|
23
mumble-1.3.0-jack-do-not-start-by-default.patch
Normal file
23
mumble-1.3.0-jack-do-not-start-by-default.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
From 0780d93aab3eec9796e1cb8606c5f3c089d64eca Mon Sep 17 00:00:00 2001
|
||||||
|
From: David Runge <dave@sleepmap.de>
|
||||||
|
Date: Sun, 8 Mar 2020 19:28:59 +0100
|
||||||
|
Subject: [PATCH] src/mumble/Settings.cpp: Setting bJackStartServer to false,
|
||||||
|
so mumble will not unconditionally start a JACK server on start (#3989).
|
||||||
|
|
||||||
|
---
|
||||||
|
src/mumble/Settings.cpp | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/mumble/Settings.cpp b/src/mumble/Settings.cpp
|
||||||
|
index 596e772dc2..b2e3990242 100644
|
||||||
|
--- a/src/mumble/Settings.cpp
|
||||||
|
+++ b/src/mumble/Settings.cpp
|
||||||
|
@@ -322,7 +322,7 @@ Settings::Settings() {
|
||||||
|
|
||||||
|
qsJackClientName = QLatin1String("mumble");
|
||||||
|
qsJackAudioOutput = QLatin1String("1");
|
||||||
|
- bJackStartServer = true;
|
||||||
|
+ bJackStartServer = false;
|
||||||
|
bJackAutoConnect = true;
|
||||||
|
|
||||||
|
bEcho = false;
|
103
mumble.spec
Normal file
103
mumble.spec
Normal file
@ -0,0 +1,103 @@
|
|||||||
|
Name: mumble
|
||||||
|
Version: 1.3.0
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: A voice chat application similar to TeamSpeak
|
||||||
|
Group: Graphical Desktop/Applications/Internet
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: https://www.mumble.info/
|
||||||
|
## GITSOURCE https://github.com/mumble-voip/mumble.git 1.3.0
|
||||||
|
Source: https://github.com/mumble-voip/mumble.git/%{version}/mumble-%{version}.tar.bz2
|
||||||
|
Patch0: mumble-1.3.0-jack-do-not-start-by-default.patch
|
||||||
|
License: BSD
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: avahi-compat-libdns_sd-devel
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: ldconfig
|
||||||
|
BuildRequires: libGL-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXi-devel
|
||||||
|
BuildRequires: libalsa-devel
|
||||||
|
BuildRequires: libavahi-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libjack-devel
|
||||||
|
BuildRequires: libopenssl-devel
|
||||||
|
BuildRequires: libopus-devel
|
||||||
|
BuildRequires: libprotobuf-devel
|
||||||
|
BuildRequires: libpulseaudio-devel
|
||||||
|
BuildRequires: libqt5-devel
|
||||||
|
BuildRequires: libsndfile-devel
|
||||||
|
BuildRequires: libspeechd-devel
|
||||||
|
BuildRequires: libspeex-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
A voice chat application similar to TeamSpeak.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
qmake-qt5 main.pro \
|
||||||
|
CONFIG+="no-bundled-opus no-bundled-speex no-g15 no-xevie no-server \
|
||||||
|
no-embed-qt-translations no-update packaged bundled-celt" \
|
||||||
|
DEFINES+="PLUGIN_PATH=%{_libdir}/mumble" \
|
||||||
|
INCLUDEPATH+="%{_includedir}/speech-dispatcher"
|
||||||
|
|
||||||
|
make release
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
install -vDm 755 release/mumble -t %{buildroot}%{_bindir}
|
||||||
|
install -vDm 755 scripts/mumble-overlay -t %{buildroot}%{_bindir}
|
||||||
|
|
||||||
|
# (vendored) libs
|
||||||
|
install -vdm 755 %{buildroot}%{_libdir}/mumble/
|
||||||
|
for _lib in release/*.so*; do
|
||||||
|
if [ -L "$_lib" ]; then
|
||||||
|
cp -vP "$_lib" %{buildroot}%{_libdir}/mumble/
|
||||||
|
else
|
||||||
|
install -vDm 755 "$_lib" -t %{buildroot}%{_libdir}/mumble/
|
||||||
|
fi
|
||||||
|
done
|
||||||
|
install -vDm 755 release/plugins/*.so -t %{buildroot}%{_libdir}/mumble/
|
||||||
|
# XDG desktop integration
|
||||||
|
install -vDm 644 scripts/mumble.desktop -t %{buildroot}%{_datadir}/applications/
|
||||||
|
# man page
|
||||||
|
install -vDm 644 man/mumble*.1 -t %{buildroot}%{_mandir}/man1/
|
||||||
|
# XDG desktop icons
|
||||||
|
install -vDm 644 icons/mumble.svg -t %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/mumble
|
||||||
|
%{_bindir}/mumble-overlay
|
||||||
|
%dir %{_libdir}/mumble
|
||||||
|
%{_libdir}/mumble/libcelt0.so*
|
||||||
|
%{_libdir}/mumble/libl4d2.so
|
||||||
|
%{_libdir}/mumble/liblink.so
|
||||||
|
%{_libdir}/mumble/libmumble.so*
|
||||||
|
%{_libdir}/mumble/librl.so
|
||||||
|
%{_datadir}/applications/mumble.desktop
|
||||||
|
%{_datadir}/icons/hicolor/scalable/apps/mumble.svg
|
||||||
|
%{_mandir}/man1/mumble-overlay.1*
|
||||||
|
%{_mandir}/man1/mumble.1*
|
||||||
|
%doc AUTHORS LICENSE
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Apr 27 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.0-2mamba
|
||||||
|
- added a patch to disable starting jack server by default
|
||||||
|
|
||||||
|
* Mon Apr 27 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.0-1mamba
|
||||||
|
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user