update to 1.5.613 [release 1.5.613-1mamba;Fri Mar 15 2024]
This commit is contained in:
parent
6057c9a848
commit
3086c18324
@ -1,23 +0,0 @@
|
|||||||
From 0780d93aab3eec9796e1cb8606c5f3c089d64eca Mon Sep 17 00:00:00 2001
|
|
||||||
From: David Runge <dave@sleepmap.de>
|
|
||||||
Date: Sun, 8 Mar 2020 19:28:59 +0100
|
|
||||||
Subject: [PATCH] src/mumble/Settings.cpp: Setting bJackStartServer to false,
|
|
||||||
so mumble will not unconditionally start a JACK server on start (#3989).
|
|
||||||
|
|
||||||
---
|
|
||||||
src/mumble/Settings.cpp | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/mumble/Settings.cpp b/src/mumble/Settings.cpp
|
|
||||||
index 596e772dc2..b2e3990242 100644
|
|
||||||
--- a/src/mumble/Settings.cpp
|
|
||||||
+++ b/src/mumble/Settings.cpp
|
|
||||||
@@ -322,7 +322,7 @@ Settings::Settings() {
|
|
||||||
|
|
||||||
qsJackClientName = QLatin1String("mumble");
|
|
||||||
qsJackAudioOutput = QLatin1String("1");
|
|
||||||
- bJackStartServer = true;
|
|
||||||
+ bJackStartServer = false;
|
|
||||||
bJackAutoConnect = true;
|
|
||||||
|
|
||||||
bEcho = false;
|
|
86
mumble.spec
86
mumble.spec
@ -1,5 +1,5 @@
|
|||||||
Name: mumble
|
Name: mumble
|
||||||
Version: 1.3.4
|
Version: 1.5.613
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A voice chat application similar to TeamSpeak
|
Summary: A voice chat application similar to TeamSpeak
|
||||||
Group: Graphical Desktop/Applications/Internet
|
Group: Graphical Desktop/Applications/Internet
|
||||||
@ -7,32 +7,32 @@ Vendor: openmamba
|
|||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://www.mumble.info/
|
URL: https://www.mumble.info/
|
||||||
## GITSOURCE https://github.com/mumble-voip/mumble.git 1.3.0
|
Source: https://github.com/mumble-voip/mumble.git/v%{version}/mumble-%{version}.tar.bz2
|
||||||
Source: https://github.com/mumble-voip/mumble.git/%{version}/mumble-%{version}.tar.bz2
|
|
||||||
Patch0: mumble-1.3.0-jack-do-not-start-by-default.patch
|
|
||||||
License: BSD
|
License: BSD
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: avahi-compat-libdns_sd-devel
|
BuildRequires: avahi-compat-libdns_sd-devel
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libQt5Svg-devel
|
||||||
BuildRequires: libX11-devel
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXext-devel
|
||||||
BuildRequires: libXi-devel
|
BuildRequires: libXi-devel
|
||||||
|
BuildRequires: libabseil-cpp-devel
|
||||||
BuildRequires: libalsa-devel
|
BuildRequires: libalsa-devel
|
||||||
BuildRequires: libavahi-devel
|
BuildRequires: libcap-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libglib-devel
|
BuildRequires: libglib-devel
|
||||||
BuildRequires: libglvnd-devel
|
|
||||||
BuildRequires: libjack-devel
|
|
||||||
BuildRequires: libopenssl-devel
|
BuildRequires: libopenssl-devel
|
||||||
BuildRequires: libopus-devel
|
BuildRequires: libopus-devel
|
||||||
|
BuildRequires: libpoco-devel
|
||||||
BuildRequires: libprotobuf-devel
|
BuildRequires: libprotobuf-devel
|
||||||
BuildRequires: libpulseaudio-devel
|
|
||||||
BuildRequires: libqt5-devel
|
|
||||||
BuildRequires: libsndfile-devel
|
BuildRequires: libsndfile-devel
|
||||||
BuildRequires: libspeechd-devel
|
BuildRequires: libspeechd-devel
|
||||||
BuildRequires: libspeex-devel
|
|
||||||
BuildRequires: libspeexdsp-devel
|
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: qt5-qtbase-devel
|
||||||
|
BuildRequires: zeroc-ice-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libpoco-devel
|
||||||
|
BuildRequires: zeroc-ice-devel
|
||||||
|
|
||||||
%description
|
%description
|
||||||
A voice chat application similar to TeamSpeak.
|
A voice chat application similar to TeamSpeak.
|
||||||
@ -41,60 +41,58 @@ A voice chat application similar to TeamSpeak.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch0 -p1
|
# protobuf 23 requires C++17
|
||||||
|
sed -i "s|CMAKE_CXX_STANDARD 14|CMAKE_CXX_STANDARD 17|" CMakeLists.txt
|
||||||
|
|
||||||
%build
|
%build
|
||||||
qmake-qt5 main.pro \
|
%cmake \
|
||||||
CONFIG+="no-bundled-opus no-bundled-speex no-g15 no-xevie no-server \
|
-DMUMBLE_INSTALL_SYSCONFDIR=%{_sysconfdir}/mumble \
|
||||||
no-embed-qt-translations no-update packaged bundled-celt" \
|
-DMUMBLE_INSTALL_SERVICEFILEDIR=%{_unitdir} \
|
||||||
DEFINES+="PLUGIN_PATH=%{_libdir}/mumble" \
|
-DMUMBLE_INSTALL_SYSUSERSDIR=%{_sysusersdir} \
|
||||||
INCLUDEPATH+="%{_includedir}/speech-dispatcher"
|
-DMUMBLE_INSTALL_TMPFILESDIR=%{_tmpfilesdir}
|
||||||
|
|
||||||
make release
|
%cmake_build
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
install -vDm 755 release/mumble -t %{buildroot}%{_bindir}
|
%cmake_install
|
||||||
install -vDm 755 scripts/mumble-overlay -t %{buildroot}%{_bindir}
|
|
||||||
|
|
||||||
# (vendored) libs
|
|
||||||
install -vdm 755 %{buildroot}%{_libdir}/mumble/
|
|
||||||
for _lib in release/*.so*; do
|
|
||||||
if [ -L "$_lib" ]; then
|
|
||||||
cp -vP "$_lib" %{buildroot}%{_libdir}/mumble/
|
|
||||||
else
|
|
||||||
install -vDm 755 "$_lib" -t %{buildroot}%{_libdir}/mumble/
|
|
||||||
fi
|
|
||||||
done
|
|
||||||
install -vDm 755 release/plugins/*.so -t %{buildroot}%{_libdir}/mumble/
|
|
||||||
# XDG desktop integration
|
|
||||||
install -vDm 644 scripts/mumble.desktop -t %{buildroot}%{_datadir}/applications/
|
|
||||||
# man page
|
|
||||||
install -vDm 644 man/mumble*.1 -t %{buildroot}%{_mandir}/man1/
|
|
||||||
# XDG desktop icons
|
|
||||||
install -vDm 644 icons/mumble.svg -t %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
|
%config(noreplace) %{_sysconfdir}/mumble/mumble-server.ini
|
||||||
%{_bindir}/mumble
|
%{_bindir}/mumble
|
||||||
%{_bindir}/mumble-overlay
|
%{_bindir}/mumble-overlay
|
||||||
|
%{_bindir}/mumble-server
|
||||||
|
%{_bindir}/mumble-server-user-wrapper
|
||||||
|
%{_unitdir}/mumble-server.service
|
||||||
|
%{_sysusersdir}/mumble-server.conf
|
||||||
|
%{_tmpfilesdir}/mumble-server.conf
|
||||||
|
%{_datadir}/applications/info.mumble.Mumble.desktop
|
||||||
|
%{_metainfodir}/info.mumble.Mumble.appdata.xml
|
||||||
|
%{_libdir}/mumble/libmumbleoverlay.x86.so
|
||||||
|
%{_libdir}/mumble/libmumbleoverlay.x86.so.*
|
||||||
|
%{_libdir}/mumble/libmumbleoverlay.*.so
|
||||||
|
%{_libdir}/mumble/libmumbleoverlay.*.so.*
|
||||||
%dir %{_libdir}/mumble
|
%dir %{_libdir}/mumble
|
||||||
%{_libdir}/mumble/libcelt0.so*
|
%dir %{_libdir}/mumble/plugins
|
||||||
%{_libdir}/mumble/libl4d2.so
|
%{_libdir}/mumble/plugins/lib*.so
|
||||||
%{_libdir}/mumble/liblink.so
|
%{_datadir}/mumble-server/MumbleServer.ice
|
||||||
%{_libdir}/mumble/libmumble.so*
|
%{_datadir}/icons/hicolor/256x256/apps/mumble.png
|
||||||
%{_libdir}/mumble/librl.so
|
|
||||||
%{_datadir}/applications/mumble.desktop
|
|
||||||
%{_datadir}/icons/hicolor/scalable/apps/mumble.svg
|
%{_datadir}/icons/hicolor/scalable/apps/mumble.svg
|
||||||
%{_mandir}/man1/mumble-overlay.1*
|
%{_mandir}/man1/mumble-overlay.1*
|
||||||
%{_mandir}/man1/mumble.1*
|
%{_mandir}/man1/mumble.1*
|
||||||
%doc AUTHORS LICENSE
|
%{_mandir}/man1/mumble-server-user-wrapper.1*
|
||||||
|
%{_mandir}/man1/mumble-server.1*
|
||||||
|
%doc LICENSE
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 15 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.613-1mamba
|
||||||
|
- update to 1.5.613
|
||||||
|
|
||||||
* Fri Apr 30 2021 Automatic Build System <autodist@mambasoft.it> 1.3.4-1mamba
|
* Fri Apr 30 2021 Automatic Build System <autodist@mambasoft.it> 1.3.4-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user