rebuilt to remove executable requirements [release 0.6.2-3mamba;Fri Feb 05 2010]
This commit is contained in:
parent
31ff1e79c6
commit
7441b90e2d
@ -1,2 +1,10 @@
|
||||
# msysklogd
|
||||
|
||||
Msysklogd is a small and simple syslog and kernel log daemon.
|
||||
It does not need any configuration file and does not write any files.
|
||||
It just writes all messages to standard out (descriptor 1) or to a remote host.
|
||||
I recommend to use it with a powerful logging service such as multilog from daemontools.
|
||||
|
||||
The idea and some code is from Olaf Dreesen's od_syslog.
|
||||
Even if it is possible to link msysklogd against the glibc I strongly recommend to use the dietlibc from Felix von Leitner.
|
||||
|
||||
|
22
msysklogd-0.6.2-DESTDIR.patch
Normal file
22
msysklogd-0.6.2-DESTDIR.patch
Normal file
@ -0,0 +1,22 @@
|
||||
diff -Nru msysklogd-0.6.2.orig/Makefile msysklogd-0.6.2/Makefile
|
||||
--- msysklogd-0.6.2.orig/Makefile 2005-12-03 23:44:29.000000000 +0100
|
||||
+++ msysklogd-0.6.2/Makefile 2007-07-31 13:44:23.000000000 +0200
|
||||
@@ -29,12 +29,12 @@
|
||||
$(CC) $(LDFLAGS) -o $@ sysklogd.o $(LIBS)
|
||||
|
||||
install: $(PROGS)
|
||||
- mkdir -p $(PREFIX)/{bin,sbin}
|
||||
- mkdir -p $(PREFIX)/man/man{1,8}
|
||||
- cp logwrite $(PREFIX)/bin
|
||||
- cp logwrite.1 $(PREFIX)/man/man1
|
||||
- cp klogctl sysklogd $(PREFIX)/sbin
|
||||
- cp klogctl.8 sysklogd.8 $(PREFIX)/man/man8
|
||||
+ mkdir -p $(DESTDIR)$(PREFIX)/{bin,sbin}
|
||||
+ mkdir -p $(DESTDIR)$(PREFIX)/share/man/man{1,8}
|
||||
+ cp logwrite $(DESTDIR)$(PREFIX)/bin
|
||||
+ cp logwrite.1 $(DESTDIR)$(PREFIX)/share/man/man1
|
||||
+ cp klogctl sysklogd $(DESTDIR)$(PREFIX)/sbin
|
||||
+ cp klogctl.8 sysklogd.8 $(DESTDIR)$(PREFIX)/share/man/man8
|
||||
|
||||
clean:
|
||||
rm -f *.o *~ $(PROGS)
|
38
msysklogd-initscript
Normal file
38
msysklogd-initscript
Normal file
@ -0,0 +1,38 @@
|
||||
#! /bin/bash
|
||||
# Begin $rc_base/init.d/msysklogd - Mini Sysklogd loader
|
||||
#
|
||||
# msysklogd: This starts and stops the Mini Sysklogd
|
||||
# chkconfig: 2345 14 93
|
||||
# description: Mini Sysklogd loader
|
||||
#
|
||||
# Copyright (c) by Davide Madrisan <davide.madrisan@qilinux.it>
|
||||
|
||||
. /etc/init.d/functions
|
||||
|
||||
case "$1" in
|
||||
start)
|
||||
echo -n "Starting msysklogd: "
|
||||
sysklogd -c 1 -k /dev/null -m0 >/dev/null 2>&1 &
|
||||
evaluate_retval
|
||||
echo
|
||||
;;
|
||||
stop)
|
||||
echo -n "Stopping msysklogd: "
|
||||
killproc sysklogd
|
||||
evaluate_retval
|
||||
echo
|
||||
;;
|
||||
status)
|
||||
statusproc sysklogd
|
||||
;;
|
||||
restart)
|
||||
$0 stop
|
||||
sleep 1
|
||||
$0 start ;;
|
||||
*)
|
||||
echo "Usage: $0 {start|stop|status|restart}"
|
||||
exit 1
|
||||
esac
|
||||
|
||||
# End $rc_base/init.d/msysklogd
|
||||
|
99
msysklogd.spec
Normal file
99
msysklogd.spec
Normal file
@ -0,0 +1,99 @@
|
||||
Name: msysklogd
|
||||
Version: 0.6.2
|
||||
Release: 3mamba
|
||||
Summary: A small and simple syslog and kernel log daemon
|
||||
Group: System/Kernel and Hardware
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://maxrelax.de/~tknop/msysklogd.html
|
||||
Source0: http://maxrelax.de/~tmueller/msysklogd/msysklogd-%{version}.tar.bz2
|
||||
Source1: msysklogd-initscript
|
||||
Patch: msysklogd-0.6.2-DESTDIR.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: dietlibc-devel >= 0.25
|
||||
BuildRequires: libowfat-devel >= 0.16
|
||||
Conflicts: sysklogd
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-build
|
||||
|
||||
%description
|
||||
Msysklogd is a small and simple syslog and kernel log daemon.
|
||||
It does not need any configuration file and does not write any files.
|
||||
It just writes all messages to standard out (descriptor 1) or to a remote host.
|
||||
I recommend to use it with a powerful logging service such as multilog from daemontools.
|
||||
|
||||
The idea and some code is from Olaf Dreesen's od_syslog.
|
||||
Even if it is possible to link msysklogd against the glibc I strongly recommend to use the dietlibc from Felix von Leitner.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeoldinstall PREFIX=%{buildroot}%{_prefix}
|
||||
|
||||
mkdir -p %{buildroot}%{_initrddir}
|
||||
install -m 744 %{SOURCE1} %{buildroot}%{_initrddir}/msysklogd
|
||||
|
||||
%post
|
||||
# new install
|
||||
if [ $1 -eq 1 ]; then
|
||||
chkconfig --add msysklogd
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%preun
|
||||
#erase
|
||||
if [ $1 -eq 0 ]; then
|
||||
chkconfig msysklogd
|
||||
test $? -eq 0 && {
|
||||
service msysklogd stop
|
||||
chkconfig --del msysklogd
|
||||
}
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%postun
|
||||
# upgrade
|
||||
if [ $1 -eq 1 ]; then
|
||||
chkconfig msysklogd
|
||||
test $? -eq 0 && service msysklogd restart
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_initrddir}/msysklogd
|
||||
%{_bindir}/logwrite
|
||||
%{_sbindir}/klogctl
|
||||
%{_sbindir}/sysklogd
|
||||
%{_mandir}/man1/logwrite.*
|
||||
%{_mandir}/man8/klogctl.*
|
||||
%{_mandir}/man8/sysklogd.*
|
||||
%doc CHANGES COPYING README
|
||||
|
||||
%changelog
|
||||
* Fri Feb 05 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.2-3mamba
|
||||
- rebuilt to remove executable requirements
|
||||
|
||||
* Tue Mar 11 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.2-2mamba
|
||||
- disable service with chkconfig on uninstall
|
||||
|
||||
* Tue Jul 31 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.2-1mamba
|
||||
- update to 0.6.2
|
||||
|
||||
* Fri Jan 28 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5-2qilnx
|
||||
- don't activate service on first install
|
||||
- fixed checks on restart e stop scripts
|
||||
|
||||
* Tue Apr 27 2004 Davide Madrisan <davide.madrisan@qilinux.it> 0.5-1qilnx
|
||||
- first build
|
Loading…
Reference in New Issue
Block a user