67 lines
2.1 KiB
RPMSpec
67 lines
2.1 KiB
RPMSpec
Name: mqtt-explorer
|
|
Version: 0.3.5
|
|
Release: 2mamba
|
|
Summary: An all-round MQTT client that provides a structured topic overview
|
|
Group: Graphical Desktop/Applications/Networking
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://mqtt-explorer.com/
|
|
Source: https://github.com/thomasnordquist/MQTT-Explorer.git/v%{version}/MQTT-Explorer-%{version}.tar.bz2
|
|
Source1: mqtt-explorer.desktop
|
|
License: CCPL:by-nd
|
|
## AUTOBUILDREQ-BEGIN
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: yarn
|
|
Requires: yarn
|
|
|
|
%description
|
|
An all-round MQTT client that provides a structured topic overview.
|
|
|
|
%debug_package
|
|
|
|
%define _build_id_links none
|
|
%global __requires_exclude_from ^%{_datadir}/mqtt-explorer/.*$
|
|
%global __provides_exclude_from ^%{_datadir}/mqtt-explorer/.*$
|
|
|
|
%prep
|
|
%setup -q -n MQTT-Explorer-%{version}
|
|
|
|
%build
|
|
export NODE_OPTIONS="--openssl-legacy-provider"
|
|
yarn || sed -i 's/node-gyp rebuild/node-gyp rebuild --openssl_fips=X/' app/package.json
|
|
yarn build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
install -d -m0755 %{buildroot}%{_datadir}/mqtt-explorer
|
|
cp -r * %{buildroot}%{_datadir}/mqtt-explorer/
|
|
|
|
install -D -m0644 %{SOURCE1} %{buildroot}%{_datadir}/applications/mqtt-explorer.desktop
|
|
|
|
install -d -m0755 %{buildroot}%{_bindir}
|
|
cat > %{buildroot}%{_datadir}/mqtt-explorer/mqtt-explorer << _EOF
|
|
#!/bin/bash
|
|
yarn --cwd %{_datadir}/mqtt-explorer start
|
|
_EOF
|
|
|
|
chmod +x %{buildroot}%{_datadir}/mqtt-explorer/mqtt-explorer
|
|
ln -s ../share/mqtt-explorer/mqtt-explorer %{buildroot}%{_bindir}/mqtt-explorer
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_bindir}/mqtt-explorer
|
|
%{_datadir}/applications/mqtt-explorer.desktop
|
|
%dir %{_datadir}/mqtt-explorer
|
|
%{_datadir}/mqtt-explorer/*
|
|
|
|
%changelog
|
|
* Sun Sep 11 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.5-2mamba
|
|
- exclude provides and don't add build_id_links
|
|
|
|
* Wed Jul 07 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.5-1mamba
|
|
- package created using the webbuild interface
|