update to 1.5+20240812svn.38542
removed build requirement for libglib1, other specfile fixes [release 1.5+20240812svn.38542-1mamba;Sat Nov 16 2024]
This commit is contained in:
parent
593d9b74e4
commit
4fd8959a60
@ -1,14 +0,0 @@
|
|||||||
diff -Naupr MPlayer-0.90pre9.orig/mplayer.c MPlayer-0.90pre9/mplayer.c
|
|
||||||
--- MPlayer-0.90pre9.orig/mplayer.c Thu Oct 24 00:07:11 2002
|
|
||||||
+++ MPlayer-0.90pre9/mplayer.c Fri Oct 25 17:32:50 2002
|
|
||||||
@@ -539,9 +539,7 @@ int gui_no_filename=0;
|
|
||||||
gCpuCaps.hasMMX,gCpuCaps.hasMMX2,
|
|
||||||
gCpuCaps.has3DNow, gCpuCaps.has3DNowExt,
|
|
||||||
gCpuCaps.hasSSE, gCpuCaps.hasSSE2);
|
|
||||||
-#ifdef RUNTIME_CPUDETECT
|
|
||||||
- mp_msg(MSGT_CPLAYER,MSGL_INFO, MSGTR_CompiledWithRuntimeDetection);
|
|
||||||
-#else
|
|
||||||
+#ifndef RUNTIME_CPUDETECT
|
|
||||||
mp_msg(MSGT_CPLAYER,MSGL_INFO, MSGTR_CompiledWithCPUExtensions);
|
|
||||||
#ifdef HAVE_MMX
|
|
||||||
mp_msg(MSGT_CPLAYER,MSGL_INFO," MMX");
|
|
@ -1,56 +0,0 @@
|
|||||||
diff -ru MPlayer-1.0rc1/libmpcodecs/native/minilzo.c MPlayer-1.0rc1-fix/libmpcodecs/native/minilzo.c
|
|
||||||
--- MPlayer-1.0rc1/libmpcodecs/native/minilzo.c 2006-10-23 00:32:24.000000000 +0200
|
|
||||||
+++ MPlayer-1.0rc1-fix/libmpcodecs/native/minilzo.c 2007-01-22 10:29:26.000000000 +0100
|
|
||||||
@@ -61,7 +61,7 @@
|
|
||||||
|
|
||||||
#if !defined(__LZO_IN_MINILZO)
|
|
||||||
# ifndef __LZOCONF_H
|
|
||||||
-# include <lzoconf.h>
|
|
||||||
+# include <lzo/lzoconf.h>
|
|
||||||
# endif
|
|
||||||
#endif
|
|
||||||
|
|
||||||
@@ -1307,7 +1307,7 @@
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#if !defined(__LZO_IN_MINILZO)
|
|
||||||
-#include <lzo1x.h>
|
|
||||||
+#include <lzo/lzo1x.h>
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#define LZO_EOF_CODE
|
|
||||||
diff -ru MPlayer-1.0rc1/libmpcodecs/vd_lzo.c MPlayer-1.0rc1-fix/libmpcodecs/vd_lzo.c
|
|
||||||
--- MPlayer-1.0rc1/libmpcodecs/vd_lzo.c 2006-10-23 00:32:24.000000000 +0200
|
|
||||||
+++ MPlayer-1.0rc1-fix/libmpcodecs/vd_lzo.c 2007-01-22 10:30:12.000000000 +0100
|
|
||||||
@@ -7,7 +7,7 @@
|
|
||||||
#include "vd_internal.h"
|
|
||||||
|
|
||||||
#ifdef USE_LIBLZO
|
|
||||||
-#include <lzo1x.h>
|
|
||||||
+#include <lzo/lzo1x.h>
|
|
||||||
#else
|
|
||||||
#include "native/minilzo.h"
|
|
||||||
#define lzo_malloc malloc
|
|
||||||
diff -ru MPlayer-1.0rc1/libmpdemux/demux_mkv.c MPlayer-1.0rc1-fix/libmpdemux/demux_mkv.c
|
|
||||||
--- MPlayer-1.0rc1/libmpdemux/demux_mkv.c 2006-10-23 00:32:31.000000000 +0200
|
|
||||||
+++ MPlayer-1.0rc1-fix/libmpdemux/demux_mkv.c 2007-01-22 10:25:19.000000000 +0100
|
|
||||||
@@ -35,7 +35,7 @@
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#ifdef USE_LIBLZO
|
|
||||||
-#include <lzo1x.h>
|
|
||||||
+#include <lzo/lzo1x.h>
|
|
||||||
#else
|
|
||||||
#include "libmpcodecs/native/minilzo.h"
|
|
||||||
#endif
|
|
||||||
--- MPlayer-1.0rc1/configure.orig 2007-01-22 11:03:32.000000000 +0100
|
|
||||||
+++ MPlayer-1.0rc1/configure 2007-01-22 11:04:10.000000000 +0100
|
|
||||||
@@ -5569,7 +5569,7 @@
|
|
||||||
fi
|
|
||||||
if test "$_liblzo" = yes ; then
|
|
||||||
_def_liblzo='#define USE_LIBLZO 1'
|
|
||||||
- _ld_liblzo='-llzo'
|
|
||||||
+ _ld_liblzo='-llzo2'
|
|
||||||
_codecmodules="liblzo $_codecmodules"
|
|
||||||
else
|
|
||||||
_def_liblzo='#undef USE_LIBLZO'
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -Nru MPlayer-1.0rc2.orig/playtreeparser.c MPlayer-1.0rc2/playtreeparser.c
|
|
||||||
--- MPlayer-1.0rc2.orig/playtreeparser.c 2009-04-17 02:33:53.000000000 +0200
|
|
||||||
+++ MPlayer-1.0rc2/playtreeparser.c 2009-04-17 02:34:38.000000000 +0200
|
|
||||||
@@ -228,7 +228,7 @@
|
|
||||||
}
|
|
||||||
|
|
||||||
num = atoi(line);
|
|
||||||
- if(num < 0) {
|
|
||||||
+ if(num <= 0) {
|
|
||||||
num = max_entry+1;
|
|
||||||
mp_msg(MSGT_PLAYTREE,MSGL_WARN,"No entry index in entry %s\nAssuming %d\n",line,num);
|
|
||||||
}
|
|
@ -1,38 +0,0 @@
|
|||||||
--- mplayer-svn/libvo/vo_ivtv.c 2007-12-03 00:06:22.036407830 +0100
|
|
||||||
+++ mplayer-current/libvo/vo_ivtv.c 2008-01-08 23:40:30.744386376 +0100
|
|
||||||
@@ -38,6 +38,7 @@
|
|
||||||
#include <linux/videodev2.h>
|
|
||||||
#include <linux/ivtv.h>
|
|
||||||
#include <linux/ioctl.h>
|
|
||||||
+#include <linux/dvb/video.h>
|
|
||||||
|
|
||||||
#include "mp_msg.h"
|
|
||||||
#include "subopt-helper.h"
|
|
||||||
@@ -76,25 +77,14 @@
|
|
||||||
static uint32_t
|
|
||||||
ivtv_reset (int blank_screen)
|
|
||||||
{
|
|
||||||
- struct ivtv_cfg_stop_decode sd;
|
|
||||||
- struct ivtv_cfg_start_decode sd1;
|
|
||||||
- int flags = 0;
|
|
||||||
-
|
|
||||||
- if (blank_screen)
|
|
||||||
- flags |= IVTV_STOP_FL_HIDE_FRAME;
|
|
||||||
- sd.flags = flags;
|
|
||||||
-
|
|
||||||
- if (ioctl (ivtv_fd, IVTV_IOC_STOP_DECODE, &sd) < 0)
|
|
||||||
+ if (ioctl (ivtv_fd, VIDEO_STOP, 0) < 0)
|
|
||||||
{
|
|
||||||
mp_msg (MSGT_VO, MSGL_ERR,
|
|
||||||
"IVTV_IOC_STOP_DECODE: %s\n", strerror (errno));
|
|
||||||
return 1;
|
|
||||||
}
|
|
||||||
|
|
||||||
- sd1.gop_offset = 0;
|
|
||||||
- sd1.muted_audio_frames = 0;
|
|
||||||
-
|
|
||||||
- if (ioctl (ivtv_fd, IVTV_IOC_START_DECODE, &sd1) < 0)
|
|
||||||
+ if (ioctl (ivtv_fd, VIDEO_PLAY, 0) < 0)
|
|
||||||
{
|
|
||||||
mp_msg (MSGT_VO, MSGL_ERR,
|
|
||||||
"IVTV_IOC_START_DECODE: %s\n", strerror (errno));
|
|
@ -1,24 +0,0 @@
|
|||||||
diff -Nru mplayer-export-2009-07-12.orig/libavcodec/libx264.c mplayer-export-2009-07-12/libavcodec/libx264.c
|
|
||||||
--- mplayer-export-2009-07-12.orig/libavcodec/libx264.c 2009-07-01 01:45:01.000000000 +0200
|
|
||||||
+++ mplayer-export-2009-07-12/libavcodec/libx264.c 2009-12-07 22:46:18.000000000 +0100
|
|
||||||
@@ -187,7 +187,7 @@
|
|
||||||
x4->params.b_cabac = avctx->coder_type == FF_CODER_TYPE_AC;
|
|
||||||
x4->params.i_bframe_adaptive = avctx->b_frame_strategy;
|
|
||||||
x4->params.i_bframe_bias = avctx->bframebias;
|
|
||||||
- x4->params.b_bframe_pyramid = avctx->flags2 & CODEC_FLAG2_BPYRAMID;
|
|
||||||
+ x4->params.i_bframe_pyramid = avctx->flags2 & CODEC_FLAG2_BPYRAMID ? X264_B_PYRAMID_NORMAL : X264_B_PYRAMID_NONE;
|
|
||||||
avctx->has_b_frames= avctx->flags2 & CODEC_FLAG2_BPYRAMID ? 2 : !!avctx->max_b_frames;
|
|
||||||
|
|
||||||
x4->params.i_keyint_min = avctx->keyint_min;
|
|
||||||
diff -Nru mplayer-export-2009-07-12.orig/libmpcodecs/ve_x264.c mplayer-export-2009-07-12/libmpcodecs/ve_x264.c
|
|
||||||
--- mplayer-export-2009-07-12.orig/libmpcodecs/ve_x264.c 2009-05-13 04:58:57.000000000 +0200
|
|
||||||
+++ mplayer-export-2009-07-12/libmpcodecs/ve_x264.c 2009-12-07 23:01:05.000000000 +0100
|
|
||||||
@@ -207,7 +207,7 @@
|
|
||||||
mod->mux->bih->biSize= sizeof(BITMAPINFOHEADER) + extradata_size;
|
|
||||||
}
|
|
||||||
|
|
||||||
- if (param.i_bframe > 1 && param.b_bframe_pyramid)
|
|
||||||
+ if (param.i_bframe > 1 && param.i_bframe_pyramid)
|
|
||||||
mod->mux->decoder_delay = 2;
|
|
||||||
else
|
|
||||||
mod->mux->decoder_delay = param.i_bframe ? 1 : 0;
|
|
95
mplayer-1.5+20240812svn.38542-ffmpeg-7.patch
Normal file
95
mplayer-1.5+20240812svn.38542-ffmpeg-7.patch
Normal file
@ -0,0 +1,95 @@
|
|||||||
|
Index: libao2/ao_jack.c
|
||||||
|
===================================================================
|
||||||
|
--- libao2/ao_jack.c (revisión: 38542)
|
||||||
|
+++ libao2/ao_jack.c (copia de trabajo)
|
||||||
|
@@ -71,7 +71,7 @@
|
||||||
|
#define BUFFSIZE (NUM_CHUNKS * CHUNK_SIZE)
|
||||||
|
|
||||||
|
//! buffer for audio data
|
||||||
|
-static AVFifoBuffer *buffer;
|
||||||
|
+static AVFifo *buffer;
|
||||||
|
|
||||||
|
/**
|
||||||
|
* \brief insert len bytes into buffer
|
||||||
|
@@ -82,9 +82,10 @@
|
||||||
|
* If there is not enough room, the buffer is filled up
|
||||||
|
*/
|
||||||
|
static int write_buffer(unsigned char* data, int len) {
|
||||||
|
- int free = av_fifo_space(buffer);
|
||||||
|
+ int free = av_fifo_can_write(buffer);
|
||||||
|
if (len > free) len = free;
|
||||||
|
- return av_fifo_generic_write(buffer, data, len, NULL);
|
||||||
|
+ av_fifo_write(buffer, data, len);
|
||||||
|
+ return len;
|
||||||
|
}
|
||||||
|
|
||||||
|
static void silence(float **bufs, int cnt, int num_bufs);
|
||||||
|
@@ -125,12 +126,12 @@
|
||||||
|
*/
|
||||||
|
static int read_buffer(float **bufs, int cnt, int num_bufs) {
|
||||||
|
struct deinterleave di = {bufs, num_bufs, 0, 0};
|
||||||
|
- int buffered = av_fifo_size(buffer);
|
||||||
|
+ int buffered = av_fifo_can_read(buffer);
|
||||||
|
if (cnt * sizeof(float) * num_bufs > buffered) {
|
||||||
|
silence(bufs, cnt, num_bufs);
|
||||||
|
cnt = buffered / sizeof(float) / num_bufs;
|
||||||
|
}
|
||||||
|
- av_fifo_generic_read(buffer, &di, cnt * num_bufs * sizeof(float), deinterleave);
|
||||||
|
+ av_fifo_read(buffer, &di, cnt * num_bufs * sizeof(float));
|
||||||
|
return cnt;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -242,7 +243,7 @@
|
||||||
|
mp_msg(MSGT_AO, MSGL_FATAL, "[JACK] cannot open server\n");
|
||||||
|
goto err_out;
|
||||||
|
}
|
||||||
|
- buffer = av_fifo_alloc(BUFFSIZE);
|
||||||
|
+ buffer = av_fifo_alloc2(BUFFSIZE, 1, 0);
|
||||||
|
jack_set_process_callback(client, outputaudio, 0);
|
||||||
|
|
||||||
|
// list matching ports if connections should be made
|
||||||
|
@@ -302,7 +303,7 @@
|
||||||
|
free(client_name);
|
||||||
|
if (client)
|
||||||
|
jack_client_close(client);
|
||||||
|
- av_fifo_free(buffer);
|
||||||
|
+ av_fifo_freep2(&buffer);
|
||||||
|
buffer = NULL;
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
@@ -315,7 +316,7 @@
|
||||||
|
reset();
|
||||||
|
usec_sleep(100 * 1000);
|
||||||
|
jack_client_close(client);
|
||||||
|
- av_fifo_free(buffer);
|
||||||
|
+ av_fifo_freep2(&buffer);
|
||||||
|
buffer = NULL;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -324,7 +325,7 @@
|
||||||
|
*/
|
||||||
|
static void reset(void) {
|
||||||
|
paused = 1;
|
||||||
|
- av_fifo_reset(buffer);
|
||||||
|
+ av_fifo_reset2(buffer);
|
||||||
|
paused = 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -343,7 +344,7 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
static int get_space(void) {
|
||||||
|
- return av_fifo_space(buffer);
|
||||||
|
+ return av_fifo_can_write(buffer);
|
||||||
|
}
|
||||||
|
|
||||||
|
/**
|
||||||
|
@@ -357,7 +358,7 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
static float get_delay(void) {
|
||||||
|
- int buffered = av_fifo_size(buffer); // could be less
|
||||||
|
+ int buffered = av_fifo_can_read(buffer); // could be less
|
||||||
|
float in_jack = jack_latency;
|
||||||
|
if (estimate && callback_interval > 0) {
|
||||||
|
float elapsed = (float)GetTimer() / 1000000.0 - callback_time;
|
12
mplayer-autoupdate
Normal file
12
mplayer-autoupdate
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
#!/bin/bash
|
||||||
|
version=$1
|
||||||
|
[ "${version}" ] || exit 1
|
||||||
|
revision=`echo $version | cut -d+ -f2 | cut -d. -f2`
|
||||||
|
[ "${revision}" ] || exit 1
|
||||||
|
svn co svn://svn.mplayerhq.hu/mplayer/trunk MPlayer-${version}
|
||||||
|
cd MPlayer-${version}
|
||||||
|
svn update -r ${revision}
|
||||||
|
rm -rf .svn
|
||||||
|
cd ..
|
||||||
|
tar cJf MPlayer-${version}.tar.xz MPlayer-${version}
|
||||||
|
rm -rf MPlayer-${version}
|
140
mplayer.spec
140
mplayer.spec
@ -4,11 +4,10 @@
|
|||||||
|
|
||||||
%define with_gui 1
|
%define with_gui 1
|
||||||
%define with_mencoder 1
|
%define with_mencoder 1
|
||||||
%define with_plf 1
|
|
||||||
|
|
||||||
Name: mplayer
|
Name: mplayer
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 1.5
|
Version: 1.5+20240812svn.38542
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: MPlayer, the Movie Player for Linux
|
Summary: MPlayer, the Movie Player for Linux
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
@ -19,12 +18,9 @@ URL: http://mplayerhq.hu/
|
|||||||
Source0: http://www2.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
|
Source0: http://www2.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
|
||||||
Source1: http://www.mplayerhq.hu/MPlayer/skins/Blue-%{skin_blue_ver}.tar.bz2
|
Source1: http://www.mplayerhq.hu/MPlayer/skins/Blue-%{skin_blue_ver}.tar.bz2
|
||||||
Source2: mplayer.desktop
|
Source2: mplayer.desktop
|
||||||
Patch0: %{name}-0.90pre9-runtimemsg.patch
|
Source3: mplayer-autoupdate
|
||||||
Patch1: %{name}-1.0rc2-playlist.patch
|
Patch0: mplayer-1.4-missing-time-h.patch
|
||||||
Patch5: %{name}-1.0rc1-liblzo.patch
|
Patch1: mplayer-1.5+20240812svn.38542-ffmpeg-7.patch
|
||||||
Patch6: %{name}-1.0rc2-vo_ivtv.patch
|
|
||||||
Patch7: %{name}-1.0rc2.svn2009_07_12-x264.patch
|
|
||||||
Patch8: mplayer-1.4-missing-time-h.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: enca-devel
|
BuildRequires: enca-devel
|
||||||
@ -111,19 +107,13 @@ BuildRequires: perl-devel
|
|||||||
%if "%{stage1}" != "1"
|
%if "%{stage1}" != "1"
|
||||||
BuildRequires: libbio2jack-devel
|
BuildRequires: libbio2jack-devel
|
||||||
%endif
|
%endif
|
||||||
#BuildRequires: libdvdread-devel
|
|
||||||
BuildRequires: libvorbis-devel
|
BuildRequires: libvorbis-devel
|
||||||
BuildRequires: libmatroska-devel
|
BuildRequires: libmatroska-devel
|
||||||
BuildRequires: libao-devel
|
BuildRequires: libao-devel
|
||||||
%if %with_plf
|
|
||||||
BuildRequires: liblame-devel
|
BuildRequires: liblame-devel
|
||||||
BuildRequires: libfaad2-devel
|
BuildRequires: libfaad2-devel
|
||||||
#BuildRequires: libdvdcss-devel
|
#BuildRequires: libdvdcss-devel
|
||||||
%endif
|
|
||||||
BuildRequires: ladspa-devel
|
BuildRequires: ladspa-devel
|
||||||
#BuildRequires: libmad-devel
|
|
||||||
#BuildRequires: libflac-devel
|
|
||||||
#BuildRequires: libdvdnav-devel
|
|
||||||
#Requires: mplayer-fonts
|
#Requires: mplayer-fonts
|
||||||
%if %with_mencoder
|
%if %with_mencoder
|
||||||
Requires: mencoder = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: mencoder = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
@ -149,21 +139,12 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
|
|
||||||
%description -n mencoder
|
%description -n mencoder
|
||||||
MEncoder a movie encoder and is a part of the MPlayer package.
|
MEncoder a movie encoder and is a part of the MPlayer package.
|
||||||
%if ! %with_plf
|
|
||||||
Note: this version doesn't have support for encoding mp3 audio streams in the video files.
|
|
||||||
%else
|
|
||||||
This PLF build has additional support for AAC decoding with libfaad and MP3 encoding with lame, both are covered by software patents.
|
|
||||||
It also includes support for reading DVDs encrypted with CSS which might be illegal in some countries.
|
|
||||||
%endif
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %with_gui
|
%if %with_gui
|
||||||
%package gui
|
%package gui
|
||||||
Summary: GUI for MPlayer
|
Summary: GUI for MPlayer
|
||||||
Group: Graphical Desktop/Applications/Multimedia
|
Group: Graphical Desktop/Applications/Multimedia
|
||||||
BuildRequires: libgtk-devel >= 2.6.7
|
|
||||||
BuildRequires: libglib1-devel >= 1.2.10
|
|
||||||
BuildRequires: ImageMagick
|
|
||||||
Provides: MPlayer-gui
|
Provides: MPlayer-gui
|
||||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
@ -178,17 +159,13 @@ This package contains a GUI for MPlayer.
|
|||||||
%setup -q -n MPlayer-%{version}
|
%setup -q -n MPlayer-%{version}
|
||||||
#-D -T
|
#-D -T
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
%patch8 -p1
|
%patch 0 -p1
|
||||||
|
%patch 1 -p0 -b .ffmpeg-7
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
find . -name "CVS" | xargs rm -rf
|
|
||||||
|
|
||||||
%if %with_plf
|
export CFLAGS="%{optflags} -Wno-incompatible-pointer-types -Wno-implicit-function-declaration -Wno-int-conversion"
|
||||||
%define realpath %{_libdir}/RealPlayer9/Codecs
|
|
||||||
%else
|
|
||||||
%define realpath %{_libdir}/win32
|
|
||||||
%endif
|
|
||||||
|
|
||||||
# not a standard configure script
|
# not a standard configure script
|
||||||
CC=%{_host}-gcc CPP=%{_host}-cpp \
|
CC=%{_host}-gcc CPP=%{_host}-cpp \
|
||||||
@ -197,6 +174,7 @@ CC=%{_host}-gcc CPP=%{_host}-cpp \
|
|||||||
--datadir=%{_datadir}/%{name} \
|
--datadir=%{_datadir}/%{name} \
|
||||||
--confdir=%{_sysconfdir}/%{name} \
|
--confdir=%{_sysconfdir}/%{name} \
|
||||||
--mandir=%{_mandir} \
|
--mandir=%{_mandir} \
|
||||||
|
--enable-runtime-cpudetection \
|
||||||
%ifarch %{ix86} x86_64
|
%ifarch %{ix86} x86_64
|
||||||
--enable-mmx \
|
--enable-mmx \
|
||||||
--enable-mmxext \
|
--enable-mmxext \
|
||||||
@ -204,9 +182,6 @@ CC=%{_host}-gcc CPP=%{_host}-cpp \
|
|||||||
--enable-sse \
|
--enable-sse \
|
||||||
--enable-sse2 \
|
--enable-sse2 \
|
||||||
--enable-fastmemcpy \
|
--enable-fastmemcpy \
|
||||||
%endif
|
|
||||||
%ifarch %{ix86} x86_64 ppc
|
|
||||||
--enable-runtime-cpudetection \
|
|
||||||
%endif
|
%endif
|
||||||
--enable-dynamic-plugins \
|
--enable-dynamic-plugins \
|
||||||
--enable-freetype \
|
--enable-freetype \
|
||||||
@ -221,40 +196,24 @@ CC=%{_host}-gcc CPP=%{_host}-cpp \
|
|||||||
%else
|
%else
|
||||||
--disable-mencoder \
|
--disable-mencoder \
|
||||||
%endif
|
%endif
|
||||||
|
--disable-arts \
|
||||||
|
--disable-ffmpeg_a \
|
||||||
--enable-theora \
|
--enable-theora \
|
||||||
--enable-menu \
|
--enable-menu \
|
||||||
--enable-radio \
|
--enable-radio \
|
||||||
--enable-radio-capture \
|
--enable-radio-capture \
|
||||||
%if "%{stage1}" != "1"
|
|
||||||
--enable-jack \
|
--enable-jack \
|
||||||
%endif
|
|
||||||
--enable-smb \
|
--enable-smb \
|
||||||
--disable-arts \
|
|
||||||
--enable-fribidi \
|
--enable-fribidi \
|
||||||
--enable-liblzo \
|
--enable-liblzo \
|
||||||
--enable-libvorbis \
|
--enable-libvorbis \
|
||||||
--enable-xshape \
|
--enable-xshape \
|
||||||
--codecsdir=%{_libdir}/win32 \
|
--codecsdir=%{_libdir}/win32 \
|
||||||
%if ! %with_plf
|
|
||||||
--disable-internal-faad \
|
|
||||||
--disable-mpdvdkit \
|
|
||||||
%endif
|
|
||||||
--enable-x11 \
|
--enable-x11 \
|
||||||
--extra-cflags="`pkg-config --cflags smbclient`" \
|
--extra-cflags="`pkg-config --cflags smbclient`" \
|
||||||
--extra-ldflags="\
|
--extra-ldflags="-ljack -lfribidi -ldca -lX11 -lXext"
|
||||||
%if "%{stage1}" != "1"
|
|
||||||
-ljack \
|
|
||||||
%endif
|
|
||||||
-lfribidi -ldca -lX11 -lXext"
|
|
||||||
|
|
||||||
# --enable-xmms \
|
|
||||||
# --realcodecsdir=%{realpath} \
|
|
||||||
# --disable-libavformat_a \
|
|
||||||
# --disable-libavutil_a \
|
|
||||||
# --with-extralibdir="%{_libdir}/samba" \
|
|
||||||
# -ljack: workaround to link against jack library
|
|
||||||
make
|
make
|
||||||
#make -C vidix
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
@ -270,36 +229,16 @@ install -m 644 etc/codecs.conf %{buildroot}%{_sysconfdir}/%{name}
|
|||||||
install -m 644 etc/input.conf %{buildroot}%{_sysconfdir}/%{name}
|
install -m 644 etc/input.conf %{buildroot}%{_sysconfdir}/%{name}
|
||||||
install -m 644 etc/menu.conf %{buildroot}%{_sysconfdir}/%{name}
|
install -m 644 etc/menu.conf %{buildroot}%{_sysconfdir}/%{name}
|
||||||
|
|
||||||
|
%find_lang %{name} --with-man
|
||||||
|
|
||||||
%if %with_mencoder
|
%if %with_mencoder
|
||||||
install -m 755 TOOLS/{divx2svcd.sh,mencvcd.sh,midentify.sh,wma2ogg.pl} \
|
install -m 755 TOOLS/{divx2svcd.sh,mencvcd.sh,midentify.sh,wma2ogg.pl} \
|
||||||
%{buildroot}%{_bindir}
|
%{buildroot}%{_bindir}
|
||||||
|
%find_lang mencoder --with-man
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%find_lang %{name}
|
|
||||||
|
|
||||||
%if %with_gui
|
%if %with_gui
|
||||||
#install -d %{buildroot}%{_datadir}/pixmaps
|
%find_lang gmplayer --with-man
|
||||||
## install icons
|
|
||||||
#install -D -m644 gui/mplayer/pixmaps/mplayer-desktop.xpm \
|
|
||||||
# %{buildroot}%{_datadir}/mplayer/mplayer-desktop.xpm
|
|
||||||
#install -D -m644 etc/mplayer.xpm \
|
|
||||||
# %{buildroot}%{_datadir}/pixmaps/mplayer.xpm
|
|
||||||
|
|
||||||
## FIXME : use a better location for icons
|
|
||||||
#install -d %{buildroot}%{_datadir}/icons/{16x16,32x32,48x48}
|
|
||||||
#( cd %{buildroot}%{_datadir}/mplayer/Skin/Blue/icons/
|
|
||||||
# convert -transparent white icon48x48.png \
|
|
||||||
# %{buildroot}%{_datadir}/icons/48x48/gmplayer.png
|
|
||||||
# convert -transparent white icon32x32.png \
|
|
||||||
# %{buildroot}%{_datadir}/icons/32x32/gmplayer.png
|
|
||||||
# convert -transparent white -scale 16x16 icon48x48.png \
|
|
||||||
# %{buildroot}%{_datadir}/icons/16x16/gmplayer.png )
|
|
||||||
|
|
||||||
#rm -f %{buildroot}%{_datadir}/applications/mplayer.desktop
|
|
||||||
#
|
|
||||||
## add system menu entry for KDE
|
|
||||||
#install -D -m644 %{S:2} \
|
|
||||||
# %{buildroot}%{_datadir}/applications/%{name}.desktop
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %with_gui
|
%if %with_gui
|
||||||
@ -310,58 +249,34 @@ fi
|
|||||||
exit 0
|
exit 0
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%post -p /sbin/ldconfig
|
|
||||||
%postun -p /sbin/ldconfig
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-, root, root)
|
%defattr(-, root, root)
|
||||||
%{_bindir}/midentify.sh
|
|
||||||
%{_bindir}/mplayer
|
|
||||||
%dir %{_datadir}/mplayer
|
|
||||||
#%dir %{_libdir}/mplayer
|
|
||||||
#%dir %{_libdir}/mplayer/vidix
|
|
||||||
#%{_libdir}/mplayer/vidix/*so
|
|
||||||
%dir %{_sysconfdir}/mplayer
|
%dir %{_sysconfdir}/mplayer
|
||||||
%config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
|
%config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
|
||||||
%config(noreplace) %{_sysconfdir}/mplayer/input.conf
|
%config(noreplace) %{_sysconfdir}/mplayer/input.conf
|
||||||
%config(noreplace) %{_sysconfdir}/mplayer/menu.conf
|
%config(noreplace) %{_sysconfdir}/mplayer/menu.conf
|
||||||
%config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
|
%config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
|
||||||
|
%{_bindir}/midentify.sh
|
||||||
|
%{_bindir}/mplayer
|
||||||
|
%dir %{_datadir}/mplayer
|
||||||
%{_mandir}/man1/mplayer.1*
|
%{_mandir}/man1/mplayer.1*
|
||||||
%lang(cs) %{_mandir}/cs/man1/mplayer.1*
|
#% doc README DOCS/default.css DOCS/tech/
|
||||||
%lang(de) %{_mandir}/de/man1/mplayer.1*
|
|
||||||
%lang(es) %{_mandir}/es/man1/mplayer.1*
|
|
||||||
%lang(fr) %{_mandir}/fr/man1/mplayer.1*
|
|
||||||
%lang(hu) %{_mandir}/hu/man1/mplayer.1*
|
|
||||||
%lang(it) %{_mandir}/it/man1/mplayer.1*
|
|
||||||
%lang(pl) %{_mandir}/pl/man1/mplayer.1*
|
|
||||||
%lang(sv) %{_mandir}/ru/man1/mplayer.1*
|
|
||||||
%lang(zh_CN) %{_mandir}/zh_CN/man1/mplayer.1*
|
|
||||||
%doc README DOCS/default.css DOCS/tech/
|
|
||||||
|
|
||||||
%if %with_mencoder
|
%if %with_mencoder
|
||||||
%files -n mencoder
|
%files -n mencoder -f mencoder.lang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/divx2svcd.sh
|
%{_bindir}/divx2svcd.sh
|
||||||
%{_bindir}/mencoder
|
%{_bindir}/mencoder
|
||||||
%{_bindir}/mencvcd.sh
|
%{_bindir}/mencvcd.sh
|
||||||
%{_bindir}/wma2ogg.pl
|
%{_bindir}/wma2ogg.pl
|
||||||
%{_mandir}/man1/mencoder.*
|
%{_mandir}/man1/mencoder.*
|
||||||
%lang(cs) %{_mandir}/cs/man1/mencoder.1*
|
|
||||||
%lang(de) %{_mandir}/de/man1/mencoder.1*
|
|
||||||
%lang(es) %{_mandir}/es/man1/mencoder.1*
|
|
||||||
%lang(fr) %{_mandir}/fr/man1/mencoder.1*
|
|
||||||
%lang(hu) %{_mandir}/hu/man1/mencoder.1*
|
|
||||||
%lang(it) %{_mandir}/it/man1/mencoder.1*
|
|
||||||
%lang(pl) %{_mandir}/pl/man1/mencoder.1*
|
|
||||||
%lang(ru) %{_mandir}/ru/man1/mencoder.1*
|
|
||||||
%lang(zh_CN) %{_mandir}/zh_CN/man1/mencoder.1*
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %with_gui
|
%if %with_gui
|
||||||
%files gui
|
%files gui -f gmplayer.lang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/gmplayer
|
%{_bindir}/gmplayer
|
||||||
%{_datadir}/applications/%{name}.desktop
|
%{_datadir}/applications/%{name}.desktop
|
||||||
@ -369,18 +284,13 @@ exit 0
|
|||||||
%{_datadir}/mplayer/Skin/default
|
%{_datadir}/mplayer/Skin/default
|
||||||
%{_datadir}/mplayer/Skin/Blue/*
|
%{_datadir}/mplayer/Skin/Blue/*
|
||||||
%{_mandir}/man1/gmplayer.1*
|
%{_mandir}/man1/gmplayer.1*
|
||||||
%lang(cs) %{_mandir}/cs/man1/gmplayer.1*
|
|
||||||
%lang(de) %{_mandir}/de/man1/gmplayer.1*
|
|
||||||
%lang(es) %{_mandir}/es/man1/gmplayer.1*
|
|
||||||
%lang(fr) %{_mandir}/fr/man1/gmplayer.1*
|
|
||||||
%lang(hu) %{_mandir}/hu/man1/gmplayer.1*
|
|
||||||
%lang(it) %{_mandir}/it/man1/gmplayer.1*
|
|
||||||
%lang(pl) %{_mandir}/pl/man1/gmplayer.1*
|
|
||||||
%lang(ru) %{_mandir}/ru/man1/gmplayer.1*
|
|
||||||
%lang(zh_CN) %{_mandir}/zh_CN/man1/gmplayer.1*
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Nov 16 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5+20240812svn.38542-1mamba
|
||||||
|
- update to 1.5+20240812svn.38542
|
||||||
|
- removed build requirement for libglib1, other specfile fixes
|
||||||
|
|
||||||
* Fri Mar 04 2022 Automatic Build System <autodist@mambasoft.it> 1.5-1mamba
|
* Fri Mar 04 2022 Automatic Build System <autodist@mambasoft.it> 1.5-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user