update to 4.1.3 [release 4.1.3-1mamba;Tue Dec 01 2020]
This commit is contained in:
parent
866b02cc29
commit
55b6d025eb
11
mp4v2-4.1.3-gcc-10.0.patch
Normal file
11
mp4v2-4.1.3-gcc-10.0.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/rtphint.cpp 2012-05-20 16:11:53.000000000 -0600
|
||||
+++ src/rtphint.cpp 2017-05-16 10:25:26.930705191 -0600
|
||||
@@ -339,7 +339,7 @@
|
||||
pSlash = strchr(pSlash, '/');
|
||||
if (pSlash != NULL) {
|
||||
pSlash++;
|
||||
- if (pSlash != '\0') {
|
||||
+ if (*pSlash != '\0') {
|
||||
length = (uint32_t)strlen(pRtpMap) - (pSlash - pRtpMap);
|
||||
*ppEncodingParams = (char *)MP4Calloc(length + 1);
|
||||
strncpy(*ppEncodingParams, pSlash, length);
|
68
mp4v2-4.1.3-narrowing-cast.patch
Normal file
68
mp4v2-4.1.3-narrowing-cast.patch
Normal file
@ -0,0 +1,68 @@
|
||||
Bug: https://bugs.gentoo.org/723098
|
||||
|
||||
--- a/libutil/Utility.cpp
|
||||
+++ b/libutil/Utility.cpp
|
||||
@@ -493,7 +493,7 @@
|
||||
if( codes.find( code ) == codes.end() )
|
||||
continue;
|
||||
|
||||
- switch( code ) {
|
||||
+ switch( static_cast<unsigned>(code) ) {
|
||||
case 'z':
|
||||
_optimize = true;
|
||||
break;
|
||||
--- a/util/mp4art.cpp
|
||||
+++ b/util/mp4art.cpp
|
||||
@@ -376,7 +376,7 @@
|
||||
{
|
||||
handled = true;
|
||||
|
||||
- switch( code ) {
|
||||
+ switch( static_cast<unsigned>(code) ) {
|
||||
case LC_ART_ANY:
|
||||
_artFilter = numeric_limits<uint32_t>::max();
|
||||
break;
|
||||
--- a/util/mp4chaps.cpp
|
||||
+++ b/util/mp4chaps.cpp
|
||||
@@ -632,7 +632,7 @@
|
||||
{
|
||||
handled = true;
|
||||
|
||||
- switch( code ) {
|
||||
+ switch( static_cast<unsigned>(code) ) {
|
||||
case 'A':
|
||||
case LC_CHPT_ANY:
|
||||
_ChapterType = MP4ChapterTypeAny;
|
||||
--- a/util/mp4file.cpp
|
||||
+++ b/util/mp4file.cpp
|
||||
@@ -189,7 +189,7 @@
|
||||
{
|
||||
handled = true;
|
||||
|
||||
- switch( code ) {
|
||||
+ switch( static_cast<unsigned>(code) ) {
|
||||
case LC_LIST:
|
||||
_action = &FileUtility::actionList;
|
||||
break;
|
||||
--- a/util/mp4subtitle.cpp
|
||||
+++ b/util/mp4subtitle.cpp
|
||||
@@ -164,7 +164,7 @@
|
||||
{
|
||||
handled = true;
|
||||
|
||||
- switch( code ) {
|
||||
+ switch( static_cast<unsigned>(code) ) {
|
||||
case LC_LIST:
|
||||
_action = &SubtitleUtility::actionList;
|
||||
break;
|
||||
--- a/util/mp4track.cpp
|
||||
+++ b/util/mp4track.cpp
|
||||
@@ -788,7 +788,7 @@
|
||||
{
|
||||
handled = true;
|
||||
|
||||
- switch( code ) {
|
||||
+ switch( static_cast<unsigned>(code) ) {
|
||||
case LC_TRACK_WILDCARD:
|
||||
_trackMode = TM_WILDCARD;
|
||||
break;
|
22
mp4v2.spec
22
mp4v2.spec
@ -1,5 +1,5 @@
|
||||
Name: mp4v2
|
||||
Version: 2.0.0
|
||||
Version: 4.1.3
|
||||
Release: 1mamba
|
||||
Summary: A library to create and modify mp4 files as defined by ISO-IEC:14496-1:2001 MPEG-4 Systems
|
||||
Group: Applications/Multimedia
|
||||
@ -7,10 +7,16 @@ Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://code.google.com/p/mp4v2/
|
||||
Source: http://mp4v2.googlecode.com/files/mp4v2-%{version}.tar.bz2
|
||||
Source: https://github.com/TechSmith/mp4v2/archive/Release-ThirdParty-MP4v2-%{version}.tar.gz
|
||||
#Source: http://mp4v2.googlecode.com/files/mp4v2-%{version}.tar.bz2
|
||||
Patch0: mp4v2-4.1.3-gcc-10.0.patch
|
||||
Patch1: mp4v2-4.1.3-narrowing-cast.patch
|
||||
License: MPL 1.1
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
## note: run 'autospec -u -a6 mp4v2' to get the list of build requirements.
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libstdc++6-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
@ -39,10 +45,14 @@ This package contains libraries and header files for developing applications tha
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%setup -q -n mp4v2-Release-ThirdParty-MP4v2-%{version}
|
||||
sed -i "s,| arm-\* |,| aarch64-\* | arm-\* |," autoaux/config.sub
|
||||
%patch0 -p0
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
@ -83,8 +93,10 @@ This package contains libraries and header files for developing applications tha
|
||||
%{_libdir}/libmp4v2.a
|
||||
%{_libdir}/libmp4v2.la
|
||||
%{_libdir}/libmp4v2.so
|
||||
%doc README
|
||||
|
||||
%changelog
|
||||
* Tue Dec 01 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 4.1.3-1mamba
|
||||
- update to 4.1.3
|
||||
|
||||
* Sat Mar 15 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.0-1mamba
|
||||
- package created using the webbuild interface
|
||||
|
Loading…
Reference in New Issue
Block a user