automatic version update by autodist [release 128.6.0-1mamba;Mon Jan 20 2025]
This commit is contained in:
parent
79d9e98417
commit
8c43bc0426
@ -1,77 +0,0 @@
|
||||
From: Takuro Ashie <ashie>
|
||||
Date: Thu, 18 Apr 2019 07:21:00 -0700
|
||||
Subject: Bug 1545437 - Add options to specify Rust target name
|
||||
|
||||
Certain build systems such as Yocto know more suitable Rust target name, so it
|
||||
would be better that there is a way to pass it to Mozilla's build system.
|
||||
|
||||
Bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1545437
|
||||
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=954774
|
||||
Forwarded: https://phabricator.services.mozilla.com/D28069
|
||||
Applied-upstream: no, upstream consider this a workaround and do not support armel
|
||||
---
|
||||
build/moz.configure/rust.configure | 37 +++++++++++++++++++++++++++++++++----
|
||||
1 file changed, 33 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/build/moz.configure/rust.configure b/build/moz.configure/rust.configure
|
||||
index 9647cbc..5aed73f 100644
|
||||
--- a/build/moz.configure/rust.configure
|
||||
+++ b/build/moz.configure/rust.configure
|
||||
@@ -218,6 +218,28 @@ def rust_supported_targets(rustc):
|
||||
return namespace(per_os=per_os, per_raw_os=per_raw_os)
|
||||
|
||||
|
||||
+option(env='RUST_HOST',
|
||||
+ nargs=1,
|
||||
+ help='Define the system type for Rust performing the build')
|
||||
+
|
||||
+@depends('RUST_HOST')
|
||||
+@checking('rust host', lambda host: host)
|
||||
+def rust_host_env(value):
|
||||
+ if value:
|
||||
+ return value[0]
|
||||
+
|
||||
+
|
||||
+option(env='RUST_TARGET',
|
||||
+ nargs=1,
|
||||
+ help='Define the system type for Rust where the resulting executables will be used')
|
||||
+
|
||||
+@depends('RUST_TARGET')
|
||||
+@checking('rust target', lambda target: target)
|
||||
+def rust_target_env(value):
|
||||
+ if value:
|
||||
+ return value[0]
|
||||
+
|
||||
+
|
||||
@template
|
||||
def rust_triple_alias(host_or_target):
|
||||
"""Template defining the alias used for rustc's --target flag.
|
||||
@@ -228,8 +250,9 @@ def rust_triple_alias(host_or_target):
|
||||
|
||||
host_or_target_str = {host: 'host', target: 'target'}[host_or_target]
|
||||
|
||||
- @depends(rustc, host_or_target, c_compiler, rust_supported_targets,
|
||||
- arm_target, when=rust_compiler)
|
||||
+ @depends(rustc, host_or_target, rust_host_env, rust_target_env,
|
||||
+ c_compiler, rust_supported_targets, arm_target,
|
||||
+ when=rust_compiler)
|
||||
@checking('for rust %s triplet' % host_or_target_str)
|
||||
@imports('os')
|
||||
@imports('subprocess')
|
||||
@@ -237,8 +260,14 @@ def rust_triple_alias(host_or_target):
|
||||
@imports(_from='mozbuild.shellutil', _import='quote')
|
||||
@imports(_from='tempfile', _import='mkstemp')
|
||||
@imports(_from='textwrap', _import='dedent')
|
||||
- def rust_target(rustc, host_or_target, compiler_info,
|
||||
- rust_supported_targets, arm_target):
|
||||
+ def rust_target(rustc, host_or_target, rust_host_env, rust_target_env,
|
||||
+ compiler_info, rust_supported_targets, arm_target):
|
||||
+
|
||||
+ specified_targets = {"host": rust_host_env, "target": rust_target_env}
|
||||
+ specified_target = specified_targets[host_or_target_str]
|
||||
+ if (specified_target):
|
||||
+ return specified_target
|
||||
+
|
||||
# Rust's --target options are similar to, but not exactly the same
|
||||
# as, the autoconf-derived targets we use. An example would be that
|
||||
# Rust uses distinct target triples for targetting the GNU C++ ABI
|
@ -1,13 +0,0 @@
|
||||
--- mozjs-68.4.2/js/src/wasm/WasmSignalHandlers.cpp.orig 2020-04-10 10:54:39.434292787 +0200
|
||||
+++ mozjs-68.4.2/js/src/wasm/WasmSignalHandlers.cpp 2020-04-10 10:54:54.684009520 +0200
|
||||
@@ -243,10 +243,6 @@
|
||||
// If you run into compile problems on a tier-3 platform, you can disable the
|
||||
// emulation here.
|
||||
|
||||
-#if defined(__linux__) && defined(__arm__)
|
||||
-# define WASM_EMULATE_ARM_UNALIGNED_FP_ACCESS
|
||||
-#endif
|
||||
-
|
||||
#ifdef WASM_EMULATE_ARM_UNALIGNED_FP_ACCESS
|
||||
# include <sys/user.h>
|
||||
#endif
|
@ -1,10 +0,0 @@
|
||||
--- mozjs-68.4.2/mfbt/FunctionTypeTraits.h.orig 2020-12-01 09:23:27.539907533 +0000
|
||||
+++ mozjs-68.4.2/mfbt/FunctionTypeTraits.h 2020-12-01 09:08:14.179410222 +0000
|
||||
@@ -10,6 +10,7 @@
|
||||
#define mozilla_FunctionTypeTraits_h
|
||||
|
||||
#include <tuple>
|
||||
+#include <cstring>
|
||||
|
||||
namespace mozilla {
|
||||
|
@ -1,66 +0,0 @@
|
||||
From 1af9fdd2124547099eb0cf5a71b513ef5592dbf9 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Franti=C5=A1ek=20Zatloukal?= <fzatlouk@redhat.com>
|
||||
Date: Tue, 10 Aug 2021 00:00:50 +0200
|
||||
Subject: [PATCH] Tests: Use native TemporaryDirectory
|
||||
|
||||
Without ugly wrapper for Py < 3.2 that doesn't work half of the times...
|
||||
---
|
||||
js/src/jit-test/jit_test.py | 2 +-
|
||||
js/src/tests/jstests.py | 2 +-
|
||||
js/src/tests/lib/tempfile.py | 17 +----------------
|
||||
3 files changed, 3 insertions(+), 18 deletions(-)
|
||||
|
||||
diff --git a/js/src/jit-test/jit_test.py b/js/src/jit-test/jit_test.py
|
||||
index f5d7794..8d443aa 100755
|
||||
--- a/js/src/jit-test/jit_test.py
|
||||
+++ b/js/src/jit-test/jit_test.py
|
||||
@@ -38,7 +38,7 @@ from lib.tests import (
|
||||
get_environment_overlay,
|
||||
change_env,
|
||||
)
|
||||
-from lib.tempfile import TemporaryDirectory
|
||||
+from tempfile import TemporaryDirectory
|
||||
|
||||
|
||||
def which(name):
|
||||
diff --git a/js/src/tests/jstests.py b/js/src/tests/jstests.py
|
||||
index 6fa2f5f..53ceff6 100755
|
||||
--- a/js/src/tests/jstests.py
|
||||
+++ b/js/src/tests/jstests.py
|
||||
@@ -37,7 +37,7 @@ from lib.tests import (
|
||||
from lib.results import ResultsSink, TestOutput
|
||||
from lib.progressbar import ProgressBar
|
||||
from lib.adaptor import xdr_annotate
|
||||
-from lib.tempfile import TemporaryDirectory
|
||||
+from tempfile import TemporaryDirectory
|
||||
|
||||
if sys.platform.startswith("linux") or sys.platform.startswith("darwin"):
|
||||
from lib.tasks_unix import run_all_tests
|
||||
diff --git a/js/src/tests/lib/tempfile.py b/js/src/tests/lib/tempfile.py
|
||||
index ecc21c9..f0a1fa3 100644
|
||||
--- a/js/src/tests/lib/tempfile.py
|
||||
+++ b/js/src/tests/lib/tempfile.py
|
||||
@@ -2,19 +2,4 @@
|
||||
# License, v. 2.0. If a copy of the MPL was not distributed with this
|
||||
# file, You can obtain one at http://mozilla.org/MPL/2.0/.
|
||||
from __future__ import absolute_import
|
||||
-
|
||||
-try:
|
||||
- # Python 3.2
|
||||
- from tempfile import TemporaryDirectory
|
||||
-except ImportError:
|
||||
- import tempfile
|
||||
- import shutil
|
||||
- from contextlib import contextmanager
|
||||
-
|
||||
- @contextmanager
|
||||
- def TemporaryDirectory(*args, **kwds):
|
||||
- d = tempfile.mkdtemp(*args, **kwds)
|
||||
- try:
|
||||
- yield d
|
||||
- finally:
|
||||
- shutil.rmtree(d)
|
||||
+from tempfile import TemporaryDirectory
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,26 +0,0 @@
|
||||
From 9be85b155c6df0454c5faef9e850f572c99e3615 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Franti=C5=A1ek=20Zatloukal?= <fzatlouk@redhat.com>
|
||||
Date: Wed, 15 Jul 2020 08:32:44 +0200
|
||||
Subject: [PATCH] Increase the test timeout for slower buildds
|
||||
|
||||
Ported forward from Debian: https://bugs.debian.org/878284
|
||||
---
|
||||
js/src/Makefile.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/js/src/Makefile.in b/js/src/Makefile.in
|
||||
index b86aeed..d68655a 100644
|
||||
--- a/js/src/Makefile.in
|
||||
+++ b/js/src/Makefile.in
|
||||
@@ -53,7 +53,7 @@ check:: check-js-msg
|
||||
|
||||
check-jstests:
|
||||
$(wildcard $(RUN_TEST_PROGRAM)) $(PYTHON3) -u $(srcdir)/tests/jstests.py \
|
||||
- --no-progress --format=automation --timeout 300 \
|
||||
+ --no-progress --format=automation --timeout 600 \
|
||||
$(JSTESTS_EXTRA_ARGS) \
|
||||
$(DIST)/bin/$(JS_SHELL_NAME)$(BIN_SUFFIX)
|
||||
|
||||
--
|
||||
2.26.2
|
||||
|
17
mozjs128-128.6.0-fix_error_on_delete_declared_private.patch
Normal file
17
mozjs128-128.6.0-fix_error_on_delete_declared_private.patch
Normal file
@ -0,0 +1,17 @@
|
||||
--- firefox-128.6.0/js/src/gc/Cell.h.orig 2025-01-20 15:54:27.277347446 +0100
|
||||
+++ firefox-128.6.0/js/src/gc/Cell.h 2025-01-20 15:54:51.480383325 +0100
|
||||
@@ -221,13 +221,13 @@
|
||||
void dump(GenericPrinter& out) const;
|
||||
void dump() const;
|
||||
#endif
|
||||
+ void operator delete(void*) = delete;
|
||||
|
||||
protected:
|
||||
uintptr_t address() const;
|
||||
|
||||
private:
|
||||
// Cells are destroyed by the GC. Do not delete them directly.
|
||||
- void operator delete(void*) = delete;
|
||||
} JS_HAZ_GC_THING;
|
||||
|
||||
// A GC TenuredCell gets behaviors that are valid for things in the Tenured
|
@ -1,7 +1,7 @@
|
||||
%define MAJver %(echo %version | cut -d. -f1)
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: mozjs128
|
||||
Version: 128.5.1
|
||||
Version: 128.6.0
|
||||
Release: 1mamba
|
||||
Summary: Mozilla stand-alone library implementing JavaScript 24
|
||||
Group: System/Libraries
|
||||
@ -11,18 +11,14 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.mozilla.org/en-US/
|
||||
Source: https://archive.mozilla.org/pub/firefox/releases/%{version}esr/source/firefox-%{version}esr.source.tar.xz
|
||||
Patch0: mozjs-91.8.0-fix-soname.patch
|
||||
Patch1: mozjs-68.4.2-arm-Add-options-to-specify-Rust-target-name.patch
|
||||
Patch2: mozjs-68.4.2-arm-disable_emulate_arm_unaligned_fp_access.patch
|
||||
Patch3: mozjs-68.4.2-gcc-10.0.patch
|
||||
Patch4: mozjs-91.8.0-copy-headers.patch
|
||||
Patch5: mozjs-91.8.0-tests-increase-timeout.patch
|
||||
Patch6: mozjs-91.8.0-icu_sources_data.py-Decouple-from-Mozilla-build-system.patch
|
||||
Patch7: mozjs-91.8.0-icu_sources_data-Write-command-output-to-our-stderr.patch
|
||||
Patch8: mozjs-91.8.0-emitter.patch
|
||||
Patch9: mozjs-91.8.0-tests-Use-native-TemporaryDirectory.patch
|
||||
Patch10: mozjs-91.8.0-init_patch.patch
|
||||
Patch11: mozjs-91.8.0-remove-sloppy-m4-detection-from-bundled-autoconf.patch
|
||||
Patch12: mozjs-91.8.0-spidermonkey_checks_disable.patch
|
||||
Patch13: mozjs128-128.6.0-fix_error_on_delete_declared_private.patch
|
||||
# Only GPL because linking to readline
|
||||
License: GPL
|
||||
#License: MPL, GPL, LGPL
|
||||
@ -59,7 +55,6 @@ Requires: pkg-config
|
||||
%description -n lib%{name}-devel
|
||||
This package contains libraries and header files for developing applications that use %{name}.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -c -a0
|
||||
@ -74,6 +69,7 @@ cd firefox-%{version}
|
||||
%patch 10 -p1 -b .init_patch
|
||||
%patch 11 -p1 -b .remove-sloppy-m4-detection-from-bundled-autoconf
|
||||
%patch 12 -p1 -b .spidermonkey_checks_disable
|
||||
%patch 13 -p1 -b .fix_error_on_delete_declared_private.patch
|
||||
|
||||
%build
|
||||
cd firefox-%{version}/js/src
|
||||
@ -166,6 +162,9 @@ ln -s libmozjs-%{MAJver}.so.0 %{buildroot}%{_libdir}/libmozjs-%{MAJver}.so
|
||||
%{_libdir}/pkgconfig/mozjs-%{MAJver}.pc
|
||||
|
||||
%changelog
|
||||
* Mon Jan 20 2025 Automatic Build System <autodist@openmamba.org> 128.6.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Nov 30 2024 Automatic Build System <autodist@openmamba.org> 128.5.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user