added requirement for gst-plugins-ugly (for libmad plugin) [release 0.1.2-3mamba;Mon Jul 14 2008]

This commit is contained in:
Silvan Calarco 2024-01-06 07:14:28 +01:00
parent 9c4fe94a1b
commit 50a4b2e77f
3 changed files with 90 additions and 0 deletions

View File

@ -1,2 +1,6 @@
# moodbar
The Moodbar is an algorithm for creating a colorful visual representation of the contents of an audio file, giving an idea of its "mood" (this is a rather fanciful term for the simple analysis it actually does).
The Moodbar was invented by Gavin Wood and Simon O'Keefe for inclusion in the Amarok music player.
This package contains a GStreamer plugin with elements that are used in the moodbar analysis, and an application that actually does the analysis.

View File

@ -0,0 +1,21 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 10_gthread_init.dpatch by <bdonlan@gmail.com>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Initialize the GLib threading system before we make any other calls
## DP: to glib.
@DPATCH@
diff -urNad moodbar-0.1.2~/analyzer/main.c moodbar-0.1.2/analyzer/main.c
--- moodbar-0.1.2~/analyzer/main.c 2006-10-12 01:43:30.000000000 -0400
+++ moodbar-0.1.2/analyzer/main.c 2007-04-01 13:20:33.000000000 -0400
@@ -262,6 +262,9 @@
GOptionContext *ctx;
GError *err = NULL;
+ // must be called before any other glib function is called
+ if (!g_thread_supported ()) g_thread_init(NULL);
+
ctx = g_option_context_new ("[INFILE] - Run moodbar analyzer");
g_option_context_add_group (ctx, gst_init_get_option_group ());
g_option_context_add_main_entries (ctx, entries, NULL);

65
moodbar.spec Normal file
View File

@ -0,0 +1,65 @@
Name: moodbar
Version: 0.1.2
Release: 3mamba
Summary: Creates a colorful visual representation of the contents of an audio file
Group: Applications/Multimedia
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://amarok.kde.org/wiki/Moodbar
Source: http://pwsp.net/~qbob/moodbar-%{version}.tar.gz
Patch0: %{name}-0.1.2-g_thread_init.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libfftw-devel
BuildRequires: libglib-devel
BuildRequires: libgstreamer-devel
BuildRequires: libselinux-devel
BuildRequires: libxml2-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: pkgconfig
Requires: gst-plugins-ugly
Provides: gst-plugins-moodbar = %{?epoch:%epoch:}%{version}-%{release}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
The Moodbar is an algorithm for creating a colorful visual representation of the contents of an audio file, giving an idea of its "mood" (this is a rather fanciful term for the simple analysis it actually does).
The Moodbar was invented by Gavin Wood and Simon O'Keefe for inclusion in the Amarok music player.
This package contains a GStreamer plugin with elements that are used in the moodbar analysis, and an application that actually does the analysis.
%prep
%setup -q
%patch0 -p1
%build
%configure
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
rm -f %{buildroot}%{_libdir}/gstreamer-0.10/libmoodbar.a
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{_bindir}/moodbar
%{_libdir}/gstreamer-0.10/libmoodbar.la
%{_libdir}/gstreamer-0.10/libmoodbar.so
%doc AUTHORS COPYING ChangeLog NEWS README TODO
%changelog
* Mon Jul 14 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.2-3mamba
- added requirement for gst-plugins-ugly (for libmad plugin)
* Mon Jul 14 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.2-2mamba
- rebuilt agains recent libgstreamer
- added g_thread_init patch
* Fri Feb 09 2007 Davide Madrisan <davide.madrisan@qilinux.it> 0.1.2-1qilnx
- package created by autospec