update to 1.3.0 [release 1.3.0-1mamba;Tue Apr 09 2024]
This commit is contained in:
parent
9eaf739781
commit
0f69aedb3e
@ -1,21 +0,0 @@
|
|||||||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
|
||||||
## 10_gthread_init.dpatch by <bdonlan@gmail.com>
|
|
||||||
##
|
|
||||||
## All lines beginning with `## DP:' are a description of the patch.
|
|
||||||
## DP: Initialize the GLib threading system before we make any other calls
|
|
||||||
## DP: to glib.
|
|
||||||
|
|
||||||
@DPATCH@
|
|
||||||
diff -urNad moodbar-0.1.2~/analyzer/main.c moodbar-0.1.2/analyzer/main.c
|
|
||||||
--- moodbar-0.1.2~/analyzer/main.c 2006-10-12 01:43:30.000000000 -0400
|
|
||||||
+++ moodbar-0.1.2/analyzer/main.c 2007-04-01 13:20:33.000000000 -0400
|
|
||||||
@@ -262,6 +262,9 @@
|
|
||||||
GOptionContext *ctx;
|
|
||||||
GError *err = NULL;
|
|
||||||
|
|
||||||
+ // must be called before any other glib function is called
|
|
||||||
+ if (!g_thread_supported ()) g_thread_init(NULL);
|
|
||||||
+
|
|
||||||
ctx = g_option_context_new ("[INFILE] - Run moodbar analyzer");
|
|
||||||
g_option_context_add_group (ctx, gst_init_get_option_group ());
|
|
||||||
g_option_context_add_main_entries (ctx, entries, NULL);
|
|
19
moodbar.spec
19
moodbar.spec
@ -1,15 +1,13 @@
|
|||||||
Name: moodbar
|
Name: moodbar
|
||||||
Version: 1.2.1
|
Version: 1.3.0
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: Creates a colorful visual representation of the contents of an audio file
|
Summary: Creates a colorful visual representation of the contents of an audio file
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://amarok.kde.org/wiki/Moodbar
|
URL: https://github.com/exaile/moodbar
|
||||||
Source: https://github.com/exaile/moodbar/releases/download/v%{version}/moodbar-%{version}.tar.xz
|
Source: https://github.com/exaile/moodbar.git/v%{version}/moodbar-%{version}.tar.bz2
|
||||||
#Source: http://pwsp.net/~qbob/moodbar-%{version}.tar.gz
|
|
||||||
Patch0: %{name}-0.1.2-g_thread_init.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -21,8 +19,6 @@ BuildRequires: libgstreamer-devel
|
|||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: pkgconfig
|
BuildRequires: pkgconfig
|
||||||
#Requires: gst-plugins-ugly
|
|
||||||
#Provides: gst-plugins-moodbar = %{?epoch:%epoch:}%{version}-%{release}
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The Moodbar is an algorithm for creating a colorful visual representation of the contents of an audio file, giving an idea of its "mood" (this is a rather fanciful term for the simple analysis it actually does).
|
The Moodbar is an algorithm for creating a colorful visual representation of the contents of an audio file, giving an idea of its "mood" (this is a rather fanciful term for the simple analysis it actually does).
|
||||||
@ -33,7 +29,6 @@ This package contains a GStreamer plugin with elements that are used in the mood
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%meson
|
%meson
|
||||||
@ -44,20 +39,18 @@ This package contains a GStreamer plugin with elements that are used in the mood
|
|||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%meson_install
|
%meson_install
|
||||||
|
|
||||||
#rm -f %{buildroot}%{_libdir}/gstreamer-0.10/libmoodbar.a
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/moodbar
|
%{_bindir}/moodbar
|
||||||
#%{_libdir}/gstreamer-0.10/libmoodbar.la
|
|
||||||
#%{_libdir}/gstreamer-0.10/libmoodbar.so
|
|
||||||
%doc COPYING
|
%doc COPYING
|
||||||
#ChangeLog NEWS README TODO
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 09 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.0-1mamba
|
||||||
|
- update to 1.3.0
|
||||||
|
|
||||||
* Mon Jul 12 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.1-1mamba
|
* Mon Jul 12 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.1-1mamba
|
||||||
- update to 1.2.1
|
- update to 1.2.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user