added patch to use plughw:0 device in alsa mode (default through dmix does not work) [release 0.60.3-2mamba;Sun Oct 28 2012]
This commit is contained in:
parent
c9f9fec8cf
commit
47558f3e2a
@ -1,2 +1,4 @@
|
||||
# monobristol
|
||||
|
||||
GUI for Bristol Synthesiser, an emulation package for a number of different 'classic' synthesisers including additive and subtractive and a few organs.
|
||||
|
||||
|
20
monobristol-0.60.3-alsa-default-plughw.patch
Normal file
20
monobristol-0.60.3-alsa-default-plughw.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- monobristol-0.60.3-src/MainWindow.cs.orig 2012-10-28 16:59:53.868711030 +0100
|
||||
+++ monobristol-0.60.3-src/MainWindow.cs 2012-10-28 17:00:28.247376980 +0100
|
||||
@@ -296,7 +296,7 @@
|
||||
if (mode == "easy") {
|
||||
param = param + "-"+easydriver;
|
||||
if (easydriver == "alsa"){
|
||||
- param = param+" -audiodev default ";
|
||||
+ param = param+" -audiodev plughw:0 ";
|
||||
} else if (easydriver == "jack"){
|
||||
if (autoe == "1"){
|
||||
param = param+" -autoconn";
|
||||
@@ -326,7 +326,7 @@
|
||||
if (mode == "advanced") {
|
||||
param = param + "-audio "+adriver+" -midi "+mdriver;
|
||||
if (adriver == "alsa"){
|
||||
- param = param+" -audiodev default ";
|
||||
+ param = param+" -audiodev plughw:0 ";
|
||||
} if (adriver == "jack"){
|
||||
if (autoa == "1"){
|
||||
param = param+" -autoconn";
|
71
monobristol.spec
Normal file
71
monobristol.spec
Normal file
@ -0,0 +1,71 @@
|
||||
Name: monobristol
|
||||
Version: 0.60.3
|
||||
Release: 2mamba
|
||||
Summary: GUI for Bristol Synthesiser, an emulation package for a number of different 'classic' synthesisers
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.dacr.hu/monobristol
|
||||
Source: http://www.dacr.hu/monobristol/monobristol-%{version}-src.tar.gz
|
||||
Patch0: monobristol-0.60.3-alsa-default-plughw.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: monodevelop
|
||||
Requires: bristol
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
GUI for Bristol Synthesiser, an emulation package for a number of different 'classic' synthesisers including additive and subtractive and a few organs.
|
||||
|
||||
%prep
|
||||
%setup -q -c -n %{name}-%{version}-src
|
||||
cd monobristol-%{version}-src
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
cd monobristol-%{version}-src
|
||||
mdtool build
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
cd monobristol-%{version}-src
|
||||
install -D -m0644 monoBristol.desktop %{buildroot}%{_datadir}/applications/monoBristol.desktop
|
||||
install -D -m0644 monobristol.png %{buildroot}%{_datadir}/pixmaps/monobristol.png
|
||||
install -D -m0755 bin/Debug/monoBristol.exe %{buildroot}%{_bindir}/monoBristol.exe
|
||||
|
||||
cat >> %{buildroot}%{_bindir}/monobristol << _EOF
|
||||
#!/bin/sh
|
||||
mono %{_bindir}/monoBristol.exe
|
||||
_EOF
|
||||
chmod +x %{buildroot}%{_bindir}/monobristol
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post
|
||||
update-desktop-database &> /dev/null || :
|
||||
exit 0
|
||||
|
||||
%postun
|
||||
if [ "$1" -eq "0" ]; then
|
||||
update-desktop-database &> /dev/null || :
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/monobristol
|
||||
%{_bindir}/monoBristol.exe
|
||||
%{_datadir}/pixmaps/monobristol.png
|
||||
%{_datadir}/applications/monoBristol.desktop
|
||||
%doc monobristol-%{version}-src/AUTHORS monobristol-%{version}-src/COPYING
|
||||
%doc monobristol-%{version}-src/README
|
||||
|
||||
%changelog
|
||||
* Sun Oct 28 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.60.3-2mamba
|
||||
- added patch to use plughw:0 device in alsa mode (default through dmix does not work)
|
||||
|
||||
* Mon Mar 28 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.60.3-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user