automatic rebuild by autodist [release 0.4.0-2mamba;Wed Nov 19 2008]

This commit is contained in:
Silvan Calarco 2024-01-06 07:13:24 +01:00
parent 0934119c5c
commit e45d640032
7 changed files with 288 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# monkey-bubble
Monkey Bubble is in a game in which you must explode all bubbles in the game area.
You explode bubbles by putting at least 3 of the same colour in contact. Any bubble that is connected to the top or the sides of the game area by bubbles you just exploded falls too.

View File

@ -0,0 +1,84 @@
diff -ru monkey-bubble-0.3.2/src/audio/Makefile.am monkey-bubble-0.3.2-fix/src/audio/Makefile.am
--- monkey-bubble-0.3.2/src/audio/Makefile.am 2004-06-29 08:53:42.000000000 +0200
+++ monkey-bubble-0.3.2-fix/src/audio/Makefile.am 2005-11-09 15:13:02.000000000 +0100
@@ -3,7 +3,7 @@
INCLUDES = \
$(LIBMONKEYAUDIO_A_CFLAGS) \
-I$(top_srcdir)/src/monkey \
- -g -O2 -Wall -Werror -D_REENTRANT -DDATADIR=\""$(datadir)"\"
+ -g -O2 -Wall -D_REENTRANT -DDATADIR=\""$(datadir)"\"
noinst_LIBRARIES = libmonkeyaudio.a
diff -ru monkey-bubble-0.3.2/src/input/Makefile.am monkey-bubble-0.3.2-fix/src/input/Makefile.am
--- monkey-bubble-0.3.2/src/input/Makefile.am 2004-06-29 08:53:47.000000000 +0200
+++ monkey-bubble-0.3.2-fix/src/input/Makefile.am 2005-11-09 15:13:12.000000000 +0100
@@ -2,7 +2,7 @@
INCLUDES = \
$(LIBMBINPUT_A_CFLAGS) \
- -g -O2 -Wall -Werror -D_REENTRANT -DDATADIR=\""$(datadir)"\"
+ -g -O2 -Wall -D_REENTRANT -DDATADIR=\""$(datadir)"\"
noinst_LIBRARIES = libmbinput.a
diff -ru monkey-bubble-0.3.2/src/monkey/Makefile.am monkey-bubble-0.3.2-fix/src/monkey/Makefile.am
--- monkey-bubble-0.3.2/src/monkey/Makefile.am 2004-06-29 08:53:42.000000000 +0200
+++ monkey-bubble-0.3.2-fix/src/monkey/Makefile.am 2005-11-09 15:13:20.000000000 +0100
@@ -4,7 +4,7 @@
INCLUDES = \
$(LIBMONKEY_A_CFLAGS) \
- -Wall -Werror -g
+ -Wall -g
noinst_LIBRARIES = libmonkey.a
diff -ru monkey-bubble-0.3.2/src/net/Makefile.am monkey-bubble-0.3.2-fix/src/net/Makefile.am
--- monkey-bubble-0.3.2/src/net/Makefile.am 2004-06-29 08:53:44.000000000 +0200
+++ monkey-bubble-0.3.2-fix/src/net/Makefile.am 2005-11-09 15:12:28.000000000 +0100
@@ -7,7 +7,7 @@
-I$(top_srcdir)/src/view \
-I$(top_srcdir)/src/ui \
-I$(top_srcdir)/src/util \
- -g -O2 -Wall -Werror -D_REENTRANT -D_DEBUG_ -D_TIME_DEBUG_ \
+ -g -O2 -Wall -D_REENTRANT -D_DEBUG_ -D_TIME_DEBUG_ \
$(NULL)
# -g -O2 -Wall -Wstrict-prototypes -Wmissing-prototypes -Werror -D_REENTRANT -D_TIME_DEBUG_ -D_DEBUG_
diff -ru monkey-bubble-0.3.2/src/ui/Makefile.am monkey-bubble-0.3.2-fix/src/ui/Makefile.am
--- monkey-bubble-0.3.2/src/ui/Makefile.am 2004-06-29 08:53:46.000000000 +0200
+++ monkey-bubble-0.3.2-fix/src/ui/Makefile.am 2005-11-09 15:12:17.000000000 +0100
@@ -13,7 +13,7 @@
-I$(top_srcdir)/src/util \
-I$(top_srcdir)/src/net \
-I$(top_srcdir)/src/input \
- -Wall -Werror
+ -Wall
bin_PROGRAMS = monkey-bubble
diff -ru monkey-bubble-0.3.2/src/util/Makefile.am monkey-bubble-0.3.2-fix/src/util/Makefile.am
--- monkey-bubble-0.3.2/src/util/Makefile.am 2004-06-29 08:53:46.000000000 +0200
+++ monkey-bubble-0.3.2-fix/src/util/Makefile.am 2005-11-09 15:12:52.000000000 +0100
@@ -4,7 +4,7 @@
INCLUDES = \
$(LIBMONKEYUTIL_A_CFLAGS) \
- -Wall -Werror -g
+ -Wall -g
noinst_LIBRARIES = libmonkeyutil.a
diff -ru monkey-bubble-0.3.2/src/view/Makefile.am monkey-bubble-0.3.2-fix/src/view/Makefile.am
--- monkey-bubble-0.3.2/src/view/Makefile.am 2004-07-01 10:30:17.000000000 +0200
+++ monkey-bubble-0.3.2-fix/src/view/Makefile.am 2005-11-09 15:12:43.000000000 +0100
@@ -5,7 +5,7 @@
$(LIBMONKEYVIEW_A_CFLAGS) \
$(AM_CFLAGS) \
-I$(top_srcdir)/src/monkey \
- -g -O2 -Wall -Werror -D_REENTRANT -DDATADIR=\""$(datadir)"\"
+ -g -O2 -Wall -D_REENTRANT -DDATADIR=\""$(datadir)"\"
noinst_LIBRARIES = libmonkeyview.a

View File

@ -0,0 +1,16 @@
--- monkey-bubble-0.3.2/monkey-bubble.desktop.in.orig 2005-11-09 15:31:47.000000000 +0100
+++ monkey-bubble-0.3.2/monkey-bubble.desktop.in 2005-11-09 15:34:37.000000000 +0100
@@ -2,9 +2,11 @@
Encoding=UTF-8
_Name=Monkey Bubble
_Comment=Monkey Bubble Arcade Game
+Comment[it]=Gioco Arcade Monkey Bubble
+GenericName[it]=Gioco arcade Monkey Bubble
Exec=monkey-bubble
Icon=monkey-bubble-icon.png
Terminal=false
Type=Application
-Categories=GNOME;Application;Game;
-StartupNotify=true
+Categories=GNOME;Application;Game;ArcadeGame;
+StartupNotify=false

View File

@ -0,0 +1,28 @@
--- monkey-bubble-0.3.2/src/ui/eggcellrendererkeys.c 2004-06-29 08:53:44.000000000 +0200
+++ monkey-bubble-0.3.2/src/ui/eggcellrendererkeys.c.gcc34 2005-08-09 10:22:26.000000000 +0200
@@ -586,9 +586,9 @@ egg_cell_renderer_keys_start_editing (Gt
}
void
-egg_cell_renderer_keys_set_accelerator (EggCellRendererKeys *keys,
- guint keyval,
- GdkModifierType mask)
+egg_cell_renderer_keys_set_accelerator (EggCellRendererKeys *keys,
+ guint keyval,
+ EggVirtualModifierType mask)
{
char *text;
gboolean changed;
@@ -628,9 +628,9 @@ egg_cell_renderer_keys_set_accelerator (
}
void
-egg_cell_renderer_keys_get_accelerator (EggCellRendererKeys *keys,
- guint *keyval,
- GdkModifierType *mask)
+egg_cell_renderer_keys_get_accelerator (EggCellRendererKeys *keys,
+ guint *keyval,
+ EggVirtualModifierType *mask)
{
g_return_if_fail (EGG_IS_CELL_RENDERER_KEYS (keys));

View File

@ -0,0 +1,17 @@
diff -Nru monkey-bubble-0.4.0.orig/src/ui/ui-main.c monkey-bubble-0.4.0/src/ui/ui-main.c
--- monkey-bubble-0.4.0.orig/src/ui/ui-main.c 2006-08-01 15:47:04.000000000 +0200
+++ monkey-bubble-0.4.0/src/ui/ui-main.c 2008-11-06 14:12:43.000000000 +0100
@@ -35,12 +35,12 @@
#include "keyboard-properties.h"
#include "sound-manager.h"
+#include <glib/gi18n.h>
#include <libgnomeui/gnome-about.h>
#include <libgnome/gnome-sound.h>
#include <libgnome/gnome-help.h>
#include <gdk/gdkkeysyms.h>
#include <glade/glade.h>
-#include <bonobo/bonobo-i18n.h>
#include <string.h>
#include <stdlib.h>

View File

@ -0,0 +1,24 @@
diff -Nru monkey-bubble-0.4.0/help/C/monkey-bubble.xml monkey-bubble-0.4.0orig/help/C/monkey-bubble.xml
--- monkey-bubble-0.4.0/help/C/monkey-bubble.xml 2008-11-17 17:03:16.000000000 +0100
+++ monkey-bubble-0.4.0orig/help/C/monkey-bubble.xml 2006-08-01 17:12:41.000000000 +0200
@@ -23,10 +23,10 @@
<publishername>GNOME Documentation Project</publishername>
</publisher>
<authorgroup>
- <author>
+ <author role="maintainer">
<firstname>Thomas</firstname>
<surname>Cataldo</surname>
- <affiliation>
+ <affiliation>
<orgname>GNOME Documentation Project</orgname>
</affiliation>
</author>
@@ -55,7 +55,8 @@
manual, follow the directions in the
<ulink url="ghelp:gnome-feedback" type="help">GNOME Feedback Page</ulink>. </para>
</legalnotice>
+ <abstract role="description"><para><application>An arcade game</application></para></abstract>
</articleinfo>
<indexterm>

116
monkey-bubble.spec Normal file
View File

@ -0,0 +1,116 @@
Name: monkey-bubble
Version: 0.4.0
Release: 2mamba
Summary: A game in which you must explode all bubbles in the game area
Group: Graphical Desktop/Applications/Games
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://home.gna.org/monkeybubble
Source: http://home.gna.org/monkeybubble/downloads/monkey-bubble-%{version}.tar.gz
Patch0: %{name}-0.3.2-gcc34.patch
Patch1: %{name}-0.3.2-Werror.patch
Patch2: %{name}-0.3.2-desktop_file.patch
Patch3: %{name}-0.4.0-glib2.patch
Patch4: %{name}-0.4.0-xmlhelp.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: GConf-devel
BuildRequires: ORBit2-devel
BuildRequires: glibc-devel
BuildRequires: libICE-devel
BuildRequires: libSM-devel
BuildRequires: libart_lgpl-devel
BuildRequires: libatk-devel
BuildRequires: libbonobo-devel
BuildRequires: libbonoboui-devel
BuildRequires: libcairo-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgdk-pixbuf-devel
BuildRequires: libglade-devel
BuildRequires: libglib-devel
BuildRequires: libgnome-devel
BuildRequires: libgnome-vfs-devel
BuildRequires: libgnomecanvas-devel
BuildRequires: libgnomeui-devel
BuildRequires: libgstreamer010-devel
BuildRequires: libgtk2-devel
BuildRequires: libpango-devel
BuildRequires: libpopt-devel
BuildRequires: librsvg-devel
BuildRequires: libxml2-devel
## AUTOBUILDREQ-END
BuildRequires: perl
BuildRequires: pkgconfig >= 0.15.0
BuildRequires: libgtk-devel >= 2.6.8
BuildRequires: gettext-devel >= 0.14.4
BuildRequires: gconf >= 2.12.0
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Monkey Bubble is in a game in which you must explode all bubbles in the game area.
You explode bubbles by putting at least 3 of the same colour in contact. Any bubble that is connected to the top or the sides of the game area by bubbles you just exploded falls too.
%prep
%setup -q
#%patch0 -p1
#%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
# Fix compilation error
sed -i "s_glib/gthread.h_glib.h_" \
src/net/message-handler.c \
src/net/simple-server.c \
src/ui/main.c
%build
%configure \
--disable-scrollkeeper \
CFLAGS="-Wno-unused-but-set-variable -Wno-deprecated-declarations" \
LDFLAGS="-lm"
%make -j1
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%find_lang %{name}
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files -f %{name}.lang
%defattr(-,root,root)
%{_bindir}/*
%dir %{_datadir}/monkey-bubble
%{_datadir}/monkey-bubble/*
%dir %{_datadir}/omf/monkey-bubble
%{_datadir}/omf/monkey-bubble/*
%{_datadir}/pixmaps/*
%{_datadir}/applications/monkey-bubble.desktop
%dir %{_datadir}/gnome/help/monkey-bubble
%{_datadir}/gnome/help/monkey-bubble/*
%{_sysconfdir}/gconf/schemas/monkey-bubble.schemas
%doc AUTHORS COPYING NEWS README
%changelog
* Wed Nov 19 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.0-2mamba
- automatic rebuild by autodist
* Fri Jan 26 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.0-1qilnx
- update to version 0.4.0 by autospec
* Wed Nov 09 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.3.2-3qilnx
- patched to compile with gcc 4
- added italian translation to desktop file
* Tue Aug 09 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.3.2-2qilnx
- rebuilt
- patched to compile with gcc 3.4
* Sun Jul 04 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.2-1qilnx
- first build