87 lines
2.5 KiB
RPMSpec
87 lines
2.5 KiB
RPMSpec
Name: mongo-tools
|
|
Version: 3.2.4
|
|
Release: 3mamba
|
|
Summary: MongoDB Tools
|
|
Group: Applications/Databases
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
|
URL: https://github.com/mongodb/mongo-tools
|
|
Source: https://github.com/mongodb/mongo-tools/archive/r%{version}.tar.gz
|
|
License: Apache License 2.0
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libgo-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: libgo-devel >= 7.3.0-1mamba
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
The MongoDB Tools:
|
|
- bsondump - display BSON files in a human-readable format
|
|
- mongoimport - Convert data from JSON, TSV or CSV and insert them into a collection
|
|
- mongoexport - Write an existing collection to CSV or JSON format
|
|
- mongodump/mongorestore - Dump MongoDB backups to disk in .BSON format, or restore them to a live database
|
|
- mongostat - Monitor live MongoDB servers, replica sets, or sharded clusters
|
|
- mongofiles - Read, write, delete, or update files in [GridFS](http://docs.mongodb.org/manual/core/gridfs/)
|
|
- mongooplog - Replay oplog entries between MongoDB servers
|
|
- mongotop - Monitor read/write activity on a mongo server
|
|
|
|
%prep
|
|
%setup -q -n %{name}-r%{version}
|
|
|
|
%build
|
|
mkdir -p src/github.com/mongodb
|
|
ln -s ../../../ src/github.com/mongodb/mongo-tools
|
|
export GOPATH=$(pwd):$(pwd)/vendor
|
|
|
|
mkdir bin
|
|
|
|
tools="\
|
|
bsondump
|
|
mongoimport \
|
|
mongoexport
|
|
mongodump
|
|
mongorestore
|
|
mongostat
|
|
mongofiles
|
|
mongooplog
|
|
mongotop"
|
|
|
|
for tool in $tools; do
|
|
go build -o bin/$tool $tool/main/${tool}.go
|
|
# go build -o bin/$tool -tags ssl $tool/main/${tool}.go
|
|
done
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
install -d -p %{buildroot}%{_bindir}
|
|
install -p -m 0755 bin/* %{buildroot}%{_bindir}
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_bindir}/bsondump
|
|
%{_bindir}/mongoimport
|
|
%{_bindir}/mongoexport
|
|
%{_bindir}/mongodump
|
|
%{_bindir}/mongorestore
|
|
%{_bindir}/mongostat
|
|
%{_bindir}/mongofiles
|
|
%{_bindir}/mongooplog
|
|
%{_bindir}/mongotop
|
|
%doc README.md
|
|
|
|
%changelog
|
|
* Thu Apr 19 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.4-3mamba
|
|
- rebuilt by autoport with build requirements: libgo-devel>=7.3.0-1mamba
|
|
|
|
* Sat May 14 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.4-2mamba
|
|
- rebuilt by autoport with build requirements: libgo-devel>=6.1.0-2mamba
|
|
|
|
* Tue Apr 12 2016 Davide Madrisan <davide.madrisan@gmail.com> 3.2.4-1mamba
|
|
- package created using the webbuild interface
|