update to 2.5.2 [release 2.5.2-1mamba;Mon Dec 27 2021]
This commit is contained in:
parent
91b310f751
commit
1968552de7
33
moc-2.5.2-ffmpeg4.patch
Normal file
33
moc-2.5.2-ffmpeg4.patch
Normal file
@ -0,0 +1,33 @@
|
||||
Index: decoder_plugins/ffmpeg/ffmpeg.c
|
||||
===================================================================
|
||||
--- decoder_plugins/ffmpeg/ffmpeg.c (revisión: 2963)
|
||||
+++ decoder_plugins/ffmpeg/ffmpeg.c (copia de trabajo)
|
||||
@@ -697,7 +697,7 @@
|
||||
* FFmpeg/LibAV in use. For some versions this will be caught in
|
||||
* *_find_stream_info() above and misreported as an unfound codec
|
||||
* parameters error. */
|
||||
- if (data->codec->capabilities & CODEC_CAP_EXPERIMENTAL) {
|
||||
+ if (data->codec->capabilities & AV_CODEC_CAP_EXPERIMENTAL) {
|
||||
decoder_error (&data->error, ERROR_FATAL, 0,
|
||||
"The codec is experimental and may damage MOC: %s",
|
||||
data->codec->name);
|
||||
@@ -705,8 +705,8 @@
|
||||
}
|
||||
|
||||
set_downmixing (data);
|
||||
- if (data->codec->capabilities & CODEC_CAP_TRUNCATED)
|
||||
- data->enc->flags |= CODEC_FLAG_TRUNCATED;
|
||||
+ if (data->codec->capabilities & AV_CODEC_CAP_TRUNCATED)
|
||||
+ data->enc->flags |= AV_CODEC_FLAG_TRUNCATED;
|
||||
|
||||
if (avcodec_open2 (data->enc, data->codec, NULL) < 0)
|
||||
{
|
||||
@@ -725,7 +725,7 @@
|
||||
|
||||
data->sample_width = sfmt_Bps (data->fmt);
|
||||
|
||||
- if (data->codec->capabilities & CODEC_CAP_DELAY)
|
||||
+ if (data->codec->capabilities & AV_CODEC_CAP_DELAY)
|
||||
data->delay = true;
|
||||
data->seek_broken = is_seek_broken (data);
|
||||
data->timing_broken = is_timing_broken (data->ic);
|
49
moc.spec
49
moc.spec
@ -1,6 +1,6 @@
|
||||
%define pkgver %(echo %version | tr _ -)
|
||||
Name: moc
|
||||
Version: 2.5.1
|
||||
Version: 2.5.2
|
||||
Release: 1mamba
|
||||
Summary: A console audio player for LINUX/UNIX designed to be powerful and easy to use
|
||||
Group: Applications/Multimedia
|
||||
@ -8,7 +8,8 @@ Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://moc.daper.net
|
||||
Source: http://ftp.daper.net/pub/soft/moc/stable/moc-%{pkgver}.tar.bz2
|
||||
Source: https://web.archive.org/web/20191025005721/https://ftp.daper.net/pub/soft/moc/stable/moc-%{version}.tar.bz2
|
||||
Patch0: moc-2.5.2-ffmpeg4.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -16,16 +17,17 @@ BuildRequires: libalsa-devel
|
||||
BuildRequires: libavcodec-ffmpeg-devel
|
||||
BuildRequires: libavformat-ffmpeg-devel
|
||||
BuildRequires: libavutil-ffmpeg-devel
|
||||
BuildRequires: libbrotli-devel
|
||||
BuildRequires: libcares-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libdb51-devel
|
||||
BuildRequires: libdb53-devel
|
||||
BuildRequires: libfaad2-devel
|
||||
BuildRequires: libflac-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgcrypt-devel
|
||||
BuildRequires: libgpg-error-devel
|
||||
BuildRequires: libgss-devel
|
||||
BuildRequires: libid3tag-devel
|
||||
BuildRequires: libidn-devel
|
||||
BuildRequires: libidn2-devel
|
||||
BuildRequires: libjack-devel
|
||||
BuildRequires: libltdl-devel
|
||||
BuildRequires: libmad-devel
|
||||
@ -33,24 +35,28 @@ BuildRequires: libmagic-devel
|
||||
BuildRequires: libmodplug-devel
|
||||
BuildRequires: libmusepack-devel
|
||||
BuildRequires: libncurses-devel
|
||||
BuildRequires: libnghttp2-devel
|
||||
BuildRequires: libntlm-devel
|
||||
BuildRequires: libogg-devel
|
||||
BuildRequires: libopenldap-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpsl-devel
|
||||
BuildRequires: librtmp-devel
|
||||
BuildRequires: libsamplerate-devel
|
||||
BuildRequires: libsasl-devel
|
||||
BuildRequires: libsasl2-devel
|
||||
BuildRequires: libsidplay2-devel
|
||||
BuildRequires: libsndfile-devel
|
||||
BuildRequires: libspeex-devel
|
||||
BuildRequires: libssh2-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtag-devel
|
||||
BuildRequires: libunistring-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: libwavpack-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: libzstd-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libtag-devel >= 1.9.1
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
MOC (music on console) is a console audio player for LINUX/UNIX designed to be powerful and easy to use.
|
||||
@ -59,8 +65,12 @@ MOC (music on console) is a console audio player for LINUX/UNIX designed to be p
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{pkgver}
|
||||
%define _default_patch_fuzz 2
|
||||
%patch0 -p0 -b .ffmpeg4
|
||||
|
||||
%build
|
||||
export PKG_CONFIG_PATH='%{_libdir}/ffmpeg4/pkgconfig'
|
||||
|
||||
%configure
|
||||
%make
|
||||
|
||||
@ -75,17 +85,17 @@ MOC (music on console) is a console audio player for LINUX/UNIX designed to be p
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/mocp
|
||||
%dir %{_libdir}/moc/decoder_plugins
|
||||
%{_libdir}/moc/decoder_plugins/libaac_decoder.*
|
||||
%{_libdir}/moc/decoder_plugins/libffmpeg_decoder.*
|
||||
%{_libdir}/moc/decoder_plugins/libflac_decoder.*
|
||||
%{_libdir}/moc/decoder_plugins/libmodplug_decoder.*
|
||||
%{_libdir}/moc/decoder_plugins/libmp3_decoder.*
|
||||
%{_libdir}/moc/decoder_plugins/libmusepack_decoder.*
|
||||
%{_libdir}/moc/decoder_plugins/libsidplay2_decoder.*
|
||||
%{_libdir}/moc/decoder_plugins/libsndfile_decoder.*
|
||||
%{_libdir}/moc/decoder_plugins/libspeex_decoder.*
|
||||
%{_libdir}/moc/decoder_plugins/libvorbis_decoder.*
|
||||
%{_libdir}/moc/decoder_plugins/libwavpack_decoder.*
|
||||
%{_libdir}/moc/decoder_plugins/libaac_decoder.so
|
||||
%{_libdir}/moc/decoder_plugins/libffmpeg_decoder.so
|
||||
%{_libdir}/moc/decoder_plugins/libflac_decoder.so
|
||||
%{_libdir}/moc/decoder_plugins/libmodplug_decoder.so
|
||||
%{_libdir}/moc/decoder_plugins/libmp3_decoder.so
|
||||
%{_libdir}/moc/decoder_plugins/libmusepack_decoder.so
|
||||
%{_libdir}/moc/decoder_plugins/libsidplay2_decoder.so
|
||||
%{_libdir}/moc/decoder_plugins/libsndfile_decoder.so
|
||||
%{_libdir}/moc/decoder_plugins/libspeex_decoder.so
|
||||
%{_libdir}/moc/decoder_plugins/libvorbis_decoder.so
|
||||
%{_libdir}/moc/decoder_plugins/libwavpack_decoder.so
|
||||
%dir %{_docdir}/moc
|
||||
%{_docdir}/moc/*
|
||||
%{_mandir}/man1/mocp.1*
|
||||
@ -96,6 +106,9 @@ MOC (music on console) is a console audio player for LINUX/UNIX designed to be p
|
||||
%doc AUTHORS COPYING THANKS
|
||||
|
||||
%changelog
|
||||
* Mon Dec 27 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.5.2-1mamba
|
||||
- update to 2.5.2
|
||||
|
||||
* Sun Jul 31 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.5.1-1mamba
|
||||
- update to 2.5.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user