automatic version update by autodist [release 7.26.0-1mamba;Mon Aug 26 2024]
This commit is contained in:
parent
b45d40049c
commit
f5d23b1fae
@ -1,19 +0,0 @@
|
||||
Index: mlt-0.3.0/src/modules/sox/filter_sox.c
|
||||
===================================================================
|
||||
--- mlt-0.3.0.orig/src/modules/sox/filter_sox.c
|
||||
+++ mlt-0.3.0/src/modules/sox/filter_sox.c
|
||||
@@ -33,9 +33,13 @@
|
||||
# define ST_SUCCESS SOX_SUCCESS
|
||||
# define st_sample_t sox_sample_t
|
||||
# define eff_t sox_effect_t*
|
||||
-# define st_size_t sox_size_t
|
||||
# define ST_LIB_VERSION_CODE SOX_LIB_VERSION_CODE
|
||||
# define ST_LIB_VERSION SOX_LIB_VERSION
|
||||
+#if (ST_LIB_VERSION_CODE >= ST_LIB_VERSION(14,2,0))
|
||||
+# define st_size_t size_t
|
||||
+#else
|
||||
+# define st_size_t sox_size_t
|
||||
+#endif
|
||||
# define ST_SIGNED_WORD_TO_SAMPLE(d,clips) SOX_SIGNED_16BIT_TO_SAMPLE(d,clips)
|
||||
#if (ST_LIB_VERSION_CODE >= ST_LIB_VERSION(14,1,0))
|
||||
# define ST_SSIZE_MIN SOX_SAMPLE_MIN
|
@ -1,71 +0,0 @@
|
||||
diff -Nru mlt-0.3.8/src/modules/avformat/consumer_avformat.c mlt-0.3.8.patched/src/modules/avformat/consumer_avformat.c
|
||||
--- mlt-0.3.8/src/modules/avformat/consumer_avformat.c 2009-04-10 09:18:41.000000000 +0200
|
||||
+++ mlt-0.3.8.patched/src/modules/avformat/consumer_avformat.c 2009-05-30 22:37:20.000000000 +0200
|
||||
@@ -35,11 +35,11 @@
|
||||
#include <unistd.h>
|
||||
|
||||
// avformat header files
|
||||
-#include <avformat.h>
|
||||
+#include <libavformat/avformat.h>
|
||||
#ifdef SWSCALE
|
||||
-#include <swscale.h>
|
||||
+#include <libswscale/swscale.h>
|
||||
#endif
|
||||
-#include <opt.h>
|
||||
+#include <opt.h>
|
||||
|
||||
#if LIBAVUTIL_VERSION_INT < (50<<16)
|
||||
#define PIX_FMT_RGB32 PIX_FMT_RGBA32
|
||||
diff -Nru mlt-0.3.8/src/modules/avformat/factory.c mlt-0.3.8.patched/src/modules/avformat/factory.c
|
||||
--- mlt-0.3.8/src/modules/avformat/factory.c 2009-04-10 09:18:41.000000000 +0200
|
||||
+++ mlt-0.3.8.patched/src/modules/avformat/factory.c 2009-05-30 22:37:53.000000000 +0200
|
||||
@@ -32,7 +32,7 @@
|
||||
extern mlt_producer producer_avformat_init( mlt_profile profile, char *file );
|
||||
|
||||
// ffmpeg Header files
|
||||
-#include <avformat.h>
|
||||
+#include <libavformat/avformat.h>
|
||||
|
||||
// A static flag used to determine if avformat has been initialised
|
||||
static int avformat_initialised = 0;
|
||||
diff -Nru mlt-0.3.8/src/modules/avformat/filter_avcolour_space.c mlt-0.3.8.patched/src/modules/avformat/filter_avcolour_space.c
|
||||
--- mlt-0.3.8/src/modules/avformat/filter_avcolour_space.c 2009-03-10 06:55:27.000000000 +0100
|
||||
+++ mlt-0.3.8.patched/src/modules/avformat/filter_avcolour_space.c 2009-05-30 22:38:14.000000000 +0200
|
||||
@@ -22,9 +22,9 @@
|
||||
#include <framework/mlt_frame.h>
|
||||
|
||||
// ffmpeg Header files
|
||||
-#include <avformat.h>
|
||||
+#include <libavformat/avformat.h>
|
||||
#ifdef SWSCALE
|
||||
-#include <swscale.h>
|
||||
+#include <libswscale/swscale.h>
|
||||
#endif
|
||||
|
||||
#if LIBAVUTIL_VERSION_INT < (50<<16)
|
||||
diff -Nru mlt-0.3.8/src/modules/avformat/filter_avresample.c mlt-0.3.8.patched/src/modules/avformat/filter_avresample.c
|
||||
--- mlt-0.3.8/src/modules/avformat/filter_avresample.c 2008-02-02 07:07:30.000000000 +0100
|
||||
+++ mlt-0.3.8.patched/src/modules/avformat/filter_avresample.c 2009-05-30 22:38:31.000000000 +0200
|
||||
@@ -26,7 +26,7 @@
|
||||
#include <string.h>
|
||||
|
||||
// ffmpeg Header files
|
||||
-#include <avformat.h>
|
||||
+#include <libavformat/avformat.h>
|
||||
|
||||
/** Get the audio.
|
||||
*/
|
||||
diff -Nru mlt-0.3.8/src/modules/avformat/producer_avformat.c mlt-0.3.8.patched/src/modules/avformat/producer_avformat.c
|
||||
--- mlt-0.3.8/src/modules/avformat/producer_avformat.c 2009-04-09 09:17:17.000000000 +0200
|
||||
+++ mlt-0.3.8.patched/src/modules/avformat/producer_avformat.c 2009-05-30 22:39:05.000000000 +0200
|
||||
@@ -25,8 +25,8 @@
|
||||
#include <framework/mlt_profile.h>
|
||||
|
||||
// ffmpeg Header files
|
||||
-#include <avformat.h>
|
||||
-#include <opt.h>
|
||||
+#include <libavformat/avformat.h>
|
||||
+#include <opt.h>
|
||||
#ifdef SWSCALE
|
||||
# include <swscale.h>
|
||||
#endif
|
@ -1,40 +0,0 @@
|
||||
From 2125e3955a0d0be61571cf43b674f74b4b93c6f8 Mon Sep 17 00:00:00 2001
|
||||
From: Dan Dennedy <dan@dennedy.org>
|
||||
Date: Sat, 26 Aug 2017 18:31:47 -0700
|
||||
Subject: [PATCH] Fix #248 xlocale.h was removed in glibc 2.26.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Reported by schnitzeltony on Andreas Müller.
|
||||
Patch by Dave Plater.
|
||||
---
|
||||
src/framework/mlt_property.h | 8 ++++++--
|
||||
1 file changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/framework/mlt_property.h b/src/framework/mlt_property.h
|
||||
index 404d513f..043f530b 100644
|
||||
--- a/src/framework/mlt_property.h
|
||||
+++ b/src/framework/mlt_property.h
|
||||
@@ -3,7 +3,7 @@
|
||||
* \brief Property class declaration
|
||||
* \see mlt_property_s
|
||||
*
|
||||
- * Copyright (C) 2003-2014 Meltytech, LLC
|
||||
+ * Copyright (C) 2003-2017 Meltytech, LLC
|
||||
*
|
||||
* This library is free software; you can redistribute it and/or
|
||||
* modify it under the terms of the GNU Lesser General Public
|
||||
@@ -31,7 +31,11 @@
|
||||
#endif
|
||||
|
||||
#if defined(__GLIBC__) || defined(__APPLE__) || (__FreeBSD_version >= 900506)
|
||||
-#include <xlocale.h>
|
||||
+# if __GLIBC_MINOR__ >= 26 && !defined(__APPLE__)
|
||||
+# include <locale.h>
|
||||
+# else
|
||||
+# include <xlocale.h>
|
||||
+# endif
|
||||
#else
|
||||
typedef char* locale_t;
|
||||
#endif
|
28
mlt.spec
28
mlt.spec
@ -1,6 +1,6 @@
|
||||
%define apiver %(echo %version | cut -d. -f1)
|
||||
Name: mlt
|
||||
Version: 7.24.0
|
||||
Version: 7.26.0
|
||||
Release: 1mamba
|
||||
Summary: An open source multimedia framework, designed and developed for television broadcasting
|
||||
Group: Development/Tools
|
||||
@ -9,9 +9,6 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.mltframework.org
|
||||
Source: https://github.com/mltframework/mlt.git/v%{version}/mlt-%{version}.tar.bz2
|
||||
Patch0: %{name}-0.3.0-sox1420.patch
|
||||
Patch1: %{name}-0.3.8-ffmpeg-headers.patch
|
||||
Patch2: mlt-6.4.1-glibc-2.26.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -19,11 +16,11 @@ BuildRequires: libQt5Svg-devel
|
||||
BuildRequires: libSDL2-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libarchive-devel
|
||||
BuildRequires: libavcodec-ffmpeg-devel
|
||||
BuildRequires: libavdevice-ffmpeg-devel
|
||||
BuildRequires: libavfilter-ffmpeg-devel
|
||||
BuildRequires: libavformat-ffmpeg-devel
|
||||
BuildRequires: libavutil-ffmpeg-devel
|
||||
BuildRequires: libavcodec-devel
|
||||
BuildRequires: libavdevice-devel
|
||||
BuildRequires: libavfilter-devel
|
||||
BuildRequires: libavformat-devel
|
||||
BuildRequires: libavutil-devel
|
||||
BuildRequires: libebur128-devel
|
||||
BuildRequires: libexif-devel
|
||||
BuildRequires: libfftw-devel
|
||||
@ -35,6 +32,7 @@ BuildRequires: libglib-devel
|
||||
BuildRequires: libglvnd-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libjack-devel
|
||||
BuildRequires: liblilv-devel
|
||||
BuildRequires: libopencv-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpython311-devel
|
||||
@ -42,8 +40,8 @@ BuildRequires: librubberband-devel
|
||||
BuildRequires: libsamplerate-devel
|
||||
BuildRequires: libsdl12-compat-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libswresample-ffmpeg-devel
|
||||
BuildRequires: libswscale-ffmpeg-devel
|
||||
BuildRequires: libswresample-devel
|
||||
BuildRequires: libswscale-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
@ -104,7 +102,6 @@ This package contains the Python binding for %{name}.
|
||||
%prep
|
||||
%setup -q
|
||||
#-D -T
|
||||
#%patch2 -p1
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
@ -113,6 +110,8 @@ This package contains the Python binding for %{name}.
|
||||
-DMOD_GLAXNIMATE=ON \
|
||||
-DMOD_QT6=ON \
|
||||
-DSWIG_PYTHON=ON \
|
||||
-DPython3_EXECUTABLE=%{__python3} \
|
||||
-DPython3_LIBRARY=%{_libdir}/libpython%{python3_version}.so \
|
||||
-DMOD_RTAUDIO=OFF
|
||||
|
||||
%make
|
||||
@ -124,8 +123,6 @@ This package contains the Python binding for %{name}.
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n lib%{name} -p /sbin/ldconfig
|
||||
%postun -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
@ -162,6 +159,9 @@ This package contains the Python binding for %{name}.
|
||||
%{python3_sitearch}/mlt7.py
|
||||
|
||||
%changelog
|
||||
* Mon Aug 26 2024 Automatic Build System <autodist@openmamba.org> 7.26.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Apr 28 2024 Automatic Build System <autodist@openmamba.org> 7.24.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user