really rebuilt with sox 14.4 [release 0.8.8-3mamba;Thu Feb 28 2013]
This commit is contained in:
parent
1330994e85
commit
b12db65164
@ -1,2 +1,4 @@
|
|||||||
# mlt
|
# mlt
|
||||||
|
|
||||||
|
MLT is an open source multimedia framework, designed and developed for television broadcasting. It provides a toolkit for broadcasters, video editors, media players, transcoders, web streamers and many more types of applications. The functionality of the system is provided via an assortment of ready to use tools, xml authoring components, and an extendible plug-in based API.
|
||||||
|
|
||||||
|
19
mlt-0.3.0-sox1420.patch
Normal file
19
mlt-0.3.0-sox1420.patch
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
Index: mlt-0.3.0/src/modules/sox/filter_sox.c
|
||||||
|
===================================================================
|
||||||
|
--- mlt-0.3.0.orig/src/modules/sox/filter_sox.c
|
||||||
|
+++ mlt-0.3.0/src/modules/sox/filter_sox.c
|
||||||
|
@@ -33,9 +33,13 @@
|
||||||
|
# define ST_SUCCESS SOX_SUCCESS
|
||||||
|
# define st_sample_t sox_sample_t
|
||||||
|
# define eff_t sox_effect_t*
|
||||||
|
-# define st_size_t sox_size_t
|
||||||
|
# define ST_LIB_VERSION_CODE SOX_LIB_VERSION_CODE
|
||||||
|
# define ST_LIB_VERSION SOX_LIB_VERSION
|
||||||
|
+#if (ST_LIB_VERSION_CODE >= ST_LIB_VERSION(14,2,0))
|
||||||
|
+# define st_size_t size_t
|
||||||
|
+#else
|
||||||
|
+# define st_size_t sox_size_t
|
||||||
|
+#endif
|
||||||
|
# define ST_SIGNED_WORD_TO_SAMPLE(d,clips) SOX_SIGNED_16BIT_TO_SAMPLE(d,clips)
|
||||||
|
#if (ST_LIB_VERSION_CODE >= ST_LIB_VERSION(14,1,0))
|
||||||
|
# define ST_SSIZE_MIN SOX_SAMPLE_MIN
|
71
mlt-0.3.8-ffmpeg-headers.patch
Normal file
71
mlt-0.3.8-ffmpeg-headers.patch
Normal file
@ -0,0 +1,71 @@
|
|||||||
|
diff -Nru mlt-0.3.8/src/modules/avformat/consumer_avformat.c mlt-0.3.8.patched/src/modules/avformat/consumer_avformat.c
|
||||||
|
--- mlt-0.3.8/src/modules/avformat/consumer_avformat.c 2009-04-10 09:18:41.000000000 +0200
|
||||||
|
+++ mlt-0.3.8.patched/src/modules/avformat/consumer_avformat.c 2009-05-30 22:37:20.000000000 +0200
|
||||||
|
@@ -35,11 +35,11 @@
|
||||||
|
#include <unistd.h>
|
||||||
|
|
||||||
|
// avformat header files
|
||||||
|
-#include <avformat.h>
|
||||||
|
+#include <libavformat/avformat.h>
|
||||||
|
#ifdef SWSCALE
|
||||||
|
-#include <swscale.h>
|
||||||
|
+#include <libswscale/swscale.h>
|
||||||
|
#endif
|
||||||
|
-#include <opt.h>
|
||||||
|
+#include <opt.h>
|
||||||
|
|
||||||
|
#if LIBAVUTIL_VERSION_INT < (50<<16)
|
||||||
|
#define PIX_FMT_RGB32 PIX_FMT_RGBA32
|
||||||
|
diff -Nru mlt-0.3.8/src/modules/avformat/factory.c mlt-0.3.8.patched/src/modules/avformat/factory.c
|
||||||
|
--- mlt-0.3.8/src/modules/avformat/factory.c 2009-04-10 09:18:41.000000000 +0200
|
||||||
|
+++ mlt-0.3.8.patched/src/modules/avformat/factory.c 2009-05-30 22:37:53.000000000 +0200
|
||||||
|
@@ -32,7 +32,7 @@
|
||||||
|
extern mlt_producer producer_avformat_init( mlt_profile profile, char *file );
|
||||||
|
|
||||||
|
// ffmpeg Header files
|
||||||
|
-#include <avformat.h>
|
||||||
|
+#include <libavformat/avformat.h>
|
||||||
|
|
||||||
|
// A static flag used to determine if avformat has been initialised
|
||||||
|
static int avformat_initialised = 0;
|
||||||
|
diff -Nru mlt-0.3.8/src/modules/avformat/filter_avcolour_space.c mlt-0.3.8.patched/src/modules/avformat/filter_avcolour_space.c
|
||||||
|
--- mlt-0.3.8/src/modules/avformat/filter_avcolour_space.c 2009-03-10 06:55:27.000000000 +0100
|
||||||
|
+++ mlt-0.3.8.patched/src/modules/avformat/filter_avcolour_space.c 2009-05-30 22:38:14.000000000 +0200
|
||||||
|
@@ -22,9 +22,9 @@
|
||||||
|
#include <framework/mlt_frame.h>
|
||||||
|
|
||||||
|
// ffmpeg Header files
|
||||||
|
-#include <avformat.h>
|
||||||
|
+#include <libavformat/avformat.h>
|
||||||
|
#ifdef SWSCALE
|
||||||
|
-#include <swscale.h>
|
||||||
|
+#include <libswscale/swscale.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#if LIBAVUTIL_VERSION_INT < (50<<16)
|
||||||
|
diff -Nru mlt-0.3.8/src/modules/avformat/filter_avresample.c mlt-0.3.8.patched/src/modules/avformat/filter_avresample.c
|
||||||
|
--- mlt-0.3.8/src/modules/avformat/filter_avresample.c 2008-02-02 07:07:30.000000000 +0100
|
||||||
|
+++ mlt-0.3.8.patched/src/modules/avformat/filter_avresample.c 2009-05-30 22:38:31.000000000 +0200
|
||||||
|
@@ -26,7 +26,7 @@
|
||||||
|
#include <string.h>
|
||||||
|
|
||||||
|
// ffmpeg Header files
|
||||||
|
-#include <avformat.h>
|
||||||
|
+#include <libavformat/avformat.h>
|
||||||
|
|
||||||
|
/** Get the audio.
|
||||||
|
*/
|
||||||
|
diff -Nru mlt-0.3.8/src/modules/avformat/producer_avformat.c mlt-0.3.8.patched/src/modules/avformat/producer_avformat.c
|
||||||
|
--- mlt-0.3.8/src/modules/avformat/producer_avformat.c 2009-04-09 09:17:17.000000000 +0200
|
||||||
|
+++ mlt-0.3.8.patched/src/modules/avformat/producer_avformat.c 2009-05-30 22:39:05.000000000 +0200
|
||||||
|
@@ -25,8 +25,8 @@
|
||||||
|
#include <framework/mlt_profile.h>
|
||||||
|
|
||||||
|
// ffmpeg Header files
|
||||||
|
-#include <avformat.h>
|
||||||
|
-#include <opt.h>
|
||||||
|
+#include <libavformat/avformat.h>
|
||||||
|
+#include <opt.h>
|
||||||
|
#ifdef SWSCALE
|
||||||
|
# include <swscale.h>
|
||||||
|
#endif
|
163
mlt.spec
Normal file
163
mlt.spec
Normal file
@ -0,0 +1,163 @@
|
|||||||
|
Name: mlt
|
||||||
|
Version: 0.8.8
|
||||||
|
Release: 3mamba
|
||||||
|
Summary: An open source multimedia framework, designed and developed for television broadcasting
|
||||||
|
Group: Development/Tools
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.mltframework.org
|
||||||
|
Source: http://downloads.sourceforge.net/project/mlt/mlt/mlt-%{version}.tar.gz
|
||||||
|
Patch0: %{name}-0.3.0-sox1420.patch
|
||||||
|
Patch1: %{name}-0.3.8-ffmpeg-headers.patch
|
||||||
|
License: LGPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: kdelibs-devel
|
||||||
|
BuildRequires: libalsa-devel
|
||||||
|
BuildRequires: libavcodec-ffmpeg-devel
|
||||||
|
BuildRequires: libavdevice-ffmpeg-devel
|
||||||
|
BuildRequires: libavformat-ffmpeg-devel
|
||||||
|
BuildRequires: libavutil-ffmpeg-devel
|
||||||
|
BuildRequires: libcairo-devel
|
||||||
|
BuildRequires: libdv-devel
|
||||||
|
BuildRequires: libexif-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libgtk2-devel
|
||||||
|
BuildRequires: libjack-devel
|
||||||
|
BuildRequires: libpango-devel
|
||||||
|
BuildRequires: libqt4-devel
|
||||||
|
BuildRequires: libquicktime-devel
|
||||||
|
BuildRequires: libsamplerate-devel
|
||||||
|
BuildRequires: libSDL-devel
|
||||||
|
BuildRequires: libSDL_image-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libswfdec-devel
|
||||||
|
BuildRequires: libswscale-ffmpeg-devel
|
||||||
|
BuildRequires: libvorbis-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libxml2-devel
|
||||||
|
BuildRequires: sox-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: ladspa-devel
|
||||||
|
BuildRequires: frei0r-plugins-devel
|
||||||
|
Provides: libmlt++
|
||||||
|
Obsoletes: libmlt++
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
MLT is an open source multimedia framework, designed and developed for television broadcasting. It provides a toolkit for broadcasters, video editors, media players, transcoders, web streamers and many more types of applications. The functionality of the system is provided via an assortment of ready to use tools, xml authoring components, and an extendible plug-in based API.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: An open source multimedia framework, designed and developed for television broadcasting
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Provides: libmlt++-devel
|
||||||
|
Obsoletes: libmlt++-devel
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
MLT is an open source multimedia framework, designed and developed for television broadcasting. It provides a toolkit for broadcasters, video editors, media players, transcoders, web streamers and many more types of applications. The functionality of the system is provided via an assortment of ready to use tools, xml authoring components, and an extendible plug-in based API.
|
||||||
|
This package contains static files and headers used for development.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
|
||||||
|
%setup -q
|
||||||
|
|
||||||
|
%build
|
||||||
|
export KDEDIR=%{kdedir}
|
||||||
|
%configure \
|
||||||
|
--enable-gpl \
|
||||||
|
--enable-motion-est \
|
||||||
|
--avformat-swscale \
|
||||||
|
--qimage-libdir=%_qt4_libdir \
|
||||||
|
--qimage-includedir=%_qt4_headerdir
|
||||||
|
|
||||||
|
CFLAGS="-I%{_includedir}/ffmpeg" %make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/melt
|
||||||
|
%dir %{_datadir}/mlt
|
||||||
|
%{_datadir}/mlt/*
|
||||||
|
%{_libdir}/libmlt.so.*
|
||||||
|
%{_libdir}/libmlt++.so.*
|
||||||
|
%{_libdir}/mlt/*.so
|
||||||
|
%doc COPYING ChangeLog README
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_includedir}/mlt/framework/*.h
|
||||||
|
%{_includedir}/mlt++/config.h
|
||||||
|
%{_includedir}/mlt++/Mlt*.h
|
||||||
|
%{_libdir}/pkgconfig/mlt-framework.pc
|
||||||
|
%{_libdir}/pkgconfig/mlt++.pc
|
||||||
|
%{_libdir}/libmlt.so
|
||||||
|
%{_libdir}/libmlt++.so
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Feb 28 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.8-3mamba
|
||||||
|
- really rebuilt with sox 14.4
|
||||||
|
|
||||||
|
* Thu Feb 28 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.8-2mamba
|
||||||
|
- rebuilt with sox 14.4
|
||||||
|
|
||||||
|
* Fri Feb 01 2013 Automatic Build System <autodist@mambasoft.it> 0.8.8-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri May 18 2012 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 0.7.8-1mamba
|
||||||
|
- update to 0.7.8
|
||||||
|
|
||||||
|
* Thu Jul 28 2011 Automatic Build System <autodist@mambasoft.it> 0.7.4-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sat Jun 25 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.7.2-1mamba
|
||||||
|
- update to 0.7.2
|
||||||
|
|
||||||
|
* Wed Jun 30 2010 Automatic Build System <autodist@mambasoft.it> 0.4.10-3mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Wed Jun 09 2010 Automatic Build System <autodist@mambasoft.it> 0.4.10-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Tue May 11 2010 Automatic Build System <autodist@mambasoft.it> 0.4.10-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Mon Dec 07 2009 Automatic Build System <autodist@mambasoft.it> 0.4.6-1mamba
|
||||||
|
- update to 0.4.6
|
||||||
|
|
||||||
|
* Mon Jul 13 2009 Automatic Build System <autodist@mambasoft.it> 0.4.4-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sat May 30 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.8-1mamba
|
||||||
|
- update to 0.3.8
|
||||||
|
- added configure option --avformat-swscale (http://bugs.archlinux.org/task/8531)
|
||||||
|
|
||||||
|
* Mon Mar 02 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.6-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Wed Dec 10 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.2-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Wed Nov 19 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.2-1mamba
|
||||||
|
- update to 0.3.2
|
||||||
|
|
||||||
|
* Wed Nov 19 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.5-3mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Mon Jun 02 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.5-2mamba
|
||||||
|
- rebuilt against updated libdc1394
|
||||||
|
|
||||||
|
* Wed Apr 02 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.5-1mamba
|
||||||
|
- update to 0.2.5 (svn20080402)
|
||||||
|
|
||||||
|
* Mon Mar 31 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.4-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user