mjpegtools/mjpegtools-1.9.0-kernel-2.6.38.patch

185 lines
9.1 KiB
Diff

diff -ur mjpegtools-1.9.0.orig/configure.ac mjpegtools-1.9.0/configure.ac
--- mjpegtools-1.9.0.orig/configure.ac 2011-07-07 11:07:45.211089635 +0200
+++ mjpegtools-1.9.0/configure.ac 2011-07-07 11:18:42.513089556 +0200
@@ -155,11 +155,11 @@
have_video4linux=false
case $host in
*-*-linux*)
- AC_CHECK_HEADER(linux/videodev.h,
+ AC_CHECK_HEADER(libv4l1-videodev.h,
[have_video4linux=true
AC_DEFINE(HAVE_V4L, 1,
[Building for Linux - using the video4linux API])],
- [AC_MSG_ERROR([videodev.h not found - please install the linux kernel headers])])
+ [AC_MSG_ERROR([libv4l1-videodev.h not found - please install the v4l-utils devel package])])
;;
esac
AM_CONDITIONAL(HAVE_V4L, test x$have_video4linux = xtrue)
diff -ur mjpegtools-1.9.0.orig/lavtools/lavvideo.c mjpegtools-1.9.0/lavtools/lavvideo.c
--- mjpegtools-1.9.0.orig/lavtools/lavvideo.c 2011-07-07 11:07:45.220089635 +0200
+++ mjpegtools-1.9.0/lavtools/lavvideo.c 2011-07-07 11:18:27.601089556 +0200
@@ -63,7 +63,7 @@
* errors here, check your linux/time.h && sys/time.h header setup.
*/
#define _LINUX_TIME_H
-#include <linux/videodev.h>
+#include <libv4l1-videodev.h>
#include <videodev_mjpeg.h>
#include <frequencies.h>
diff -ur mjpegtools-1.9.0.orig/lavtools/liblavplay.c mjpegtools-1.9.0/lavtools/liblavplay.c
--- mjpegtools-1.9.0.orig/lavtools/liblavplay.c 2011-07-07 11:07:45.221089635 +0200
+++ mjpegtools-1.9.0/lavtools/liblavplay.c 2011-07-07 11:16:01.227089575 +0200
@@ -68,7 +68,8 @@
* errors here, check your linux/time.h && sys/time.h header setup.
*/
#define _LINUX_TIME_H
-#include <linux/videodev.h>
+#include <libv4l1-videodev.h>
+#define BASE_VIDIOCPRIVATE 192 /* 192-255 are private */
#else
#define VIDEO_MODE_PAL 0
#define VIDEO_MODE_NTSC 1
diff -ur mjpegtools-1.9.0.orig/lavtools/liblavrec.c mjpegtools-1.9.0/lavtools/liblavrec.c
--- mjpegtools-1.9.0.orig/lavtools/liblavrec.c 2011-07-07 11:07:45.221089635 +0200
+++ mjpegtools-1.9.0/lavtools/liblavrec.c 2011-07-07 11:16:18.362089573 +0200
@@ -63,7 +63,8 @@
* errors here, check your linux/time.h && sys/time.h header setup.
*/
#define _LINUX_TIME_H
-#include <linux/videodev.h>
+#include <libv4l1-videodev.h>
+#define BASE_VIDIOCPRIVATE 192 /* 192-255 are private */
#ifdef HAVE_SYS_SOUNDCARD_H
#include <sys/soundcard.h>
#endif
diff -ur mjpegtools-1.9.0.orig/lavtools/testrec.c mjpegtools-1.9.0/lavtools/testrec.c
--- mjpegtools-1.9.0.orig/lavtools/testrec.c 2011-07-07 11:07:45.220089635 +0200
+++ mjpegtools-1.9.0/lavtools/testrec.c 2011-07-07 11:19:56.128089546 +0200
@@ -89,7 +89,7 @@
* errors here, check your linux/time.h && sys/time.h header setup.
*/
#define _LINUX_TIME_H
-#include <linux/videodev.h>
+#include <libv4l1-videodev.h>
#include <linux/soundcard.h>
/* These are explicit prototypes for the compiler, to prepare separation of audiolib.c */
diff -Nru mjpegtools-1.9.0.orig/configure mjpegtools-1.9.0/configure
--- mjpegtools-1.9.0.orig/configure 2009-01-06 07:49:27.000000000 +0100
+++ mjpegtools-1.9.0/configure 2011-12-16 13:56:41.747369367 +0100
@@ -22636,8 +22636,8 @@
case $host in
*-*-linux*)
if test "${ac_cv_header_linux_videodev_h+set}" = set; then
- { echo "$as_me:$LINENO: checking for linux/videodev.h" >&5
-echo $ECHO_N "checking for linux/videodev.h... $ECHO_C" >&6; }
+ { echo "$as_me:$LINENO: checking for libv4l1-videodev.h" >&5
+echo $ECHO_N "checking for libv4l1-videodev.h... $ECHO_C" >&6; }
if test "${ac_cv_header_linux_videodev_h+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
fi
@@ -22645,8 +22645,8 @@
echo "${ECHO_T}$ac_cv_header_linux_videodev_h" >&6; }
else
# Is the header compilable?
-{ echo "$as_me:$LINENO: checking linux/videodev.h usability" >&5
-echo $ECHO_N "checking linux/videodev.h usability... $ECHO_C" >&6; }
+{ echo "$as_me:$LINENO: checking libv4l1-videodev.h usability" >&5
+echo $ECHO_N "checking libv4l1-videodev.h usability... $ECHO_C" >&6; }
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -22654,7 +22654,7 @@
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
$ac_includes_default
-#include <linux/videodev.h>
+#include <libv4l1-videodev.h>
_ACEOF
rm -f conftest.$ac_objext
if { (ac_try="$ac_compile"
@@ -22686,15 +22686,15 @@
echo "${ECHO_T}$ac_header_compiler" >&6; }
# Is the header present?
-{ echo "$as_me:$LINENO: checking linux/videodev.h presence" >&5
-echo $ECHO_N "checking linux/videodev.h presence... $ECHO_C" >&6; }
+{ echo "$as_me:$LINENO: checking libv4l1-videodev.h presence" >&5
+echo $ECHO_N "checking libv4l1-videodev.h presence... $ECHO_C" >&6; }
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
-#include <linux/videodev.h>
+#include <libv4l1-videodev.h>
_ACEOF
if { (ac_try="$ac_cpp conftest.$ac_ext"
case "(($ac_try" in
@@ -22727,25 +22727,25 @@
# So? What about this header?
case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
yes:no: )
- { echo "$as_me:$LINENO: WARNING: linux/videodev.h: accepted by the compiler, rejected by the preprocessor!" >&5
-echo "$as_me: WARNING: linux/videodev.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
- { echo "$as_me:$LINENO: WARNING: linux/videodev.h: proceeding with the compiler's result" >&5
-echo "$as_me: WARNING: linux/videodev.h: proceeding with the compiler's result" >&2;}
+ { echo "$as_me:$LINENO: WARNING: libv4l1-videodev.h: accepted by the compiler, rejected by the preprocessor!" >&5
+echo "$as_me: WARNING: libv4l1-videodev.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
+ { echo "$as_me:$LINENO: WARNING: libv4l1-videodev.h: proceeding with the compiler's result" >&5
+echo "$as_me: WARNING: libv4l1-videodev.h: proceeding with the compiler's result" >&2;}
ac_header_preproc=yes
;;
no:yes:* )
- { echo "$as_me:$LINENO: WARNING: linux/videodev.h: present but cannot be compiled" >&5
-echo "$as_me: WARNING: linux/videodev.h: present but cannot be compiled" >&2;}
- { echo "$as_me:$LINENO: WARNING: linux/videodev.h: check for missing prerequisite headers?" >&5
-echo "$as_me: WARNING: linux/videodev.h: check for missing prerequisite headers?" >&2;}
- { echo "$as_me:$LINENO: WARNING: linux/videodev.h: see the Autoconf documentation" >&5
-echo "$as_me: WARNING: linux/videodev.h: see the Autoconf documentation" >&2;}
- { echo "$as_me:$LINENO: WARNING: linux/videodev.h: section \"Present But Cannot Be Compiled\"" >&5
-echo "$as_me: WARNING: linux/videodev.h: section \"Present But Cannot Be Compiled\"" >&2;}
- { echo "$as_me:$LINENO: WARNING: linux/videodev.h: proceeding with the preprocessor's result" >&5
-echo "$as_me: WARNING: linux/videodev.h: proceeding with the preprocessor's result" >&2;}
- { echo "$as_me:$LINENO: WARNING: linux/videodev.h: in the future, the compiler will take precedence" >&5
-echo "$as_me: WARNING: linux/videodev.h: in the future, the compiler will take precedence" >&2;}
+ { echo "$as_me:$LINENO: WARNING: libv4l1-videodev.h: present but cannot be compiled" >&5
+echo "$as_me: WARNING: libv4l1-videodev.h: present but cannot be compiled" >&2;}
+ { echo "$as_me:$LINENO: WARNING: libv4l1-videodev.h: check for missing prerequisite headers?" >&5
+echo "$as_me: WARNING: libv4l1-videodev.h: check for missing prerequisite headers?" >&2;}
+ { echo "$as_me:$LINENO: WARNING: libv4l1-videodev.h: see the Autoconf documentation" >&5
+echo "$as_me: WARNING: libv4l1-videodev.h: see the Autoconf documentation" >&2;}
+ { echo "$as_me:$LINENO: WARNING: libv4l1-videodev.h: section \"Present But Cannot Be Compiled\"" >&5
+echo "$as_me: WARNING: libv4l1-videodev.h: section \"Present But Cannot Be Compiled\"" >&2;}
+ { echo "$as_me:$LINENO: WARNING: libv4l1-videodev.h: proceeding with the preprocessor's result" >&5
+echo "$as_me: WARNING: libv4l1-videodev.h: proceeding with the preprocessor's result" >&2;}
+ { echo "$as_me:$LINENO: WARNING: libv4l1-videodev.h: in the future, the compiler will take precedence" >&5
+echo "$as_me: WARNING: libv4l1-videodev.h: in the future, the compiler will take precedence" >&2;}
( cat <<\_ASBOX
## ---------------------------------------------------- ##
## Report this to mjpeg-developer@lists.sourceforge.net ##
@@ -22754,8 +22754,8 @@
) | sed "s/^/$as_me: WARNING: /" >&2
;;
esac
-{ echo "$as_me:$LINENO: checking for linux/videodev.h" >&5
-echo $ECHO_N "checking for linux/videodev.h... $ECHO_C" >&6; }
+{ echo "$as_me:$LINENO: checking for libv4l1-videodev.h" >&5
+echo $ECHO_N "checking for libv4l1-videodev.h... $ECHO_C" >&6; }
if test "${ac_cv_header_linux_videodev_h+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
@@ -22773,8 +22773,8 @@
_ACEOF
else
- { { echo "$as_me:$LINENO: error: videodev.h not found - please install the linux kernel headers" >&5
-echo "$as_me: error: videodev.h not found - please install the linux kernel headers" >&2;}
+ { { echo "$as_me:$LINENO: error: libv4l1-videodev.h not found - please install the linux kernel headers" >&5
+echo "$as_me: error: libv4l1-videodev.h not found - please install the linux kernel headers" >&2;}
{ (exit 1); exit 1; }; }
fi