rebuilt to remove .la files [release 2.2.1-3mamba;Wed Jun 19 2024]
This commit is contained in:
parent
20bd6cb9e3
commit
629f070fb6
@ -1,12 +0,0 @@
|
||||
diff -Nru mjpegtools-1.8.0.orig/jpeg-mmx/jquant_x86simd.c mjpegtools-1.8.0/jpeg-mmx/jquant_x86simd.c
|
||||
--- mjpegtools-1.8.0.orig/jpeg-mmx/jquant_x86simd.c 2003-08-02 06:31:28.000000000 +0200
|
||||
+++ mjpegtools-1.8.0/jpeg-mmx/jquant_x86simd.c 2008-06-01 16:38:25.000000000 +0200
|
||||
@@ -104,7 +104,7 @@
|
||||
|
||||
/* Initialise zero block flags */
|
||||
/* Set up SSE rounding mode */
|
||||
- __asm__ ( "ldmxcsr %0\n" : : "X" (trunc_mxcsr) );
|
||||
+ __asm__ ( "ldmxcsr %0\n" : : "m" (*&trunc_mxcsr) );
|
||||
|
||||
for (i=0; i < 64 ; i+=4)
|
||||
{
|
@ -1,11 +0,0 @@
|
||||
--- mjpegtools-1.8.0/lavtools/lav_io.c.orig 2006-10-09 12:15:55.000000000 +0200
|
||||
+++ mjpegtools-1.8.0/lavtools/lav_io.c 2006-10-09 12:19:35.000000000 +0200
|
||||
@@ -1367,7 +1367,7 @@
|
||||
break;
|
||||
#ifdef HAVE_LIBQUICKTIME
|
||||
case 'q':
|
||||
- res = fileno(((quicktime_t *)lav_file->qt_fd)->stream);
|
||||
+ res = lqt_fileno((quicktime_t *)lav_file->qt_fd);
|
||||
break;
|
||||
#endif
|
||||
default:
|
@ -1,184 +0,0 @@
|
||||
diff -ur mjpegtools-1.9.0.orig/configure.ac mjpegtools-1.9.0/configure.ac
|
||||
--- mjpegtools-1.9.0.orig/configure.ac 2011-07-07 11:07:45.211089635 +0200
|
||||
+++ mjpegtools-1.9.0/configure.ac 2011-07-07 11:18:42.513089556 +0200
|
||||
@@ -155,11 +155,11 @@
|
||||
have_video4linux=false
|
||||
case $host in
|
||||
*-*-linux*)
|
||||
- AC_CHECK_HEADER(linux/videodev.h,
|
||||
+ AC_CHECK_HEADER(libv4l1-videodev.h,
|
||||
[have_video4linux=true
|
||||
AC_DEFINE(HAVE_V4L, 1,
|
||||
[Building for Linux - using the video4linux API])],
|
||||
- [AC_MSG_ERROR([videodev.h not found - please install the linux kernel headers])])
|
||||
+ [AC_MSG_ERROR([libv4l1-videodev.h not found - please install the v4l-utils devel package])])
|
||||
;;
|
||||
esac
|
||||
AM_CONDITIONAL(HAVE_V4L, test x$have_video4linux = xtrue)
|
||||
diff -ur mjpegtools-1.9.0.orig/lavtools/lavvideo.c mjpegtools-1.9.0/lavtools/lavvideo.c
|
||||
--- mjpegtools-1.9.0.orig/lavtools/lavvideo.c 2011-07-07 11:07:45.220089635 +0200
|
||||
+++ mjpegtools-1.9.0/lavtools/lavvideo.c 2011-07-07 11:18:27.601089556 +0200
|
||||
@@ -63,7 +63,7 @@
|
||||
* errors here, check your linux/time.h && sys/time.h header setup.
|
||||
*/
|
||||
#define _LINUX_TIME_H
|
||||
-#include <linux/videodev.h>
|
||||
+#include <libv4l1-videodev.h>
|
||||
|
||||
#include <videodev_mjpeg.h>
|
||||
#include <frequencies.h>
|
||||
diff -ur mjpegtools-1.9.0.orig/lavtools/liblavplay.c mjpegtools-1.9.0/lavtools/liblavplay.c
|
||||
--- mjpegtools-1.9.0.orig/lavtools/liblavplay.c 2011-07-07 11:07:45.221089635 +0200
|
||||
+++ mjpegtools-1.9.0/lavtools/liblavplay.c 2011-07-07 11:16:01.227089575 +0200
|
||||
@@ -68,7 +68,8 @@
|
||||
* errors here, check your linux/time.h && sys/time.h header setup.
|
||||
*/
|
||||
#define _LINUX_TIME_H
|
||||
-#include <linux/videodev.h>
|
||||
+#include <libv4l1-videodev.h>
|
||||
+#define BASE_VIDIOCPRIVATE 192 /* 192-255 are private */
|
||||
#else
|
||||
#define VIDEO_MODE_PAL 0
|
||||
#define VIDEO_MODE_NTSC 1
|
||||
diff -ur mjpegtools-1.9.0.orig/lavtools/liblavrec.c mjpegtools-1.9.0/lavtools/liblavrec.c
|
||||
--- mjpegtools-1.9.0.orig/lavtools/liblavrec.c 2011-07-07 11:07:45.221089635 +0200
|
||||
+++ mjpegtools-1.9.0/lavtools/liblavrec.c 2011-07-07 11:16:18.362089573 +0200
|
||||
@@ -63,7 +63,8 @@
|
||||
* errors here, check your linux/time.h && sys/time.h header setup.
|
||||
*/
|
||||
#define _LINUX_TIME_H
|
||||
-#include <linux/videodev.h>
|
||||
+#include <libv4l1-videodev.h>
|
||||
+#define BASE_VIDIOCPRIVATE 192 /* 192-255 are private */
|
||||
#ifdef HAVE_SYS_SOUNDCARD_H
|
||||
#include <sys/soundcard.h>
|
||||
#endif
|
||||
diff -ur mjpegtools-1.9.0.orig/lavtools/testrec.c mjpegtools-1.9.0/lavtools/testrec.c
|
||||
--- mjpegtools-1.9.0.orig/lavtools/testrec.c 2011-07-07 11:07:45.220089635 +0200
|
||||
+++ mjpegtools-1.9.0/lavtools/testrec.c 2011-07-07 11:19:56.128089546 +0200
|
||||
@@ -89,7 +89,7 @@
|
||||
* errors here, check your linux/time.h && sys/time.h header setup.
|
||||
*/
|
||||
#define _LINUX_TIME_H
|
||||
-#include <linux/videodev.h>
|
||||
+#include <libv4l1-videodev.h>
|
||||
#include <linux/soundcard.h>
|
||||
|
||||
/* These are explicit prototypes for the compiler, to prepare separation of audiolib.c */
|
||||
diff -Nru mjpegtools-1.9.0.orig/configure mjpegtools-1.9.0/configure
|
||||
--- mjpegtools-1.9.0.orig/configure 2009-01-06 07:49:27.000000000 +0100
|
||||
+++ mjpegtools-1.9.0/configure 2011-12-16 13:56:41.747369367 +0100
|
||||
@@ -22636,8 +22636,8 @@
|
||||
case $host in
|
||||
*-*-linux*)
|
||||
if test "${ac_cv_header_linux_videodev_h+set}" = set; then
|
||||
- { echo "$as_me:$LINENO: checking for linux/videodev.h" >&5
|
||||
-echo $ECHO_N "checking for linux/videodev.h... $ECHO_C" >&6; }
|
||||
+ { echo "$as_me:$LINENO: checking for libv4l1-videodev.h" >&5
|
||||
+echo $ECHO_N "checking for libv4l1-videodev.h... $ECHO_C" >&6; }
|
||||
if test "${ac_cv_header_linux_videodev_h+set}" = set; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
fi
|
||||
@@ -22645,8 +22645,8 @@
|
||||
echo "${ECHO_T}$ac_cv_header_linux_videodev_h" >&6; }
|
||||
else
|
||||
# Is the header compilable?
|
||||
-{ echo "$as_me:$LINENO: checking linux/videodev.h usability" >&5
|
||||
-echo $ECHO_N "checking linux/videodev.h usability... $ECHO_C" >&6; }
|
||||
+{ echo "$as_me:$LINENO: checking libv4l1-videodev.h usability" >&5
|
||||
+echo $ECHO_N "checking libv4l1-videodev.h usability... $ECHO_C" >&6; }
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
||||
_ACEOF
|
||||
@@ -22654,7 +22654,7 @@
|
||||
cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
$ac_includes_default
|
||||
-#include <linux/videodev.h>
|
||||
+#include <libv4l1-videodev.h>
|
||||
_ACEOF
|
||||
rm -f conftest.$ac_objext
|
||||
if { (ac_try="$ac_compile"
|
||||
@@ -22686,15 +22686,15 @@
|
||||
echo "${ECHO_T}$ac_header_compiler" >&6; }
|
||||
|
||||
# Is the header present?
|
||||
-{ echo "$as_me:$LINENO: checking linux/videodev.h presence" >&5
|
||||
-echo $ECHO_N "checking linux/videodev.h presence... $ECHO_C" >&6; }
|
||||
+{ echo "$as_me:$LINENO: checking libv4l1-videodev.h presence" >&5
|
||||
+echo $ECHO_N "checking libv4l1-videodev.h presence... $ECHO_C" >&6; }
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
||||
_ACEOF
|
||||
cat confdefs.h >>conftest.$ac_ext
|
||||
cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
-#include <linux/videodev.h>
|
||||
+#include <libv4l1-videodev.h>
|
||||
_ACEOF
|
||||
if { (ac_try="$ac_cpp conftest.$ac_ext"
|
||||
case "(($ac_try" in
|
||||
@@ -22727,25 +22727,25 @@
|
||||
# So? What about this header?
|
||||
case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
|
||||
yes:no: )
|
||||
- { echo "$as_me:$LINENO: WARNING: linux/videodev.h: accepted by the compiler, rejected by the preprocessor!" >&5
|
||||
-echo "$as_me: WARNING: linux/videodev.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
|
||||
- { echo "$as_me:$LINENO: WARNING: linux/videodev.h: proceeding with the compiler's result" >&5
|
||||
-echo "$as_me: WARNING: linux/videodev.h: proceeding with the compiler's result" >&2;}
|
||||
+ { echo "$as_me:$LINENO: WARNING: libv4l1-videodev.h: accepted by the compiler, rejected by the preprocessor!" >&5
|
||||
+echo "$as_me: WARNING: libv4l1-videodev.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
|
||||
+ { echo "$as_me:$LINENO: WARNING: libv4l1-videodev.h: proceeding with the compiler's result" >&5
|
||||
+echo "$as_me: WARNING: libv4l1-videodev.h: proceeding with the compiler's result" >&2;}
|
||||
ac_header_preproc=yes
|
||||
;;
|
||||
no:yes:* )
|
||||
- { echo "$as_me:$LINENO: WARNING: linux/videodev.h: present but cannot be compiled" >&5
|
||||
-echo "$as_me: WARNING: linux/videodev.h: present but cannot be compiled" >&2;}
|
||||
- { echo "$as_me:$LINENO: WARNING: linux/videodev.h: check for missing prerequisite headers?" >&5
|
||||
-echo "$as_me: WARNING: linux/videodev.h: check for missing prerequisite headers?" >&2;}
|
||||
- { echo "$as_me:$LINENO: WARNING: linux/videodev.h: see the Autoconf documentation" >&5
|
||||
-echo "$as_me: WARNING: linux/videodev.h: see the Autoconf documentation" >&2;}
|
||||
- { echo "$as_me:$LINENO: WARNING: linux/videodev.h: section \"Present But Cannot Be Compiled\"" >&5
|
||||
-echo "$as_me: WARNING: linux/videodev.h: section \"Present But Cannot Be Compiled\"" >&2;}
|
||||
- { echo "$as_me:$LINENO: WARNING: linux/videodev.h: proceeding with the preprocessor's result" >&5
|
||||
-echo "$as_me: WARNING: linux/videodev.h: proceeding with the preprocessor's result" >&2;}
|
||||
- { echo "$as_me:$LINENO: WARNING: linux/videodev.h: in the future, the compiler will take precedence" >&5
|
||||
-echo "$as_me: WARNING: linux/videodev.h: in the future, the compiler will take precedence" >&2;}
|
||||
+ { echo "$as_me:$LINENO: WARNING: libv4l1-videodev.h: present but cannot be compiled" >&5
|
||||
+echo "$as_me: WARNING: libv4l1-videodev.h: present but cannot be compiled" >&2;}
|
||||
+ { echo "$as_me:$LINENO: WARNING: libv4l1-videodev.h: check for missing prerequisite headers?" >&5
|
||||
+echo "$as_me: WARNING: libv4l1-videodev.h: check for missing prerequisite headers?" >&2;}
|
||||
+ { echo "$as_me:$LINENO: WARNING: libv4l1-videodev.h: see the Autoconf documentation" >&5
|
||||
+echo "$as_me: WARNING: libv4l1-videodev.h: see the Autoconf documentation" >&2;}
|
||||
+ { echo "$as_me:$LINENO: WARNING: libv4l1-videodev.h: section \"Present But Cannot Be Compiled\"" >&5
|
||||
+echo "$as_me: WARNING: libv4l1-videodev.h: section \"Present But Cannot Be Compiled\"" >&2;}
|
||||
+ { echo "$as_me:$LINENO: WARNING: libv4l1-videodev.h: proceeding with the preprocessor's result" >&5
|
||||
+echo "$as_me: WARNING: libv4l1-videodev.h: proceeding with the preprocessor's result" >&2;}
|
||||
+ { echo "$as_me:$LINENO: WARNING: libv4l1-videodev.h: in the future, the compiler will take precedence" >&5
|
||||
+echo "$as_me: WARNING: libv4l1-videodev.h: in the future, the compiler will take precedence" >&2;}
|
||||
( cat <<\_ASBOX
|
||||
## ---------------------------------------------------- ##
|
||||
## Report this to mjpeg-developer@lists.sourceforge.net ##
|
||||
@@ -22754,8 +22754,8 @@
|
||||
) | sed "s/^/$as_me: WARNING: /" >&2
|
||||
;;
|
||||
esac
|
||||
-{ echo "$as_me:$LINENO: checking for linux/videodev.h" >&5
|
||||
-echo $ECHO_N "checking for linux/videodev.h... $ECHO_C" >&6; }
|
||||
+{ echo "$as_me:$LINENO: checking for libv4l1-videodev.h" >&5
|
||||
+echo $ECHO_N "checking for libv4l1-videodev.h... $ECHO_C" >&6; }
|
||||
if test "${ac_cv_header_linux_videodev_h+set}" = set; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
@@ -22773,8 +22773,8 @@
|
||||
_ACEOF
|
||||
|
||||
else
|
||||
- { { echo "$as_me:$LINENO: error: videodev.h not found - please install the linux kernel headers" >&5
|
||||
-echo "$as_me: error: videodev.h not found - please install the linux kernel headers" >&2;}
|
||||
+ { { echo "$as_me:$LINENO: error: libv4l1-videodev.h not found - please install the linux kernel headers" >&5
|
||||
+echo "$as_me: error: libv4l1-videodev.h not found - please install the linux kernel headers" >&2;}
|
||||
{ (exit 1); exit 1; }; }
|
||||
fi
|
||||
|
@ -1,50 +0,0 @@
|
||||
diff -ru mjpegtools-2.1.0/y4mdenoise/Makefile.am new/y4mdenoise/Makefile.am
|
||||
--- mjpegtools-2.1.0/y4mdenoise/Makefile.am 2012-04-01 10:43:55.000000000 +0200
|
||||
+++ new/y4mdenoise/Makefile.am 2018-09-04 02:00:06.296975920 +0200
|
||||
@@ -4,8 +4,8 @@
|
||||
|
||||
EXTRA_DIST = implementation.html
|
||||
|
||||
-AM_CFLAGS = -DNDEBUG -finline-functions @PROGRAM_NOPIC@
|
||||
-AM_CXXFLAGS = -DNDEBUG -finline-functions @PROGRAM_NOPIC@
|
||||
+AM_CFLAGS = -DNDEBUG -finline-functions
|
||||
+AM_CXXFLAGS = -DNDEBUG -finline-functions
|
||||
|
||||
INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/utils
|
||||
|
||||
diff -ru mjpegtools-2.1.0/y4munsharp/Makefile.am new/y4munsharp/Makefile.am
|
||||
--- mjpegtools-2.1.0/y4munsharp/Makefile.am 2005-06-16 19:09:38.000000000 +0200
|
||||
+++ new/y4munsharp/Makefile.am 2018-09-04 01:59:37.330309169 +0200
|
||||
@@ -4,7 +4,7 @@
|
||||
|
||||
INCLUDES = -I $(top_srcdir)/utils -I $(top_srcdir)
|
||||
|
||||
-y4munharp_CFLAGS=@PROGRAM_NOPIC@
|
||||
+y4munharp_CFLAGS=
|
||||
|
||||
bin_PROGRAMS = y4munsharp
|
||||
|
||||
diff -ru mjpegtools-2.1.0/y4mutils/Makefile.am new/y4mutils/Makefile.am
|
||||
--- mjpegtools-2.1.0/y4mutils/Makefile.am 2012-04-01 10:43:35.000000000 +0200
|
||||
+++ new/y4mutils/Makefile.am 2018-09-04 01:58:58.273642386 +0200
|
||||
@@ -1,8 +1,7 @@
|
||||
# Makefile for y4mutils
|
||||
|
||||
MAINTAINERCLEANFILES = Makefile.in
|
||||
-
|
||||
-AM_CFLAGS = @PROGRAM_NOPIC@
|
||||
+AM_CFLAGS=
|
||||
AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/utils
|
||||
|
||||
LIBMJPEGUTILS = $(top_builddir)/utils/libmjpegutils.la
|
||||
diff -ru mjpegtools-2.1.0/yuvscaler/Makefile.am new/yuvscaler/Makefile.am
|
||||
--- mjpegtools-2.1.0/yuvscaler/Makefile.am 2012-04-01 10:44:27.000000000 +0200
|
||||
+++ new/yuvscaler/Makefile.am 2018-09-04 02:00:06.296975920 +0200
|
||||
@@ -18,6 +18,6 @@
|
||||
|
||||
EXTRA_DIST = yuvscaler_implementation.txt
|
||||
|
||||
-yuvscaler_CFLAGS=@PROGRAM_NOPIC@
|
||||
+yuvscaler_CFLAGS=
|
||||
yuvscaler_SOURCES = yuvscaler.c yuvscaler_resample.c yuvscaler_bicubic.c
|
||||
yuvscaler_LDADD = $(LIBMJPEGUTILS) $(LIBM_LIBS)
|
@ -2,7 +2,7 @@
|
||||
|
||||
Name: mjpegtools
|
||||
Version: 2.2.1
|
||||
Release: 2mamba
|
||||
Release: 3mamba
|
||||
Summary: Tools for recording, editing, playing and encoding mpeg video
|
||||
Group: Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
@ -11,43 +11,28 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://mjpeg.sourceforge.io/
|
||||
Source0: http://downloads.sourceforge.net/sourceforge/mjpeg/mjpegtools-%{version}.tar.gz
|
||||
Source1: http://downloads.sourceforge.net/sourceforge/mjpeg/jpeg-mmx-%{jpegmmx_version}.tar.gz
|
||||
Patch: %{name}-1.8.0-libquicktime.patch
|
||||
Patch1: %{name}-1.8.0-gcc42.patch
|
||||
Patch2: %{name}-1.9.0-kernel-2.6.38.patch
|
||||
Patch3: mjpegtools-2.1.0-avoid-fno-pic.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libSDL-devel
|
||||
BuildRequires: libSDL_gfx-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libbrotli-devel
|
||||
BuildRequires: libbsd-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libat-spi2-core-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libdirectfb-devel
|
||||
BuildRequires: libdv-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libfaad2-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libgtk2-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libquicktime-devel
|
||||
BuildRequires: libsdl12-compat-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libts-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: nasm
|
||||
@ -82,22 +67,9 @@ This package contains static libraries and C system header files needed to compi
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%ifarch %{ix86}
|
||||
#% setup -q -a1
|
||||
#% patch1 -p1
|
||||
#%endif
|
||||
#%patch2 -p1
|
||||
#%patch3 -p1
|
||||
autoreconf -f -i
|
||||
|
||||
%build
|
||||
#%ifarch %{ix86}
|
||||
#pushd jpeg-mmx
|
||||
#% configure
|
||||
#% make -j1
|
||||
#popd
|
||||
#%endif
|
||||
|
||||
%configure \
|
||||
--with-quicktime \
|
||||
--with-dv=%{_prefix} \
|
||||
@ -158,13 +130,15 @@ rm -f %{buildroot}%{_infodir}/dir
|
||||
%dir %{_includedir}/mjpegtools/
|
||||
%{_includedir}/mjpegtools/*
|
||||
%{_libdir}/lib*.a
|
||||
%{_libdir}/lib*.la
|
||||
%{_libdir}/lib*.so
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%doc ChangeLog
|
||||
%doc BUGS CHANGES HINTS PLANS README* TODO
|
||||
|
||||
%changelog
|
||||
* Wed Jun 19 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.1-3mamba
|
||||
- rebuilt to remove .la files
|
||||
|
||||
* Fri Dec 31 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.1-2mamba
|
||||
- rebuilt with libSDL_gfx 2.0.26
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user