rebuilt with protobuf 2.5.0 [release 1.11.0-2mamba;Tue Nov 19 2013]
This commit is contained in:
parent
ab38c36d7f
commit
34750a0b12
@ -1,2 +1,6 @@
|
||||
# mixxx
|
||||
|
||||
Mixxx is an open source DJ tool designed for both professional and amateur DJs alike.
|
||||
Mixxx allows DJs to mix music live with a clean, simple interface.
|
||||
Futhermore, Mixxx has a number of key features to help DJs in the mix: Beat estimation, parallel visual displays, and support for various DJ hardware controllers.
|
||||
|
||||
|
21
mixxx-1.5.0-libs.patch
Normal file
21
mixxx-1.5.0-libs.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -ru mixxx-1.5.0/src/mixxx.pro mixxx-1.5.0-lua51/src/mixxx.pro
|
||||
--- mixxx-1.5.0/src/mixxx.pro 2007-02-23 18:51:58.000000000 +0100
|
||||
+++ mixxx-1.5.0-fix/src/mixxx.pro 2007-10-25 22:13:00.000000000 +0200
|
||||
@@ -481,7 +481,7 @@
|
||||
contains(ENABLED_FEATURES, lua) {
|
||||
HEADERS += script/lua/*.h
|
||||
SOURCES += script/lua/*.cpp
|
||||
- LIBS+=-llua -llualib -ltolua
|
||||
+ LIBS+=-llua -ltolua
|
||||
DEFINES += __LUA__
|
||||
}
|
||||
|
||||
@@ -490,7 +490,7 @@
|
||||
SOURCES += script/python/*.cpp
|
||||
DEFINES += __PYTHON__
|
||||
|
||||
- LIBS += $$system(python-config)
|
||||
+ LIBS += -lpython2.4
|
||||
exists(/usr/include/python2.4/Python.h) {
|
||||
INCLUDEPATH += /usr/include/python2.4/
|
||||
} else:exists(/usr/include/python2.3/Python.h) {
|
12
mixxx-1.7.2-mp4.patch
Normal file
12
mixxx-1.7.2-mp4.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru mixxx-1.7.2.orig/src/m4a/mp4-mixxx.cpp mixxx-1.7.2/src/m4a/mp4-mixxx.cpp
|
||||
--- mixxx-1.7.2.orig/src/m4a/mp4-mixxx.cpp 2009-12-30 03:39:12.000000000 +0100
|
||||
+++ mixxx-1.7.2/src/m4a/mp4-mixxx.cpp 2010-02-17 14:51:57.000000000 +0100
|
||||
@@ -150,7 +150,7 @@
|
||||
}
|
||||
|
||||
/* init decoder according to mpeg-4 audio config */
|
||||
- if (faacDecInit2(priv->decoder, buf, buf_size, (uint32_t*) &priv->sample_rate, &priv->channels) < 0) {
|
||||
+ if (faacDecInit2(priv->decoder, buf, buf_size, &priv->sample_rate, &priv->channels) < 0) {
|
||||
free(buf);
|
||||
goto out;
|
||||
}
|
13
mixxx-desktop
Normal file
13
mixxx-desktop
Normal file
@ -0,0 +1,13 @@
|
||||
[Desktop Entry]
|
||||
Version=1.0
|
||||
Encoding=UTF-8
|
||||
Name=Mixxx
|
||||
Comment=A digital DJ interface
|
||||
Comment[it]=Un'interfaccia digitale per DJ
|
||||
GenericName=A digital DJ interface
|
||||
GenericName[it]=Un'interfaccia digitale per DJ
|
||||
Exec=mixxx
|
||||
Terminal=false
|
||||
Icon=mixxx-icon.png
|
||||
Type=Application
|
||||
Categories=AudioVideo;Audio;
|
138
mixxx.spec
Normal file
138
mixxx.spec
Normal file
@ -0,0 +1,138 @@
|
||||
Name: mixxx
|
||||
Version: 1.11.0
|
||||
Release: 2mamba
|
||||
Summary: An open source DJ tool designed for both professional and amateur DJs alike
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://mixxx.sourceforge.net
|
||||
Source: http://downloads.mixxx.org/mixxx-%{version}/mixxx-%{version}-src.tar.gz
|
||||
Source1: mixxx-desktop
|
||||
Patch: %{name}-1.5.0-libs.patch
|
||||
Patch1: %{name}-1.7.2-mp4.patch
|
||||
License: GPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libdjconsole-devel
|
||||
BuildRequires: libfaad2-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libgpod-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libid3tag-devel
|
||||
BuildRequires: liblame-devel
|
||||
BuildRequires: libmad-devel
|
||||
BuildRequires: libmp4v2-devel
|
||||
BuildRequires: libogg-devel
|
||||
BuildRequires: libportaudio-devel
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: libshout-devel
|
||||
BuildRequires: libsndfile-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libsndfile-devel >= 1.0.17
|
||||
BuildRequires: libjack-devel >= 0.102.20
|
||||
#BuildRequires: lua-devel >= 5.0.3
|
||||
#BuildRequires: tolua >= 5.0
|
||||
BuildRequires: libpython-devel >= 2.4.4
|
||||
BuildRequires: libportmidi-devel
|
||||
BuildRequires: protobuf-devel
|
||||
BuildRequires: scons
|
||||
|
||||
%description
|
||||
Mixxx is an open source DJ tool designed for both professional and amateur DJs alike.
|
||||
Mixxx allows DJs to mix music live with a clean, simple interface.
|
||||
Futhermore, Mixxx has a number of key features to help DJs in the mix: Beat estimation, parallel visual displays, and support for various DJ hardware controllers.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
#%patch -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
#scons \
|
||||
# prefix=%{_prefix} qtdir=%{_qt4_prefix} \
|
||||
# ipod=1 ladspa=1 djconsole=1 shoutcast=1 tonal=1 m4a=1 script=1 test=1 jack=1
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
scons \
|
||||
prefix=%{_prefix} install_root=%{buildroot}%{_prefix} qtdir=%{_qt4_prefix} \
|
||||
djconsole=1 shoutcast=1 tonal=1 m4a=1 jack=1 \
|
||||
install
|
||||
|
||||
install -m0644 %{SOURCE1} %{buildroot}%{_datadir}/applications/mixxx.desktop
|
||||
## Warning: INSTALL_ROOT is passed this way as a trick
|
||||
#make install -C src INSTALL_ROOT=%{buildroot}%{_builddir}/%{name}-%{version}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/mixxx
|
||||
%dir %{_prefix}/lib/mixxx
|
||||
%dir %{_prefix}/lib/mixxx/plugins
|
||||
%dir %{_prefix}/lib/mixxx/plugins/vamp
|
||||
%{_prefix}/lib/mixxx/plugins/vamp/libmixxxminimal.so
|
||||
%{_datadir}/applications/mixxx.desktop
|
||||
%dir %{_datadir}/mixxx
|
||||
%dir %{_datadir}/mixxx/controllers
|
||||
%{_datadir}/mixxx/controllers/*
|
||||
%dir %{_datadir}/mixxx/keyboard
|
||||
%{_datadir}/mixxx/keyboard/*.cfg
|
||||
%dir %{_datadir}/mixxx/skins
|
||||
#%{_datadir}/mixxx/midi/*
|
||||
%{_datadir}/mixxx/skins/*
|
||||
%{_datadir}/pixmaps/mixxx-icon.png
|
||||
#%{_datadir}/mixxx/ladspa_presets/*.xml
|
||||
#%{_libdir}/mixxx/plugins/soundsource/libsoundsourcem4a.so
|
||||
%{_docdir}/mixxx/LICENSE
|
||||
%{_docdir}/mixxx/Mixxx-Manual.pdf
|
||||
%{_docdir}/mixxx/README
|
||||
%{_datadir}/mixxx/schema.xml
|
||||
%{_datadir}/mixxx/translations/mixxx_*.qm
|
||||
#%{_docdir}/mixxx-%{version}/*
|
||||
%doc COPYING LICENSE
|
||||
#README README.macro Mixxx-Manual.pdf
|
||||
|
||||
%changelog
|
||||
* Tue Nov 19 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.11.0-2mamba
|
||||
- rebuilt with protobuf 2.5.0
|
||||
|
||||
* Wed May 22 2013 Automatic Build System <autodist@mambasoft.it> 1.11.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Aug 11 2012 Automatic Build System <autodist@mambasoft.it> 1.10.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat May 05 2012 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 1.10.0-1mamba
|
||||
- update to 1.10.0
|
||||
|
||||
* Fri Mar 25 2011 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 1.9.0-1mamba
|
||||
- update to 1.9.0
|
||||
|
||||
* Tue Feb 09 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.7.2-2mamba
|
||||
- replace hard coded paths with parameters
|
||||
- added automatic build requirements
|
||||
- (re)add correct prefix to scons script
|
||||
- enabled support for ffmpeg, mp4, tonal analisys, scripting and test suite
|
||||
- provide desktop file with translated descriptions and execution without pasuspend
|
||||
|
||||
* Sun Feb 07 2010 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 1.7.2-1mamba
|
||||
- update to 1.7.2
|
||||
|
||||
* Sun Nov 02 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.1-1mamba
|
||||
- update to 1.6.1
|
||||
|
||||
* Thu Oct 25 2007 Aleph0 <aleph0@openmamba.org> 1.5.0.1-2mamba
|
||||
- rebuilt without deprecated lua support
|
||||
|
||||
* Thu May 10 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.0.1-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user