automatic version update by autodist [release 2.4.0-1mamba;Sun Mar 10 2024]
This commit is contained in:
parent
19d2c549a8
commit
075c8a4335
@ -3,4 +3,3 @@
|
||||
Mixxx is an open source DJ tool designed for both professional and amateur DJs alike.
|
||||
Mixxx allows DJs to mix music live with a clean, simple interface.
|
||||
Futhermore, Mixxx has a number of key features to help DJs in the mix: Beat estimation, parallel visual displays, and support for various DJ hardware controllers.
|
||||
|
||||
|
@ -1,21 +0,0 @@
|
||||
diff -ru mixxx-1.5.0/src/mixxx.pro mixxx-1.5.0-lua51/src/mixxx.pro
|
||||
--- mixxx-1.5.0/src/mixxx.pro 2007-02-23 18:51:58.000000000 +0100
|
||||
+++ mixxx-1.5.0-fix/src/mixxx.pro 2007-10-25 22:13:00.000000000 +0200
|
||||
@@ -481,7 +481,7 @@
|
||||
contains(ENABLED_FEATURES, lua) {
|
||||
HEADERS += script/lua/*.h
|
||||
SOURCES += script/lua/*.cpp
|
||||
- LIBS+=-llua -llualib -ltolua
|
||||
+ LIBS+=-llua -ltolua
|
||||
DEFINES += __LUA__
|
||||
}
|
||||
|
||||
@@ -490,7 +490,7 @@
|
||||
SOURCES += script/python/*.cpp
|
||||
DEFINES += __PYTHON__
|
||||
|
||||
- LIBS += $$system(python-config)
|
||||
+ LIBS += -lpython2.4
|
||||
exists(/usr/include/python2.4/Python.h) {
|
||||
INCLUDEPATH += /usr/include/python2.4/
|
||||
} else:exists(/usr/include/python2.3/Python.h) {
|
@ -1,12 +0,0 @@
|
||||
diff -Nru mixxx-1.7.2.orig/src/m4a/mp4-mixxx.cpp mixxx-1.7.2/src/m4a/mp4-mixxx.cpp
|
||||
--- mixxx-1.7.2.orig/src/m4a/mp4-mixxx.cpp 2009-12-30 03:39:12.000000000 +0100
|
||||
+++ mixxx-1.7.2/src/m4a/mp4-mixxx.cpp 2010-02-17 14:51:57.000000000 +0100
|
||||
@@ -150,7 +150,7 @@
|
||||
}
|
||||
|
||||
/* init decoder according to mpeg-4 audio config */
|
||||
- if (faacDecInit2(priv->decoder, buf, buf_size, (uint32_t*) &priv->sample_rate, &priv->channels) < 0) {
|
||||
+ if (faacDecInit2(priv->decoder, buf, buf_size, &priv->sample_rate, &priv->channels) < 0) {
|
||||
free(buf);
|
||||
goto out;
|
||||
}
|
64
mixxx.spec
64
mixxx.spec
@ -1,5 +1,5 @@
|
||||
Name: mixxx
|
||||
Version: 2.3.6
|
||||
Version: 2.4.0
|
||||
Release: 1mamba
|
||||
Summary: An open source DJ tool designed for both professional and amateur DJs alike
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
@ -9,8 +9,6 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://mixxx.org/
|
||||
Source: https://github.com/mixxxdj/mixxx.git/%{version}/mixxx-%{version}.tar.bz2
|
||||
Source1: mixxx-desktop
|
||||
Patch: %{name}-1.5.0-libs.patch
|
||||
Patch1: %{name}-1.7.2-mp4.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -20,6 +18,7 @@ BuildRequires: libQt5X11Extras-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libabseil-cpp-devel
|
||||
BuildRequires: libavcodec-ffmpeg-devel
|
||||
BuildRequires: libavformat-ffmpeg-devel
|
||||
BuildRequires: libavutil-ffmpeg-devel
|
||||
@ -56,68 +55,43 @@ BuildRequires: libupower-devel
|
||||
BuildRequires: libusb-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: libwavpack-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: qt5-qtbase-devel
|
||||
BuildRequires: qt5-qtscript-devel
|
||||
BuildRequires: qt5-qtdeclarative-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libchromaprint-devel >= 1.3.1-1mamba
|
||||
BuildRequires: libsndfile-devel >= 1.0.17
|
||||
BuildRequires: libjack-devel >= 0.102.20
|
||||
#BuildRequires: lua-devel >= 5.0.3
|
||||
#BuildRequires: tolua >= 5.0
|
||||
BuildRequires: libpython-devel >= 2.4.4
|
||||
BuildRequires: libportmidi-devel
|
||||
BuildRequires: libprotobuf-devel >= 1.6.1
|
||||
BuildRequires: scons
|
||||
BuildRequires: libtag-devel >= 1.9
|
||||
BuildRequires: libkeyfinder-devel
|
||||
BuildRequires: libid3tag-devel >= 0.16.1-2mamba
|
||||
BuildRequires: cmake
|
||||
BuildRequires: libbenchmark-devel
|
||||
BuildRequires: libmicrosoft-gsl-devel
|
||||
|
||||
%description
|
||||
Mixxx is an open source DJ tool designed for both professional and amateur DJs alike.
|
||||
Mixxx allows DJs to mix music live with a clean, simple interface.
|
||||
Futhermore, Mixxx has a number of key features to help DJs in the mix: Beat estimation, parallel visual displays, and support for various DJ hardware controllers.
|
||||
|
||||
%debug_package
|
||||
# FIXME:
|
||||
# /usr/bin/debugedit: Cannot handle 8-byte build ID
|
||||
#% debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#-D -T
|
||||
#%patch -p1
|
||||
#%patch1 -p1
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
%cmake -d build
|
||||
|
||||
%make
|
||||
# -DCMAKE_STRIP=/bin/true
|
||||
|
||||
#scons \
|
||||
# prefix=%{_prefix} qtdir=%{_qt4_prefix} \
|
||||
# ipod=1 ladspa=1 djconsole=1 shoutcast=1 tonal=1 m4a=1 script=1 test=1 jack=1
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
|
||||
#scons \
|
||||
# prefix=%{_prefix} install_root=%{buildroot}%{_prefix} qtdir=%{_qt5_prefix} \
|
||||
# djconsole=1 shoutcast=1 tonal=1 m4a=1 jack=1 \
|
||||
# install
|
||||
|
||||
#install -m0644 %{SOURCE1} %{buildroot}%{_datadir}/applications/mixxx.desktop
|
||||
## Warning: INSTALL_ROOT is passed this way as a trick
|
||||
#make install -C src INSTALL_ROOT=%{buildroot}%{_builddir}/%{name}-%{version}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/mixxx
|
||||
#%dir %{_prefix}/lib/mixxx
|
||||
#%dir %{_prefix}/lib/mixxx/plugins
|
||||
#%dir %{_prefix}/lib/mixxx/plugins/vampqt5
|
||||
#%{_prefix}/lib/mixxx/plugins/vampqt5/libmixxxminimal.so
|
||||
%{_udevrulesdir}/69-mixxx-usb-uaccess.rules
|
||||
%{_datadir}/applications/org.mixxx.Mixxx.desktop
|
||||
%{_datadir}/metainfo/org.mixxx.Mixxx.metainfo.xml
|
||||
@ -125,26 +99,24 @@ Futhermore, Mixxx has a number of key features to help DJs in the mix: Beat esti
|
||||
%dir %{_datadir}/mixxx/controllers
|
||||
%{_datadir}/mixxx/controllers/*
|
||||
%{_datadir}/mixxx/controllers/.eslintrc.json
|
||||
%dir %{_datadir}/mixxx/effects
|
||||
%{_datadir}/mixxx/effects/*
|
||||
%dir %{_datadir}/mixxx/keyboard
|
||||
%{_datadir}/mixxx/keyboard/*.cfg
|
||||
%dir %{_datadir}/mixxx/script
|
||||
%{_datadir}/mixxx/script/.eslintrc.json
|
||||
%{_datadir}/mixxx/script/*
|
||||
%dir %{_datadir}/mixxx/skins
|
||||
%{_datadir}/mixxx/skins/*
|
||||
%{_docdir}/mixxx/LICENSE
|
||||
%dir %{_datadir}/doc/mixxx
|
||||
%{_datadir}/doc/mixxx/*
|
||||
%{_datadir}/mixxx/translations/mixxx_*.qm
|
||||
#%dir %{_datadir}/mixxx/fonts
|
||||
#%{_datadir}/mixxx/fonts/OpenSans*
|
||||
#%{_datadir}/mixxx/fonts/Ubuntu*
|
||||
%{_datadir}/icons/hicolor/*/apps/mixxx.png
|
||||
%{_datadir}/icons/hicolor/scalable/apps/mixxx.svg
|
||||
%{_datadir}/icons/hicolor/scalable/apps/mixxx*.svg
|
||||
%doc COPYING LICENSE
|
||||
#README README.macro Mixxx-Manual.pdf
|
||||
|
||||
%changelog
|
||||
* Sun Mar 10 2024 Automatic Build System <autodist@openmamba.org> 2.4.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Aug 16 2023 Automatic Build System <autodist@mambasoft.it> 2.3.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user