121 lines
3.5 KiB
RPMSpec
121 lines
3.5 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f1-2)
|
|
|
|
Name: minuet
|
|
Version: 20.08.0
|
|
Release: 1mamba
|
|
Summary: KDE Frameworks 5 software for music education
|
|
Group: Graphical Desktop/Applications/Multimedia
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.kde.org
|
|
Source: https://download.kde.org/stable/release-service/%{version}/src/minuet-%{version}.tar.xz
|
|
# Source: http://download.kde.org/stable/frameworks/%{majver}/...-%{version}.tar.xz
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: fluidsynth-devel
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: ldconfig
|
|
BuildRequires: libgcc
|
|
BuildRequires: libkcoreaddons-devel
|
|
BuildRequires: libkcrash-devel
|
|
BuildRequires: libki18n-devel
|
|
BuildRequires: libqt5-devel
|
|
BuildRequires: libstdc++6-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: cmake
|
|
BuildRequires: rpm-macros-kde5
|
|
BuildRequires: extra-cmake-modules
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
KDE Frameworks 5 software for music education.
|
|
|
|
%package -n lib%{name}
|
|
Group: System/Libraries
|
|
Summary: Shared libraries for %{name}
|
|
|
|
%description -n lib%{name}
|
|
This package contains shared libraries for %{name}.
|
|
|
|
%package -n lib%{name}-devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n lib%{name}-devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
%cmake_kde5 -d build
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall -C build
|
|
|
|
%find_lang %{name}5_qt --with-qt --with-man --with-html --all-name || touch %{name}5_qt.lang
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -n lib%{name}
|
|
/sbin/ldconfig
|
|
exit 0
|
|
|
|
%postun -n lib%{name}
|
|
/sbin/ldconfig
|
|
exit 0
|
|
|
|
%files -f %{name}5_qt.lang
|
|
%defattr(-,root,root)
|
|
%{_bindir}/minuet
|
|
%{_datadir}/applications/org.kde.minuet.desktop
|
|
%{_datadir}/metainfo/org.kde.minuet.appdata.xml
|
|
%dir %{_datadir}/minuet
|
|
%dir %{_datadir}/minuet/definitions
|
|
%{_datadir}/minuet/definitions/*.json
|
|
%dir %{_datadir}/minuet/exercises
|
|
%{_datadir}/minuet/exercises/*.json
|
|
%dir %{_datadir}/minuet/soundfonts
|
|
%{_datadir}/minuet/soundfonts/*.sf2
|
|
%{_datadir}/icons/hicolor/*/apps/minuet.png
|
|
%{_datadir}/icons/hicolor/*/apps/minuet.svg
|
|
%{_datadir}/icons/hicolor/*/actions/minuet*.svg
|
|
%{_datadir}/icons/hicolor/scalable/apps/minuet.svgz
|
|
%doc COPYING COPYING.DOC
|
|
|
|
%files -n lib%{name}
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libminuetinterfaces.so.*
|
|
%{_libdir}/qt5/plugins/minuet/minuetfluidsynthsoundcontroller.so
|
|
|
|
%files -n lib%{name}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/minuet
|
|
%dir %{_includedir}/minuet/interfaces
|
|
%{_includedir}/minuet/interfaces/*.h
|
|
%{_libdir}/libminuetinterfaces.so
|
|
|
|
%changelog
|
|
* Sat Aug 15 2020 Automatic Build System <autodist@mambasoft.it> 20.08.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jul 10 2020 Automatic Build System <autodist@mambasoft.it> 20.04.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jun 12 2020 Automatic Build System <autodist@mambasoft.it> 20.04.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat May 16 2020 Automatic Build System <autodist@mambasoft.it> 20.04.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Apr 30 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 20.04.0-1mamba
|
|
- package created using the webbuild interface
|